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SOFTWARE LICENSE AGREEMENT

1. NOTICE. 

THIS IS A CONTRACT. BY INDICATING YOUR ACCEPTANCE BELOW, YOU ACCEPT ALL THE TERMS AND CONDITIONS OF THIS AGREEMENT. IF YOU DO 
NOT AGREE WITH THE TERMS AND CONDITIONS OF THIS AGREEMENT, DECLINE WHERE INSTRUCTED, AND YOU WILL NOT BE ABLE TO USE THE 
SOFTWARE. LEITCH TECHNOLOGY INTERNATIONAL INC. IS WILLING TO LICENSE THIS SOFTWARE TO YOU ONLY ON THE CONDITION THAT YOU ACCEPT 
ALL OF THE TERMS CONTAINED IN THIS LICENSE AGREEMENT. 

2. Ownership and License. This is a license agreement and NOT an agreement for sale. We continue to own the copy of the software installed by this program and any 
other copy that you are authorized by this Agreement to make (the "Software"). Your rights to use the Software are specified in this Agreement, and we retain all rights 
not expressly granted to you in this Agreement. Nothing in this Agreement constitutes a waiver of our rights under any copyright law or any other law.

3. Permitted Uses. 

3.01 Right to Install and Use. You may install and use the Software on the hard disk drive of any single compatible computer that you own. However, you may not under 
any circumstances have the Software installed onto the hard drives of more than one computer at the same time, nor may you install the Software onto the hard disk drive 
of one computer and then use the original distribution media on another computer. If you wish to use the Software on more than one computer, you must either erase 
the Software from the first hard drive before you install it onto a second hard drive, or else license an additional copy of the Software for each additional computer on 
which you want to use it.

3.02  Right to Copy. You may make one (1) copy of the Software for backup and archival purposes, provided that the original and the copy are kept in your possession, 
and that your installation and use of the Software does not exceed that allowed in Section 3.01, and provided you reproduce our copyright notice on the copy.

3.03 Right to Transfer. You shall not assign, transfer sublicense, rent, lend, or lease the Software or your rights under this Agreement without our prior written approval.

4. Prohibited Uses. You may not, without written permission from us: (a) use, copy, modify, merge, or transfer copies of the Software or documentation except as 
provided in this Agreement; (b) use any backup or archival copy of the Software (or allow someone else to use such copy) for any purpose other than to replace the 
original copy in the event it is destroyed or becomes defective; or (c) disassemble, decompile or "unlock," reverse translate, or in any manner decode the Software or the 
dongle security device for any reason.

5. Limited Warranty. We make the following limited warranties from the date you acquired the Software from us or our authorized dealer:

(a) Media. For a period of twenty (20) days, the distribution media and documentation in this package will be free from defects in materials and workmanship under 
normal use. If the distribution media or documentation fail to conform to this warranty, you may, as your sole and exclusive remedy, obtain a replacement free of charge 
if you return the defective disk or documentation to us with a dated proof of purchase.

(b) Interlock Security Device. Provided you are in compliance with this Agreement, we will replace a damaged or defective interlock security device (dongle) no matter 
what the cause of the damage. In order to receive a replacement device, you must return the damaged device to Leitch Technology International Inc, 26 Peppler Street, 
Waterloo, Ontario, Canada, N2J 3C4.

(c) WARRANTY DISCLAIMER. EXCEPT AS PROVIDED ABOVE, THE SOFTWARE AND DOCUMENTATION ARE PROVIDED ON AN "AS IS" BASIS, AND WE DO 
NOT WARRANT THAT THE SOFTWARE WILL MEET YOUR REQUIREMENTS OR THAT ITS OPERATION WILL BE UNINTERRUPTED OR ERROR-FREE. WE 
EXCLUDE AND EXPRESSLY DISCLAIM ALL EXPRESS AND IMPLIED WARRANTIES AND CONDITIONS NOT STATED HEREIN, INCLUDING THE IMPLIED 
WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE.

Some jurisdictions do not allow the exclusion of implied warranties, so the above exclusion may not apply to you. This limited warranty gives you specific legal rights, 
and you may also have other legal rights, which vary from jurisdiction to jurisdiction.

6. LIMITATION OF LIABILITY. IN NO EVENT SHALL WE BE LIABLE FOR ANY INDIRECT, INCIDENTAL, SPECIAL OR CONSEQUENTIAL DAMAGES, INCLUDING 
BUT NOT LIMITED TO LOSS OF PROFITS, REVENUE, DATA, OR DATA USE, OR MACHINE USE, INCURRED BY YOU OR ANY THIRD PARTY, WHETHER IN AN 
ACTION IN CONTRACT OR TORT, EVEN IF WE HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. OUR LIABILITY TO YOU FOR ANY LOSSES 
SHALL NOT EXCEED THE GREATER OF $500 AND THE AMOUNT YOU ORIGINALLY PAID FOR THE SOFTWARE. 

Some jurisdictions do not allow these limitations or exclusions, so they may not apply to you.

7. United States Government Restricted Rights. The enclosed Software and documentation are provided with Restricted Rights. Use, duplication or disclosure by the 
U.S. Government or any agency or instrumentality thereof is subject to restrictions as set forth in subdivision (c)(1 )(ii) of the Rights in Technical Data and Computer 
Software clause at 48 C. F.R. 252.227-7013, or in subdivision (c)(1) and (2) of the Commercial Computer Software -- Restricted Rights Clause at 48 C.F.R. 52.227-19, as 
applicable. Contractor Manufacturer is Leitch Technology International Inc, 26 Peppler Street, Waterloo, Ontario, Canada, N2J 3C4

8. Termination. This license and your right to use this Software automatically terminate if you fail to comply with any provisions of this Agreement, destroy the copies of 
the Software in your possession, or voluntarily return the Software to us. Upon termination you will destroy all copies of the Software and documentation. Otherwise, the 
restrictions on your rights to use the Software will expire upon expiration of the copyright to the Software.

9. Miscellaneous Provisions. This Agreement will be governed by and construed in accordance with the laws of the Province of Ontario and not by the 1980 United 
Nations Convention on Contracts for the International Sale of Goods, as amended. This is the entire agreement between us relating to the contents of this package, and 
supersedes any prior purchase order, communications, advertising or representations concerning the contents of this package. No change or modification of this 
Agreement will be valid unless it is in writing, and is signed by us.

10. Quebec Transactions. If you reside in the Province of Quebec, Canada, you agree to the following: The parties hereto have expressly required that the present 
Agreement and its Exhibits be drawn up in the English language. Les parties aux presentes ont expressement exige que la presente convention et ses Annexes soient 
redigees en langue anglaise.

If you have any questions about this Agreement, write to us at Leitch Technology International Inc, 26 Peppler Street, 
Waterloo, Ontario, Canada, N2J 3C4, or call us at 519-570-9111.
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2 InfoCaster

Introduction

Welcome to InfoCaster!
Inscriber® InfoCaster™ is an exciting out-of-the box communications solution that produces 
powerful attractive multi-zone broadcast-quality page layouts for immediate display on video monitors 
anywhere you can imagine to capture and inform your audience (transportation systems, 
entertainment, retail, services, etc.). 

With InfoCaster, you can quickly create layouts that integrate crawls, rolls, animations, clocks, video 
and audio clips for dynamic presentations. Keep your customers, employees, and public informed 
with your own dynamic advertisements, information, and branding. 
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Purchase Options InfoCaster is suitable for single installations, large scale networks, and 
everything in between. InfoCaster offers the following additional 
options that you can purchase to meet your needs. 

• The Inca Port option for the InfoCaster Creation Station (that’s this 
product) enables you to create a region in which you can display 
layers of data created in other Inca products, such as IncaRTX. 

• InfoCaster Player licences enable you to display your infocasts at 
additional sites.

• InfoCaster Network Manager enable you to manage multiple 
InfoCaster systems and effectively target localized audiences.

About This 
Document

This document introduces you to all the major features and tasks 
available in InfoCaster. It is designed to get you up and running as 
quickly as possible. You can also select Help → Help in InfoCaster to 
refer to the online help for further information.

To display the name of buttons and tools, hold the mouse cursor over 
the item on the screen. If you don’t see any text come up, select 
Help→ToolTips to activate ToolTips. 

This document assumes knowledge of Windows-based computers. For 
instructions on how to use basic Windows features, please refer to the 
Microsoft web site or to documentation that came with your computer.
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Workflow
To create and output an infocast, the workflow is as follows.

1. Open an infocast.
2. Add pages to the infocast.
3. Add regions to the page.
4. Add content (region items) to each region.
5. Schedule the playback sequence(s) for your regions and your pages.
6. Output the infocast.

Each step is covered in more detail on the following pages and in their own chapters in this manual. 

1

Open
a new or 
existing 
infocast.
 

2
The infocast
opens in the
Pages
window. By 
default,
a new page
is added to
new 
infocasts.
Click on the
New button
to add a new 
page as 
needed.
 

Double-click
on a page 
to add regions.

3b

The page
opens in the
Regions window.
Select a region
tool, then draw a
region in the 
workspace. 
Draw
more regions.

Double-click on a 
region to add
content.

4b

The region 
opens in the
Items window.
Select a content
editor from the list, 
then click on the
Add button next to it.

Add content in
editor.

5

Set playback sequence
for pages and region items.

6
Click on Play to output infocast.

3a 4a

4c
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The InfoCaster workspace consists of three main windows (Pages, Regions, and Items) and the Tree 
View list. 

Manage your pages in the Pages window. The Regions window manages the regions on your page 
layout. The Items window manages the items in the selected region. Click on the Pages, Regions, or 
Items button on the main toolbar at the top of the screen to switch windows.

The Tree View list is always available on the left side of the screen and displays all of the pages 
available in the project, as well as the regions, region items and region sequences. 

Select a page, region, or item by double-clicking on it in the Tree View list or in the appropriate 
(Pages, Regions, or Items) window. You can also select a region in the Preview window below the Tree 
View list. 

Switch to Pages, Regions, or Items window.

Preview
window

Tree View
list

Pages
window

Regions
window

Items
window
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Program 
Monitoring 
Feature

Included with InfoCaster is a program-monitoring 
feature that automatically restarts InfoCaster after 
a system interruption, such as a program closing 
or the computer rebooting. The monitor icon is 
displayed on the task bar at the bottom-right corner of your computer 
screen. 

For the most efficient operation, you should keep the program monitor 
turned on. If there is a system interruption, the monitor automatically 
logs in (if required), restarts InfoCaster, and starts the last layout that 
was playing. 

However, under some conditions, such as for software installations, 
you might want to turn the program monitor off so the automatic 
function does not interfere with other activities. 

Exit InfoCaster To exit InfoCaster, use one of these methods.

• Select File → Exit in InfoCaster.
If InfoCaster automatically restarts, the 
program monitoring feature is on. Use 
the next method to exit InfoCaster. 

• Right-click on the monitor icon and 
select Shut Down InfoCaster. For details on the monitor icon, see 
“Program Monitoring Feature” on page 6.

Restart InfoCaster To start InfoCaster with the program monitoring feature on, right-click 
on the monitor icon and select Start InfoCaster. 

To start InfoCaster with the program monitoring feature 
off, double-click on the InfoCaster icon on your 
computer desktop.

To set InfoCaster to always load your last opened project 
when you open InfoCaster, see “Load Last Infocast on Startup” on 
page 247.

InfoCaster Monitor
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Step 1: Open an 
Infocast

To create digital signage page layouts for video display, the first step is 
to open a new or existing infocast. An infocast is the project file that 
contains all the pages that you can output in a project. You can create 
an infinite amount of infocasts. Only one infocast is aired at any given 
time to an output player. 

You can start a new infocast (New button), or you can open an existing 
infocast on your hard drive (File→New), CD (File→Get from CD), or 
another location (File→Import). Refer to “1. Open an Infocast” on 
page 17. 

The infocast opens in the Pages window. All the pages that exist in the 
infocast are displayed in the Page Library. By default, a blank page is 
added to a new infocast. 

InfoCaster saves all changes immediately to the default location 
C:\InfoCasts as you work. 
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Step 2: Add Page After you open an infocast, you add pages to it. Every infocast project 
consists of one or more pages. A page is the layout of the full screen 
digital signage image that is displayed on the output screen. Page 
layouts consist of all the regions and scheduling information.

All the pages that exist in the infocast are displayed in the Pages 
window. You work with pages in the Pages window. When you open an 
infocast, you are automatically switched to the Pages window. 

You can add as many pages (layouts) as you want to an infocast. Only 
one page is aired at any given time to an output player. Typically, after 
you add your regions and region content to the page layout, you 
schedule the time and the order in which the pages are aired or accept 
the default settings.

By default, a blank page is added to a new infocast. 

To add another page to an infocast:

1 Go to the Pages window. 

By default, when you open a new or existing infocast, you are 
automatically switched to the Pages window. To switch to the 
Pages window at any other time, you can click on the Pages button 
on the main toolbar.

2 Click on the New, Duplicate, or Import button on the Pages 
window toolbar to add a new page, make a copy of a page, or 
import a page. 

Refer to “2. Add Pages to Infocast” on page 25.

Next, open a page to add regions to your page layout. Pages open in 
the Regions window.
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Step 3: Add 
Regions

After you have opened an infocast and selected a page, add regions to 
the page. Regions are playback zones or containers on your page 
layouts into which you place the content that you want to output. You 
can add many region items in each region to output at different times. 
You can create the following types of regions in your infocasts. 

• Still regions play static text or graphic displays, such as titles or 
logos. 

• Crawl regions play text and graphics that move horizontally across 
the region.

• Roll regions play text and graphics that scroll up or down the region.
• Animation regions play animated text and graphics.
• Digital Clock regions play a real-time digital clock or digital timer. 
• Video regions play video clips or live video. 
• Analog Clock regions play a real-time graphical clock.
• Audio regions play audio independent of other region items.
• Temperature regions display a temperature reading from a 

temperature probe connected to your system.

still rolldigital clock

animation

video still

crawl

background
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• You can create a pop-back region and use it to expand or shrink 
region items during output. See “Draw a Pop-Back Region” on 
page 44. 

• If you purchased the Inca Port option, you can air data created in 
other Inca products, such as IncaRTX.

• You can create a background that fills up any part of your screen 
using any of the regions types. See “Draw a Background” on 
page 44. 

To create regions in a page layout in your infocast:

1 Select the page, then switch to the Regions window. To do this, 
you can double-click on the page in the Pages window or Tree 
View list.

select page in Tree View list or Pages window

switch to Regions window
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2 Draw regions on the page in the Regions window. To do this, 
select a region tool (Still, Crawl, etc.), then click in the Regions 
workspace and drag the mouse cursor across the workspace. 

Draw all your regions. Adjust region settings as needed. 

select tool draw region
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Step 4: Add Region 
Items

Once you have drawn regions (content placeholders) on a page in your 
infocast, add content (region items) to each region. Regions open in 
the Items window. A unique set of content editors for each region type 
becomes available in the Items window. 

Use the content editors to add content. A region item is created in the 
region when you save the content in the editor. The region item is 
displayed in the Item Library. You can create many items in a region. 
You can add a blank item to the region to make the region transparent 
during playback. 

Items typically open in the content editor that you used to create them, 
but you can sometimes open them in other editors.

Later, when you schedule the playback sequence for the region, you 
can set when you want each item to air in the region. 

To add content to a region:

1 Select a region in the Regions, Tree View, or Preview window, 
then switch to the Items window. To do this, you can double-click 
on the region in the window. 

select region in Tree View, Preview, or Regions window

switch to Items window
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2 Open a content 
editor by 
selecting it 
from the editor 
list in the Items 
window, then 
clicking on the 
ADD button 
next to it. Each 
region type has 
a unique list of 
content editors. 

3 Add your content using the tools in the content editor. The 
content editors for each region type is described in individual 
chapters. 

• For Still Regions, see “Add Still Items” on page 67.
• For Crawl Regions, see “Add Crawl Items” on page 115.
• For Roll Regions, see “Add Roll Items” on page 127.
• For Animation Regions, see “Add Animation Items” on page 143.
• For Digital Clock Regions, see “Add Digital Clocks” on page 157.
• For Video Regions, see “Add Video Items” on page 169.
• For Analog Clock Regions, see “Add Analog Clocks” on page 187.
• For Audio Regions, see “Add Audio Items” on page 193.
• For Temperature Probe Regions, see “Add Temperature” on 

page 197.
Your content (region item) is displayed in the Item Library. 

select 
editor

click 
Add
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Step 5: Sequence After you add content to the regions of your layout, schedule when and 
how you want your page layouts and region items to be aired. Use the 
Sequencer on the Pages window to schedule the playback sequences of 
your infocast page. Use the Sequencer on the Items window to 
schedule the playback sequences of your region items.

During playback, InfoCaster loops through each sequence of pages 
and items until it reaches the start time of the next sequence in the list. 
Only one item in each region on a single page layout is output to air at 
any given time. 

Select page. Sequence Settings become
Page Settings. Adjust Page Settings.

2Add (drag) page
to sequence.

1 Add sequence.

Select sequence, then adjust Sequence Settings. 3

4
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To set up the playback sequence of your pages and items:

1 Add a sequence to the sequence list in the Pages window. 

By default, for pages, a sequence is created for you. To add 
another sequence, click on the Add button. See “1. Add Sequence” 
on page 208. Start another sequence and add pages to it when you 
want different sequence settings, such as a start time or transition 
type, to apply to certain pages. You can create as many sequences 
as you need. You may need to start another sequence to use a 
page or sequence in a trigger. See “Set Triggers” on page 226 for 
details.
To switch to the Pages window, click on the Pages button on the 
main toolbar at the top of the screen. See “Switch to Pages 
Window” on page 28.

2 Add pages to the sequence. 

By default, the first page of your infocast is automatically added to 
the sequence. Add as many pages to a sequence as you want. You 
do not need to include all the pages in the sequence list. You can 
add the same page to the sequence list more than once. To add 
more pages, drag a page from Page Library to a sequence. See “2. 
Add Page to Sequence” on page 209.

3 Schedule the Sequence Settings. 

Select a sequence in the sequence list, then use the options on the 
Sequence Settings panel above it to schedule the playback for all 
the pages in that sequence. See “3. Adjust Sequence Settings” on 
page 210.
If you cannot see the Settings panel, see “Display Panel, Options, 
List” on page 207.

4 Schedule individual Page Settings as needed.

Select a page in a sequence. The Sequence Settings panel changes 
to the Page Settings panel. Set playback options on the Pages 
Settings panel. Page settings bypass sequence settings. See “4. 
Adjust Page Settings” on page 211.

5 Apply a trigger as needed. 

You can set the playback of certain events to trigger other events in 
InfoCaster. See “Set Triggers” on page 226.

6 In a similar way, repeat steps 1 to 5 to create an item sequence in 
the Items window and add items to it. Adjust the Sequence 
Settings and Item Settings, and apply triggers as needed.

See “5. Schedule Playback Sequences” on page 201.
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Step 6: Output You can start playing an infocast in 2 ways.

• Click on the Play button at the top of the screen to output your 
infocast starting from the scheduled time according to the schedules 
times on your page and region item sequence lists. 
For example, you have a sequence of three items and each item 
plays for one hour. If the sequence start time is 1:00 PM and you 
start playback at 2:30 PM, item two plays. 

• Right-click on a blank space in the pages or items sequence list, then 
select Start Playback from the First Page from the menu, to output 
your infocast starting from the first page and item in all your 
sequence lists. 

InfoCaster plays the infocast to an output monitor. The region item 
that is set for output plays for the set duration. Then, the next item in 
the sequence list plays, and so on. InfoCaster loops through each 
sequence of pages and items until it reaches the start time of the next 
sequence in the list. Only one item in each region of one page layout in 
your infocast is output to air at any given time.

While your infocast is playing, you cannot adjust regions in the 
Regions window or change the crawl or roll speed, However, you can 
add, delete, and modify content, and rearrange the sequence. Changes 
apply the next time InfoCaster plays that item. You can monitor which 
region is currently playing in the sequence list. You can control plasma 
display screens. And you can log your output.

Refer to “6. Output” on page 233.
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1. Open an Infocast

Open Infocast Overview
To create digital signage page layouts for video display, the first step is to open a new or existing 
infocast. An infocast is the project file that contains all the pages that you can output in a project. 

You can create an infinite amount of infocasts. Only one infocast is aired at any given time to an 
output player. An infocast contains pages. Pages contain regions. Regions contain region items.

This chapter also explains how to save and delete your infocasts.

1

Open
a new or 
existing 
infocast.
 

2
The infocast
opens in the
Pages
window. By 
default,
a new page
is added to
new 
infocasts.
Click on the
New button
to add a new 
page as 
needed.
 

Double-click
on a page 
to add regions.

3b

The page
opens in the
Regions window.
Select a region
tool, then draw a
region in the 
workspace. 
Draw
more regions.

Double-click on a 
region to add
content.

4b

The region 
opens in the
Items window.
Select a content
editor from the list, 
then click on the
Add button next to it.

Add content in
editor.

5

Set playback sequence
for pages and region items.

6
Click on Play to output infocast.

3a 4a

4c

1)Open Infocast.  2)Add page.  3)Add regions.  4)Add items.  5)Sequence.  6)Output.
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Open New or Existing Infocast
You can start a new infocast or open an existing infocast on your hard drive, CD, or another location. 
InfoCaster saves all changes immediately to the default location as you work, so your project is always 
up-to-date. 

Open New 
Infocast

1 Click on the New button on the toolbar, or select File→New. 

2 In the New Infocast dialog box, name your infocast, then click 
OK. The infocast opens in the Pages window. 

open an infocast
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Always Open Last 
Infocast

To set InfoCaster to load the last project that was opened every time 
you start InfoCaster, select Edit→Preferences and check the Load Last 
Page Layout on Startup checkbox on the General tab in the Preferences 
dialog box. See “Load Last Infocast on Startup” on page 247.

Open on Hard 
Drive

To open an existing infocast on your computer’s hard drive:

1 Click on the Open button on the main toolbar, or select 
File→Open. 

2 In the Open dialog box, select the infocast project from the 
InfoCasts folder on your hard drive, located at C:\InfoCasts by 
default. 

The infocast opens in the Pages window. 

To check or change the default location of the InfoCasts folder, see 
“Store Infocasts In” on page 247.

Open on CD To open an infocast that was saved to CD:

1 Select the Get from CD option using one of the following 
methods. 

• If an infocast is 
already open, select 
File→InfoCaster 
CD→Get from CD. 

• If an infocast is not 
already open, select 
File→Get InfoCast 
from CD.

2 Insert the CD into your 
CD ROM drive as 
prompted.

3 In the Get InfoCast From 
Disc dialog box, select an 
infocast from the list, then click the Get InfoCast button. Click 
Done to close the dialog box.

The infocast opens in the Pages window. 
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Import Infocast You can import infocasts that were exported with the File→Export 
option. The Export option exports an entire project, leaving all 
referenced file paths in tact.

1 Select File→Import.

2 In the Import InfoCast dialog box, go to the project folder that 
you want to import, and double-click on the folder. 

3 Click OK to import the infocast. 

The infocast copies to your InfoCasts folder, located at 
C:\InfoCasts by default.

4 If an infocast is already open, click on the Open button on the 
main toolbar and select the imported infocast from the list that 
comes up.

If an infocast is not already open, the infocast you selected 
automatically opens in InfoCaster. 

The infocast opens in the Pages window. 

Note: You can also import individual pages. See “Import Page” on 
page 30.
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Save Infocast
InfoCaster automatically saves your work to a default location. You can change the default location. 
You can also save an infocast to a different location on your hard drive or on a CD, and copy an 
infocast without breaking the file paths that are referenced in the infocast. 

Auto Save InfoCaster saves all changes immediately to the default location, 
C:\InfoCasts, as you work, so your project is always up-to-date. You 
never have to save your infocast as you go. Even if something happens 
to your system, like a power outage, your projects load with your latest 
changes intact. 

All infocast projects are saved in the format C:\InfoCasts\(infocast 
name folder)\(page name folder). 

To check or change the default location of the InfoCasts folder, see 
“Store Infocasts In” on page 247.

Save Copy To save a copy of your infocast to the same location:

1 Select File→Save As. 

2 In the Save As dialog box, enter a name for the infocast and click 
Save. 

InfoCaster saves the selected page to your default Infocasts folder.

Note: Copying and pasting an infocast to a new location can break 
file paths that are referenced by the infocast.

Rename To save the infocast with a different name, select File→Rename, then 
enter the new infocast name as prompted.

Save (Export) to 
New Location

To save your project to a different location on your computer without 
breaking any file paths referenced by the infocast, use the export 
option. 

Note: Copying and pasting an infocast to a new location can break 
file paths that are referenced by the infocast.

1 Select File→Export.

2 In the Export dialog box, select a new location for the project and 
click OK.

Use the import option (File→Import) to open exported projects.
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Save to CD To burn an infocast project to CD, you must have a properly configured 
CD ROM burner (CD Read-Write drive) connected to your system. 

1 Insert a formatted, recordable CD ROM disk into your CD Read-
Write drive. 

2 In InfoCaster, select File→InfoCaster CD→Save To CD.

3 In the Save Infocast To 
Disc dialog box, enter a 
name for the CD ROM in 
the Please Name This 
Disc field. 

4 Set your options as 
follows. 

To add notes about the 
project to the infocast file, 
enter them in the 
Comments field. The 
comments appear when 
you import the project 
from the CD ROM.
To automatically load the 
project to the InfoCasts 
folder (C:\InfoCasts) when 
you import the infocast from the CD ROM, check the Enable Auto 
Load checkbox.
To set a playback start time for the page, check the Start Playing 
InfoCast checkbox, then choose one of the following options 
which apply after the page is imported from the CD ROM. 
• To start playback as soon as the infocast is copied to the 

InfoCasts folder, choose Immediately Upon Loading InfoCast.
• To set the playback time for the project, choose the At option 

and enter a start time and date. 
If you do not want to set the playback start time, clear the Start 
Playing InfoCast checkbox.
To put the infocast file in a central location for shared referencing, 
check the Save Shared Media Files checkbox. See “Store Shared 
Media Files In” on page 248 for details.

5 Click the Burn CD button to copy the infocast to the CD.

The Progress bar displays the level of completion state.

6 When the burn is completed, click Done to close the dialog box.
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Close or Delete Infocast
You can close or delete an infocast.

Close Infocast To close an infocast project in InfoCaster, select File→Close. 

The active infocast project closes, leaving the InfoCaster workspace 
blank.

Delete Infocast To permanently delete an infocast project:

1 Select File→Delete. 

2 In the Delete InfoCast Layout dialog box, select the infocast 
project from the list. 

3 Click the Delete button. The infocast is deleted from the 
InfoCasts folder, located at C:\InfoCasts by default.

4 Close the dialog box.
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2. Add Pages to Infocast

Add Pages Overview
After you open an infocast, you add pages to it. Every infocast project consists of one or more pages. 
A page is the layout of the full screen digital signage image that displays on the output screen. Page 
layouts consist of all the regions and scheduling information. Pages open in the Regions window, as 
explained in “Open Page in Regions Window” on page 36. 

1

Open
a new or 
existing 
infocast.
 

2
The infocast
opens in the
Pages
window. By 
default,
a new page
is added to
new 
infocasts.
Click on the
New button
to add a new 
page as 
needed.
 

Double-click
on a page 
to add regions.

3b

The page
opens in the
Regions window.
Select a region
tool, then draw a
region in the 
workspace. 
Draw
more regions.

Double-click on a 
region to add
content.

4b

The region 
opens in the
Items window.
Select a content
editor from the list, 
then click on the
Add button next to it.

Add content in
editor.

5

Set playback sequence
for pages and region items.

6
Click on Play to output infocast.

3a 4a

4c

1)Open Infocast.  2)Add page.  3)Add regions.  4)Add items.  5)Sequence.  6)Output.
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All the pages that exist in the infocast are displayed in the Pages window. 
You work with pages in the Pages window. When you open an infocast, you 
are automatically switched to the Pages window. 

All page layouts are saved in C:\InfoCasts. To change the default folder 
location, see “Store Infocasts In” on page 247.

Workflow By default, a blank page is added to a new infocast. To add another page to 
an infocast:

1 Switch to the Pages window. 

To do this, click on the Pages button on the main toolbar. See “Switch 
to Pages Window” on page 28.

2 Add a new page, copy a page, or import a page. 

To do this, click on the New, Duplicate, or Import button on the Pages 
window toolbar. See “Add, Copy, or Import Page” on page 30.
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Switch to Pages Window
To switch to the Pages window, use one of these methods.

• Open a new or existing infocast. When you open an infocast, you are automatically switched to the 
Pages window. 

• Click on the Pages button on the main toolbar. 

• Select Tools→Pages.

• Double-click on a page in the Tree View list.

All the pages in the selected infocast are displayed in the Page Library. 

The Pages window contains a toolbar, Library, Details panel, and Sequencer. The Pages window area 
changes into the Regions window or the Items window depending on what level of content you are 
working on. The Tree View list is always available to select pages, regions, region sequences, and 
region items. 

Preview 

Tree View 

Pages SequencerPages Details Pages toolbar

Pages button on main toolbar

Pages Library
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Change Page 
Display

To save space in the Pages window, you can change the size of the pages 
displayed in the Page Library and in the Pages Sequence list. 

Change Display of Page Library

To change the size of the page display in the Page Library, select 
Pages→Show Page Library As, then select one of the following options.

• Large Thumbnails.

• Small Thumbnails.

• Text Only.

Change Display of Page Sequencer

To change the size of the page display in the Pages Sequence list, see 
“Display Panel, Options, List” on page 207.
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Add, Copy, or Import Page
You can add as many pages (layouts) as you want to an infocast. You can add a new page, make a copy 
of a page, or import a page. Each page displays in the Page Library section of the Pages window. 

Add New Page By default, a blank page is automatically added to a new infocast. 

To add another new page to an infocast:

1 Click on the New button on the 
Pages window toolbar. 
Alternately, you can right-click in 
the Page Library, then select New 
Page from the menu. You can also 
select Pages→Add Page. 

2 In the New Page Layout dialog 
box, name the new layout.

Duplicate Page To add a copy of an existing page to your infocast:

1 Select the page in the Page Library. 

2 Click on the Duplicate button on the Pages window toolbar. 
Alternately, you can select Pages→Duplicate Page.

A copy of the page is added to the Page Library.

Import Page You can import pages that were created with the Export 
Page command, as explained in “Export Page” on page 31. 

1 Right-click on a blank space in the Page Library, then 
select Import Page from the menu. Alternately, you 
can select Pages→Import Page.
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2 In the Import Page dialog box, double-click on the folder that is 
named after the page you want to import, then click OK. 

Export Page To save your page to a new location on your computer without breaking any 
file paths referenced by the page, export the page. 

Note: Copying and pasting a page to a new location can 
break referenced file paths. 

1 In the Pages window, right-click on the page you want 
to export and select Export Page from the menu. 
Alternately, you can select Pages→Export Page. 

2 In the Export Page To dialog box, select a new 
location for the page and click OK. 

To open exported pages, import the page. See “Import Page” on page 30.

Edit Page 
(Layout)

To edit a page’s layout, use one of these methods.

• Click on the Edit button the Pages toolbar.
• Right-click on a page in the Pages window, then select Edit Page from the 

menu. 
• Select Pages→Edit Regions.

The page opens in the Regions window where you can select any region and 
edit its content. See “Open Page in Regions Window” on page 36 for 
details.
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Rename Page 1 Select the page in the Pages window, then click the Rename button in 
the Pages toolbar. You can also right-click on the page, then select 
Rename Page from the menu.

2 In the Rename Page dialog box, enter a new name for the page, then 
click OK. 

InfoCaster changes the page name in the following places.

• On the page layout in the Pages window, both in the Page Library and in 
the Page sequence list.

• On the page title displayed in the Tree View list.
• On the page layout folder, located in your infocast project folder 

(C:\InfoCasts\project folder\page folder).

Delete Page To permanently delete a page from your infocast, right-click on the page in 
the Pages window, then select Delete Page from the menu. Alternately, you 
can select Pages→Delete Page in Library. 

To delete a page from your infocast sequence, see “Delete Pages from the 
Sequence” on page 210.
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3. Add Regions to Page

Add Regions Overview
After you have opened an infocast and selected a page, add regions to the page. Regions are playback 
zones or containers on your page layouts into which you place the content (region items) that you 
want to output. You can add many region items in each region to output at different times.

You can create 9 types of regions in your infocasts. Then, open each region to add content. Each 
region opens in the Items window, as explained in “Open Region in Items Window” on page 54.

• Still regions play static 
text or graphic 
displays, such as titles 
or logos. 

• Crawl regions play text 
and graphics that move 
horizontally across the 
region.

• Roll regions play text 
and graphics that 
scroll up or down the 
region.

• Animation regions play 
animated text and 
graphics.

• Digital Clock regions 
play a real-time digital 
clock or digital timer. 

• Video regions play 
video clips or live video. 

• Analog Clock regions play an imported graphical clock.

• Audio regions play audio independent of other region items.

• Temperature regions display a temperature reading from a temperature probe connected to your 
system.

• You can create a pop-back region and use it to expand or shrink region items during output. See 
“Draw a Pop-Back Region” on page 44. 

• If you purchased the Inca Port option, you can air data created in other Inca products, such as 
IncaRTX. See “Purchase Options” on page 3.

• You can create a background that fills up any part of your screen using any of the regions types. 
See “Draw a Background” on page 44. 

still rolldigital clock

animation

video still

crawl

background
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Workflow 1 Select the page, then switch to the Regions window. 

To do this, you can double-click on the page in the Pages window or 
Tree View list. See “Open Page in Regions Window” on page 36.

2 Draw regions on the page. 

To do this, select a region tool (Still, Crawl, etc.), then click and drag 
the mouse cursor across the workspace. See “Draw Regions On the 
Page” on page 38.

3 Adjust region settings as needed. See “Adjust Region Settings” on 
page 46.

1

Open
a new or 
existing 
infocast.
 

2
The infocast
opens in the
Pages
window. By 
default,
a new page
is added to
new 
infocasts.
Click on the
New button
to add a new 
page as 
needed.
 

Double-click
on a page 
to add regions.

3b

The page
opens in the
Regions window.
Select a region
tool, then draw a
region in the 
workspace. 
Draw
more regions.

Double-click on a 
region to add
content.

4b

The region 
opens in the
Items window.
Select a content
editor from the list, 
then click on the
Add button next to it.

Add content in
editor.

5

Set playback sequence
for pages and region items.

6
Click on Play to output infocast.

3a 4a

4c
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Open Page in Regions Window
To add regions to a page layout, first select the page that you want to add regions to and switch to the 
Regions window. 

Select a Page To select a page, click on the page in the Page Library or in the Tree View 
list. Click once to select the page. Double-click to open the page. The page 
opens in the Regions window.

Switch to 
Regions 
Window

With the page selected in the Pages window, switch to the Regions window 
using one of these methods.

• Double-click on the page in the Page Library or in the Tree View list.
• Click on the Regions button on the main toolbar.
• Click on the Edit button the Pages toolbar.
• Select Tools→Regions.
• Select Pages→Edit Regions.
• Right-click on a page in the Pages window, then select Edit Page from the 

menu. 
• If you already created regions on a page, click on a region in the Tree 

View list or Preview window at the bottom of the screen. 

select page in Tree View list or Pages window

switch to Regions window
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The page opens in the Regions window, which contains the Region draw 
tools, the Regions page layout workspace, and a region Details panel. 

Region Draw tools 
Regions workspace

selected page
Region Details

Pointer tool
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Draw Regions On the Page
After you selected the page that you want to add regions to and switched to the Regions window, draw 
regions on the page layout to which you later add content. You can display the safe title area and grid 
lines on your workspace to help you position your regions.

Workflow To draw regions on a page:

1 Select a region tool in the Regions window. See “Select a Region 
Tool” on page 40. 

2 Click in the workspace, then drag the mouse cursor across the 
workspace to draw the region. You can also draw a background or a 
pop-back region. See “Draw Regions” on page 43. 

Display Safe Title Area

When creating layouts, it’s a good idea to keep your items within the safe 
title area, to avoid having items cut off on certain monitors. The safe title 
area marks a safe area for displaying items on most output screens. The 
default safe title area is set at 86% of the layout window. 

To display the safe title area:

select tool draw region
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1 Use the Pointer tool in the Regions tools list to click on an area 
in your Regions workspace that is not occupied by a region item. 
Alternately, you can select Regions→Show Safe Title Area.

2 In the Page Details panel below the workspace, check the Show Safe 
Title Area checkbox to mark the layout window with a green boundary.

Note: If a region is selected, the safe title options are not displayed.

3 To change the safe title area boundary, use one of these methods.

• Click on the Default button to set the safe title area back to 86% of 
the screen. 

• Click on the Slide Bar radio button to enable the slide bar. Use the 
Slide Bar or Percent field to set the safe title area as a percentage 
of the screen.

• Click on the radio button next to the Left field to enable these 
fields. Enter values in the Left, Right, Top, or Bottom fields to set 
the boundary a certain number of pixels from the left, right, top, 
and bottom of the screen. 

Display Grid Lines on Regions Window

To display grid lines on the Regions window to help you draw and line up 
your regions, select Regions→Show Grid Lines.
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Select a Region 
Tool

In the Regions window, select the region tool that corresponds to what you 
want to create, using one of these methods.

• Select a tool on the left side of the screen. You can also select the Pop-
Back Region tool from the Regions window menu, as explained in “Pop-
Back Region Tool” on page 42.

• Select Regions→Add Region, then select the region tool from the 
second command list. 

Note: To see the name of buttons and tools on the screen, hold 
the mouse cursor over the item. If you don’t see text come 
up, select Help→ToolTips to activate ToolTips.

Pointer Tool

The pointer tool is automatically selected when you click on a region. Use 
it to select, size, and move the region, or to change region details.

select tool draw region
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 Still Region Tool

Draw a Still region when you want to play non-moving text and/or graphics, 
such as titles or logos, in a region. The text can be text that you type in or 
text from an external data source. You can create as many lines of text as 
you want and are able to display at a time in the selected region. You can 
connect each line to a different data source. See “Add Still Items” on 
page 67.

Crawl Region Tool 

Draw a Crawl region when you want to display text and graphics that move 
horizontally across the region. The text can be text that you type in or text 
from an external data source. You can display up to 3 pre-determined 
characters (space, period, comma, hyphen, or ellipsis) and/or a graphic 
image, animation, or video clip before each text entry. You can format the 
background color. See “Add Crawl Items” on page 115.

Roll Region Tool 

Draw a Roll region when you want to display text and graphics that move 
up or down the region. The text can be text that you type in or text from an 
external data source. You can format the background color. See “Add Roll 
Items” on page 127.

Animation Region Tool

Draw an Animation region when you want to play animated text and 
graphics in a region. You can import animations. You can also create a 
layout of text and graphics and then animate it. The text can be text that 
you type in or text from an external data source. See “Add Animation 
Items” on page 143.

Digital Clock Region Tool 

Draw a Digital Clock region when you want to play a real-time digital clock 
that displays local or offset time, or a timer that counts up or down. 
Display a date or text before and/or after the clock, or on its own without 
the clock. See “Add Digital Clocks” on page 157.

Video Region Tool 

Draw a Video region when you want to play a video clips or live video in 
the region. You can expand or shrink the video, or any other region item, as 
explained in “Set Triggers” on page 226. See “Add Video Items” on 
page 169.
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Analog Clock Region Tool 

Draw an Analog Clock region when you want to play an imported real-time 
analog clock in a region. InfoCaster provides a selection of analog clock 
files that you can use. InfoCaster also provides an analog clock building 
utility. See “Add Analog Clocks” on page 187.

Audio Region Tool

Draw an Audio region when you want to play audio that is independent of 
other region content. You can draw an audio region anywhere in the layout. 
Adjust the volume, add a delay, and select a frequency (Play Once or 
Loop). See “Add Audio Items” on page 193.

Temperature Probe Region Tool

Draw a Temperature Probe region when you have a temperature probe 
connected to your system and want to display its current temperature 
reading in the region. See “Add Temperature” on page 197.

Pop-Back Region Tool

Pop-back regions set the size that a region can expand or contract to when 
you apply a trigger. Select Regions→Pop-Back Regions in the Regions 
window. The Pop-Back Region tool becomes available. See “Draw a Pop-
Back Region” on page 44 for more information. To use a pop-back region, 
see “Set Triggers” on page 226.



InfoCaster 43

A
dd

R
egions

Draw Regions With the region tool selected, click in the Regions workspace, then drag 
the mouse cursor across the workspace. The region placeholder is 
displayed in the workspace.

Repeat these steps until you have drawn all the regions in your page layout. 

To reposition the region or make any other changes to the region, see 
“Adjust Region Settings” on page 46. 

select tool draw region
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Draw a Background

You can create a background using any of the regions types. To create a 
background:

1 Draw a region in the layout window that covers the entire area.

2 Select Regions→Arrange Region→Send to Back to move the region 
behind all other regions.

3 Open a content editor and add content.

Draw a Pop-Back Region

You can expand or shrink any region during output by creating a pop-back 
region, then setting a trigger. To draw a pop-back region:

1 Select Regions→Pop-Back Regions in the Regions window.

The Region Tools change to display the Pop-Back Region tool. 
Other regions that you have drawn can be seen but cannot be selected. 

2 Click on the Pop-Back Region tool to select it.

3 Click in the Regions workspace and drag the mouse cursor across the 
workspace to draw your pop-back region. 
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You can draw as many pop-back regions as you want to use on your 
infocast page. For example, you can draw a full-size region to expand a 
region to full-size or you can draw a small over-the-shoulder region to 
shrink a region to that size.

4 In the Details panel below the workspace, you can give the region a 
unique name to make it easier to identify it in a list.

To exit the Pop-Back Regions window and be able to select other regions, 
select Regions→Pop-Back Regions again, to remove the checkmark. 

To apply a pop-back region, see “Set Triggers” on page 226. 

To add content to your regions, see “4. Add Items to Regions” on page 51.
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Adjust Region Settings 
In the Details panel below the Region workspace, you can change the size, position, and other 
settings for the selected region. These options are the same for all the region types.

Rename 
Regions

To give your regions descriptive names, enter a new name for the selected 
region in the Name field below the Regions workspace. Press ENTER to 
apply the change. Alternately, you can select Items→Rename Item. 

Reposition 
(Move) Regions

You can change the position of regions on your page layout in two ways.

• Enter values in the From Left or From Top field below the Regions 
workspace for precise positioning. This places the selected region a 
certain number of pixels away from the left or top of the layout.

• Drag the region item in the Regions workspace using the Pointer 
tool. 

Resize Regions You can change the size of regions on your page layout in two ways.

• Enter pixel values for the selected region in the Width or Height field 
below the Regions workspace for precise positioning.

• Drag the region’s corner or side border in the Regions workspace 
using the pointer tool. 

Details panel
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Delete Regions To delete the selected region, use one of these methods.

• Right-click on the region, then select Delete Region from the menu.
• Select Regions→Delete Region.

Lock Region 
Size & Position

To prevent the selected region from being resized or repositioned, you can 
lock the region using one of these methods.

• Check the Lock Size and Position checkbox below the Regions 
workspace. 

• Select Regions→Lock Region. 

You can still switch to the Items window and edit content when a region is 
locked. 

To unlock a region, remove the checkmark. 

Adjust 
Overlapping 
Regions

To change the forward and backward order of regions in your page layout, 
use one of these methods.

• Drag the region up and down in the Tree View list. Drag the region up to 
move the region in front of other regions, or down to move the region 
behind other regions.

• Use the options in the Regions→Arrange Region menu.

Designate 
Player 
Permissions

If you purchased InfoCaster Player licences for additional sites, click on the 
Region Permissions button below the Regions workspace. In the Region 
Permissions dialog box, you can set which regions of the page the sites can 
modify. 

Log Region 
Playback

To create a log file of all the times a region is aired, check the Log This 
Region checkbox in the Details panel below the Regions workspace. 

InfoCaster creates a log file that includes the player name, page name, 
region name, item name, start date, start time, stop date, stop time, and 
duration. A new log file is created each day, so the playback of an entire 
day is stored in one log file. 

To view a log file, or change default log settings, such as the status of 
automatic logging, the log file location, or the number of days a log file is 
kept on your system, see “Log Files” on page 245.
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Preview Regions (Page Layout)
As you add content to the regions of your page layout, you can view how your layout looks in the 
following ways in the Regions window.

• Display only the region borders of the 
page layout. This is the standard view. 

To display grid lines or the video safe 
title area, See “Display Grid Lines on 
Regions Window” on page 39 or 
“Display Safe Title Area” on page 38.

• Display the region borders with a still 
image representing the content within 
each region. Select 
Regions→Preview All Regions. 
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• Display the region borders with a 
still image in selected regions only. 
Select the region, then select 
Regions→Preview Region.

To remove the still image display 
from a region, select the region, 
then deselect Regions→Preview 
Region. 

• Display each region with a still 
image representing the content but 
without region borders. Select 
Regions→Show Page Without 
Adornments. 
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4. Add Item to Regions

Add Region Items Overview
Once you have drawn regions (content placeholders) on a page in your infocast, you can add content 
(region items) to the regions. 

Each region opens in the Items window. A 
unique set of content editors for each 
region type becomes available in the Items 
window. You use the content editors to 
create a region item. You can add multiple 
items to a region. You can add a blank item 
to the region to make the region 
transparent during playback. 

When you edit the content of an item, you 
sometimes can select a different editor to 
open the item in.

When you schedule the playback sequence 
for the region, you can set when you want 
each item to air in the region. For example, 
the video region in our example here plays a butterfly video region item followed by a space video 
region item. 

Workflow 1 Open an infocast. See “1. Open an Infocast” on page 17. 

2 Add pages to the infocast. See “2. Add Pages to Infocast” on page 25. 

3 Add regions to the page. See “3. Add Regions to Page” on page 33.

4 Add content (region items) to each region. 

a Select the region you want to add content to, then switch to the 
Items window. See “Open Region in Items Window” on page 54.

b Select the editor from the Editor list in the Items window, then click 
on the Add button to open it. See “Open a Content Editor” on 
page 56.

c Add content in the editor. The next 9 chapters describe how to add 
content using all of the available content editors for each of the 9 
region types. See “Add Content with the Editor” on page 62. The 
basic workflow is as follows.
• Add content.
• Format the content. 
• Add audio if applicable.
• Save your work in the editor. 

To preview a still image of your region items in a page layout, see 
“Preview Regions (Page Layout)” on page 48.
After you add content to your region, you can do the following.
• Add more region items to this region if needed, as explained in 
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“Add More Items” on page 63.
• Add items to other regions, as explained in “Add Region Items 

Overview” on page 52.

5 Schedule the playback sequence(s) for your regions and your pages. 
See “5. Schedule Playback Sequences” on page 201.

6 Output the infocast. See “6. Output” on page 233.

1

Open
a new or 
existing 
infocast.
 

2
The infocast
opens in the
Pages
window. By 
default,
a new page
is added to
new 
infocasts.
Click on the
New button
to add a new 
page as 
needed.
 

Double-click
on a page 
to add regions.

3b

The page
opens in the
Regions window.
Select a region
tool, then draw a
region in the 
workspace. 
Draw
more regions.

Double-click on a 
region to add
content.

4b

The region 
opens in the
Items window.
Select a content
editor from the list, 
then click on the
Add button next to it.

Add content in
editor.

5

Set playback sequence
for pages and region items.

6
Click on Play to output infocast.

3a 4a

4c

1)Open Infocast.  2)Add page.  3)Add regions.  4)Add items.  5)Sequence.  6)Output.
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Open Region in Items Window
To add content to your regions, select the region that you want to add region items to, then switch to 
the Items window.

Select a Region To select a region, use one of these methods.

• Click on the region in the Regions Library.
• Click on a region in the Tree View list.
• Click on a region in the Preview window. 

select region in Tree View, Preview, or Regions window

switch to Items window
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Switch to Items 
Window

To switch to the Items window, use one of these methods.

• With the region selected, click on the Items button on the main toolbar.
• Select Tools→Items.
• Double-click on the region in the Page Library, in the Tree View list, or in 

the Preview window. 
• Select Regions→Edit Item Sequences to switch to the Items window to 

schedule the region’s playback sequence, 

About the Items Window

The selected region opens in the Items window. The Items window contains 
the following components.

• List of content editors for that region type.
• Toolbar.
• Items Library that displays all the items in the region.
• Sequencer with options and its own toolbar. 

content editor list
Items Sequencer

Items toolbar

Items Library
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Open a Content Editor
You use a content editor to add content to a region and to edit the content. Most of the region types 
(Still, Crawl, etc.) have more than one content editor so you to add different kinds of region type 
content. You can add as many items as you want in a region. 

To Add Items 1 Select a region in your infocast page layout, and switch to the Items 
window. See “Open Region in Items Window” on page 54 for details.

2 Select the content editor from the drop-down list in the Items 
window. Alternately, you can select Items→Add Item, then select the 
editor from the list.

3 Click on the Add button beside the content editor list. The content 
editor opens. A description of the editors for each region type is 
provided after the next section below. Also, each of the next 9 
chapters documents a region type and all of the content editors that 
pertain to it.

About Blank 
Items

Each editor list contains a Blank Item option. Select Blank Item to create a 
blank region item. Add the blank region item to your playback sequence to 
output no content for the set duration without otherwise interrupting your 
sequence. See “5. Schedule Playback Sequences” on page 201 for details on 
sequences.

select content editor
click Add
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To Edit Items To open a content editor for the purpose of editing a region item, use one 
of these methods.

• Double-click on the item in the Item Library. 
• Click on the item, then click on the Edit button in the Items window 

toolbar. 
• Click on the item, then select Items→Edit Item With, and select the 

editor from the list.

The editor that was used to create the content opens.

In some cases, like when you create an Animation item in the TitleMotion 
editor, you can click on the item, select a different editor from the editor 
list, then click on the Edit button next to the editor list. You can then edit 
the content in a different editor.

Still Editors There are 4 Still region content editors. 

Title Quick Editor 

Add text to a Still region on your layout. The text 
can be text that you type in or text from an external 
data source. You can create as many lines of text as you want and are able 
to display at a time in the selected region. You can connect each line to a 
different data source. Format the item with a template or with custom 
settings. Add audio. See “Title Quick Editor” on page 71.

Table Quick Editor

Quickly display information from an external data source during output. 
Link text lines in Still region items that were created in TitleMotion to 
columns of external data. See “Table Quick Editor” on page 100.

TitleMotion

Create a layout of text and graphics for your region item. You cannot adjust 
audio settings in TitleMotion. You can create templates in TitleMotion. The 
templates created in TitleMotion are available in the Quick Editors. See 
“TitleMotion” on page 109.

Graphic Importer

Import a still image from a variety of file formats into the selected region. 
You can set the graphic to fill the entire Still region or to maintain the 
image aspect ratio. Attach audio to graphics using the audio options on the 
Audio tab. See “Graphic Importer” on page 111.
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Add Blank Item

To make the region transparent during playback, add a blank item to the 
sequence. See “About Blank Items” on page 56.

Crawl Editors Crawl Quick Editor 

Create a simple line of crawling text in your 
Crawl region. The text can be text that you 
type in or text from an external data source. 
Link the text line in Crawl region items that 
were created in TitleMotion to external data. 
See “Crawl Quick Editor” on page 118.

TitleMotion

Create a layout of text and graphics for your region item. You cannot adjust 
audio settings in TitleMotion. You can create templates in TitleMotion. The 
templates created in TitleMotion are available in the Quick Editors. See 
“TitleMotion” on page 125.

Add Blank Item

To make the region transparent during playback, add a blank item to the 
sequence. See “About Blank Items” on page 56.

Roll Editors Roll Quick Editor 

Create rolling text in your Roll region. The 
text can be text that you type in or text from 
an external data source. You can format with 
either a template or custom settings. See 
“Roll Quick Editor” on page 131. 

Table Quick Editor

Quickly display information from an external data source during output. 
You can create as many columns of text as you want and are able to display 
at a time in the selected region. You can connect each column to a different 
data source. Link the text line in Roll region items that were created in 
TitleMotion to columns of external data. See “Table Quick Editor” on 
page 137.
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TitleMotion

Create a layout of text and graphics for your region item. You cannot adjust 
audio settings in TitleMotion. You can create templates in TitleMotion. The 
templates created in TitleMotion are available in the Quick Editors. See 
“TitleMotion” on page 141.

Add Blank Item

To make the region transparent during playback, add a blank item to the 
sequence. See “About Blank Items” on page 56.

Animation 
Editors

TitleMotion 

Use TitleMotion’s CG module to create your 
layout that consists of text and graphics. 
Then, switch to TitleMotion’s Animation 
module to add motion to your objects. You 
can create as many lines of text as you want 
and are able to display at a time in the selected region. You can connect 
each line to a different data source in the Animation Quick Editor. See 
“TitleMotion” on page 147.

Animation Quick Editor

Quickly edit text in animations that you created in TitleMotion. You can 
connect each line that you created in TitleMotion to a different data source. 
Set audio options. See “Animation Quick Editor” on page 150.

Animation Importer

Import an animation into the selected region. Attach or adjust audio using 
the audio options on the Audio tab. See “Animation Importer” on page 153. 

Add Blank Item

To make the region transparent during playback, add a blank item to the 
sequence. See “About Blank Items” on page 56.

Digital Clock 
Editors

Digital Clock Quick Editor 

Create real-time clocks displaying local or 
offset time. The time display is based on 
your computer clock. See “Digital Clock 
Quick Editor” on page 160.
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Digital Timer Quick Editor

Create a digital timer that counts up or down. Display the day, month, and 
date. See “Digital Timer Quick Editor” on page 165.

Add Blank Item

To make the region transparent during playback, add a blank item to the 
sequence. See “About Blank Items” on page 56.

Video Editors Video Clip Quick Editor 

Import a video file into the selected region. 
See “Video Clip Quick Editor” on page 172.

Live Video Quick Editor

Set the region to display live video. See “Live Video Quick Editor” on 
page 180.

Add Blank Item

To make the region transparent during playback, add a blank item to the 
sequence. See “About Blank Items” on page 56.

Analog Clock 
Editor

Analog Clock Quick Editor 

Use the Analog Clock Quick Editor to 
import an analog clock into your layout. By 
default, the time displayed by the clock is 
the local time provided by your computer 
clock. See “Analog Clock Items Overview” on page 188.

Add Blank Item

To make the region transparent during playback, add a blank item to the 
sequence. See “About Blank Items” on page 56.

Audio Editor Audio Quick Editor 

Use the Audio Quick Editor to add audio to 
the page layout to play when you output the 
audio region. Adjust the volume, add a 
delay, and select a frequency (Play Once or 
Loop). See “Audio Items Overview” on page 194.
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Add Blank Item

To make the region transparent during playback, add a blank item to the 
sequence. See “About Blank Items” on page 56.

Temperature 
Probe Editor 

Temperature Probe Quick Editor 

If you have a temperature probe connected 
to your system, use the Temperature Probe 
Quick Editor to display current temperature 
readings in your layout. Format the item with 
custom settings.

Add Blank Item

To make the region transparent during playback, add a blank item to the 
sequence. See “About Blank Items” on page 56.
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Add Content with the Editor
Use the options on the content editor that you selected to add content to your region, to format the 
content, and to attach audio to the region item when available. 

The next 9 chapters describe the content editors for each region type. Refer to the following 9 
chapters for details on using the content editors. 

• For Still Regions, see “Add Still Items” on page 67.

• For Crawl Regions, see “Add Crawl Items” on page 115.

• For Roll Regions, see “Add Roll Items” on page 127.

• For Animation Regions, see “Add Animation Items” on page 143.

• For Digital Clock Regions, see “Add Digital Clocks” on page 157.

• For Video Regions, see “Add Video Items” on page 169.

• For Analog Clock Regions, see “Add Analog Clocks” on page 187.

• For Audio Regions, see “Add Audio Items” on page 193.

• For Temperature Probe Regions, see “Add Temperature” on page 197.

Your content (region item) is added to the Item Library. 
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Add More 
Items

To add another item to the same region, select a content editor, then click 
on the Add button on the toolbar. Add content in the editor that opens.

You can create more region items in the same region when you want the 
content in that region to change during output. The items can loop during 
playback. For example, you could add multiple items to a Still region 
displaying movie titles and times. The movie items would loop 
continuously, displaying one list of movie times followed by the next list of 
movie times.

About External 
Data Sources

You can link text lines in Still, Crawl, Roll, and Animation region items to 
the following types of external data sources.

• A text (.txt) file on your hard drive. For instructions on how to create a 
text file, see “Create Single Column Text File” on page 251.

• An HTTP or FTP page on the internet.
You can link to a text file that has been made available to you through an 
HTTP or FTP internet site. You need to know the text file name and the 
URL internet address, starting with http:// or ftp://, before you start. 

• Text from an XML/RSS source on the internet.
RSS is an XML-based format that allows the syndication of lists of 
hyperlinks, along with other information, or metadata. An RSS feed 
contains a list of items, each of which is identified by a link. Each item 
can have any amount of metadata associated with it. The most basic 
metadata supported by RSS includes a title for the link and a description 
of it. 
To link a text line to an RSS feed, you need to know the URL of the XML 
or RSS feed, starting with http://, before you start. 

• Text from an ODBC data source.
An Open Database Connectivity (ODBC) data source is a database file 
that was created in software that complies with the ODBC protocol, 
such as MS Access, MS Excel, or MS Notepad, and that is added to an 
ODBC system list. The ODBC protocol allows different programs to 
share information held in database applications. Use the ODBC option 
to feed information directly into your InfoCaster layout. 
To link a text line to an ODBC data source, you need to know the ODBC 
database and column names that you want to use before you start.
For instructions on how to create a text file or ODBC data source, see 
“Create ODBC Data Source” on page 252.

• A text file that you convert to an ODBC data source.

About Data Tags 
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Every text line in a Still, Crawl, Roll, or Animation region item that you 
create in a Quick Editor or TitleMotion editor contains a data tag. A data 
tag is a name label that InfoCaster uses to link the text line to an external 
data source. 

During output, the selected content of the external data source is displayed 
in the text line. External text displays one entry at a time for stills and 
animations. You set the item duration and transition using the options in 
the sequence list, as explained in “5. Schedule Playback Sequences” on 
page 201. Rolls and crawls gradually display all the selected entries from 
the external data source as the item moves across the screen. 

A Crawl item contains only one text line or data tag. A Still, Roll, and 
Animation region item can contain more than one text line, each with its 
own data tag. Each text line can be linked to a different data source.

View Data Tags

By default, the Table Quick Editor (for stills and rolls) and TitleMotion 
display the data tags in the workspace. 

To display the data tags in a 
(Region Type) Quick Editor, check 
the Show Tags checkbox on the 
Content tab. The tags are 
displayed to the left of the text 
fields in the editor. 

Data Tag Names

By default, InfoCaster names the data tags as follows.

• The (Region Type) Quick Editors name the data tags Line 1, Line 2, and 
so on. 

• The Table Quick Editor, which is available for stills and rolls, names the 
cells using the row/column protocol, 1-1, 1-2, 2-1, 2-2, and so on. 

• TitleMotion automatically names the data tags in Still and Animation 
items “Line1”, “Line2”, and so on, and names data tags in rolls and crawls 
“1-”, and so on. To link text lines in a Still or Animation item created in 
TitleMotion to more than one column of your external data, the data tags 
names of your text lines must follow row/column protocol, 1-1, 1-2, 2-1, 2-
2, and so on. You cannot edit tag names saved in a template.
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Change Item 
Display

To save space in the Items window, you can change the size of the items 
displayed in the Item Library and in the Items Sequence list. 

Change Display of Item Library

To change the size of the items displayed in the Item Library, select 
Items→Show Item Library As, then select one of the following.

• Large Thumbnails.

• Small Thumbnails.

• Text Only.

Change Display of Items Sequencer

To change the size of the items displayed in the Items Sequence list, see 
“Display Panel, Options, List” on page 207.

Duplicate Item To create a copy of the entire item:

1 Select the region item in the Item Library.

2 Click on the Duplicate 
button on the Items 
toolbar. Alternately, 
you can select 
Items→Duplicate 
Item. 

If you can’t see the 
button, change the size 
of the Sequence list by 
clicking on the Brief View button (double arrows) above the Sequence 
Settings. See “Display Panel, Options, List” on page 207 for details. 
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Rename Item 1 Select the region item in the Item Library.

2 Click on the Rename button on the Items toolbar. 

If you can’t see the button, change the size of the 
Sequence list by clicking on the Brief View button 
(double arrows) above the Sequence Settings. See 
“Display Panel, Options, List” on page 207 for details. 

3 In the Rename Item dialog box that opens, rename the 
item.

Delete Item To permanently delete an item from a region, right-click 
on the region item in the Item Library, then select Delete 
Item from the menu that comes up. 

Alternately, you can select Items→Delete Item in Library.

To delete an item from your region sequence, see “Delete 
Items from Sequence” on page 218.

Preview 
Regions Layout

To preview a still image of your region items in a page layout, see “Preview 
Regions (Page Layout)” on page 48.



Add Still Items
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Add Still Items

Still Items Overview
Still regions play non-moving text and/or graphics, such as titles or 
logos, in a region. You can create as many lines of text as you want and 
are able to display at a time in the selected region. You can connect 
each line to different data sources. The data can be text that you type in 
or text from an external data source. 

The external data source can be a text file on your hard drive or at an 
HTTP or FTP internet site, text from an XML/RSS source, text from an 
ODBC data source, or a text that you convert to ODBC format. See “About External Data Sources” on 
page 63 for details. For instructions on how to create a text file or ODBC data source, see “Appendix” 
on page 243.

There are 4 Still region content editors. This chapter contains instructions on how to use them. 

Note that because Crawl, Roll, and Animation regions use similar editors, this chapter refers to them 
when required.

• Title Quick Editor 

Add text to a Still region on your 
layout. The data can be text that 
you type in or text from one column 
of an external data source. 

You can create as many lines of text 
as you want and are able to display 
at a time in the selected region. You 
can connect each line to one 
column of different data sources. 

Add text on the Content tab. 
Format the item with a template or 
with custom settings on the 
Formatting tab. Add audio on the 
Audio tab. See “Title Quick Editor” 
on page 71.
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• Table Quick Editor 

Quickly display information from 
multiple columns of an external data 
source during output. Add content 
on the Content tab. Format headers 
on the Headers tab. Format content 
font on the Font Formatting tab. Add 
audio to the region item on the 
Audio tab. See “Table Quick Editor” 
on page 100. 

• TitleMotion

Create a layout that consists of text 
and graphics for your region item. 

Your text content can be text 
that you type in or text that 
you link to from an external 
data source. You create the 
layout in TitleMotion, but 
apply the links in the Table 
Quick Editor. 

To add text or graphic 
content, select a tool from 
the Tools palette on the right 
side of the screen. The first 
row of tools are for text. The 
other tools draw graphics. 
Then, enter your text or drag 
your mouse in the workspace 
to draw your shape.

Format your content using 
the tabs below the 
workspace. You cannot add 
audio in TitleMotion. 

You can create templates in 
TitleMotion that become 
available in the Quick Editors. See “TitleMotion” on page 109. 
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• Graphic Importer 

Import a still image from a variety of file 
formats into the selected region. You 
can set the graphic to fill the entire Still 
region or maintain the image aspect 
ratio. Add content on the Content tab. 
Add audio on the Audio tab. See 
“Graphic Importer” on page 111. 

• Add Blank Item

To make the region transparent during 
playback, add a blank item to the 
sequence. See “About Blank Items” on 
page 56.

Workflow 1 Open an infocast. See “1. Open an Infocast” on page 17. 

2 Add pages to the infocast. See “2. Add Pages to Infocast” on page 25. 

3 Add regions to the page. See “3. Add Regions to Page” on page 33.

4 Add content (region items) to each region. 

a Select the region you want to add 
content to, then switch to the Items 
window. See “Open Region in Items 
Window” on page 54.

b Select the editor from the Editor list in 
the Items window, then click on the 
Add button to open it. See “Open a 
Content Editor” on page 56 for details.

c Add content in the editor. The 
following sections in this chapter describe how to add content to 
the selected region using each available editor. The basic workflow 
is as follows.
• Add content.
• Format the content. 
• Add audio if applicable.
• Save your work in the editor. 

To preview a still image of your region items in a page layout, see 
“Preview Regions (Page Layout)” on page 48. To add more region 
items to this region, see “Add More Items” on page 63. To add items 
to other regions, see “Add Region Items Overview” on page 52.

5 Schedule the playback sequence(s) for your regions and your pages. 
See “5. Schedule Playback Sequences” on page 201.

6 Output the infocast. See “6. Output” on page 233.

select 
editor

click 
Add
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Title Quick Editor 
Select the Title Quick Editor to add non-moving text in your region 
item. You can create as many lines of text as you want and are able to 
display at a time in the selected region. You can connect each line to 
different data sources. The data can be text that you type in or text from 
an external data source. See “About External Data Sources” on page 63 
for details.

Add content on the Content tab. Format the content with a template or 
with custom settings on the Formatting tab. Add audio on the Audio tab. 

Workflow 1 Select the region you want to add content to, then switch to the Items 
window. See “Open Region in Items Window” on page 54.

2 Select the editor from the Editor list in the Items window, then click 
on the Add button to open it. See “Open a Content Editor” on 
page 56 for details. 

3 Add text on the Content tab. See “Add Content on Content Tab” on 
page 72.

4 Switch to the Formatting tab to format the content with custom 
settings or with a template. See “Format on Formatting Tab” on 
page 93.

5 Switch to the Audio tab to play audio with your content. See “Add 
Audio on Audio Tab” on page 97.

select 
editor

click 
Add
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6 Save your work in the editor. You can also enter a name for the region 
item in the Name field, preview your content in the editor’s Preview 
window, and automatically add the item to the Sequence list using 
options on the main window. See “Save, Preview, Add to Sequence” 
on page 99.

To preview a still image of your region items in a page layout, see “Preview 
Regions (Page Layout)” on page 48.

To add more region items to this region, see “Add More Items” on page 63.

To add items to other regions, see “Add Region Items Overview” on 
page 52.

To schedule the playback sequence(s) for your regions and your pages, see 
“5. Schedule Playback Sequences” on page 201. 

To output the infocast, see “6. Output” on page 233.

Add Content on 
Content Tab

1 Add text that displays data from the following sources.

• Text that you type in. Refer to “Type In Text” on page 75 for 
instructions. 

• A text file on your hard drive. Refer to “Link to Text File on Hard 
Drive” on page 76 for instructions. 

• A text file at an HTTP or FTP site. Refer to “Link to Text File on 
Internet” on page 80 for instructions.

• A text file that you convert into an ODBC data source. Refer to 
“Link to Text File Converted to ODBC Data Source” on page 83 for 
instructions.

• Text from an XML/RSS source. Refer to “Link to XML/RSS Source” 
on page 88 for instructions.

• Text from an ODBC data source. Refer to “Link to ODBC Data 
Source” on page 91 for instructions.

Your text displays in the editor’s Preview window. To preview a still 
image of your region item in a page layout, see “Preview Regions (Page 
Layout)” on page 48. 
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2 Use the remaining options on the Content tab as needed. 

Text fields Displays region item text. You can also type text.
Press ENTER to add another line. If you are using a 
template (available on the Formatting tab), the 
template sets the maximum number of text lines. 

Show Tags 
checkbox

Displays the data tags for each line of text. See 
“View Data Tags” on page 64 for details.

External Data 
Source 
checkbox

Activates the Setup button. Select this option when 
you want to link to an external data source, such as 
a text file or ODBC data source on your hard drive 
or on the internet.

Setup button Becomes available when you select the External 
Data Source checkbox. Opens the Select Data 
Source dialog box, where you can link to an 
external text file or ODBC data source. You cannot 
edit external text in the Title Quick Editor.

Show All New 
Data at Least 
Once checkbox

Sets InfoCaster to display all data in the database 
once before it renders new data.
This option is recommended if your data is being 
updated constantly and it is important to show all 
data that is entered into the data source. 
If this option is not selected, InfoCaster renders 
and displays new data almost immediately as the 
data source is updated. 
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Add More Lines of Text

If you are not using a template to format your text, you can add more lines 
of text to the region item. You can create as many lines of text as you need 
in the Still region item. 

To create another text line, 
place your cursor anywhere in 
the Text field on the Content 
tab, then press the ENTER key. 

Press ENTER again to add 
another line. 

To resize the content, see 
“Format on Formatting Tab” on 
page 93.

To resize the region, see “Resize Regions” on page 46.

Create Headings

To add headings, such as ‘Temperature’ or ‘Weather’, to your item layout, 
use one of these methods.

• Create text lines in this editor and type in your content, as explained in 
“Type In Text” on page 75. Position your text line using the Top and Left 
position tools on the Formatting tab, as explained in “Format with 
Custom Settings” on page 94.

• Create your item in the Table Quick Editor. Add an extra column for the 
headings on the Content tab, then format the headings on the Headers 
tab. See “Table Quick Editor” on page 100 for details.

Log Note 
button

Opens a dialog box in which you can add 
comments that are displayed in the log file every 
time the item plays.
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Type In Text
To create your own text, type the text in the Text field on the Content tab. 

To add another line of text, press the ENTER key while the cursor is on a 
text line on the Content tab. Press ENTER again to add another line. 
Crawl items are restricted to a single line, but the text field scrolls while 
you type. See “Add More Lines of Text” on page 74 for details.

Note: The following characters are reserved and cannot be used in crawls: 
@, #, $, ^, or &.

Next, switch to the Formatting tab to format the text. Switch to the Audio 
tab to play audio with your content. Save your work in the editor. Set up 
your playback sequence, as explained in “Schedule Playback Overview” on 
page 202.
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Link to Text File on Hard Drive

To link a text line to a text file on your hard drive, you need to know the 
location and name of the file before you start. To create a text file, see 
“Create Text File” on page 251.

Select Text File Option 1 Select the Text File option as your external data source.

a Check the External Data Source checkbox on the Content tab. The 
Setup button becomes enabled. 

b Click on the Setup button next to the External Data Source 
checkbox. 

c In the Select Text Source dialog box that opens, select the Text File 
option.

d check Playback
options

e click OK

c select Text File

a check External Data Source checkbox

b click on Setup
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d Change the Playback options as required. 

Playback Options • Use the Retrieve options to set when InfoCaster checks the data 
source for new information. 
• Select the On Demand option to set InfoCaster to update items 

when the data source is updated. InfoCaster will not play any 
items when the data source is unavailable.

• Select the Every option to set how often InfoCaster should look 
for new information. InfoCaster will play the last available data 
if the data source is unavailable. Enter a time in the Every field. 
The time is displayed in the form hh:mm:ss 
(hours:minutes:seconds). 

• Use the Expire retrieved data options to set when InfoCaster will 
expire external data if the data source is unavailable. 
• Select Never if you want to play the last data that was available 

to InfoCaster when the data source is unavailable.
• Select Always if you want to expire the last data that was 

available to InfoCaster when the data source is unavailable. 
• Select After and enter a time to set how long the data source 

can be unavailable before the data is expired. The time is 
displayed in the form hh:mm:ss (hours:minutes:seconds).

• Use the When data expires option to set what InfoCaster displays 
when data is expired. 
• Select the Don't Show Item option if you do not want to play 

items that have expired.
• Select the Show Custom Message option if you want to display 

a message when the data has expired. Type in your custom text 
in the field.

e Click on OK to continue. 

2 In the Select Text Access 
dialog box that opens, select 
the Read Data Directly from 
Text File option, then click 
OK to continue.
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3 Select the text file.

a In the Select Text Sources dialog box, click on the Choose button 
in the field (text line) where you are adding the content. 

b In the Select Text Sources dialog box that opens, select the Local 
Files Browsing option.

c Click on OK to continue.
d In the Open dialog box that comes up, select your text file. 
e Click on Open.
f Back in the Select Text Sources dialog box, the name of the file you 

selected is displayed in the Field box and the text is displayed in 
the lower portion of the dialog box. Click on OK. 

a click on 
Choose

d select text 
file

b select Local Files Browsing

e click on 
Open

f click 
OK

c click on OK
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The data in your text file displays in the Still region during output of that 
Still region item for the duration that you set in your playback sequence.

To add another line of text, press the ENTER key while the cursor is on a 
text line on the Content tab. Press ENTER again to add another line. 
Crawl items are restricted to a single line, but the window scrolls while 
you type. See “Add More Lines of Text” on page 74 for more information.

Next, switch to the Formatting tab to format the text. Switch to the Audio 
tab to play audio with your content. Save your work in the editor. Set up 
your playback sequence, as explained in “Schedule Playback Overview” on 
page 202.
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Link to Text File on Internet

To link a text line to a text file that has been made available to you through 
an HTTP or FTP internet location, you need to know the text file name and 
the internet address, starting with http:// or ftp://. To create a text file, see 
“Create Text File” on page 251 for instructions.

1 Select the Text File option as your external data source. See “Select 
Text File Option” on page 76 for the 5-step instructions. 

2 In the Select Text Access 
dialog box, select the Read 
Data Directly from Text File 
option, then click OK to 
continue.

d check Playback
options

e click OK

c select Text File

a check External Data Source checkbox

b click on Setup
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3 Select the text file on the internet.

a In the Select Text Sources dialog box, click on the Choose button. 

b In the Select Text Sources dialog box that comes up, select the 
HTTP/FTP Files Browsing option.

c Click on OK to continue.
d In the Internet File Browser dialog box that opens, enter the 

address of the HTTP or FTP site in the Current Path box. The 
address must start with http:// or ftp://.

e Log on to the site by selecting one of the following Login options.

a click on 
Choose

b select HTTP/
FTP Files 
Browsing

h click on OK

d enter address

e select login type

f click on Go

g select file

c click on OK
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• If the site permits anonymous login, select the Anonymous 
option. 

• If the site requires a name and password, select the Name 
option, then enter a Name and Password.

f Click on the Go button next to Current Path to go to that site.
g The files at the HTTP or FTP site are displayed in the lower portion 

of the dialog box. Select the text file you want to link to. 
h Click on OK. 

4 Back in the Select Text Sources dialog box, the name of the file you 
selected is displayed in the Field box and the text is displayed in the 
lower portion of the dialog box. Click on OK to accept this file. 

To discard this file and open another one, click on the Back button to 
return to the previous dialog box.

Each line in your text file displays in the region during output of that region 
item for the duration that you set in your playback sequence. 

To add another line of text, press the ENTER key while the cursor is on a 
text line on the Content tab. Press ENTER again to add another line. 
Crawl items are restricted to a single line, but the window scrolls while 
you type. See “Add More Lines of Text” on page 74 for more information.

Next, switch to the Formatting tab to format the text. Switch to the Audio 
tab to play audio with your content. Save your work in the editor. Set up 
your playback sequence, as explained in “Schedule Playback Overview” on 
page 202.
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Link to Text File Converted to ODBC Data Source

To link to a text file that contains the data you want to display:

1 Select the Text File option as your external data source. See “Select 
Text File Option” on page 76 for the 5-step instructions. 

2 In the Select Text Access 
dialog box that opens, select 
the Read Data Through 
ODBC driver option, then 
click OK to continue.

d check Playback
options

e click OK

c select Text File

a check External Data Source checkbox

b click on Setup
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3 In the ODBC Text File Setup dialog box, select the file. 

a Click on the Browse button. In the Open dialog box, select your 
text file. The file name is displayed in the File Path field in the 
ODBC Text File Setup dialog box.

b In the Data Source Name field, enter a name to identify the text 
file. 

c Select the DSN option that matches the rights and permissions you 
want.
• Make Data Source Name specific to this user (User DSN). This 

is the default setting.
• Data Source Name is available to all users with access to the 

system (System DSN).
d Click on Next to continue.
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4 In the next segment of the ODBC Text File Setup, change the default 
settings as needed, then click Next to continue. The settings you can 
change are as follows.

• Data Delimiter:
If the text file has more than one column of data, choose the 
delimiter that separates the columns. Usually this is a comma or a 
tab, as determined by the application that generates your text file. 
If you select Custom, enter a custom delimiter in the Custom field.

• Character Set: 
Normally, you use ANSI.

• Set First Row as the Column Headers:
Check this if your text file has headers and you want to display 
them as headers in the item layout.

5 Your headings and data type are displayed in the third segment of the 
ODBC Text File Setup. A sample of your data layout is also displayed. 
Change the following settings as needed, then click Finish to 
continue. 

• If you do not have headers, enter a name for your column in the 
Column Name field. 

• Data Type. Select a data type for each column. You can choose Bit, 
Byte, Char(acter), Currency, Date, Float, Integer, LongChar, Short, 
or Single. 

• Data Maximum. If the data type is Characters, you can change the 
maximum width that you want to display, measured in pixels. The 
default is 255 characters. 



St
ill

s

86 InfoCaster

• Set. Click the Set button to accept the new settings. 

6 Back in the Select Text Source dialog box, select the correct Database 
and Table.

7 Click OK to continue.
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8 In the Select Database Items dialog box, select the table column that 
you want from the Source Column list. 

9 Click on the Refresh button to view the text. For further information 
on using this dialog box, see “3. Link ODBC to Item” on page 258.

10 Click on OK.

Each line in your text file displays during output of the region item for the 
duration that you set in your playback sequence. 

To add another line of text, press the ENTER key while the cursor is on a 
text line on the Content tab. Press ENTER again to add another line. 
Crawl items are restricted to a single line, but the window scrolls while 
you type. See “Add More Lines of Text” on page 74 for more information.

Next, switch to the Formatting tab to format the text. Switch to the Audio 
tab to play audio with your content. Save your work in the editor. 

9 click on Refresh

10 click on OK

8 select a table
heading from  
Source Column
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Link to XML/RSS Source

To link a text line to an RSS feed, you need to know the URL of the XML or 
RSS feed, starting with http://, before you start. For information on RSS 
feeds, see “About External Data Sources” on page 63.

1 Select the XML/RSS option as your external data source. 

a Check the External Data Source checkbox on the Content tab. The 
Setup button becomes enabled.

b Click on the Setup button next to the External Data Source 
checkbox. 

c In the Select Text Source dialog box that opens, select the XML/
RSS option.

d Change the Playback options as required. See “Playback Options” 
on page 77.

e Click on OK to continue. 

d check Playback
options

e click OK

c select XML/RSS

a check External Data Source checkbox

b click on Setup
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2 In the XML Data Source Setup dialog box, select the file as follows.

a Enter the URL of the XML or RSS feed, starting with http://.
b Enter a name in the XML Data Source Name field.
c Click OK to continue.
d In the Select Data Source Structure dialog box, select an item in 

the XML File Structure list that you want to display in your region.
e Click on the Left Arrow button. The selected item is added to the 

Column Name list.
f Click OK to continue.

3 Connect the file data to your Crawl region.

a Back in the Select Text Sources dialog box, click on the ODBC 
radio button to select it. 

b Select the file (that you just named) from the Database drop-down 
list.

c Click OK to continue.
d In the Select Database Item dialog box, select a table heading from 

the Source Column list.
e Click OK.

d select XML/RSS 
data

a enter XML or RSS file path

c click OKb enter a name

e add to Column
Name list

f click 
OK
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Each line in your RSS feed displays in the region during output of that 
region item for the duration that you set in your playback sequence. 

To add another line of text, press the ENTER key while the cursor is on a 
text line on the Content tab. Press ENTER again to add another line. 
Crawl items are restricted to a single line, but the window scrolls while 
you type. See “Add More Lines of Text” on page 74 for more information.

Next, switch to the Formatting tab to format the text. Switch to the Audio 
tab to play audio with your content. Save your work in the editor. Set up 
your playback sequence, as explained in “Schedule Playback Overview” on 
page 202.

a select ODBC option
d select Source Column

e
click OK

c
click OKselect database 

b
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Link to ODBC Data Source

To link a text line to an ODBC data source, you need to know the ODBC 
database and column names that you want to use before you start. The 
ODBC option is available for Still, Crawl, Roll, and Animation regions. For 
information on ODBC sources, see “About External Data Sources” on 
page 63. 

1 Check the External Data Source checkbox on the Content tab. 

2 Click on the Setup button next to the External Data Source checkbox. 

3 In the Select Text Source dialog box, select the ODBC option.

4 Select the database from the Database drop-down list. 

5 Select a table in that database from the Table list. 

check Playback
options

select ODBC option
select database
select table

1 select External Data Source checkbox

2 click on Setup

7 click
OK

3

5

4

6
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6 To change the playback options, see “Playback Options” on page 77.

7 Click on OK.

8 In the Select Database Items dialog box, select the table column that 
you want from the Source Column list. 

9 Click on the Refresh button to view the text. For further information 
on using this dialog box, see “3. Link ODBC to Item” on page 258.

10 Click on OK.

Each line in your text file displays during output for the duration that you 
set in your playback sequence. To display data from more than one column 
of an ODBC database table, press ENTER to create more lines of text. See 
“Add More Lines of Text” on page 74 for more information. 

Next, switch to the Formatting tab to format the text. 

9 click on Refresh

10 click on OK

8 select a table
heading from  
Source Column
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Format on 
Formatting Tab

You can format the Still region content on the Title Quick Editor’s 
Formatting tab using one of these methods.

• Format with a template. See “Format with Template” on page 93 below.
• Format with custom settings. See “Format with Custom Settings” on 

page 94.

You can also resize and reposition the region within the page layout, as 
explained in “Adjust Region Settings” on page 46.

Format with Template

1 Click on the Template radio button on the Formatting tab. 

2 Select a template from the drop-down list.

Only the template text is editable. You cannot change the text position, the 
text formatting, or add new text lines.

Note: You can create your own templates in TitleMotion. 

Next, switch to the Audio tab to play audio with your content. Save your 
work in the editor. Set up your playback sequence, as explained in 
“Schedule Playback Overview” on page 202.
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Format with Custom Settings

Custom formatting allows you to change your text attributes and enter new 
text lines in the editor.

1 Select the Custom radio button on the Formatting tab. 

2 Select any of the following options on the Formatting tab.

Font list Changes font.

Size field Changes font size.

B button Makes font bold.

i button Makes font italic.

u button Underlines font.

Tracking field Changes spacing between characters.

(Tracking) 
Width field

Changes width of each character.

Opacity field Changes font transparency level, where 0% 
represents complete transparency.
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Color chip Opens the Color Picker 
dialog box in which you 
change font color. 

Leading field Changes amount of space between text lines.

Position: Top, 
Left field

Positions the text in the region item X number of 
pixels from the top of the region or X number of 
pixels from the left side of the region. (To position 
the region item within the page layout, see 
“Reposition (Move) Regions” on page 46.)

Position: Top, 
Hidden, Bottom 
field

For Crawl regions. Positions text to the top, 
middle, or bottom of the region. (To position the 
region item within the page layout, see “Reposition 
(Move) Regions” on page 46.)

Alignment:
Left, Centre, 
Right button

Positions the text so that it aligns to the left, 
centre, or right in the region. 

Edge checkbox Adds an edge to the text. Click on the Color chip 
to select the edge color.

(Edge) Width 
field

Changes the edge width.

(Edge) Color 
chip

Opens the Color Picker dialog box in which you 
change edge color.

Background 
checkbox

Adds a solid background color to the region. Click 
on the Color chip to select color.

(Background) 
Opacity field

Changes background transparency level, where 0% 
represents complete transparency.

(Background) 
Color chip

Opens the Color Picker dialog box in which you 
change background color. 

Shadow 
checkbox

Enables the (Shadow) Custom button to add a 
shadow to the text.
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Next, switch to the Audio tab to play audio with your content. Save your 
work in the editor. Set up your playback sequence, as explained in 
“Schedule Playback Overview” on page 202.

(Shadow) 
Custom button

Opens the 
Custom 
Shadow 
dialog box in 
which you 
change the 
distance, 
softness, 
direction, and 
opacity of the 
shadow. 
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Add Audio on 
Audio Tab

The audio options allow you to attach an audio file to the region item. The 
audio plays whenever the region item plays in the sequence. Once the 
region item stops playing, the sound stops. Audio is available in all 
Content Editors except TitleMotion. 

To add audio to your region item:

1 On the Audio tab, check the Enable Audio checkbox to enable the 
audio options.

2 Click the Choose button, then open an audio file as prompted.

3 Use the remaining options on the Audio tab as needed.

Enable Audio 
checkbox

Enables the audio options, to add audio to the 
region item. 

Audio file field Displays the name of the audio file.

Choose button Opens a dialog box in which you select an audio 
file. The name of the audio file appears in the 
audio file field.

Shared Media 
checkbox

Enables the shared media option, to put the audio 
file in a central location for shared referencing. 
Then, select the shared media location from the 
drop-down list. 
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To disable all InfoCaster audio as the default setting, see “Audio Ducking 
Level” on page 249.

Next, save your work in the editor. Set up your playback sequence, as 
explained in “Schedule Playback Overview” on page 202.

Shared Media 
Sub-Folder 
drop-down list

Becomes available when you check the Shared 
Media checkbox. Select the shared media location 
from the following options.
• All. Adds the file to the default location 

C:\Shared Media, which is set in Preferences. See 
“Store Shared Media Files In” on page 248.

• Audio. Adds the file to a sub-folder called Audio 
under C:\Shared Media. 

• Type in a sub-folder name to create a new sub-
folder under C:\Shared Media. Adds the file to 
the new sub-folder.

Level field Adjusts the volume of the audio clip. Audio levels 
range from zero to 100. Zero mutes the audio 
completely. One is the lowest audible level and 100 
is the highest.

Delay field Delays the audio playback from the start of the 
region item by the set time, measured in 
hours:minutes:seconds.

Play Once radio 
button

Sets the audio file to play once. If you select this 
radio button, the audio file plays once and does not 
repeat.

Loop radio 
button

Sets the audio file to repeat during output when the 
region item is playing. 
The audio plays whenever the region item plays in 
the sequence. Once the region item stops playing, 
the sound stops.

Preview button Plays a preview of the audio file.

Enable Audio 
Ducking 
checkbox

Sets all other audio to duck (go quiet) when the 
current audio file is playing. Set the audio ducking 
level in Preferences. See “Audio Ducking Level” on 
page 249.
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Save, Preview, 
Add to 
Sequence

The following options are available on all the tabs in the content editor. 

Name field Displays the region item’s name. You can enter a name for 
a new region item only. The name displays in the Item 
Library, Items sequence list, and Tree View list. To rename 
existing region items, see “Rename Item” on page 66.

editor’s 
Preview 
window

Shows how the content displays in the region. To make 
your text fit in the region, you can resize the text on the 
Format tab, or you can resize the region in the Regions 
window as explained in the section “Adjust Region 
Settings” on page 46. 

Auto Add To 
Sequence
checkbox

Available for new region items only. When you click Save 
in the editor, this option automatically adds the item to the 
end of the currently selected playback sequence. This is a 
global setting that applies to all Quick Editors, so 
selecting the checkbox in one editor selects the checkbox 
in all editors. For details on sequencing, see “Schedule 
Playback Overview” on page 202.

Help button Opens the online help text for the editor.

Cancel button Cancels all selections since the last Save.

Save button Adds the region item content to the selected region on 
your page layout. After that, InfoCaster saves all changes 
to your infocast immediately to the default location as you 
work, so your project is always up-to-date. 
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Table Quick Editor
Select the Table Quick Editor to quickly create columns of data in your 
Still or Roll region item from text that you type in or from an external 
data source. You can create as many lines of text as you want and are 
able to display at a time in the selected region. You can connect each 
line to a different data source. See “About External Data Sources” on 
page 63 for details.

Add content on the Content tab. Format headers on the Headers tab. 
Format font on the Font Formatting tab. Add audio to the region item on the Audio tab. 

Workflow To add content to the selected region using the Table Quick Editor, the 
basic workflow is as follows.

1 Select the region you want to add content to, then switch to the Items 
window. See “Open Region in Items Window” on page 54.

2 Select the editor from the Editor list in the Items window, then click 
on the Add button to open it. See “Open a Content Editor” on 
page 56 for details. 

3 Set up your table columns and link to external data on the Content 
tab. See “Add Content on Content Tab” on page 102.

4 Format your column heading text on the Headers tab. See “Format on 
Headers Tab” on page 104.

select 
editor

click 
Add
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5 Format your row text on the Row Formatting tab. See “Format on Row 
Formatting Tab” on page 106.

6 Add audio on the Audio tab. See “Add Audio on Audio Tab” on 
page 97.

7 Save your work in the editor. You can also enter a name for the region 
item in the Name field, preview your content in the editor’s Preview 
window, and automatically add the item to the Sequence list using 
options on the main window. See “Save, Preview, Add to Sequence” 
on page 99.

To preview a still image of your region items in a page layout, see “Preview 
Regions (Page Layout)” on page 48.

To add more region items to this region, see “Add More Items” on page 63.

To add items to other regions, see “Add Region Items Overview” on 
page 52.

To schedule the playback sequence(s) for your regions and your pages, see 
“5. Schedule Playback Sequences” on page 201. 

To output the infocast, see “6. Output” on page 233.
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Add Content on 
Content Tab

Set up your columns on the Content tab. 

1 In the Number of Columns field on the Content tab, enter the number 
of columns you want your table to contain. 

2 Select the column heading from one of the following the options.

• To use the first row of data in each column of your database as the 
column headers, select the Use First Entry from Database radio 
button. 

• To create your own custom column headings, select the Custom 
radio button. The Column list and Header fields become available.

4 select text source

1 enter number of columns you want

2 select column heading

3 select Setup Data Source
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• Select a column from the Column drop-down list where you 
want your header to be displayed.

• Enter the name of the header in the Header field. 

3 Click on the Setup Data Source button to link your table to an 
external data source. 

4 In the Select Text Sources dialog box, select one of the following 
sources.

• a text file on your hard drive. See “Link to Text File on Hard Drive” 
on page 76 for instructions.

• a text file at an HTTP or FTP internet site. See “Link to Text File on 
Internet” on page 80.

• a text file that you can convert into an ODBC data source. See 
“Link to Text File Converted to ODBC Data Source” on page 83.

• text from an XML/RSS source. See “Link to XML/RSS Source” on 
page 88.

• an ODBC data source. See “Link to ODBC Data Source” on 
page 91.

5 Use the remaining options on the Content tab as needed.

Number of 
Columns field

Sets the number of columns of the data source that 
you want to display in the region item.

Header: Use 
First Entry from 
Database radio 
button

Displays the first row of data in each column of the 
data source as the column header.

Header: 
Custom radio 
button

Displays a custom column header for each column. 
Enables the Column Header options below.

Column drop-
down list

Becomes available when you select the Header: 
Custom radio button. Select a column from the list. 
The number of columns displayed is equivalent to 
the number in the Number of Columns field. 
Enter a name for the Selected column in the 
Header field. 

Header field Becomes available when you select the Header: 
Custom radio button. Enter a header name for the 
column you selected in the Column drop-down list.

Setup Data 
Source button

Opens the Select Data Source window, where you 
can link to your external data source. 
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Format on 
Headers Tab

Use the options on the Header tab to display column headings in your 
region item and format the font of the header.

1 On the Headers tab, check the Show Header checkbox to display 
column headings in your table.

2 Select your header formatting options on the Headers tab.

Show Header 
checkbox

Adds column headings to your table and enables 
the Header options.

Font drop-down 
list

Lists all the available fonts for your text. Select a 
font to apply the font to all the text in the region 
item. The external data displays with the selected 
font during output.

Size field Sets the size of the text.

B button Makes font bold.

i button Makes font italic.

u button Underlines font.

Tracking field Sets the space between text characters. The 
tracking applies to all characters in the region item.
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(Tracking) 
Width field

Sets the width of the characters. By default, text is 
set at 100% of its normal width. Increase the value 
to expand the text characters and decrease the 
value to compress the text characters. The width 
applies to all characters in the region item.

Opacity field Changes font’s transparency level, where 0% 
represents complete transparency. 

Color chip Opens the Color Picker dialog box in which you 
change font color. The color is applied to all text in 
the region item.

Edge checkbox Enables the Edge options, to add an outline to text 
characters. Use the (Edge) Width field to set the 
size of the edge. Click on the (Edge) Color Chip to 
select a new edge color.s

(Edge) Width 
field

Changes the edge width.

(Edge) Color 
chip

Opens the Color Picker dialog box in which you 
change edge color.

Shadow 
checkbox

Enables the (Shadow) Custom button to add a 
shadow to your text characters.

(Shadow) 
Custom button

Opens the Custom Shadow dialog box in which you 
change the distance, softness, direction, and 
opacity of the shadow.

Space Below 
Header 
checkbox 

Adds extra space (in pixels) between the bottom of 
the header and the top of the first column row. This 
space is added to the amount of leading that is set 
on the Row Formatting tab.

(Space Below 
Header) field

Adds the amount of space (in pixels) that you enter 
between the bottom of the header and the top of 
the first column row. This space is added to the 
amount of leading that is set on the Row 
Formatting tab.
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Format on Row 
Formatting Tab

Use the options on the Row Formatting tab to format the font of the row 
text. 

Font Menu list Lists available fonts for your text. Select a font to apply 
the font to all the text in the region item. The external 
data displays with the selected font during output.

Size field Sets the size of the text.

B button Makes font bold.

i button Makes font italic.

u button Underlines font.

Tracking field Sets the space between text characters. The tracking 
applies to all characters in the region item.

(Tracking) 
Width field

Sets the width of the characters. By default, text is set at 
100% of its normal width. Increase the value to expand 
the text characters and decrease the value to compress 
the text characters. The width applies to all characters in 
the region item.

Opacity field Changes font’s transparency level, where 0% represents 
complete transparency. 

Color chip Opens the Color Picker dialog box in which you change 
font color. 
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Next, switch to the Audio tab to play audio with your content. Save your 
work in the editor. 

Leading field Sets the distance between lines in the region item. The 
leading is applied to all text lines in the region item.

Alignment 
buttons:
Left, Centre, 
Right buttons

Positions the text so that it aligns to the left, centre, or 
right in the region. 

Edge checkbox Enables the Edge options to add an outline to all of your 
text characters. Use the (Edge) Width field to set the 
size of the edge. Click on the (Edge) Color Chip to 
select a new edge color.

(Edge) Width 
field

Changes the edge width.

(Edge) Color 
chip

Opens the Color Picker dialog box in which you change 
edge color.

Background 
checkbox

Adds a solid color background to the region item. The 
background displays in the region for the duration that 
the region item plays. Click the color chip to select a 
background color.

(Background) 
Opacity field

Changes background’s transparency level, where 0% 
represents complete transparency.

(Background) 
Color chip

Opens the Color Picker dialog box in which you change 
background color.

Shadow 
checkbox

Enables the (Shadow) Custom button to add a shadow 
to all of your text characters. 

(Shadow) 
Custom button

Opens the Custom Shadow dialog box in which you 
change the distance, softness, direction, and opacity of 
the shadow.

Column Widths 
bar 

Sets the width of the columns. By default, columns are 
spaced evenly. Click and drag a column separator to 
customize the width of the columns in your table.

Padding: Vert, 
Horiz fields

Sets space (in pixels) above and below (Vert) or to the 
left and right (Horiz) of the text. Enter a number in the 
Vert or Horiz fields to set the vertical or horizontal 
padding. 
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Add Audio on 
Audio Tab

The audio options on the Audio tab allow you to attach an audio file to the 
region item. The audio plays whenever the region item plays in the 
sequence. Once the region item stops playing, the sound stops.

The options on the InfoCaster Table Quick Editor’s Audio tab are identical 
to the options on the Still Regions Title Quick Editor’s Audio tab. Refer to 
“Add Audio on Audio Tab” on page 97 for instructions on how to add 
audio to your region item. 

Next, save your work in the editor as explained in “Save, Preview, Add to 
Sequence” on page 99. Add more items to your region as needed by 
selecting an editor and clicking on the Add button next to it, as explained 
in “Add Content with the Editor” on page 62. Set up your playback 
sequence, as explained in “Schedule Playback Overview” on page 202. 
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TitleMotion 

TitleMotion is a full-feature, broadcast quality character generator that 
you can use to create a layout that consists of text and graphics in your 
Still, Crawl, Roll, or Animation region items. Your text can be text that 
you type in, text that you import, or text from an external data source. 

Use the tools on the Tools palette to add your content. Format content 
with the tabs below the workspace. You cannot adjust audio settings in 
TitleMotion. To link your text line to an external data source, you must 
open the item in a Quick Editor. 

Create templates in TitleMotion that you can use in Still, Crawl, Roll, and Animation Quick Editors.

select 
editor

click 
Add

3 select Text or
Graphic plane

format content
with tab options

add content with
Tools Palette options

2 select template
(optional) 

451 select item
in playlist 
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Workflow 1 Select a region item layout slot in the TitleMotion play list to work on. 
By default, the first layout is already selected. 

To open the TitleMotion editor:
a Select the region you want to add content to, then switch to the 

Items window. See “Open Region in Items Window” on page 54.
b Select the TitleMotion editor from the Editor list in the Items 

window, then click on the Add button to open it. See “Open a 
Content Editor” on page 56 for details. 

2 Select another template from the list as needed. 

3 Select the Text Plane or Graphics (draw) Plane. 

4 Add text and graphic content. 

a Select a tool from the Tools palette. The first two tools are for text. 
The other tools draw items on the graphics plane.

b Add your text or draw your shape in the workspace. 
To link a text line to an external data source, finish designing your 
region item layout in TitleMotion, then open the item in a Quick 
Editor. You may need to rename the data tags in the TitleMotion 
CG module if you want to display entries from more than one 
column of an ODBC data source in a Still or Animation item, 
In the Quick Editor, select a text line, then check the External Data 
Source checkbox. Select your external data source. See “Table 
Quick Editor” on page 100. 

5 Format content. Use the tabs below the workspace. 

For further information on using TitleMotion, see TitleMotion’s Online 
Help menu or the TitleMotion manual that came with your InfoCaster 
product.

Next, save your work, as explained in “Save, Preview, Add to Sequence” on 
page 99. Set up your playback sequence, as explained in “Schedule 
Playback Overview” on page 202.
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Graphic Importer 

Use the Graphic Importer to import a still image (graphic file) from a 
variety of file formats into the selected region. 

Attach audio to graphics using the audio options on the Audio tab. 

Workflow To add content to the selected region using the Graphic Importer Editor, 
the basic workflow is:

1 Select the region you want to add content to, then switch to the Items 
window. See “Open Region in Items Window” on page 54.

2 Select the editor from the Editor list in the Items window, then click 
on the Add button to open it. See “Open a Content Editor” on 
page 56 for details. 

3 Add content on the Content tab. See “Add Content on the Content 
Tab” on page 112.

4 Add audio. See “Add Audio on Audio Tab” on page 114.

5 Save your work in the editor. You can also enter a name for the region 
item in the Name field, preview your content in the editor’s Preview 
window, and automatically add the item to the Sequence list using 
options on the main window. See “Save, Preview, Add to Sequence” 
on page 99.

select 
editor

click
Add
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To preview a still image of your region items in a page layout, see 
“Preview Regions (Page Layout)” on page 48. To add more region 
items to this region, see “Add More Items” on page 63. To add items 
to other regions, see “Add Region Items Overview” on page 52. To 
schedule the playback sequence(s) for your regions and your pages, 
see “5. Schedule Playback Sequences” on page 201. To output the 
infocast, see “6. Output” on page 233.

Add Content on 
the Content Tab

1 In the Graphic Importer, click the Choose button on the Content tab. 

2 In the Browsing Options dialog box, select 
one of the following:

• If your graphic file is on your hard drive, 
select the Local Files Browsing radio 
button, then select the file as prompted. 

• If your graphic file is on the internet, 
select the HTTP/FTP Files Browsing radio button, then do the 
following: 
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a In the Internet File 
Browser dialog box, 
enter the address of 
the HTTP or FTP site 
in the Current Path 
box. The address 
must start with http:// 
or ftp://. 

b Log on to the site. If 
the site permits 
anonymous login, 
select the Anonymous 
option. If the site 
requires a name and 
password, select the 
Name option, then 
enter a Name and 
Password.

c Click on the Go button 
next to Current Path to go to that site. 

d The list of files that are available at the site are displayed in the 
dialog box. Select the file from the list.

3 Use the following options on the Content tab as needed. 

Next, switch to the Audio tab to play audio with your content. Save your 
work in the editor. Set up your playback sequence.

Choose Button Click the Choose button to select your graphic file.

Scale to Fill 
Region 
checkbox

Sets the imported graphic to fill the entire region with 
the imported graphic. Filling the region may increase or 
decrease the size of the original graphic, causing some 
distortion. When this checkbox is checked, the Maintain 
Aspect Ratio checkbox becomes available.

Maintain 
Aspect Ratio 
checkbox

Becomes available when you check the Scale to Fill 
Region checkbox. Scale the graphic to the largest 
possible size without changing the aspect ratio of the 
original graphic.

Update When 
Source Changes 
checkbox

Updates the imported graphic in InfoCaster when the 
source graphic is updated in the referenced location.

Log Note 
button

Opens a dialog box in which you can add comments that 
display in the log file every time the item plays.
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Add Audio on 
Audio Tab

Adjust audio settings on the Audio tab. Audio is available in all Content 
Editors except TitleMotion. The audio options allow you to attach an audio 
file to the region item. The audio plays whenever the region item plays in 
the sequence. Once the region item stops playing, the sound stops.

The options on the InfoCaster Graphic Importer’s Audio tab are identical 
to the options on the Still Region’s Title Quick Editor Audio tab. Refer to 
“Add Audio on Audio Tab” on page 97 for instructions on how to add 
audio to your region item.

Next, save your work, as explained in “Save, Preview, Add to Sequence” on 
page 99. Set up your playback sequence, as explained in “Schedule 
Playback Overview” on page 202. 



Add Crawl Items



C
ra

w
ls

116 InfoCaster

Add Crawl Items

Crawl Items Overview
Crawl regions move text and graphics horizontally across the region. 

The text can be text that you type in or text from an external data 
source. See “About External Data Sources” on page 63 for details. Note 
that the following characters are reserved and cannot be used in crawls: 
@, #, $, ^, or &.

You can change the speed of your crawls and set crawls to move left or right. See “5. Schedule 
Playback Sequences” on page 201 for details. To change the default direction of all crawls, see 
“Default Crawl Direction” on page 248.

There are 2 Crawl region content editors. This chapter contains instructions on how to use them. 

• Crawl Quick Editor

Create a simple line of crawling text 
in your Crawl region that displays 
text that you type in or text from an 
external data source. Add text on the 
Content tab. Format the item with a 
template or with custom settings on 
the Formatting tab. Add audio on 
the Audio tab. See “Crawl Quick 
Editor” on page 118. 

• Add Blank Item

Make the region transparent during 
playback. See “About Blank Items” 
on page 56.

• TitleMotion

Create a layout of text and graphics for your region item. 
Add text to a Still region on your layout that displays text that you type in or text from an external 
data source.
Add text or graphic content by selecting a tool from the Tools palette on the right side of the 
screen. The first row of tools are for text. The other tools draw graphics. Then, enter your text or 
draw your shape in the workspace.
Format your content using the tabs below the workspace. You cannot add audio in TitleMotion. 
You can create templates in TitleMotion that become are available in the Quick Editors. 
See “TitleMotion” on page 125 for the workflow. 
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Workflow 1 Open an infocast. See “1. Open an Infocast” on page 17. 

2 Add pages to the infocast. See “2. Add Pages to Infocast” on page 25. 

3 Add regions to the page. See “3. Add Regions to Page” on page 33.

4 Add content (region items) to each region. 

a Select the region you want to add content to, then switch to the 
Items window. See “Open Region in Items Window” on page 54.

b Select the editor from the Editor list, then click on the Add button 
to open it. See “Open a Content Editor” on page 56.

c Add content in the editor. This chapter explains how to add 
content using each available editor. The workflow is:
• Add content.
• Format the content. 
• Add audio if applicable.
• Save your work in the editor. 

To add more region items to this region, see “Add More Items” on 
page 63. To add items to other regions, see “Add Region Items 
Overview” on page 52.

5 Schedule the playback sequence(s) for your regions and your pages. 
See “5. Schedule Playback Sequences” on page 201.

6 Output the infocast. See “6. Output” on page 233.
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Crawl Quick Editor 
Select the Crawl Quick Editor to create a simple line of crawling text 
in your Crawl region that displays text that you type in or text from an 
external data source. The external data source can be a text file on 
your hard drive or at an HTTP or FTP site (internet), text from an 
XML/RSS source, text from an ODBC data source, or a text file that 
you convert to an ODBC data source. 

Add content on the Content tab. Format the content with a template 
or with custom settings on the Formatting tab. Add audio on the Audio tab. 

Workflow 1 Select the region you want to add content to, then switch to the Items 
window. See “Open Region in Items Window” on page 54.

2 Select the editor from the Editor list in the Items window, then click 
on the Add button to open it. See “Open a Content Editor” on 
page 56 for details. 

3 Add text on the Content tab. See “Add Content on Content Tab” on 
page 119.

4 Format the content on the Formatting tab. See “Format on Formatting 
Tab” on page 123. 

5 Add audio on the Audio tab. See “Add Audio on Audio Tab” on 
page 124. 

6 Save your work in the editor. You can also enter a name for the region 
item in the Name field, preview your content in the editor’s Preview 

select 
editor

click 
Add
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window, and automatically add the item to the Sequence list, using 
options on the main window. See “Save, Preview, Add to Sequence” 
on page 99.

To preview a still image of your region items in a page layout, see “Preview 
Regions (Page Layout)” on page 48.

To add more region items to this region, see “Add More Items” on page 63.

To add items to other regions, see “Add Region Items Overview” on 
page 52.

To schedule the playback sequence(s) for your regions and your pages, see 
“5. Schedule Playback Sequences” on page 201. 

To output the infocast, see “6. Output” on page 233.

Add Content on 
Content Tab

1 Add text that displays data from the following sources:

• Text that you type in. The procedures are similar to those for 
adding content to Still regions with the Title Quick Editor. Refer to 
“Type In Text” on page 75 for instructions. 

Note:The following characters are reserved and cannot be used in 
crawls: @, #, $, ^, or &. 

• A text file on your hard drive. Refer to “Link to Text File on Hard 
Drive” on page 76 for instructions. 

• A text file at an HTTP or FTP site. Refer to “Link to Text File on 
Internet” on page 80 for instructions.

• A text file that you convert into an ODBC data source. Refer to 
“Link to Text File Converted to ODBC Data Source” on page 83 for 
instructions.

• Text from an XML/RSS source. Refer to “Link to XML/RSS Source” 
on page 88 for instructions.

• Text from an ODBC data source. Refer to “Link to ODBC Data 
Source” on page 91 for instructions.

Your text displays in the editor’s Preview window. To preview a still 
image of your region item in a page layout, see “Preview Regions (Page 
Layout)” on page 48.
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2 To add a video clip, animation, or graphic and up to 3 pre-determined 
characters and/or a scalable graphic image before each text entry of 
your Crawl item, do the following:

a Check the Crawl Prefix checkbox on the Content tab.
b Click the Setup button.
c In the Crawl Prefix 

dialog box that 
opens, use the 4 
drop-down lists to 
select up to 4 items. 
For example, to place 
two items in front of 
your crawl text, select 
an item from the first 
list and an item from the second list. 

Each of the last 3 lists contain the following options:
• Nothing
• Graphic (Then, select the file in the Open dialog box.)
• Space
• Period ( . )
• Comma ( , )
• Hyphen ( - )
• Ellipsis ( ... )
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3 Use the remaining options on the Content tab as needed.

Text field Displays region item text. You can also type text.

Crawl Prefix 
checkbox

Enables the Setup button to place up to 4 elements 
in front of the crawl text.

(Crawl Prefix) 
Setup button

Becomes available when you check the Crawl Prefix 
checkbox. Opens the Crawl Prefix dialog box where 
you can place up to 4 elements in front of the crawl 
text. See “Add Content on Content Tab” on 
page 119.

External Data 
Source 
checkbox

Enables the Setup button to select an external data 
source.

(External Data 
Source) Setup 
button 

Becomes available when you select the External 
Data Source checkbox. Opens the Select Data 
Source dialog box, where you can link to an 
external text file or ODBC data source. You cannot 
edit external text in the Quick Editor.

Show All New 
Data at Least 
Once checkbox

Sets InfoCaster to display all data in the database 
once before it renders new data.
This option is recommended if your data is being 
updated constantly and it is important to show all 
data that is entered into the data source. 
If this option is not selected, InfoCaster renders 
and displays new data almost immediately as the 
data source is updated. 

Transition list Becomes available when you check the Enable 
Onscreen Update When Content Changes 
checkbox. Sets the transition type for on-screen 
updates. New information entered into the external 
database file is updated immediately on-screen 
using the selected transition. Only available for text 
from an external source.

Transition 
Duration field

Becomes available when you check the Enable 
Onscreen Update When Content Changes 
checkbox. Sets the amount of time, in seconds, that 
the transition for on-screen updates takes. Not 
available for Snap transitions.

Log Note 
button

Opens a dialog box in which you can add 
comments that are displayed in the log file every 
time the item plays.
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Enable 
Onscreen 
Update When 
Content 
Changes 
checkbox

Sets InfoCaster to update external text immediately 
on-screen. 
This option is recommended if your text contains 
information like temperatures or sports scores 
where the spacing remains constant. This option is 
not recommended if the length of your text entries 
varies because the spacing of the text does not 
adjust until the crawl starts from the beginning. 
This means that a text entry that is longer than the 
one it is replacing is not immediately updated, and 
a text entry that is shorter than the one it is 
replacing contains extra space.
If this option is not selected, the crawl is updated 
with new content from the external data source as 
soon as the crawl starts from the beginning.



InfoCaster 123

C
raw

ls

Format on 
Formatting Tab

You can format the Crawl region content on the Title Quick Editor’s 
Formatting tab using one of these methods.

• Format with a template only if you created a crawl template using 
TitleMotion in the crawl editors list. Click on the Template radio button, 
then select a template from the list. The procedures are identical to those 
for Still region items, as explained in “Format with Template” on page 93. 
See the TitleMotion manual for instructions on how to create a template.

• Format with custom settings. Select the Custom radio button, then select 
any of the formatting options that become available. The procedures are 
similar to those for Still region items. See “Format with Custom Settings” 
on page 94 for instructions. 

You can also resize and reposition the region within the page layout, as 
explained in “Adjust Region Settings” on page 46. 

Next, switch to the Audio tab to play audio with your content. Save your 
work in the editor. Set up your playback sequence, as explained in 
“Schedule Playback Overview” on page 202.
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Add Audio on 
Audio Tab

The audio options allow you to attach an audio file to the region item. The 
audio plays whenever the region item plays in the sequence. Once the 
region item stops playing, the sound stops.

The options on the InfoCaster Crawl Quick Editor’s Audio tab are identical 
to the options on the Still Region’s Title Quick Editor Audio tab. Refer to 
“Add Audio on Audio Tab” on page 97 for instructions on how to add 
audio to your Crawl region item.

Next, save your work in the editor. See “Save, Preview, Add to Sequence” 
on page 99 for details. Set up your playback sequence, as explained in 
“Schedule Playback Overview” on page 202.
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TitleMotion
TitleMotion is a full-feature, broadcast quality character generator 
that you can use to create a layout that consists of text and graphics 
in your Still, Crawl, Roll, or Animation region items. Your text can be 
text that you type in, text that you import, or text from an external 
data source. 

Use the tools on the Tools palette to add your content. Format 
content with the tabs below the workspace. You cannot adjust audio 
settings in TitleMotion. To link your text line to an external data source, you must open the item in a 
Quick Editor.

You can create Crawl region templates in TitleMotion, then use them in the Crawl Quick Editor. 

select 
editor

click 
Add
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Workflow Add and Format Content

TitleMotion for crawls is very similar to that for Still regions with one 
exception. You can only create one text line, so you cannot select a 
template unless you create one specifically for Crawl regions. The basic 
workflow is: 

1 Select a region item layout slot in the TitleMotion play list. By default, 
the first layout is already selected. 

To open the TitleMotion editor, see “Open a Content Editor” on 
page 56. 

2 Select another template from the list as needed.

3 Select the Text Plane or Graphics (draw) Plane. 

4 Add text and graphic content. 

a Select a tool from the Tools palette. 
b Add your text or draw your shape in the workspace. 

To link a text line to an external data source, finish designing your 
region item layout in TitleMotion, then open the item in a Quick 
Editor. In the Quick Editor, select a text line, then check the 
External Data Source checkbox. Select your external data source. 

5 Format content. Use the tabs below the workspace. 

For further information on using TitleMotion, see TitleMotion’s Online 
Help menu or the TitleMotion manual that came with your InfoCaster 
product.

Next, schedule the playback sequence(s) for your regions and your pages as 
explained in “5. Schedule Playback Sequences” on page 201. Output the 
infocast as explained in “6. Output” on page 233.
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Add Roll Items

Roll Items Overview
Roll regions scroll text and graphics up or down the region. 

The text can be text that you type in or text from an external data 
source. See “About External Data Sources” on page 63 for details.

There are 3 Roll region content editors. This chapter contains 
instructions on how to use them.

• Roll Quick Editor 
Create rolling text in your Roll 
region that displays text that you 
type in or text from an external 
data source. 

Add text on the Content tab. 
Format the item with a template or 
with custom settings on the 
Formatting tab. Add audio on the 
Audio tab.

See “Roll Quick Editor” on 
page 131. 

• Table Quick Editor 

Quickly display information from an 
external data source during output. 

Add content on the Content tab. 
Format headers on the Headers tab. 
Format content font on the Font 
Formatting tab. Add audio to the 
region item on the Audio tab.

See “Table Quick Editor” on 
page 137.
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• TitleMotion:

Create a layout of text and 
graphics for your region item. 
Add text that you type in or 
text from an external data 
source. 

Add text or graphic content 
by selecting a tool from the 
Tools palette on the right side 
of the screen. The first row of 
tools are for text. The other 
tools draw graphics. Then, 
enter your text or draw your 
shape in the workspace.

Format your content using the 
tabs below the workspace. 
You cannot add audio in 
TitleMotion. 

You can create templates in 
TitleMotion that become 
available in the Quick Editors. 

See “TitleMotion” on page 141. 

• Add Blank Item

To make the region transparent during playback, add a blank item to the sequence. See “About 
Blank Items” on page 56.

You can change the speed of your rolls and set rolls to move up or down. See “3. Adjust Sequence 
Settings” on page 219 for details on using the Sequence settings. To change the default direction of all 
rolls, “Default Roll Direction” on page 247.

Workflow 1 Open an infocast. See “1. Open an Infocast” on page 17. 

2 Add pages to the infocast. See “2. Add Pages to Infocast” on page 25. 

3 Add regions to the page. See “3. Add Regions to Page” on page 33.

4 Add content (region items) to each region. 

a Select the region you want to add content to, then switch to the 
Items window. See “Open Region in Items Window” on page 54.

b Select the editor from the Editor list in the Items window, then click 
on the Add button to open it. See “Open a Content Editor” on 
page 56.

c Add content in the editor. The following sections in this chapter 
describe how to add content to the selected region using each 
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available editor. The basic workflow is:
• Add content.
• Format the content. 
• Add audio if applicable.
• Save your work in the editor. 

To preview a still image of your region items in a page layout, see 
“Preview Regions (Page Layout)” on page 48.
To add more region items to this region, see “Add More Items” on 
page 63.
To add items to other regions, see “Add Region Items Overview” on 
page 52.

5 Schedule the playback sequence(s) for your regions and your pages. 
See “5. Schedule Playback Sequences” on page 201.

6 Output the infocast. See “6. Output” on page 233.
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Roll Quick Editor 
Select the Roll Quick Editor to create rolling text in your region item 
that displays text that you type in or text from an external data source. 
The external data source can be a text file on your hard drive or at an 
HTTP or FTP site (internet), text from an XML/RSS source, text from 
an ODBC data source, or a text file that you convert to an ODBC data 
source. 

Add content on the Content tab. Format the content with a template 
or with custom settings on the Formatting tab. Add audio on the 
Audio tab. 

Workflow 1 Select the region you want to add content to, then switch to the Items 
window. See “Open Region in Items Window” on page 54.

2 Select the editor from the Editor list in the Items window, then click 
on the Add button to open it. See “Open a Content Editor” on 
page 56 for details. 

3 Add text on the Content tab. See “Add Content on Content Tab” on 
page 132.

4 Format content on the Formatting tab. See “Format on Formatting 
Tab” on page 135. 

5 Add audio on the Audio tab. See “Add Audio on Audio Tab” on 
page 136.

select 
editor
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Add
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6 Save your work in the editor. You can also enter a name for the region 
item in the Name field, preview your content in the editor’s Preview 
window, and automatically add the item to the Sequence list, using 
options on the main window. See “Save, Preview, Add to Sequence” 
on page 99.

To preview a still image of your region items in a page layout, see “Preview 
Regions (Page Layout)” on page 48.

To add more region items to this region, see “Add More Items” on page 63.

To add items to other regions, see “Add Region Items Overview” on 
page 52.

To schedule the playback sequence(s) for your regions and your pages, see 
“5. Schedule Playback Sequences” on page 201. 

To output the infocast, see “6. Output” on page 233.

Add Content on 
Content Tab

1 Add text that displays data from the following sources:

• Text that you type in. The procedures are similar to those for 
adding content to Still regions with the Title Quick Editor. Refer to 
“Type In Text” on page 75 for instructions. 

• A text file on your hard drive. Refer to “Link to Text File on Hard 
Drive” on page 76 for instructions. 

• A text file at an HTTP or FTP site. Refer to “Link to Text File on 
Internet” on page 80 for instructions.

• A text file that you convert into an ODBC data source. Refer to 
“Link to Text File Converted to ODBC Data Source” on page 83 for 
instructions.

• Text from an XML/RSS source. Refer to “Link to XML/RSS Source” 
on page 88 for instructions.

• Text from an ODBC data source. Refer to “Link to ODBC Data 
Source” on page 91 for instructions.
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Your text displays in the editor’s Preview window. To preview a still 
image of your region item in a page layout, see “Preview Regions (Page 
Layout)” on page 48. 

2 Use the remaining options on the Content tab as needed. 

Text field Displays region item text. You can also type text.
Press ENTER to add another line. If you are using 
a template (available on the Formatting tab), the 
template sets the maximum number of text lines. 

External Data 
Source 
checkbox

Enables the Setup button to link to an external 
data source.

(External Data 
Source) Setup 
button 

Becomes available when you select the External 
Data Source checkbox. Opens the Select Data 
Source dialog box, where you can link to an 
external text file or ODBC data source. You 
cannot edit external text in the Quick Editor.
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Show All New 
Data at Least 
Once 
checkbox

Sets InfoCaster to display all data in the database 
once before it renders new data.
This option is recommended if your data is being 
updated constantly and it is important to show all 
data that is entered into the data source. 
If this option is not selected, InfoCaster renders 
and displays new data almost immediately as the 
data source is updated. 

Enable 
Onscreen 
Update When 
Content 
Changes 
checkbox

Sets InfoCaster to update external text 
immediately on-screen. 
This option is recommended if your text contains 
information like temperatures or sports scores 
where the spacing remains constant. 
If this option is not selected, the roll is updated 
with new content from the external data source as 
soon as the roll starts from the beginning.

Transition list Becomes available when you check the Enable 
Onscreen Update When Content Changes 
checkbox. Sets the transition type for on-screen 
updates. New information entered into the 
external database file is updated immediately on-
screen using the selected transition. Only 
available for text from an external source.

Transition 
Duration field

Becomes available when you check the Enable 
Onscreen Update When Content Changes 
checkbox. Sets the amount of time, in seconds, 
that the transition for on-screen updates takes. 
Not available for Snap transitions.

Log Note 
button

Opens a dialog box in which you can add 
comments that are displayed in the log file every 
time the item plays.
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Format on 
Formatting Tab

You can format the Roll region content on the Roll Quick Editor’s 
Formatting tab using one of these methods.

• Format with a template. Click on the Template radio button, then select a 
template from the list. The procedures are identical to those for Still 
region items. See “Format with Template” on page 93 for instructions. 

• Format with custom settings. Select the Custom radio button, then select 
any of the formatting options that become available. The procedures are 
similar to those for Still region items. See “Format with Custom Settings” 
on page 94 for instructions.

You can also resize and reposition the region within the page layout, as 
explained in “Adjust Region Settings” on page 46.

Next, switch to the Audio tab to play audio with your content. Save your 
work in the editor. Set up your playback sequence, as explained in 
“Schedule Playback Overview” on page 202.
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Add Audio on 
Audio Tab

The audio options allow you to attach an audio file to the region item. The 
audio plays whenever the region item plays in the sequence. Once the 
region item stops playing, the sound stops.

The options on the InfoCaster Roll Quick Editor’s Audio tab are identical 
to the options on the Still Region’s Title Quick Editor Audio tab. Refer to 
“Add Audio on Audio Tab” on page 97 for instructions on how to add 
audio to your region item.

Next, save your work in the editor. See “Save, Preview, Add to Sequence” 
on page 99 for details. Set up your playback sequence, as explained in 
“Schedule Playback Overview” on page 202.
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Table Quick Editor
Select the Table Quick Editor to quickly create columns of external 
data in your region item that display information from an external 
data source during output. You can create as many columns of text as 
you need and are able to display at a time in the selected region. You 
can connect each text line to a different data source. See “About 
External Data Sources” on page 63 for information about external 
data sources.

Add content on the Content tab. Format headers on the Headers tab. 
Format text font on the Font Formatting tab. Add audio to the region item on the Audio tab. 

Workflow The Table Quick Editor for Roll regions is identical to the Table Quick 
Editor for Still regions. For complete instructions on adding content to a 
Roll region using the Table Quick Editor, refer to “Table Quick Editor” on 
page 100. The basic workflow is:

1 Select the region you want to add content to, then switch to the Items 
window. See “Open Region in Items Window” on page 54.

2 Select the editor from the Editor list in the Items window, then click 
on the Add button to open it. See “Open a Content Editor” on 
page 56 for details. 

select 
editor

click 
Add
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3 Set up your table columns and link to external data on the Content 
tab. “Add Content on Content Tab” on page 102 for instructions. 

4 Format your column heading text on the Headers tab. See “Format on 
Headers Tab” on page 104.
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5 Format your row text on the Row Formatting tab. See “Format on Row 
Formatting Tab” on page 106.

6 Add audio on the Audio tab. See “Add Audio on Audio Tab” on 
page 97.



R
ol

ls

140 InfoCaster

7 Save your work in the editor. You can also enter a name for the region 
item in the Name field, preview your content in the editor’s Preview 
window, and automatically add the item to the Sequence list, using 
options on the main window. See “Save, Preview, Add to Sequence” 
on page 99.

To preview a still image of your region items in a page layout, see “Preview 
Regions (Page Layout)” on page 48.

To add more region items to this region, see “Add More Items” on page 63.

To add items to other regions, see “Add Region Items Overview” on 
page 52.

To schedule the playback sequence(s) for your regions and your pages, see 
“5. Schedule Playback Sequences” on page 201. 

To output the infocast, see “6. Output” on page 233.
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TitleMotion
TitleMotion is a full-feature, broadcast quality character generator 
that you can use to create a layout that consists of text and graphics 
in your Still, Crawl, Roll, or Animation region items. Your text can be 
text that you type in, text that you import, or text from an external 
data source. 

Use the tools on the Tools palette to add your content. Format 
content with the tabs below the workspace. You cannot adjust audio 
settings in TitleMotion. To link your text line to an external data source, you must open the item in a 
Quick Editor.

You can create templates in TitleMotion that become available in the Still, Crawl, Roll, and Animation 
Quick Editors. 

select 
editor
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Add
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Workflow TitleMotion for rolls is very similar to that for Still regions. The workflow 
is:

1 Select a region item layout slot in the TitleMotion play list to work on. 
By default, the first layout is already selected. 

To open the TitleMotion editor:
a Select the region you want to add content to, then switch to the 

Items window. See “Open Region in Items Window” on page 54.
b Select the TitleMotion editor from the Editor list in the Items 

window, then click on the Add button to open it. See “Open a 
Content Editor” on page 56 for details. 

2 Select another template from the list as needed. 

3 Select the Text Plane or Graphics (draw) Plane. 

4 Add text and graphic content. 

a Select a tool from the Tools palette. The first two tools are for text. 
The other tools draw items on the graphics plane.

b Add your text or draw your shape in the workspace. 
To link a text line to an external data source, finish designing your 
region item layout in TitleMotion, then open the item in a Quick 
Editor. You may need to rename the data tags in the TitleMotion 
CG module if you want to display entries from more than one 
column of an ODBC data source in a Still or Animation item, 
In the Quick Editor, select a text line, then check the External Data 
Source checkbox. Select your external data source. 

5 Format content. Use the tabs below the workspace. 

For further information on using TitleMotion, see TitleMotion’s Online 
Help menu or the TitleMotion manual that came with your InfoCaster 
product.

Next, schedule the playback sequence(s) for your regions and your pages as 
explained in “5. Schedule Playback Sequences” on page 201. Output the 
infocast as explained in “6. Output” on page 233.



Add Animation Items
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Add Animation Items

Animation Items Overview 

Animation regions play animated text and graphics.

The text can be text that you type in or text from an external data 
source. See “About External Data Sources” on page 63 for details.

You can create as many lines of text as you want and are able to display at a time in the selected 
region. You can connect each line to a different data source.

There are 3 Animation region content editors. This chapter contains instructions on how to use them.

• TitleMotion 

Create a layout that 
consists of text and 
graphics in TitleMotion’s 
CG module. Animate the 
layout in TitleMotion’s 
Animation module.

Your text content can be 
text that you type in or text 
that you link to from an 
external data source. You 
create the layout and 
animate it in TitleMotion, 
but apply the links in the 
Animation Quick Editor.

You cannot adjust audio 
settings in TitleMotion, 
but you can in the Quick 
Editor. 

See “TitleMotion” on 
page 147. 
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• Animation Quick Editor 

Quickly edit the text in animations 
that you created in TitleMotion, to 
link to an external data source, and to 
set audio options. You cannot add an 
animation with the Animation Quick 
Editor. 

Add text on the Content tab. Add 
audio on the Audio tab. Format the 
content in TitleMotion. See 
“Animation Quick Editor” on 
page 150. 

• Animation Importer 

Import an animation into the selected 
region. Attach or adjust audio using 
the audio options on the Audio tab. 

See “Animation Importer” on 
page 153. 

• Add Blank Item

To make the region transparent during playback, add a blank item to the sequence. See “About 
Blank Items” on page 56.

Note that animations play back at the frame rate of the playback device. 

• ATI: 1 second = 60 frames

• NTSC: 1 second = 30 frames

• PAL: 1 second = 25 frames
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Workflow 1 Open an infocast. See “1. Open an Infocast” on page 17. 

2 Add pages to the infocast. See “2. Add Pages to Infocast” on page 25. 

3 Add regions to the page. See “3. Add Regions to Page” on page 33.

4 Add content (region items) to each region. 

a Select the region you want to add content to, then switch to the 
Items window. See “Open Region in Items Window” on page 54.

b Select the editor from the Editor list in the Items window, then click 
on the Add button to open it. See “Open a Content Editor” on 
page 56.

c Add content in the editor. The following sections in this chapter 
describe how to add content to the selected region using each 
available editor. The basic workflow is:
• Add content.
• Format the content. 
• Add audio if applicable.
• Save your work in the editor. 

To preview a still image of your region items in a page layout, see 
“Preview Regions (Page Layout)” on page 48.
To add more region items to this region, see “Add More Items” on 
page 63.
To add items to other regions, see “Add Region Items Overview” on 
page 52.

5 Schedule the playback sequence(s) for your regions and your pages. 
See “5. Schedule Playback Sequences” on page 201.

6 Output the infocast. See “6. Output” on page 233.
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TitleMotion 

Select TitleMotion to create animations for your Animation region. 
TitleMotion is a full-feature, broadcast quality character generator 
that you can use to create a layout that consists of text and graphics 
in your Still, Crawl, Roll, or Animation region items. Your text 
content can be text that you type in or text that you link to from an 
external data source. 

You create the layout in TitleMotion’s CG module, then switch to 
TitleMotion’s Animation module to animate it. To link your text line to an external data source, you 
must open the item in a Quick Editor. 

select 
editor
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Add
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The Animation module takes the 2 dimensional graphic and text objects created in the CG module 
and allows you to animate them in 3 dimensional space along the X (horizontal), Y (vertical), and Z 
(depth) axes. Fly text on and off the screen, spin letters, fade objects in and out, and more. This 
module is only available for Animation regions.

Workflow In TitleMotion’s CG Module

1 Select a region item layout slot in the TitleMotion play list to work on. 
By default, the first layout is already selected. 

To open the TitleMotion editor:
a Select the region you want to add content to, then switch to the 

Items window. See “Open Region in Items Window” on page 54.
b Select the TitleMotion editor from the Editor list in the Items 

window, then click on the Add button to open it. See “Open a 
Content Editor” on page 56 for details. 

2 Select another template from the list as needed. 

3 Select the Text Plane or Graphics (draw) Plane. 

4 Add text and graphic content. 

a Select a tool from the Tools palette. The first two tools are for text. 
The other tools draw items on the graphics plane.

b Add your text or draw your shape in the workspace. 
To link a text line to an external data source, finish designing your 
region item layout in TitleMotion, then open the item in a Quick 
Editor. You may need to rename the data tags in the TitleMotion 
CG module if you want to display entries from more than one 
column of an ODBC data source in a Still or Animation item, 
In the Quick Editor, select a text line, then check the External Data 
Source checkbox. Select your external data source. 

5 Format content. Use the tabs below the workspace. 

In TitleMotion’s Animation Module

Once your have created your text and graphic layout in TitleMotion’s CG 
module, add movement to the text lines and graphic objects in 
TitleMotion’s Animation module. The workflow is: 

1 While still in TitleMotion’s CG module, select your export options for 
each layer on the Animation Settings tab. 

2 Click on the animation button at the top of the screen to switch to the 
Animation module.

3 To create an animation, select the object, press INSERT, then drag the 
keyframe.

4 Select an object that you want to animate.
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5 Add keyframes to the selected object using one of these methods: 

• Select an animation template on the Templates tab. Animation 
templates have pre-set keyframes along pre-set paths. You can 
move the keyframes. 

• Press the INSERT key. A keyframe is added to the object. While the 
keyframe is still selected, drag it to a new location in your 
workspace to create your animation path. Press INSERT again to 
add another keyframe. 

6 Reposition and format the keyframes. Even if you applied a template, 
you can adjust the following attributes of each keyframe:

• Position and movement, on the Placement tab.
• Shape, on the Shape tab. 
• Filters, on the Filter tab. 
• Timing effects, on the Time tab and Spline tab.

In the Animation Quick Editor

To link the text lines to an external data source, switch to the Animation 
Quick Editor. See “Animation Quick Editor” on page 150.

For further information on using TitleMotion, see TitleMotion’s Online 
Help menu or the TitleMotion manual that came with your InfoCaster 
product.

Next, save your work in the editor. Set up your playback sequence, as 
explained in “Schedule Playback Overview” on page 202.
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Animation Quick Editor
Select the Animation Quick Editor to quickly edit the text in 
animations that you created in TitleMotion, to link to an external 
data source, and to set audio options. 

To use the Animation Quick Editor, create an animation in 
TitleMotion, as explained in the TitleMotion manual that came with 
your InfoCaster product or in the TitleMotion online help. Then, 
edit the animation in the Animation Quick Editor. You cannot add an 
animation with the Animation Quick Editor. 

Add text on the Content tab. Add audio on the Audio tab. To format the content, use TitleMotion. 

Workflow To add content to an Animation region using the Animation Quick Editor, 
the process is the same as adding content to a Still region using the Title 
Quick Editor. Refer to “Title Quick Editor” on page 71 for instructions on 
how to use this editor. The workflow is:

1 Select the region you want to add content to, then switch to the Items 
window. See “Open Region in Items Window” on page 54.

2 Create an animation in TitleMotion from the Animation editors list, as 
explained in the TitleMotion manual. Then, save the animation as a 
template, as explained in the TitleMotion manual. 

3 Select the editor from the Editor list in the Items window, then click 
on the Add button to open it. See “Open a Content Editor” on 
page 56 for details. 

select 
editor
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Add
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4 Add content on the Content tab. 

You can type your own text or link a text line to an external data 
source. The external data source can be a text file on your hard drive 
or at an HTTP or FTP site (internet), text from an XML/RSS source, 
text from an ODBC data source, or a text file that you convert to an 
ODBC data source. 
The options on this editor are identical to those on the Title Quick 
Editor. Refer to “Title Quick Editor” on page 71 for details. 

5 To format the text or graphics content of your Animation item, you 
must use TitleMotion. Refer to the TitleMotion manual. You cannot 
format the content in Animation Quick Editor. 
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6 Add audio on the Audio tab. The options on this editor are identical 
to those on the Title Quick Editor. Refer to “Title Quick Editor” on 
page 71 for details.

7 Save your work in the editor. You can also enter a name for the region 
item in the Name field, preview your content in the editor’s Preview 
window, and automatically add the item to the Sequence list, using 
options on the main window. See “Save, Preview, Add to Sequence” 
on page 99.

To preview a still image of your region items in a page layout, see “Preview 
Regions (Page Layout)” on page 48.

To add more region items to this region, see “Add More Items” on page 63.

To add items to other regions, see “Add Region Items Overview” on 
page 52.

To schedule the playback sequence(s) for your regions and your pages, see 
“5. Schedule Playback Sequences” on page 201. 

To output the infocast, see “6. Output” on page 233.
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Animation Importer
Use the Animation Importer to import an animation file into the 
selected region. Attach or adjust audio using the audio options on 
the Audio tab. 

Workflow To add content to the selected region using the Animation Importer editor, 
the basic workflow is:

1 Select the region you want to add content to, then switch to the Items 
window. See “Open Region in Items Window” on page 54.

2 Select the editor from the Editor list in the Items window, then click 
on the Add button to open it and add a new region item. See “Open a 
Content Editor” on page 56 for details. 

3 Add content on the Content tab. See “Add Content on the Content 
Tab” on page 154.

4 Add audio on the Audio tab. See “Add Audio on Audio Tab” on 
page 156.

5 Save your work in the editor. You can also enter a name for the region 
item in the Name field, preview your content in the editor’s Preview 
window, and automatically add the item to the Sequence list, using 
options on the main window. See “Save, Preview, Add to Sequence” 
on page 99.

To preview a still image of your region items in a page layout, see “Preview 
Regions (Page Layout)” on page 48.
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To add more region items to this region, see “Add More Items” on page 63. 
To add items to other regions, see “Add Region Items Overview” on 
page 52.

To schedule the playback sequence(s) for your regions and your pages, see 
“5. Schedule Playback Sequences” on page 201. To output the infocast, see 
“6. Output” on page 233.

Add Content on 
the Content Tab

1 In the Animation Importer editor, click the Choose button on the 
Content tab. 

2 In the Open dialog box, select the animation file. 

You can select multiple animations by holding down the SHIFT or 
CTRL key as you click. When you click on the Save button in the editor, 
a region item for each animation that you selected is added to the 
Items Library.
Once the file is imported, the other tools on this tab become available.

3 Preview the animation in the editor’s Preview window. 

Use the 3 play buttons below the animation timeline bar. 
• Rewind: Jumps to the first frame of the clip.
• Stop: Stops a playing animation.
• Play: Plays clip from current position.
Drag the top arrow indicator above the timeline to manually preview 
the animation.

4 Use the remaining options on the Content tab as needed.

Animation file 
name field

Displays the name of the selected animation file.
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Next, switch to the Audio tab to play audio with your content. Save your 
work in the editor.

Choose button Opens a dialog box where you select an animation 
for your region item.

Shared Media 
checkbox

Enables the shared media option to put the 
animation file in a central location for shared 
referencing. 
Then, select the shared media location from the 
drop-down list. 

Shared Media 
Sub-Folder 
drop-down list

Becomes available when you check the Shared 
Media checkbox. Select the shared media location 
from the following options:
• All: Adds the file to the default location 

C:\Shared Media, which is set in Preferences. 
See “Store Shared Media Files In” on page 248.

• Audio: Adds the file to a sub-folder called Audio 
under C:\Shared Media. 

• Type in a sub-folder name to create a new sub-
folder under C:\Shared Media. Adds the file to 
the new sub-folder.

Indicator 
(arrow) above 
Timeline

Shows the current playback position of your 
preview in the editor. You can drag the indicator 
back and forth along the timeline to manually go 
to that location in the animation file.

Timeline bar Portrays a graphic representation of your 
animation file, from start to end.

Rewind button Jumps to the first frame of the clip.

Stop button Stops a playing animation.

Play button Plays clip from current position.

Duration field Displays the duration of the animation in 
HH:MM:SS:FF (hours:minutes:seconds:frames).

Opacity field Changes animation’s transparency level, where 0% 
represents complete transparency

Log Note 
button

Opens a dialog box in which you can add 
comments that are displayed in the log file every 
time the item plays.
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Add Audio on 
Audio Tab

The audio options allow you to attach an audio file to the region item. The 
audio plays whenever the region item plays in the sequence. Once the 
region item stops playing, the sound stops.

The options on the InfoCaster Animation Importer’s Audio tab are identical 
to the options on the Still Region’s Title Quick Editor Audio tab. Refer to 
“Add Audio on Audio Tab” on page 97 for instructions on how to add 
audio to your region item. 

Next, set up your playback sequence, as explained in “Schedule Playback 
Overview” on page 202.



Add Digital Clocks
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Add Digital Clock

Digital Clock Items Overview
Digital Clock regions play a real-time digital clock or a timer that 
counts up or down. 

There are 2 digital clock region content editors. This chapter contains 
instructions on how to use them. 

• Digital Clock Quick Editor

Create real-time clocks displaying 
local or offset time. The time display 
is based on your computer clock. 

Set the time and date display 
options on the Content tab. Format 
the content on the Formatting tab. 
Add audio on the Audio tab. 

See “Digital Clock Quick Editor” on 
page 160. 

• Digital Timer Quick Editor

Create a digital timer that counts up or down. Display the day, month, and date. Add content on 
the Content tab. Format on the Formatting tab. Add audio on the Audio tab. See “Digital Timer 
Quick Editor” on page 165. 

• Add Blank Item

To make the region transparent during playback, add a blank item to the sequence. See “About 
Blank Items” on page 56.
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Workflow 1 Open an infocast. See “1. Open an Infocast” on page 17. 

2 Add pages to the infocast. See “2. Add Pages to Infocast” on page 25. 

3 Add regions to the page. See “3. Add Regions to Page” on page 33.

4 Add content (region items) to each region. 

a Select the region you want to add content to, then switch to the 
Items window. See “Open Region in Items Window” on page 54.

b Select the editor from the Editor list in the Items window, then click 
on the Add button to open it. See “Open a Content Editor” on 
page 56.

c Add content in the editor. The following sections in this chapter 
describe how to add content to the selected region using each 
available editor. The basic workflow is:
• Add content.
• Format the content. 
• Add audio if applicable.
• Save your work in the editor. 

To preview a still image of your region items in a page layout, see 
“Preview Regions (Page Layout)” on page 48.
To add more region items to this region, see “Add More Items” on 
page 63.
To add items to other regions, see “Add Region Items Overview” on 
page 52.

5 Schedule the playback sequence(s) for your regions and your pages. 
See “5. Schedule Playback Sequences” on page 201.

6 Output the infocast. See “6. Output” on page 233.



D
ig

it
al

 C
lo

ck
s

160 InfoCaster

Digital Clock Quick Editor 

Select the Digital Clock Quick Editor to create real-time clocks 
displaying local or offset time, and date information. 

Set the time and date display options on the Content tab. Set the text 
display options on the Formatting tab. Adjust the audio settings on the 
Audio tab.

By default, the time displayed by the digital clock is the local time 
provided by your computer clock. 

Workflow 1 Select the region you want to add content to, then switch to the Items 
window. See “Open Region in Items Window” on page 54.

2 Select the editor from the Editor list in the Items window, then click 
on the Add button to open it. See “Open a Content Editor” on 
page 56 for details. 

3 Add content on the Content tab. See “Add Content on Content Tab” 
on page 161.

4 Format the content on the Formatting tab. See “Format on Formatting 
Tab” on page 164.

5 Add audio on the Audio tab. See “Add Audio on Audio Tab” on 
page 164.

6 Save your work in the editor. You can also enter a name for the region 
item in the Name field, preview your content in the editor’s Preview 
window, and automatically add the item to the Sequence list, using 
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editor
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options on the main window. See “Save, Preview, Add to Sequence” 
on page 99.

To preview a still image of your region items in a page layout, see “Preview 
Regions (Page Layout)” on page 48.

To add more region items to this region, see “Add More Items” on page 63. 
To add items to other regions, see “Add Region Items Overview” on 
page 52.

To schedule the playback sequence(s) for your regions and pages, see “5. 
Schedule Playback Sequences” on page 201. To output the infocast, see “6. 
Output” on page 233.

Add Content on 
Content Tab

1 Check the Show Time checkbox to enable clock display. 

If you deselect this option, you can still display the day, month, and/or 
date (Show Prefix or Show Suffix).

2 Select clock display options. 

• Select the 12 Hour option to display the clock in 12 hour format, or 
select the 24 Hour option to display the clock in 24 hour format. 
When you select the 12 hour option, you can check the Show AM/
PM checkbox to display the time of day.

• Check the Show Leading Zeros checkbox to display the hour with 
two digits. For example, if the current time is 9:14, InfoCaster 
displays 09:14.

• Check the Show Seconds checkbox to display seconds on your 
clock.
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• Check the Offset checkbox to advance or delay your clock by a set 
amount of time.
• To advance your clock enter a positive number in the hours (hr) 

and minutes (min) fields. For example, to advance the clock by 
one hour ten minutes, enter 1 hr 10 min.

• To delay your clock enter a negative number in the hours (hr) 
and minutes (min) fields. For example, to delay the clock by one 
hour ten minutes, enter -1 hr -10 min.

3 To display a string of text before the digital clock, check the Show 
Prefix checkbox. Then, select one of the following prefix options: 

• Select the first option to choose a preset 
Day/Date/Month arrangement. The 
Windows Short Format and Windows 
Long Format options use the format set in 
the Microsoft Windows Date and Time 
Control Panel.

• Select the second option to enter custom text that appears before 
the digital clock. Enter the text in the text box.

4 To display a string of text after the digital clock, check the Show Suffix 
checkbox.

• Select the first option to choose a preset Day/Date/Month 
arrangement. The Windows Short Format and Windows Long 
Format options use the format set in the Microsoft Windows Date 
and Time Control Panel.

• Select the second option to enter custom text that appears after the 
digital clock. Enter the text in the text box.

5 Use the remaining options on the Content tab as needed. 

Show Time 
checkbox

Enables and disables the display of the digital 
clock.

12 Hour radio 
button

Displays the digital clock in 12 hour format.

24 Hour radio 
button

Displays the digital clock in 24 hour format.

Show AM/PM 
checkbox

Displays the AM/PM indicators after the digital. 
The Show AM/PM checkbox is not available when 
the 24 hour option is selected.

Show Leading 
Zeros

Sets the clock to display the hour in two digits. For 
example, if the time is 8:04 AM, the digital clock 
displays 08:04 AM.

Show Seconds 
checkbox

Includes seconds in the digital clock display.
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Offset Time 
checkbox

Delays or advances the clock by the set number of 
hours and minutes. By default, the time displayed 
by the digital clock is the local time provided by 
the computer clock.

hr field Advances or delays the clock by that amount of 
hours you enter in this field. To delay a clock, enter 
a negative value. 

min field Advances or delays the clock by the amount of 
minutes you enter in this field. To delay a clock, 
enter a negative value. 

Show Prefix 
checkbox

Enables the prefix options, to display text before 
the clock display. Then select either the first or the 
second radio button.

(Show Prefix) 
(Day, Month, 
Date) radio 
button & drop-
down list

Becomes available when you check the Show Prefix 
checkbox. Sets the item you select from the list to 
appear before the digital clock display. The 
Windows Short Format and the Windows Long 
Format options use the format set in Microsoft 
Windows’ Date and Time Control Panel.

(Show Prefix) 
Custom radio 
button & field

Becomes available when you check the Show Prefix 
checkbox. Sets the text that you enter in the field to 
appear before the digital clock display. 

Show Suffix 
checkbox

Enables the suffix options, to display text after the 
clock display. Then select either the first or the 
second radio button.

(Show Suffix) 
(Day, Month, 
Date) list

Becomes available when you check the Show Suffix 
checkbox. Sets the item you select from list to 
appear after the digital clock display. The Windows 
Short Format and Windows Long Format options 
use the format set in Microsoft Windows’ Date and 
Time Control Panel.

(Show Suffix) 
Custom list

Becomes available when you check the Show Suffix 
checkbox. Sets the text that you enter in the field to 
appear after the digital clock display.

Log Note 
button

Opens a dialog box in which you can add 
comments that are displayed in the log file every 
time the item plays.
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Format on 
Formatting Tab

Format the text using the options on the Formatting tab. Refer to “Format 
with Custom Settings” on page 94 for details about these options. 

Add Audio on 
Audio Tab

Attach an audio file to the region item. Refer to “Add Audio on Audio Tab” 
on page 97 for instructions. 

Next, set up your playback sequence, as explained in “Schedule Playback 
Overview” on page 202.
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Digital Timer Quick Editor 

Select the Digital Timer Quick Editor to create a digital timer that 
counts up or counts down with precision in your digital clock region. 

Set the timer display options on the Content tab, set the text display 
options on the Formatting tab, and adjust the audio settings on the 
Audio tab. 

Workflow 1 Select the region you want to add content to, then switch to the Items 
window. See “Open Region in Items Window” on page 54.

2 Select the editor from the Editor list in the Items window, then click 
on the Add button to open it. See “Open a Content Editor” on 
page 56 for details. 

3 Add content on the Content tab. See “Add Content on Content Tab” 
on page 166.

4 Format the content on the Formatting tab. See “Format on Formatting 
Tab” on page 168.

5 Add audio on the Audio tab. See “Add Audio on Audio Tab” on 
page 168.

6 Save your work in the editor. You can also enter a name for the region 
item in the Name field, preview your content in the editor’s Preview 
window, and automatically add the item to the Sequence list, using 

select 
editor

click 
Add
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options on the editor’s main window. See “Save, Preview, Add to 
Sequence” on page 99.

To preview a still image of your region items in a page layout, see “Preview 
Regions (Page Layout)” on page 48.

To add more region items to this region, see “Add More Items” on page 63.

To add items to other regions, see “Add Region Items Overview” on 
page 52.

To schedule the playback sequence(s) for your regions and your pages, see 
“5. Schedule Playback Sequences” on page 201. 

To output the infocast, see “6. Output” on page 233.

Add Content on 
Content Tab

A digital timer is added as a Digital Clock region item in your Digital Clock 
region when you save in this editor. 

To select how the digital timer is displayed, use the options on the Content 
tab.

Format list Sets the timing elements (hours, minutes, seconds) that 
the timer displays.

Separator list Sets which character separates the hours, minutes, and 
seconds.

Show Leading 
Zeros

Sets the timer to display the time in two digits. For 
example, 8:00 displays as 08:00.
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Next, format the appearance of the timer numbers.

Count Up radio 
button

Sets the timer to count-up.

Count Down 
radio button

Sets the timer to count-down.

From options Sets the timer to start counting either at 0:00 or at the 
time set in the available field.

From 0:00 
radio button

Sets the timer to start counting at 0:00.

From (custom 
list) radio 
button

Sets the timer to start counting at the time set in the 
available field.

From (custom 
list) field

Sets the timer to start counting at the time you enter.

To options Sets the timer to stop counting at 0:00, at the time set 
in the available field, or when you choose to stop the 
timer playback (Stop option).

To 0:00 radio 
button

Sets the timer to stop counting at 0:00.

To (custom list) 
radio button

Sets the timer to stop counting at the time you enter in 
the available field.

To (custom list) 
field

Sets the timer to stop counting at the time you enter.

Stop radio 
button

Sets the timer to stop counting when you click on this 
Stop radio button.

Log Note 
button

Opens a dialog box in which you can add comments that 
are displayed in the log file every time the item plays.
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Format on 
Formatting Tab

Format the text using the options on the Formatting tab. Refer to “Format 
with Custom Settings” on page 94 for details about these options. 

Add Audio on 
Audio Tab

Attach an audio file to the region item using options on the Audio tab. 
Refer to “Add Audio on Audio Tab” on page 97 for instructions on how to 
add audio to your region item. 

Next, set up your playback sequence. See “Schedule Playback Overview” on 
page 202.
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Add Video Items

Video Items Overview
Add video clips or live video to your video region using the Content 
Editors in the Items window. 

There are 2 video region content editors. This chapter contains 
instructions on how to use them.

• Video Clip Quick Editor

Import a video file into the selected 
region. 

Set the display options on the 
Content tab, apply graphics to 
overlay the video on the Overlay tab 
and adjust audio settings on the 
Audio tab. See “Video Clip Quick 
Editor” on page 172. 

• Live Video Quick Editor

Set the region to display live video. 
Select hardware sources for video 
and audio, or link to a streaming 
media file on the Content tab, apply a 
graphic overlay on the Overlay tab 
and adjust the audio settings on the Audio tab. See “Live Video Quick Editor” on page 180.

• Add Blank Item

To make the region transparent during playback, add a blank item to the sequence. See “About 
Blank Items” on page 56.
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Workflow 1 Open an infocast. See “1. Open an Infocast” on page 17. 

2 Add pages to the infocast. See “2. Add Pages to Infocast” on page 25. 

3 Add regions to the page. See “3. Add Regions to Page” on page 33.

4 Add content (region items) to each region. 

a Select the region you want to add content to, then switch to the 
Items window. See “Open Region in Items Window” on page 54.

b Select the editor from the Editor list in the Items window, then click 
on the Add button to open it. See “Open a Content Editor” on 
page 56.

c Add content in the editor. The following sections in this chapter 
describe how to add content to the selected region using each 
available editor. The basic workflow is:
• Add content.
• Format the content. 
• Add audio if applicable.
• Save your work in the editor. 

To preview a still image of your region items in a page layout, see 
“Preview Regions (Page Layout)” on page 48.
To add more region items to this region, see “Add More Items” on 
page 63.
To add items to other regions, see “Add Region Items Overview” on 
page 52.

5 Schedule the playback sequence(s) for your regions and pages. See 
“5. Schedule Playback Sequences” on page 201.

6 Output the infocast. See “6. Output” on page 233.
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Video Clip Quick Editor 

The Video Clip Quick Editor imports a video clip into the selected 
region. Set the display options on the Content tab and apply a graphic 
overlay on the Overlay tab. Add audio on the Audio tab. 

Workflow 1 Select the region you want to add content to, then switch to the Items 
window. See “Open Region in Items Window” on page 54.

2 Select the editor from the Editor list in the Items window, then click 
on the Add button to open it. See “Open a Content Editor” on 
page 56 for details. 

3 Add content on the Content tab. See “Add Content on Content Tab” 
on page 173.

4 Apply graphics to overlay the video on the Overlay tab. See “Format 
Content on Overlay Tab” on page 178. 

5 Add audio. See “Add Audio on Audio Tab” on page 179.

6 Save your work in the editor. You can also enter a name for the region 
item in the Name field, preview your content in the editor’s Preview 
window, and automatically add the item to the Sequence list, using 
options on the editor’s main window. See “Save, Preview, Add to 
Sequence” on page 99.

select 
editor

click 
Add
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To preview a still image of your region items in a page layout, see “Preview 
Regions (Page Layout)” on page 48. To add more region items to this 
region, see “Add More Items” on page 63. To add items to other regions, 
see “Add Region Items Overview” on page 52. To schedule the playback 
sequence(s) for your regions and your pages, see “5. Schedule Playback 
Sequences” on page 201. To output the infocast, see “6. Output” on 
page 233.

Add Content on 
Content Tab

1 Click the Choose button. 

The Choose button is only available when creating a new region item. 

2 Open your video clip as prompted. 

To select multiple video clips to import at once, hold down the SHIFT 
or CTRL key as you click. When you click on the Save button in the 
editor, a region item for each video clip that you selected is added to 
the Items Library. 

3 To put the video clip file in a central location for shared referencing 
so that all the region items use the same file instead of referring to 
copies of the same file, check the Shared Media checkbox.

Then, select the shared media location from the following options:
• All: Adds the file to the default location C:\Shared Media, which is 

set in Preferences. See “Store Shared Media Files In” on page 248.
• Audio: Adds the file to a sub-folder called Audio under C:\Shared 

Media. 
• Type in a sub-folder name to create a new sub-folder under 

C:\Shared Media. Adds the file to the new sub-folder.
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4 To preview the video, use one of these methods:

• Drag the top arrow indicator 
above the timeline back and 
forth to any position in the timeline. The top indicator shows the 
current playback position of your preview in the editor. 

• Use the Play buttons to preview your video. 

5 To set the In and Out points for the clip, use one of these methods:

• Drag the left indicator in the timeline to the frame that you want to 
use as the In point. Drag the right indicator in the timeline to the 
frame that you want as the Out point. 

• Enter the timecode of the frame you want to use for the In and for 
the Out point in the fields below the timeline. The timecode is 
measured in hours:minutes:seconds:frames (HH:MM:SS:FF). The 
left field is for the In point and the right field is for the Out field.

• During preview, click the Set In button to set the current frame as 
the In point and click the Set Out button to set the current frame as 
the Out point.

6 To scale the video, check the Scale checkbox to enable the scale 
options, then use any of these methods:

• Check the Maintain Aspect Ratio checkbox to display the video clip 
at the aspect ratio stored in the video file. Clear the checkbox to 
size the video to the aspect ratio of the region. The video may 
distort if you clear the checkbox.

• Use the Scale slider to size the video display in your region. Click 
the Best Fit button to scale the video to the dimensions of the 
region. If the Maintain Aspect Ratio option is selected, the video 
may not completely fill the width or the height. 

• Check the Highest Quality checkbox to display your video with the 
highest image quality.

7 Click and drag the video in the editor’s Preview window to reposition 
the video display in the region. 

Play Trimmed Clip

Rewind

Previous Frame

Stop Play

Next Frame

Fast Forward
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8 Use the remaining options on the Content tab as needed. 

Choose field Displays the name of the video clip file.

Choose button Opens a dialog box in which you select a video clip 
for your region item.

Shared Media 
checkbox

Enables the shared media option to put the file in a 
central location for shared referencing. Then, 
select the shared media location from the list. 

Shared Media 
Sub-Folder 
drop-down list

Becomes available when you check the Shared 
Media checkbox. Select the shared media location 
from the following options:
• All: Adds the file to the default location 

C:\Shared Media, which is set in Preferences. See 
“Store Shared Media Files In” on page 248.

• Audio: Adds the file to a sub-folder called Audio 
under C:\Shared Media. 

• Type in a sub-folder name to create a new sub-
folder under C:\Shared Media. Adds the file to 
the new sub-folder.

Timeline bar Represents the entire timeline for the video file. 
When the clip is first opened the In point is set at 
the first frame and the Out point is set at the last 
frame. The fields for the In point, Out point, and 
Trimmed time update automatically.

Arrow Indicator 
above Timeline

Shows the current playback position of your 
preview in the editor. You can drag the indicator 
back and forth to any position in the timeline.

Left Arrow 
Indicator on 
Timeline

Shows the current In point for the clip. Drag the 
indicator to change the In point for the video clip. 
Double-click on the left indicator to jump the 
preview to the In point. 

Right Arrow 
Indicator on 
Timeline

Shows the current Out point for the clip. Drag the 
indicator to change the Out point for the video 
clip. Double-click on the right indicator to jump 
the preview to the Out point.

In (timecode) 
field below 
timeline on the 
left

Displays the timecode of the In point in 
hours:minutes:seconds:frames. Set the In point 
using the left arrow indicator on the timeline, or 
enter a specific frame in the In field.
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Out (timecode) 
field below 
timeline on the 
right

Displays the timecode of the Out point in 
hours:minutes:seconds:frames. Set the Out point 
using the right arrow indicator on the timeline, or 
enter a specific frame in the Out field.

Rewind Jumps to the first frame of the clip. 

Previous Frame Moves back one frame.

Stop Stops a playing clip.

Play Plays clip from current position.

Next Frame Moves forward one frame.

Fast Forward Jumps to the last frame of the clip.

Set In Sets the current frame as the In point.

Play Trimmed 
Clip

Plays the clip from the In point to the Out point.

Set Out Sets the current frame as the Out point.

Full field Displays the length of the full video clip. You 
cannot edit this field.

Trimmed field Displays the length of the video clip between the In 
point and the Out point. You cannot edit this field.

Scale checkbox Enables and disables the scale options. 

Maintain 
Aspect Ratio

Displays the video clip at the aspect ratio stored in 
the video file. 
If you maintain the aspect ratio of the clip, part of 
the video clip may extend outside of the region's 
boundaries. If you clear the checkbox to size the 
video to the aspect ratio of the region, the video 
may distort.
Use the scale slider to size the video clip to fit your 
region while maintaining the video clip aspect 
ratio. You can also click on the Best Fit button to 
size the video clip to the best fit possible. 

Play Trimmed Clip

Rewind

Previous Frame

Stop Play

Next Frame

Fast Forward
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Next, switch to the Formatting tab to format the text. 

Scale Slider Scales the display size of the video clip. You can 
size the video clip to fit your region while 
maintaining the video clip aspect ratio. The editor’s 
Preview window matches the region size, so as you 
scale the clip, the preview shows how much of the 
region is filled. The scaling is anchored to the top-
left corner of the region. 
Click and drag the video in the editor’s Preview 
window to reposition the clip in the region.
Click on the Best Fit button to size the video clip 
to the best fit possible. 

Best Fit Button Located to the right of the Scale slider. Scales and 
positions the video clip to fill the region. If the 
Maintain Aspect Ratio checkbox is selected, the 
video clip fills the region to maximum size while 
maintaining the video clip's aspect ratio, so the 
video might not fill the width or height completely. 
If the Maintain Aspect Ratio checkbox is not 
selected, the video clip is stretched or compressed 
to fill the dimensions of the entire region.

Log Note 
button

Opens a dialog box in which you can add 
comments that are displayed in the log file every 
time the item plays.
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Format Content 
on Overlay Tab

Apply a graphic to display over the video on the Overlay tab. 

1 Check the Display Graphic Overlay checkbox to enable the overlay 
options.

2 Click the Choose button and open your graphic file as prompted. 
When the graphic first loads, the image displays in the editor’s 
Preview window at 100% of its original size. 

3 Check the Scale checkbox to enable the scale options. Use the scale 
options to set the display options for your graphic.

• Check the Maintain Aspect Ratio checkbox to display the graphic at 
the aspect ratio stored in the image file. Clear the checkbox to size 
the graphic to the aspect ratio of the region. The graphic may 
distort if you clear the checkbox.

• Use the Scale slider to resize the graphic. 
Click the Best Fit button at the end of the scale slider to scale the 
graphic to the dimensions of the region. If the Maintain Aspect 
Ratio option is selected, the graphic may not completely fill the 
width or the height of the region. 

4 Click and drag the image in the editor’s Preview window to reposition 
the graphic.

Next, switch to the Audio tab. Save your work in the editor.
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Add Audio on 
Audio Tab

The audio options allow you to attach an audio file to the region item. The 
audio plays whenever the region item plays in the sequence. Once the 
region item stops playing, the sound stops. 

To add audio to your region item:

1 On the Audio tab, check the Enable Audio checkbox to enable the 
audio options.

2 Choose the audio source from the following options:

• Select Clip Audio Source to play the video clip's audio file. This 
option is selected by default when audio is enabled.

• Select External Audio file to attach an audio file to the video clip. If 
you attach an external audio file, the video clip's audio file does not 
play. When you select this option, the rest of the audio options 
become available. 
Click the Choose button, then select the an audio file as prompted.

The rest of the options on the InfoCaster Video Clip Quick Editor’s Audio 
tab are identical to the options on the Still Region’s Title Quick Editor 
Audio tab. Refer to “Add Audio on Audio Tab” on page 97 for details.

Next, set up your playback sequence, as explained in “Schedule Playback 
Overview” on page 202.
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Live Video Quick Editor 

The Live Video Quick Editor sets the region to display live video during 
playback. 

Select hardware sources for video and audio, or link to a streaming 
media file on the Content tab. Apply a graphic overlay on the Overlay 
tab. Adjust audio on the Audio tab. 

Workflow To add content to the selected region using the Live Video Quick Editor, 
the basic workflow is:

1 Select the region you want to add content to, then switch to the Items 
window. See “Open Region in Items Window” on page 54.

2 Select the editor from the Editor list in the Items window, then click 
on the Add button to open it. See “Open a Content Editor” on 
page 56 for details. 

3 Add content on the Content tab. See “Add Content on Content Tab” 
on page 181.

4 Apply graphics to overlay the video on the Overlay tab. See “Format 
Content on Overlay Tab” on page 184. 

5 Add audio on the Audio tab. See “Add Audio on Audio Tab” on 
page 185.

6 Save your work in the editor. You can also enter a name for the region 
item in the Name field, preview your content in the editor’s Preview 
window, and automatically add the item to the Sequence list, using 

select 
editor

click 
Add
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options on the editor’s main window. See “Save, Preview, Add to 
Sequence” on page 99.

To preview a still image of your region items in a page layout, see “Preview 
Regions (Page Layout)” on page 48. To add more region items to this 
region, see “Add More Items” on page 63. To add items to other regions, 
see “Add Region Items Overview” on page 52. To schedule the playback 
sequence(s) for your regions and your pages, see “5. Schedule Playback 
Sequences” on page 201. To output the infocast, see “6. Output” on 
page 233.

Add Content on 
Content Tab

1 Select one of the two following sources of your live video, Video 
Device or URL, as follows:

• Video Device: To display video from a video device connected to 
your system:
a Select the Video Device radio button.
b Select a hardware device from the Video Device list. The list 

displays all available hardware devices capable of delivering 
video. The video device must be installed on the same 
computer that is running InfoCaster.

c Select a source from the Source (video device) list. The list 
displays the sources available within the selected video device.

d Select a hardware device from the Audio Device list. The list 
displays all available hardware devices capable of delivering 
audio. The audio device must be installed on the same 
computer that is running InfoCaster.
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e Select a source from the Source (audio device) list. The list 
displays the sources available within the selected audio device.

• URL: To display video from an .asx or .asf media file streaming over 
the internet:
a Select the URL (Windows Media Video Stream) radio button.
b Enter the URL or file path for the .asx or .asf media file or click 

the browse button next to this field to browse for the file. You 
can have an .asx file locally which manages the connection to 
.asf media files. 

c Click the Connect button to start streaming the .asx or .asf 
media file selected in the URL field.

2 To display the live video at full screen size during output, check the 
Show Full Screen checkbox. The live video plays over top of all other 
regions. After the video region item finishes playback, the other 
region items are visible on-screen again.

3 Enter a duration for the live video display in the Duration field. Time 
is measured in HH:MM:SS:FF (hours:minutes:seconds: frames).

4 To enable the scale options, check the Scale checkbox. Then, use the 
following scale options to set the video display in the region item.

• Check the Maintain Aspect Ratio checkbox to display the live video 
at its original aspect ratio. Clear the checkbox to size the video to 
the aspect ratio of the region. The video may distort if you clear the 
checkbox.

• Use the Scale slider to size the video display in your region. Click 
the Best Fit button to scale the video to the dimensions of the 
region. If the Maintain Aspect Ratio option is selected, the video 
may not completely fill the width or the height. 

5 To reverse the field order of the incoming live video, check the Invert 
Field checkbox. Use this option if your input device inputs video in 
the opposite field order to your output device. 

6 To set the frame currently displayed in the preview as the image for 
representing the live video, click the Set Picon button below the 
Preview window. The image displays in the Items window's Item 
Library and Sequence list.

7 To reposition the video display in the region, click on the video in the 
editor’s Preview window, then drag the video to its new location.

8 Use the remaining options on the Content tab as needed.

Video Device 
radio button

Displays video from a video device connected to 
your system. 
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Video Device 
list

Displays all available hardware devices capable of 
delivering video. The video device must be 
installed on the same computer that is running 
InfoCaster.

(Video Device) 
Source list

Displays the sources available within the selected 
video device.

Audio Device 
list

Displays all available hardware devices capable of 
delivering audio. The audio device must be 
installed on the same computer that is running 
InfoCaster.

(Audio Device) 
Source list

Displays the sources available within the selected 
audio device.

URL radio 
button

Displays video from an .asx or .asf media file 
streaming over the internet. 

Connect button Starts streaming the .asx or .asf media file selected 
in the URL field.

URL file list Goes to the URL or file path that you enter for the 
.asx or .asf media file. You can have an .asx file 
locally which manages the connection to .asf media 
files.

(...) button Opens the Open dialog box to select a URL file.

Duration field Sets the duration for the live video display. Time is 
measured in HH:MM:SS:FF 
(hours:minutes:seconds: frames).

Invert Fields 
checkbox

Reverses the field order of the incoming live video.

Scale checkbox Enables the scale options. Use the scale options to 
set the video display in the region item.

Maintain 
Aspect Ratio 
checkbox

Displays the live video at its original aspect ratio. 
Clear the checkbox to size the video to the aspect 
ratio of the region. The video may distort if you 
clear the checkbox.

Scale Slide Resizes the video display in your region. 

Best Fit (4-way 
arrow) button

Scales the video to the dimensions of the region. If 
the Maintain Aspect Ratio option is selected, the 
video may not completely fill the width or the 
height.

Log Note 
button

Opens a dialog box in which you can add 
comments that are displayed in the log file every 
time the item plays.
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Format Content 
on Overlay Tab

Apply a graphic to display over the video on the Overlay tab. The selected 
graphic displays over the live video. 

1 Check the Display Graphic Overlay checkbox to enable the options.

2 Click the Choose button, then open your graphic file as prompted. 

3 Check the Scale checkbox to enable the scale options. Use the 
following scale options to set the display options for your graphic.

• Check the Maintain Aspect Ratio checkbox to display the graphic at 
the aspect ratio stored in the image file. Clear the checkbox to size 
the graphic to the aspect ratio of the region. The graphic may 
distort if you clear the checkbox. If you maintain the aspect ratio, 
part of the graphic may extend outside the region's boundaries. 

• Use the scale slider to size the image to fit your region while 
maintaining the image aspect ratio. 

• Click on the Best Fit button beside the slider to size the graphic to 
the best fit possible. If the Maintain Aspect Ratio option is 
selected, the graphic may not completely fill the region. 

4 To reposition the graphic, drag the image in the editor’s Preview 
window.

The Duration field displays the set duration of the live video or the 
playback duration for the graphic. You cannot edit the Duration field when 
live video is set for playback. However, if there is no live video source 
selected, enter a playback duration for the selected graphic file. Time is 
measured in HH:MM:SS:FF (hours:minutes:seconds:frames).
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Add Audio on 
Audio Tab

The audio options allow you to attach an audio file to the region item. The 
audio plays whenever the region item plays in the sequence. Once the 
region item stops playing, the sound stops. 

To add audio to your region item: 

1 On the Audio tab, check the Enable Audio checkbox to enable the 
audio options.

2 Choose the audio source from the following options:

• Select Live Audio Source to use the input from the audio device 
that is selected on the Content tab. When audio is enabled, this 
option is selected by default.

• Select External Audio file to attach an audio file to the live video 
input. If you attach an external audio file, the audio device selected 
on the Content tab is not used. When you select this option, the 
rest of the audio options become available. 
Click the Choose button, then open an audio file as prompted.

The rest of the options on the InfoCaster Live Video Quick Editor’s 
Audio tab are identical to the options on the Still Region’s Title Quick 
Editor Audio tab. Refer to “Add Audio on Audio Tab” on page 97 for 
details.

Next, set up your playback sequence, as explained in “Schedule Playback 
Overview” on page 202.
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Add Analog Clocks

Analog Clock Items Overview
Add an analog clock to your analog clock region item using the 
content editor in the Items window. 

There is 1 analog clock editor. This chapter contains instructions on 
how to use it.

• Analog Clock Quick Editor

Import the clock and format it on the Content tab. InfoCaster 
provides a selection of analog clock files that you can use. 
InfoCaster also provides an analog clock building utility. Adjust the audio settings on the Audio 
tab. By default, the time displayed by the clock is the local time provided by your computer clock. 
See “Analog Clock Quick Editor” on page 190. 

• Add Blank Item

To make the region transparent during playback, add a blank item to the sequence. See “About 
Blank Items” on page 56.

InfoCaster also provides an analog clock building utility, AClkBuilder.exe, with which you can create 
your own analog clocks. See “Create Analog Clocks” on page 192.

select 
editor

click 
Add
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Workflow 1 Open an infocast. See “1. Open an Infocast” on page 17. 

2 Add pages to the infocast. See “2. Add Pages to Infocast” on page 25. 

3 Add regions to the page. See “3. Add Regions to Page” on page 33.

4 Add content (region items) to each region. 

a Select the region you want to add content to, then switch to the 
Items window. See “Open Region in Items Window” on page 54.

b Select the editor from the Editor list in the Items window, then click 
on the Add button to open it. See “Open a Content Editor” on 
page 56.

c Add content on the content tab. See “Add & Format Content” on 
page 190. 

d Add audio on the Audio tab. See “Add Audio on Audio Tab” on 
page 191. 

e Save your work in the editor. You can also enter a name for the 
region item in the Name field, preview your content in the editor’s 
Preview window, and automatically add the item to the Sequence 
list, using options on the main window. See “Save, Preview, Add to 
Sequence” on page 99.

To preview a still image of your region items in a page layout, see 
“Preview Regions (Page Layout)” on page 48.
To add more region items to this region, see “Add More Items” on 
page 63.
To add items to other regions, see “Add Region Items Overview” on 
page 52.

5 Schedule the playback sequence(s) for your regions and your pages. 
See “5. Schedule Playback Sequences” on page 201.

6 Output the infocast. See “6. Output” on page 233.
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Analog Clock Quick Editor
Import the clock and format it on the Content tab. Adjust the audio settings on the Audio tab. The 
time displayed by the clock is the local time provided by your computer clock.

Add & Format 
Content

1 Click on the Choose button, then select the clock file from the dialog 
box as prompted. InfoCaster provides a selection of analog clock files 
that you can use. 

2 Adjust the clock display options as needed. 

Scale checkbox Enables and disables the scale option.

Scale slide bar Scales the display size of the clock. The editor’s 
Preview window matches the region size, so as you 
scale the clock, the preview shows how much of the 
region is filled. The scaling is anchored in the top-
left corner of the region. 

Position: Top 
field

Repositions the clock the displayed number of 
pixels away from the top of the region.

Position: Left 
field

Repositions the clock the displayed number of 
pixels away from the left edge of the region.

Opacity field Changes clock’s transparency level, where 0% 
represents complete transparency

Log Note 
button

Opens a dialog box in which you can add 
comments that are displayed in the log file every 
time the item plays.
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Add Audio on 
Audio Tab

Attach an audio file to the region item. Refer to “Add Audio on Audio Tab” 
on page 97 for instructions. 

Next, save your work in the editor. See “Save, Preview, Add to Sequence” 
on page 99. Set up your playback sequence, as explained in “Schedule 
Playback Overview” on page 202.
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Create Analog Clocks
When you create an analog clock item in a layout, InfoCaster provides a selection of analog clock files 
that you can use as content. InfoCaster also provides an analog clock building utility, AClkBuilder.exe, 
with which you can create your own analog clocks.

Open Analog 
Clock Builder

To open the Analog Clock Builder, select Start → Program Files → 
Inscriber → InfoCaster → Utilities → Analog Clock Builder.

For instructions on how to use this utility to create an analog clock file, use 
the Help menu in the Analog Clock Builder. 
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Add Audio Items

Audio Items Overview
Add audio to an Audio region on your page layout to play audio 
independent of other content. To add audio that plays when a region 
item plays, go to the Audio tab on the region item’s content editor. 

There is 1 audio region content editor. This chapter contains 
instructions on how to use it.

• Audio Quick Editor

Add audio to the page layout to play when you output the audio 
region. Adjust the volume, add a delay, and select a frequency 
(Play Once or Loop). 

• Add Blank Item

To make the region blank during playback, add a blank item to the sequence. See “About Blank 
Items” on page 56.

Workflow 1 Open an infocast. See “1. Open an Infocast” on page 17. 

2 Add pages to the infocast. See “2. Add Pages to Infocast” on page 25. 

3 Add regions to the page. See “3. Add Regions to Page” on page 33.

4 Add content (region items) to each region. 

a Select the region you want to add content to, then switch to the 
Items window. See “Open Region in Items Window” on page 54.

b Select the editor from the Editor list in the Items window, then click 
on the Add button to open it. See “Open a Content Editor” on 
page 56.

c Add audio content in the Audio Quick Editor. See “Add Content” 
on page 195.

d Save your work in the editor. You can also enter a name for the 
region item in the Name field, preview your content in the editor’s 
Preview window, and automatically add the item to the Sequence 
list, using options on the main window. See “Save, Preview, Add to 
Sequence” on page 99.

To preview a still image of your region items in a page layout, see 
“Preview Regions (Page Layout)” on page 48.
To add more region items to this region, see “Add More Items” on 
page 63.
To add items to other regions, see “Add Region Items Overview” on 
page 52.

5 Schedule the playback sequence(s) for your regions and your pages. 
See “5. Schedule Playback Sequences” on page 201.

6 Output the infocast. See “6. Output” on page 233.
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editor
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Audio Quick Editor
Add audio to the page layout to play when you output the audio region. Adjust the volume, add a 
delay, and select a frequency (Play Once or Loop).

Add Content 1 Click the Choose button, 
then open an audio file as 
prompted. 

2 To put the audio file in a 
central location so that all 
the region items use the 
same file instead of 
referring to copies of the 
same file, check the Shared 
Media checkbox.

Then, select the shared 
media location from the 
following options:
• All: Adds the file to the 

default location 
C:\Shared Media, which 
is set in Preferences. See 
“Store Shared Media 
Files In” on page 248.

• Audio: Adds the file to a sub-folder called Audio under C:\Shared 
Media. 

• Type in a sub-folder name to create a new sub-folder under 
C:\Shared Media. Adds the file to the new sub-folder.

Format Content 1 Format the audio file using any of these options:

• To adjust the volume, use the Level option. Audio levels range from 
zero to 100. Zero mutes the audio. 1 is the lowest audible level.

• To delay the audio playback from the start of the region item, enter 
the delay value in hours:minutes:seconds in the Delay field.

• To repeat the audio file, select the Loop radio button. To play the 
audio file only once, select the Play Once radio button.

• To set all other audio to duck (quiet) while the current audio file is 
playing, check the Enable Audio Ducking checkbox. To change the 
default audio ducking level, see “Audio Ducking Level” on 
page 249.

2 Use the remaining options as needed.
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Next, save your work in the editor. See “Save, Preview, Add to Sequence” 
on page 99. Set up your playback sequence, as explained in “Schedule 
Playback Overview” on page 202.

Enable Audio 
checkbox

Enables the audio options and enables audio for 
the region item. Audio options are not available if 
the Enable checkbox is not selected.

Audio file field Displays the name of the audio file.

Choose button Opens a dialog box in which you select an audio 
file. The name of the audio file appears in the 
audio file field.

Shared Media 
checkbox

Enables the shared media option to put the 
animation file in a central location for shared 
referencing. Then, select the shared media location 
from the drop-down list. 

Shared Media 
Sub-Folder 
drop-down list

Becomes available when you check the Shared 
Media checkbox. Select the shared media location 
from the following options:
• All: Adds the file to the default location 

C:\Shared Media. See “Store Shared Media Files 
In” on page 248.

• Audio: Adds the file to a sub-folder called Audio 
under C:\Shared Media. 

• Type in a sub-folder name to create a new sub-
folder under C:\Shared Media.

Level field Sets the volume of the audio clip. Audio levels 
range from zero to 100. Zero mutes the audio 
completely. 1 is the lowest audible level.

Delay field Delays the audio by the set time, measured in 
hours:minutes:seconds.

Play Once radio 
button

Sets the audio file to play once. If you select this 
radio button, the audio file plays once and does not 
repeat.

Loop radio 
button

Sets the audio file to repeat during output when the 
region item is playing. The audio plays whenever 
the region item plays in the sequence. Once the 
region item stops playing, the sound stops.

Preview button Plays a preview of the audio file.

Enable Audio 
Ducking 
checkbox

Sets all other audio to go quiet when the current 
item's audio is playing. See “Audio Ducking Level” 
on page 249.
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Add Temperature

Temperature Items Overview
If you have a temperature probe connected to your system, you can 
display current temperature readings in your layout. 

There is 1 temperature probe region content editor. This chapter 
contains instructions on how to use it.

• Temperature Probe Quick Editor

Add a temperature reading to the region. 

• Add Blank Item

To make the region transparent during playback, add a blank item to the sequence. See “About 
Blank Items” on page 56.

Workflow 1 Open an infocast. See “1. Open an Infocast” on page 17. 

2 Add pages to the infocast. See “2. Add Pages to Infocast” on page 25. 

3 Add regions to the page. See “3. Add Regions to Page” on page 33.

4 Add content (region items) to each region. 

a Select the region you want to add content to, then switch to the 
Items window. See “Open Region in Items Window” on page 54.

b Select the editor from the Editor list in the Items window, then click 
on the Add button to open it. See “Open a Content Editor” on 
page 56.

c Add content on the Content tab. See “Add Content on Content 
Tab” on page 199. 

d Format the content on the Formatting tab. See “Format on 
Formatting Tab” on page 200.

e Add audio on the Audio tab. See “Add Audio on Audio Tab” on 
page 200.

f Save your work in the editor. You can also enter a name for the 
region item in the Name field, preview your content in the editor’s 
Preview window, and automatically add the item to the Sequence 
list, using options on the main window. See “Save, Preview, Add to 
Sequence” on page 99. To preview a still image of your region 
items in a page layout, see “Preview Regions (Page Layout)” on 
page 48.

To add more region items to this region, see “Add More Items” on 
page 63.
To add items to other regions, see “Add Region Items Overview” on 
page 52.

5 Schedule the playback sequence(s) for your regions and your pages. 
See “5. Schedule Playback Sequences” on page 201.

6 Output the infocast. See “6. Output” on page 233.
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Temperature Quick Editor
If you have a temperature probe connected to your system, display current temperature readings in 
your layout.

Add Content on 
Content Tab 

1 All the temperature probes that are connected to your system are 
displayed in the Temperature Probe drop-down list. Select the probe 
you want to use. 

2 Select the communication port that the temperature probe is 
connected to in the ComPort list.

3 Click on either the Celsius or Fahrenheit radio button to select your 
unit of measure.
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Format on 
Formatting Tab 

The options on this editor are similar to those on the Title Quick Editor. 
Refer to “Title Quick Editor” on page 71 for details.

Add Audio on 
Audio Tab

The options on this Audio tab are identical to the options on the Still 
Region’s Title Quick Editor Audio tab. Refer to “Add Audio on Audio Tab” 
on page 97 for instructions on how to add audio to your region item. 

Next, schedule playback and output your infocast.



5. Schedule Playback
Sequences
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5. Schedule Playback Sequences

Schedule Playback Overview
Before you output your infocast, schedule the playback sequence(s) of both your infocast pages and 
your region items, or accept the default settings. You schedule playback sequences in the Sequencer 
on the respective Pages window and Items window. 

Start by scheduling playback sequences for your 
infocast pages in the Pages window. By default, a 
sequence is created and the first page of your 
infocast is added to the sequence. Add as many 
pages to a sequence as you want. You do not 
need to include all the pages in the sequence 
list. You can add the same page to the sequence 
list more than once. You can create multiple 
sequences. See “1. Add Sequence” on page 208 
and “2. Add Page to Sequence” on page 209. 

Then, adjust the Sequence Settings for the 
selected sequence and for the selected pages in 
a sequence, or use the default settings. 
Sequence settings apply to every page in that 
sequence. When you select a page in the 
sequence list, the Sequence Settings panel 
changes to the Pages Settings panel. Page 
settings bypass sequence settings. See “3. Adjust Sequence Settings” on page 210 and “4. Adjust Page 
Settings” on page 211. If you cannot see the sequence settings panel, see “Display Panel, Options, 
List” on page 207. 

You can set the playback of certain events, such 
as a region item, a region item sequence, a time, 
or a GPI trigger to trigger other events, such as 
play item, play item sequence, play page, output 
in pop-back region, or output GPO to action. 
See “Set Triggers” on page 226 for details.

In a similar way, schedule the playback 
sequences for your region items in the Items 
window. Then, adjust the Sequence Settings and 
Item Settings. See “Schedule Region Items” on 
page 213.

When you start playback, the pages and the 
items in each region play in the selected order, 
for the set duration, using the set transition and 
other options. See “6. Output” on page 233. The 
following illustration displays the basic workflow 

when creating an infocast.

select a sequence and 
adjust Sequence Settings

select a page and 
adjust Page Settings
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1

Open
a new or 
existing 
infocast.
 

2
The infocast
opens in the
Pages
window. By 
default,
a new page
is added to
new 
infocasts.
Click on the
New button
to add a new 
page as 
needed.
 

Double-click
on a page 
to add regions.

3b

The page
opens in the
Regions window.
Select a region
tool, then draw a
region in the 
workspace. 
Draw
more regions.

Double-click on a 
region to add
content.

4b

The region 
opens in the
Items window.
Select a content
editor from the list, 
then click on the
Add button next to it.

Add content in
editor.

5

Set playback sequence
for pages and region items.

6
Click on Play to output infocast.

3a 4a

4c

1)Open Infocast.  2)Add page.  3)Add regions.  4)Add items.  5)Sequence.  6)Output.
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Schedule Infocast Pages
Schedule the playback sequence of the pages in your infocast using the options in the Sequencer on 
the Pages window. 

By default, a sequence is created and the first page of your infocast is added to the sequence.

Add as many pages to a sequence as you want. You do not need to include all the pages in the 
sequence list. You can add the same page to the sequence list more than once. 

You can create as many sequences as you need. 

See “1. Add Sequence” on page 208 and “2. Add 
Page to Sequence” on page 209. 

Then, adjust the Sequence Settings for the 
selected sequence and for individual pages in a 
sequence, or use the default settings. Sequence 
settings apply to every page in that sequence. 
When you select a page in the sequence list, the 
Sequence Settings panel changes to the Pages 
Settings panel. Page settings bypass sequence 
settings. See “3. Adjust Sequence Settings” on 
page 210 and “4. Adjust Page Settings” on 
page 211. If you cannot see the sequence settings 
panel, see “Display Panel, Options, List” on 
page 207. 

 
You can set the playback of certain events, such as 
a region item, a region item sequence, a time, or a 
GPI trigger to trigger other events, such as play 
item, play item sequence, play page, output in 
pop-back region, or output GPO to action. See 
“Set Triggers” on page 226 for details.

When you start playback, the pages and the items 
in each region play in the selected order, for the 
set duration, using the set transition and other 
options. See “6. Output” on page 233.

select a sequence and 
adjust Sequence Settings

select a page and 
adjust Page Settings
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Workflow 1 Add a sequence to the sequence list in the Pages window. 

By default, for pages, a sequence is created for you. To add another 
sequence, click on the Add button in the Sequencer. See “1. Add 
Sequence” on page 208. Start another sequence and add pages to it 
when you want different sequence settings, such as a start time or 
transition type, to apply to certain pages. You can create as many 
sequences as you need. You may need to start another sequence to use 
a page or sequence in a trigger. See “Set Triggers” on page 226 for 
details.
To switch to the Pages window, click on the Pages button on the main 
toolbar at the top of the screen. See “Switch to Pages Window” on 
page 28.

2 Add a page(s) to the sequence. 

By default, the first page of your infocast is automatically added to the 
sequence. Add as many pages to a sequence as you want. You do not 
need to include all the pages in the sequence list. You can add the 
same page to the sequence list more than once. To add more pages, 
drag a page from Page Library to a sequence. See “2. Add Page to 
Sequence” on page 209.

3 Schedule the Sequence Settings. 

Select a sequence in the sequence list, then use the options on the 
Sequence Settings panel above it to schedule the playback for all the 
pages in that sequence. See “3. Adjust Sequence Settings” on 
page 210.
If you cannot see the Settings panel, see “Display Panel, Options, List” 
on page 207.

4 Schedule Page Settings as needed.

Select a page in a sequence. The Sequence Settings panel changes to 
the Page Settings panel. Set playback options on the Pages Settings 
panel. Page settings bypass sequence settings. See “4. Adjust Page 
Settings” on page 211.

5 Apply a trigger as needed. 

You can set the playback of certain events to trigger other events in 
InfoCaster. See “Set Triggers” on page 226.

To set the playback sequences of region items, see “Schedule Region 
Items” on page 213. To send your content to air, see “6. Output” on 
page 233.
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Select page. Sequence Settings become
Page Settings. Adjust Page Settings.

2Add (drag) page
to sequence.

1 Add sequence.

Select sequence, then adjust Sequence Settings. 3

4
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Set an Offline 
Graphic

To display an image on your output device whenever a page is switched 
during playback, select Edit→Preferences. Use the Choose button beside 
the Offline Graphic field on the General tab to select a graphic file. See 
“Offline Graphic” on page 247 for details.

Display Panel, 
Options, List

You can change how much information is displayed in the Sequencer on the 
Pages window to make more room to see your pages or your sequence list.

• To display the Sequence Settings panel, click on the Extended View 
button (double arrows) on the Sequencer toolbar. The Extended View 
button becomes the Brief View button. 
To hide the Sequence Settings, when you want more room to work on 
the region items, click on the Brief View button.

• To display or hide the Settings options, click on the triangle in front of 
the Sequence Settings title.

• To display or hide the sequence list, click on the triangle in front of the 
Sequence heading.

• To change the way pages are displayed in the sequence list, click on the 
Text Only button or on the Small Thumbnails buttons located above the 
Sequence Settings or Pages Settings panel. 

hides/displays sequence list

hides/displays Settings
panel options

Brief View/Extended View
hides/displays Settings panel

Text Only

Small Thumbnails
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1. Add 
Sequence

Sequence Added by Default

By default, a sequence 
(Sequence 1) is 
automatically added to 
the sequence list and 
the first page layout in 
your infocast project is 
set up for output. New 
pages that you create or 
import are not 
automatically included 
in the page sequence for output. 

Add Another Sequence 

When you want to apply 
different sequence 
options, such as a 
different playback time, 
to your page(s), add 
another sequence to 
your infocast, then drag 
a page there.

To add another 
sequence, click the Add 
button above the 
Sequence Settings 
panel. 

You can create as many sequences as you want for each region. 

The Sequence Settings are applied to every page in that sequence.

Skip or Play Sequence During Playback

By default, the checkboxes on the sequence headings are checked so that 
they play during output.

To skip a sequence 
during playback, clear 
the sequence heading 
checkbox. 

To skip only one page during output, place the page in its own sequence, 
then clear the sequence checkbox. You can do this when setting triggers, 
for example. See “Set Triggers” on page 226 for details.

check to play during output



InfoCaster 209

Sequence

Rename Sequence

To give your sequence a descriptive name, select the sequence heading in 
the sequence list, then click on the Rename button above the Sequence 
Settings panel. Name the sequence as prompted.

Delete a Sequence

To remove a sequence from the sequence list, select the sequence heading, 
then click the Delete button above the Sequencer panel. 

InfoCaster deletes the sequence heading and removes the pages from the 
sequence list. The pages remain available in the Page Library.

2. Add Page to 
Sequence 

You can add as many pages to the sequence list as you need. You don’t 
need to include all your pages in the sequencer. You can add the same page 
to the sequence more than once. 

Pages that are in the sequence are colored green in the Page Library. Pages 
that are not in the sequence are blue.

Page Added by Default

The default page that InfoCaster creates when you start an infocast is 
automatically added to the sequence list and the default settings are 
applied. New pages that you create or import are not automatically 
included in the page sequence for output.

Add Another Page to Sequence

To add a page to the sequence, drag the page from the Page Library to the 
sequence list under the sequence heading that you want.

drag page from library drag page to a sequence
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Change Order of Pages in the Sequence

To change the playback order of Pages, drag the page up or down in the 
sequence list in the Pages window.

Delete Pages from the Sequence

To remove a page from the sequence, use one of these methods.

• Drag the page from the sequence back to the Page Library. 
• Right-click on the page in the sequence, then select Remove Page from 

the menu. 
• Select the page, then select Pages→Delete Page from Sequence.

The page remains available in the Page Library, so you can add it to the 
sequence at a later time.

3. Adjust 
Sequence 
Settings

Set the playback schedule for each sequence in an infocast or accept the 
default settings. You can change the start time and the transition settings.

Sequence settings in the Pages sequencer apply to every page in that 
sequence. You can bypass sequence settings for individual pages in the 
sequence by applying page settings to the page. Page setting options 
become available when you click on a page in the sequence list. See “4. 
Adjust Page Settings” on page 211. 

To adjust Sequence settings for the playback of infocast pages:

1 Click on a sequence heading in the sequence list to select it. The 
Sequence Settings panel becomes available. 

select a sequence and 
adjust Sequence Settings
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2 In the Sequence Settings panel, adjust the following playback setting 
for the selected sequence. 

Skip or Play Sequence During Playback

To skip a page sequence during playback, clear the checkbox on the 
sequence heading. See “Skip or Play Sequence During Playback” on 
page 208 for details.

4. Adjust Page 
Settings

Every page in a sequence receives the same Sequence Settings until you 
change the Page Settings options for a page in the sequence. Page settings 
bypass sequence settings. 

You can set the page to play on specific days of the week, set the page to 
not play before or after a specific date, set the page to play for a specific 
length of time, and set the transition for the page. For example, you have an 
elaborate sequence and you want to play page layout #2 for a set duration 
every day except Sunday. 

To adjust page settings:

Start Sequence 
At field

Sets the playback start time for the sequence. 
When you start playback, the page that is set for 
output at the current time plays for the set 
duration. Then, the next page in the sequence list 
plays, and so on. 

Default 
Transition list

Applies the selected transition to every page in the 
selected sequence. For example, if you select a 
dissolve transition, every page in the sequence 
dissolves when it comes on-screen. 
To apply a different transition to some pages in a 
sequence, see “4. Adjust Page Settings” on 
page 211.

Default 
Transition 
Duration field

Sets the length of time it takes for the transition to 
complete.

Default 
Transition 
Softness field

Sets how soft or hard the edges of the transition 
appear. Increase the number to increase the 
softness. 



Se
qu

en
ce

212 InfoCaster

1 Click on a page in the sequence to select it. The Sequence Settings 
panel changes into the Page Settings panel. 

2 Adjust the playback setting for the selected page in the Pages Settings 
panel. Refer to the following table for details. 

Play This Item On 
(days of week) 
check boxes

Plays the page only on the days of the week that 
are selected. Clear the days of the week that you 
do not want the page to play.
The days that the page is set to play appear 
beside the page bar in the sequence list. You can 
also click on these buttons on the page bar in the 
sequence list to quickly adjust the days for 
playback.

Don’t Play Before 
checkbox & field

Sets the page to NOT play before a certain date. 
Enter the date in the field.

Don’t Play After 
checkbox & field

Set the page to NOT play after a certain date. 
Enter the date in the field.

Page Duration 
h m s fields

Changes the page duration from the sequence 
default duration.

Transition list Applies the selected transition to that page. Page 
transitions bypass Sequence Setting transitions.

(Transition) 
Duration field

Sets the length of time it takes for the transition 
to complete.

(Transition) 
Softness field

Sets how soft or hard the edges of the transition 
appear. Increase the number to increase the 
softness.

select a page and 
adjust Page Settings
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Schedule Region Items
Schedule the playback sequence of the items in each region using the options in the Sequencer on the 
Item window. 

If you had selected the Auto Add To Sequence checkbox in the region item editor, all your region 
items are added to the sequence by default. See “Save, Preview, Add to Sequence” on page 99 for 
details on this option.

Add as many region items to a sequence as you want. You do not need to include all the items in the 
sequence list. You can add the same item to the sequence list more than once. 

You can create as many sequences as you need. 

See “1. Add Sequence” on page 216 and “2. Add 
Items to Sequence” on page 217. 

Then, adjust the Sequence Settings for the 
selected sequence and for individual items in a 
sequence, or use the default settings. Sequence 
settings apply to every page in that sequence. 
When you select an item in the sequence list, the 
Sequence Settings panel changes to the Items 
Settings panel. Item settings bypass sequence 
settings. See “3. Adjust Sequence Settings” on 
page 219 and “4. Adjust Item Settings” on 
page 222. If you cannot see the sequence settings 
panel, see “Display Panel, Options, List” on 
page 207. 

You can set the playback of certain events, such as 
a region item, a region item sequence, a time, or a 
GPI trigger to trigger other events, such as play 
item, play item sequence, play page, output in 
pop-back region, or output GPO to action. See 
“Set Triggers” on page 226 for details.

When you start playback, the pages and the items 
in each region play in the selected order, for the 
set duration, using the set transition and other 
options. See “6. Output” on page 233.

select item and adjust Item Settings
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Workflow 1 Add a sequence to the sequence list in the Items window. 

Click on the Add button in the Sequencer. See “1. Add Sequence” on 
page 216.
To switch to the Items window, click on the Items button on the main 
toolbar at the top of the screen. See “Switch to Items Window” on 
page 55.

2 Add items to the sequence. 

Drag an item from Item Library to a sequence. See “2. Add Items to 
Sequence” on page 217.

3 Schedule the Sequence Settings. 

Select a sequence in the sequence list, then use the options on the 
Sequence Settings panel above it to schedule the playback for all the 
items in that sequence. See “3. Adjust Sequence Settings” on page 219.

4 Schedule Item Settings as needed.

Select an item in a sequence. The Sequence Settings panel changes to 
the Item Settings panel. Set playback options on the Item Settings 
panel. Item settings bypass sequence settings. See “4. Adjust Item 
Settings” on page 222.

5 Apply a trigger as needed. 

You can set the playback of certain events to trigger other events in 
InfoCaster. See “Set Triggers” on page 226.

To set the playback sequences of the page, see “Schedule Infocast Pages” 
on page 204. To send your content to air, see “6. Output” on page 233. 
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Display Panel, 
Options, and 
List

You can change how much information is displayed in the Sequencer on the 
to make more room for your Library or your sequence list. See “Display 
Panel, Options, List” on page 207 for details.

select item, then adjust Items Settings 

select sequence, then adjust Sequence Settings 

2 add (drag) 
item to
sequence

1 add sequence

3

4



Se
qu

en
ce

216 InfoCaster

1. Add 
Sequence

Sequence Added by Default

By default, a sequence (Sequence 1) is automatically added to the sequence 
list. 

Add Another Sequence 

To apply different 
sequence options, such 
as a different playback 
time or transition, to 
your region item(s), or 
to organize items in 
your region, create 
another sequence in 
your region in the 
Items window. 

To add another 
sequence, click the 
Add button above the 
Sequence Settings 
panel. 

You can create as many 
sequences as you need for each region. 
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Skip or Set Sequence During Playback

By default, the checkboxes on the sequence headings are checked, so that 
they play during output. 

To skip a sequence 
during playback, clear 
the sequence heading 
checkbox. 

To set a sequence to play during output, check the sequence heading 
checkbox. 

Rename Sequence

To give a sequence a descriptive name, select the sequence heading in the 
sequence lists, then click on the Rename button above the Sequence 
Settings panel. Name the sequence as prompted.

Delete a Sequence

To remove a sequence from the sequence list, select the sequence heading, 
then click the Delete button above the Sequencer panel.

InfoCaster deletes the sequence heading and removes the region items 
from the sequence list. The region items remain available in the Item 
Library.

2. Add Items to 
Sequence 

You can add as many items to the sequence as you need. You don’t need to 
include all your items in the sequencer. You can add the same item to the 
sequence more than once. 

Items that are in the sequence are colored green in the Item Library. Items 
that are not in the sequence are blue.

Auto Add to Sequence

If you checked the Auto Add to Sequence checkbox in the content editor 
when you created your region item, the region item was automatically 
added to the sequence list. See “Save, Preview, Add to Sequence” on 
page 99 for details. 

Add Items to Sequence

To add an item to the sequence, drag the item from the Item Library to the 
sequence list under the sequence heading that you want.

check to play during output
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Add Blank Item to Sequence

To make the region transparent, add a blank item to the sequence. To do 
this, select Add Blank Item from the region item editor list. See “About 
Blank Items” on page 56 for further information. 

Change Order of Items in Sequence

To change the playback order of items, drag the item up or down in the 
sequence list in the Items window.

Delete Items from Sequence

To remove an item from the sequence, while keeping the item in the Item 
Library, use one of these methods.

• Drag the item from the sequence list back to the Item Library. 
• Right-click on the item in the sequence list, then select Remove Item 

from the menu. 
• Select Items→Delete Item in Sequencer.

drag item from library drag item to a sequence
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3. Adjust 
Sequence 
Settings

Set the playback schedule for each sequence in a region or accept the 
default settings. 

You can set the sequence start time, set the playback duration of stills, 
digital clocks, analog clocks, and temperature probes in the sequence, set 
the transition type, set the sequence to loop, and set items to finish 
playback before starting the next sequence in the list.

Sequence settings in the Items sequencer apply to every item in that 
sequence. You can bypass sequence settings for individual items by 
applying item settings to the item. Item setting options become available 
when you click on an item in the sequence list. See “4. Adjust Item 
Settings” on page 222 for details.

To adjust region item sequence settings:

1 Click on a sequence heading to select it. The Sequence Settings panel 
becomes available. 

Some of the options vary for each region type, as shown in the 
following illustrations.

• Still Region Sequence Settings

• Crawl Region Sequence Settings

select sequence and adjust Sequence Settings
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• Roll Region Sequence Settings

• Animation Region Sequence Settings

• Digital Clock Region Sequence Settings

• Video Region Sequence Settings

• Analog Clock Region Sequence Settings

• Audio Region Sequence Settings
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• Temperature Probe Region Sequence Settings

2 In the Sequence Settings panel, adjust the playback setting for the 
selected item. Refer to the following table for details.

Start Sequence 
At field

Available for all region types. Sets the start time for 
the sequence. When you start playback, the region 
item that is set for output at the current time plays 
for the set duration. Then, the next item plays, and 
so on. For example, you have a sequence of three 
items and each item plays for one hour. If the 
sequence start time is 1:00 PM and you start 
playback at 2:30 PM, item two plays.

Speed slide bar Available for Crawl and Roll regions only. 
Adjusts Crawl or Roll speed. The speed applies to 
all Crawl or Roll items in the sequence.

Direction: To 
Left or To Right 
radio buttons

Available for Crawl regions only. Adjusts Crawl 
Direction. Set crawls to move left or right. The 
direction applies to all Crawl items in the 
sequence. To change the direction that applies to 
all crawls by default, change the direction option in 
the Preferences dialog box. See “Default Crawl 
Direction” on page 248.

Direction: Up 
or Down radio 
buttons

Available for Roll regions only. Adjusts Roll 
Direction. Set rolls to scroll up or down. The 
direction applies to all Roll items in the sequence.
To change the direction that applies to all rolls by 
default, change the direction option in the 
Preferences dialog box. See “Default Roll 
Direction” on page 247.

Default 
Duration h m s 
fields

Available for Still, Digital Clock, and Analog Clock 
regions. Sets a default playback duration for the 
selected item, in hours, minutes, and seconds. 
Each item in the sequence plays for that duration.
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4. Adjust Item 
Settings

There are 2 ways to apply different playback settings to an item.

• Create a new sequence and drag the item to the new sequence. 
• Change the playback schedule for individual pages in a sequence, as 

explained here. 
Do this when you want most of the settings to be the same for all your 
items and want to modify only a few details of individual items. For 
example, to display a different menu every day but have everything else 
remain the same in the region, select each menu region item and adjust 
their play dates. 
You can set the item to play on specific days of the week, to play during 
a specific period of the day, or to not play before or after a specific date. 
Item settings, such as transitions for still or video items, bypass 
sequence settings.

Default 
Transition list

Available for Still and Video regions only. Applies 
the selected transition to every item under the 
sequence heading. If you apply an Items Settings 
transition to individual region items, the item 
transition bypasses the Sequence Setting 
transition.

Default 
Transition 
Duration field

Available for Still and Video regions only. Sets the 
length of time it takes for the transition to 
complete.

Default 
Transition 
Softness field

Available for Still and Video regions only. Sets how 
soft or hard the edges of the transition appear. 
Increase the number to increase the softness.

Loop Sequence 
checkbox

Available for all region types except Still. Repeats 
the sequence from the beginning once playback has 
completed. If you clear the checkbox, the sequence 
plays through only once.

End Item Before 
Changing 
Sequences 
checkbox

Available for all region types except Still. Finishes 
playback of the active item before InfoCaster starts 
the next sequence in the list. If you clear the 
checkbox, the playing item stops immediately when 
the next sequence starts at the set start time.
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To Adjust Item Settings

1 Click on an item in the sequence to select it. The Sequence Settings 
panel changes into the Item Settings panel. 

The options vary for each region type, as shown in the following 
illustrations.

• Still Region Item Settings

• Crawl Region Item Settings

• Roll Region Item Settings

select item and adjust Item Settings
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• Animation Region Item Settings

• Digital Clock Region Item Settings

• Video Region Item Settings

• Analog Clock Region Item Settings

• Audio Region Item Settings

• Temperature Probe Region Item Settings
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2 Adjust the playback setting for the selected item in the Items Settings 
panel. Refer to the following table for details. Some of the Items 
Settings options vary for different region type. 

Play This Item 
On (days of 
week) check 
boxes

Available for all region types. Plays the item only 
on the days of the week that are checked. Clear the 
days of the week that you do not want the item to 
play.
The days that the item is set to play appear beside 
the item bar in the sequence list. You can click on 
these buttons in the item bar to quickly adjust the 
days for playback.

Play Item 
Between _ and 
_ checkbox & 
fields

Available for all region types. Enables the Play Item 
Between _ and _ fields, to set the item to play only 
during a certain time period in the day. Specify a 
start and end time.

Don’t Play 
Before 
checkbox & 
field

Available for all region types. Becomes available 
when you check the Play Item Between checkbox. 
Sets the item to not play before the date you enter.

Don’t Play After 
checkbox & 
field

Available for all region types. Becomes available 
when you check the Play Item Between checkbox. 
Sets the item to not play after the date you enter.

Duration h m s 
fields

Available for Still, Digital Clock, and Analog Clock 
regions only. Sets the item’s duration.

Transition list Available for Still and Video regions only. Applies 
the selected transition to the item. Item transitions 
bypass Sequence Setting transitions.

(Transition) 
Duration field

Available for Still and Video regions only. Sets the 
length of time it takes for the transition to 
complete.

(Transition) 
Softness field

Available for Still and Video regions only. Sets how 
soft or hard the edges of the transition appear. 
Increase the number to increase the softness.
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Set Triggers
You can set the playback of certain events to trigger other events to action in InfoCaster. The trigger 
event can be a region item, a region item sequence, a time, or a GPI trigger. The action event can be 
play item, play item sequence, play page, output in pop-back region, or output GPO. 

Workflow 1 Disable the sequence, page, or item that you want to use as the 
action.

2 Open the Conditional Playback dialog box and start a New trigger.

3 Select a trigger.

4 Select an action.

5 Save.

1. Disable 
Sequence, 
Page, or Item

In the Sequence list, disable the sequence, page, or item that you want to 
use as the action.

To do this, switch to the Pages or Items window, then clear the checkbox in 
the sequence heading. See “Skip or Play Sequence During Playback” on 
page 208 for details. You may need to put an item in its own sequence, 
then disable the sequence. 

2. Open 
Conditional 
Playback

1 Select Tools→Conditional 
Playback, or click on the 
Conditional Playback 
button on the main toolbar, 
located after the Stop 
button. 

Conditional Playback (Triggers) button
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2 In the Conditional Playback dialog box, click New to create a new 
conditional playback event.

3. Select 
Trigger

From the Trigger drop-
down list in the Event 
Setup dialog box, select 
one of the following 
items that triggers the 
start of the next action. 

Item Starts 

Sets the playback of an 
item to trigger an action. 
Select the page, region, 
sequence, and item from 
the drop-down lists.
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When the trigger is aired, the item plays once, then scheduled playback 
resumes. If you want the item to loop during playback, place the item in its 
own sequence, then select the Loop option in the Items Sequence Settings 
panel. See “3. Adjust Sequence Settings” on page 219.

Sequence Starts

Sets the playback of a 
sequence to trigger an 
action. Select the page 
that contains the 
sequence, the region that 
contains the sequence, 
and the sequence that is 
used as the trigger. 

When the trigger is aired, the sequence either plays once or loops, 
depending on what you selected in the Sequence Settings panel. Then, 
scheduled playback resumes.

GPI

Sets a GPI trigger to 
trigger an action. Select 
the GPI number from the 
list which contains all 
known GPIs connected to 
your system. Then, check 
the Pulse radio button to 
trigger your selections immediately upon touching the GPI trigger, or check 
the Tone radio button to trigger your selection after holding down the GPI 
trigger for a moment.

Note: The GPI Initiated option is only available after you select the GPI 
device in the Configuration Utility. To do this: 

a Click on the Windows START button on the bottom left corner 
of your screen, then select Programs→ Inscriber→ 
InfoCaster→ Utilities→ InfoCaster Configuration Utility. 
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b In the Configuration Utility, select the GPI device connected to 
your system: Live Link Installed, Serial GPI, or Software GPIs. 

The GPIs that are available with that device are displayed in the 
GPI List panel. These numbers are also displayed in the 
Conditional Playback dialog box.

c If you selected the Serial GPI option and have more than 1 
Comm port, select the port for each GPI trigger in the Serial 
GPI Configration panel.

Reaching Specified 
Time

Sets an action to be 
triggered at a particular 
time. Select the date and 
time. 
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4. Select Action From the Action drop-down list, select one of the following events to occur 
when the Trigger is reached. 

Note: Only pages, items, and sequences that are disabled in the sequence 
list are available in the Action list, as explained in “1. Disable 
Sequence, Page, or Item” on page 226.

Play Item 

Sets an item to play when 
the trigger has been 
reached. Select the page, 
region, sequence, and 
item from the list. 

Note: Only items that 
are disabled in the sequence list are available in the Action list, as 
explained in “1. Disable Sequence, Page, or Item” on page 226.

Play Sequence 

Sets a sequence to play 
when the trigger has 
been reached. Select the 
page, region, and 
sequence from the list.

Note: Only sequences that are disabled in the sequence list are available 
in the Action list, as explained in “1. Disable Sequence, Page, or 
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Item” on page 226.

Play Page:

Sets a page to play when 
the trigger has been 
reached. Select the page 
from the list. 

Note: Only pages that are disabled in the sequence list are available in 
the Action list, as explained in “1. Disable Sequence, Page, or Item” 
on page 226.

Pop-Back Resize 

Sets a region to be 
resized to a pop-back 
region size when the 
trigger has been reached. 
Select the page that the 
region is in, then the region. In the And It Resizes To field, select the pop-
back region that you want the region to resized to. 

To return the region of a pop-back action to its original size, create another 
trigger event and select Its Original Size in the And It Resizes To field. 

For details on pop-back regions, see “Draw a Pop-Back Region” on 
page 44. 

GPO

Sets output from an 
external device to play 
when the trigger has 
been reached.
Select the number of the external device in the list. 

5. Save Click Save in the Event Setup dialog box.
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The trigger is displayed in the Conditional Playback dialog box.

Skip Trigger 
Events

To skip a trigger event during output, or to reset an event that you skipped:

1 Select Tools→Conditional Playback.

2 In the Conditional Playback dialog box, the checkmark beside each 
trigger event sets the trigger event to be active during output. To skip 
the trigger event during output, clear the checkbox beside the trigger 
event.



6. Output
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6. Output

Output Overview
You can start playing an infocast in 2 ways.

• Click on the Play button in the main toolbar to output your infocast starting from the scheduled 
time according to the times that are set in the page and region item sequence lists. For example, 
you have a sequence of 3 items and each item plays for 1 hour. If the sequence start time is 1:00 
PM and you start playback at 2:30 PM, item number 2 plays. 

• Right-click on a blank space in the pages or items sequence list, then select Start Playback from 
the First Page from the menu, to output your infocast starting from the first page and item in all 
your sequence lists. 

InfoCaster plays the infocast to an output monitor. The region item that is set for output plays for the 
set duration. Then, the next item in the sequence list plays, and so on. InfoCaster loops through each 
sequence of pages and items until it reaches the start time of the next sequence in the list. Only one 
item in each region of one page layout in your infocast is output to air at any given time.

While your infocast is playing, you cannot adjust regions in the Regions window or change the crawl 
or roll speed, However, you can add, delete, and modify content, and rearrange the sequence. 
Changes apply the next time InfoCaster plays that item. You can track which region is currently playing 
in the sequence list. You can control plasma display screens. And you can log your output, as 
explained in “Log Files” on page 245.
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1

Open
a new or 
existing 
infocast.
 

2
The infocast
opens in the
Pages
window. By 
default,
a new page
is added to
new 
infocasts.
Click on the
New button
to add a new 
page as 
needed.
 

Double-click
on a page 
to add regions.

3b

The page
opens in the
Regions window.
Select a region
tool, then draw a
region in the 
workspace. 
Draw
more regions.

Double-click on a 
region to add
content.

4b

The region 
opens in the
Items window.
Select a content
editor from the list, 
then click on the
Add button next to it.

Add content in
editor.

5

Set playback sequence
for pages and region items.

6
Click on Play to output infocast.

3a 4a

4c
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Preview Before Playback
Before you send your infocast to air, you can preview your content in the following ways.

Content Editor 
Preview Panel

You can preview the relative content of each region item in the preview 
panel of the content editor as you create each item. Refer to chapters about 
adding region items, starting with “4. Add Items to Regions” on page 51.

Regions 
Window 
Workspace

You can preview a still image of each region item on your page layout in the 
Regions window workspace. See “Preview Regions (Page Layout)” on 
page 48 for details.

Desktop Video 
Window

If you select Desktop Video window as your output device (as explained in 
“Select Output Device” on page 238), your infocast outputs to your 
computer monitor. You can use this method to test your layouts before 
outputting to the public.

Use GPU 
Acceleration

GPU Acceleration uses your system's graphics processing unit (GPU) 
instead of the central processing unit (CPU) to accelerate certain effects. 
GPU Acceleration is available for progressive VGA output. By default, it is 
enabled in new layouts. 

If you are updating an infocast that has been created in an earlier version of 
InfoCaster, you need to enable GPU Acceleration. 

To enable GPU Acceleration, switch to the Regions window, then select 
Regions→GPU Acceleration→All Regions On.

It is recommended that you leave GPU Acceleration on.
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Play Infocast
There are two ways you can output your infocast; starting from the beginning of the sequence, or 
starting from the scheduled time. 

During playback, the ON AIR indicator at the top right corner of the screen lights up.

Animations play back at the frame rate of the playback device. 

• ATI:  1 second = 60 frames

• NTSC: 1 second = 30 frames

• PAL: 1 second = 25 frames

Play From 
Scheduled Time

You can output your infocast so that it starts playing the content that is 
scheduled to play at specific times in the playback sequences of your 
infocast pages and region items. For example, you have a sequence of 3 
items and each item plays for 1 hour. If the sequence start time is 1:00 PM 
and you start playback at 2:30 PM, item number 2 plays.

With your infocast project open, click the Play button on the main toolbar 
at the top of the screen. Alternately, you can right-click on the page in the 
Pages window, then select Play Page from the menu, or you can select 
File→Start Playback

Play From Start You can output your infocast so that it starts playing the content on the first 
page and the first region item in your page and item sequence list. 

Right-click on the pages or region items sequence window below the 
sequence list, then select Start Playback from the First Page.

Stop Infocasts Click the Stop button on the main toolbar at the top of the screen to stop 
the output. Alternately, you can select File→Stop Playback

Play from location in sequence

On Air
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View Playback
While your infocast is on air, you can view the infocast in 2 locations.

• The Preview window at the bottom left corner of your InfoCaster screen.

• The selected output device.

View from 
Preview 
Window 

To see the output of your infocast in the Preview window at the 
bottom-left corner of your InfoCaster Creation Station screen, 
select Tools→Preview Playback. InfoCaster displays exactly 
what is being aired. 

Note: If Desktop Video is selected as the output device, this 
option is not available. See “Select Output Device” on page 238 
below for details.

Select Output 
Device

InfoCaster plays your infocasts to an output monitor. This may be a VGA 
monitor, a video monitor, or a plasma display, depending on your hardware 
configuration. If your output monitor supports external control, you may be 
able to control it from InfoCaster. 

When you first install InfoCaster, the Configuration Utility opens, in which 
you select your output device.

To change the output device:

1 Click on the Windows START button on the bottom left corner of 
your screen, then select Programs→ Inscriber→ InfoCaster→ 
Utilities→ InfoCaster Configuration Utility.
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2 In the Configuration Utility, select one of the following output devices 
from the Select Output Device drop-down list on the Video/Audio 
Standard Change tab:

• Inca PCI-100: Select this option to output to the output device that 
is connected to your PCI-100 card.

• Desktop Video 
Window: Select 
this option to 
output to your 
computer 
monitor via the 
Desktop Video 
window. 

• VGA Out: Select 
this option to 
output to the 
VGA output 
device that is 
connected to 
your ATI card.

• TV Out: Select this option to output to the TV output device that is 
connected to your ATI card.

• Matrox G450 / G550: Select this option to output to the output 
device that is connected to your Matrox card.

To output to more sources, you can purchase player licences. See 
“Purchase Options” on page 3 for further information.

3 Select a video standard from the list.

4 To connect to live video input:
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a Select the Yes, I have live video input radio button. The PCI-100 
checkbox and the NTSC drop-down list become available.

b If you have a PCI-100 card, check the PCI-100 checkbox. 
c Select NTSC or PAL from the drop-down list.

4 Click OK to continue. Restart InfoCaster as prompted.

Control Plasma 
Display Screens

You can use a serial trigger to turn your plasma monitor on or off. 

1 In the Pages window, select Tools→Plasma Display Control.

2 In the Plasma Display Control dialog box, select the COM port that 
connects to your plasma display screen from the Com Port list.

3 Select your plasma display's make and model from the Plasma Display 
list. If your model is not listed, contact support@inscriber.com for 
assistance.

4 Check the Enable Automatic Display Control checkbox to enable the 
scheduling options. 

Clear the checkbox to disable InfoCaster's automatic control of the 
display screens.

5 Schedule the selected plasma display screen by selecting one of the 
following options for each day of the week:

• Select the On From radio button, then enter a start display time in 
the first field, and an end display time in the second field. 
InfoCaster keeps the plasma display on from the time set in the first 
field to the time set in the second field.

• Select On All Day to keep the plasma display on all day.
• Select Off to turn the plasma display off for that day.
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Track Output You can track which item in the sequence list is currently playing in any 
region. You can track the playback of region items in log files. 

Track Playback Item in Sequence List

To highlight, in the Items sequence list on the Items window, the item that 
is currently playing: 

1 Open the region in 
the Items window to 
display its sequence 
list. See “Open 
Region in Items 
Window” on page 54.

2 Select 
Items→Display 
Playback Position in the Items window to enable this feature.

3 Click the Play button to output the infocast. 

Track Playback of Region Items in Log File

To create a log file of all the times the content of a region is aired, check 
the Log This Region checkbox in the Details panel below the Regions 
workspace. as explained in “Log Region Playback” on page 47.

Each day, InfoCaster creates a new log file that contains the playback 
information of the entire day. The log includes the player name, page name, 
region name, item name, start date, start time, stop date, stop time, and 
duration. 

To view a log file, or change default log settings, such as the status of 
automatic logging, the log file location, or the number of days a log file is 
kept on your system, see “Log Files” on page 245.

Change 
Content During 
Playback

While your infocast is playing, you cannot adjust regions in the Regions 
window or change the crawl or roll speed, but you can add, delete, and 
modify content, and rearrange the sequence. Changes apply the next time 
InfoCaster plays that item. 

To skip a sequence 
during playback, clear 
the sequence heading 
checkbox. 

To set a sequence to play during output, check the sequence heading 
checkbox. To skip or enable a trigger, see “Skip Trigger Events” on 
page 232.

check to play during output
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Appendix

Additional Tasks
In addition to creating infocasts and airing them, you can also do the following in InfoCaster:

Log Files Create log files, view log files, or change default log settings, such as the 
status of automatic logging, the log file location, or the number of days a 
log file is kept on your system. See “Log Files” on page 245.

Change 
Preferences

Change your default settings in the Preferences dialog box. See “Change 
Preferences” on page 247.

Create External 
Data Sources

Create a text file or an ODBC data source that you can link to a Still, Crawl, 
Roll, or Animation region item. See “Create External Data Sources” on 
page 251. 
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Log Files
You can log the playback of region items. A new log file is created each day, so the playback of an 
entire day is stored in one log file.

You can automatically set all regions to be logged, change the log file location, or change the number 
of days a log file is kept on your system. 

Log Region 
Playback

To create a log file of all the times the content of a region is aired, check 
the Log This Region checkbox in the Details panel below the Regions 
workspace. as explained in “Log Region Playback” on page 47.

Each day, InfoCaster creates a new log file that contains the playback 
information of the entire day. 

View Log File To view the log file after you output the project, select Tools→Log Viewer. 
The Log Viewer opens, displaying the log file for the current day. 

To open a different log file, select File→Open in the Log Viewer dialog 
box, then select the log file you want. The default folder is C:\Program 
Files\Inscriber\InfoCaster\PlaybackLogs. The date that the data was logged 
is stored as part of the log file name.
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Change Logging 
Defaults

By default, items are not set to be logged. You can enable or disable 
logging as the default, change the default storage folder for log files, and 
change the default number of days that log files are stored on your system.

To change logging defaults, select Edit→Preferences and select the 
Logging tab in the Preferences dialog box. See “Log Region Playback” on 
page 245 for details. 
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Change Preferences
Select Edit→Preferences to change your default settings in the Preferences dialog box.

General Tab

Store Infocasts In

InfoCaster saves your infocast projects to C:\InfoCasts by default. Pages are 
saved to C:\InfoCasts\project folder. To change the location for saved 
projects, click on the Choose button next to the Store InfoCasts In field, 
then select a new location in the dialog box that comes up. 

Load Last Infocast on Startup

To set InfoCaster to load your last opened project when you start 
InfoCaster, check the Load Last Page Layout on Startup checkbox on the 
General tab.

Offline Graphic

To display a graphic on your output device whenever a page is switched 
during playback, use the Choose button beside the Offline Graphic field to 
select a graphic file.

Default Roll Direction

To change the default direction that applies to all rolls, change the Default 
Roll Direction option on the General tab.
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Default Crawl Direction

To change the default direction that applies to all Crawl items, change the 
Default Crawl Direction option on the General tab.

Store Shared Media Files In

You can save your audio, video, and animation files in a central location for 
shared referencing. All the region items that use the same file refer to the 
shared media folder instead of referring to copies of the same file in 
different places. 

To use this feature, you must select the Shared Media option in a content 
editor when you add a region item to a region. See “4. Add Items to 
Regions” on page 51 for more information about region items.

InfoCaster saves your shared media files to the default location C:\Shared 
Media. This is true when saving an infocast to CD as well. InfoCaster 
automatically creates the directory folders it needs.

To change the default location for shared media, click on the Choose 
button next to the Store Shared Media Files On field on the General tab in 
the Preferences dialog box. Then, select a new file location for your shared 
media.

Automatically Delete Shared Media Files

To automatically delete files in the Shared Media folder that are no longer 
referred to by any infocasts, check the Automatically Delete Stored Media 
Files That Are Not Referenced or Being Used By Any InfoCast checkbox.

Output Aspect Ratio

You can set the aspect ratio for your output monitor and for your computer 
display. The aspect ratio is a global setting applied to all page layouts you 
open in InfoCaster, so individual layouts do not store aspect ratio 
information. Selecting the right aspect ratio ensures that objects maintain 
their proper shape without appearing skewed during playback. For 
example, if you output to a 16:9 display, select 16:9 in the Preferences 
dialog box. 

To select an aspect ratio for your output screen, select an option from the 
Output Aspect Ratio drop-down list.

To select an aspect ratio for your computer display, select an option from 
the VGA Aspect Ratio drop-down list.
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VGA Aspect Ratio

To select an aspect ratio for your computer display, select an option from 
the VGA Aspect Ratio drop-down list. See “Output Aspect Ratio” on 
page 248 for details.

Audio Ducking Level

If you are playing several items with audio, you may want to shut off or 
reduce the audio levels when one specific item plays. This is known as 
audio ducking. 

When you enable Audio ducking for an item, all other audio that is playing 
ducks (goes quiet) by the percentage indicated in the Audio Ducking Level 
field. The default ducking level is 30% of the normal audio level. 

To change the default audio ducking level, enter a new audio ducking level 
percentage in the Audio Ducking Level field on the General tab.

Logging Tab

Change Status of Automatic Logging

By default, items are not set to be logged. To set all items to be logged, 
check the Enable Logging checkbox on the Logging tab. To disable logging, 
clear the checkbox.

Change Default Log File Location

To store log files in a different default folder, click the Choose button and 
select a new folder as prompted.
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Set Number of Keep Log Days

To change the default number of days that log files are stored on your 
system, enter another number in the Days field.

Network Tab When operating as part of the Network Manager solution, InfoCaster uses 
the options on the Network tab to connect to a Network Manager. The 
Network Manager solution includes InfoCaster, Network Manager, and the 
players. See the online help (Help→Online Help) for details.



InfoCaster 251

A
ppendix

Create External Data Sources
In this section, we explain how to create a text file and an ODBC data source. For information on 
external data sources or data tags, see “About External Data Sources” on page 63.

Create Text File You can create a text (.txt) file that you save to your hard drive or to an 
HTTP or FTP internet location and then link to a Still, Crawl, Roll, or 
Animation region item to display its content during output. 

Create Single Column Text File

1 Open a text editor, like Windows Notepad (Start → Programs → 
Accessories → Notepad).

2 Type your first entry, such as a word, number, or phrase.

3 Press the ENTER key on your keyboard to move to the next line, then 
add another entry as needed. 

Note: You cannot use tabs to separate your text entries. The TAB 
key is used to move to the next column.

4 Save the file as a .txt file on your hard drive. 

Note: To save a text file to an internet location, ask your IT 
specialist for specific server details.

5 To link the text file to a region item, see “Add Still Items” on page 67, 
“Add Crawl Items” on page 115, “Add Roll Items” on page 127, or 
“Add Animation Items” on page 143. 

About Text Files with Multiple Columns

You can create a text file with multiple columns (using the TAB key to move 
to the next column). You can then link a region item to a text file in two 
ways that provide two different displays of the data in your text line. 

• Link to a text file with multiple columns. See “1. Create Database in Text 
Editor” on page 255 for details. The data displays one row at a time. 

• Link to a text file with multiple columns that was added to an ODBC 
system list. You can then choose the column that you want to display. See 
“2. Add Text File to ODBC” on page 257 for details.
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Create ODBC 
Data Source

The Open Database Connectivity (ODBC) protocol allows different 
software programs, such as Microsoft Access, Microsoft Excel, and 
Microsoft Notepad, to share information held in database applications. 

Workflow

1 Create a database in any ODBC-compliant software program, such as 
MS Access, MS Excel, or MS Notepad. You can add any type of 
information, such as flight or TV schedules, headlines, and so on.

See “1. Create Database in MS Access” on page 253. 
See “1. Create Database in MS Excel” on page 254.
See “1. Create Database in Text Editor” on page 255.

2 Add the database to an ODBC system list. 

See “2. Add MS Access or MS Excel Database to ODBC” on page 256.
See “2. Add Text File to ODBC” on page 257.

3 Link the ODBC to the Still, Crawl, Roll, or Animation region item. 

By linking an ODBC data source to a Still, Crawl, Roll, or Animation 
region item, you can select specific data for output, set the output 
order of information, and apply special formatting to specific table 
entries before the data displays during output. When you change the 
data in this file, the data in InfoCaster changes as well.
To link an ODBC data source to a region item, see “Add Still Items” on 
page 67, “Add Crawl Items” on page 115, “Add Roll Items” on page 127, 
or “Add Animation Items” on page 143. 
In this section, we describe the many features in the Select Database 
dialog box, which is used to link a system list to an item. See “3. Link 
ODBC to Item” on page 258.
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1. Create Database in MS Access

Create a Microsoft Access database for your layout content. Use multiple 
tables to organize information. When you update the database, the 
information automatically updates in InfoCaster. To create a database file in 
MS Access for use in an ODBC system list:

1 Open Microsoft Access and choose Create a Blank Access Database.

2 In the New Database window, enter a name and select a location for 
your database.

3 In the Database window, double-click on the Create Table in Design 
View option.

4 In the new Table window, enter ID in the first Field Name text box and 
select Number as your Data Type. In Access, every table must have a 
column that uniquely identifies each table row. Right-click on the ID 
entry and select Primary Key from the menu.

5 Enter the field names (or column headings) and data types for your 
table. Your field names are your column headings.

6 Click the Save button. In the Save As dialog box, enter a name for 
your table.

7 Select View→Datasheet View to view the table cells.

8 Enter your information in the table cells and save the table.
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1. Create Database in MS Excel 

You can use a Microsoft Excel spreadsheet as your database for your layout 
content. When you update the spreadsheet, the information automatically 
updates in InfoCaster. To create a database file in MS Excel for use in an 
ODBC system list:

1 Open Microsoft Excel.

2 Enter your column headings in the first cell of the column. InfoCaster 
uses the heading to refer to the column text.

3 Enter your information in the table cells.

4 Highlight all of the cells you want included in your table. Make sure to 
include the headings as well. You can highlight the cells by clicking 
and dragging your mouse over the cells, or by clicking on the first cell 
and then SHIFT+clicking on the last cell.

5 Select Insert→Name→Define.

6 Enter a name for your table and then click the Add button. The name 
must be one word only, and must not contain spaces, underscores, 
slashes, or dashes. Click OK to close the dialog box.

7 Save the Excel spreadsheet.
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1. Create Database in Text Editor

To create a database in a text editor, such as MS Notepad for use in an 
ODBC system list, create a text file with multiple columns as follows: 

1 Open a text editor, like Windows Notepad 
(Start→Programs→Accessories→Notepad).

2 On the first line of text in the file, type the name of the first column 
heading. For example, write ‘News’. 

3 Press the TAB key and enter your second column heading. You can 
press the TAB key twice for proper spacing, if necessary.

4 Enter the remaining column headings, using the TAB key to move to 
the next column.

5 Press ENTER to move to the second line. The data begins on the 
second line. 

Note: You cannot use tabs to separate your text entries.

6 Add the first data entry, such as a word, number, or phrase, under the 
first column heading.

7 Press TAB to move to the second column, and add the column entry.

8 Add the remaining column entries, using the TAB key to move to the 
next column.

9 Press ENTER to move to the next line of text, as needed.

10 Continue adding your column entries in each new line, using the TAB 
key to move to the next column.

11 Save the file as a .txt file to a unique folder, such as c:\TextODBC. 
Files in the folder become tables in the database. 

12 Proceed to “2. Add MS Access or MS Excel Database to ODBC” on 
page 256 for instructions on linking a text file to an ODBC.
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2. Add MS Access or MS Excel Database to ODBC

To add an MS Access or MS Excel file to an ODBC system list:

1 In Windows, open the Data Sources (ODBC) option. To do this:

• In Windows XP view: Select Start→Control 
Panel→Administrative Tools→Data Sources (ODBC).

• In Windows Classic view: Select Start→Control 
Panel→Administrative Tools→Data Sources (ODBC).

2 Select the User DSN tab or the System DSN tab.

• The User DSN tab registers the database for the current logged-on 
user. If someone else logs on to the computer, the database is not 
visible.

• The System DSN tab registers the database in a global location on 
the computer and is visible for any logged-on user.

3 Click the Add button to open the Create New Data Source dialog box.

4 Select the driver from the list for your database.

• If you're connecting to an Access database select Microsoft Access 
Driver (*.mdb).

• If you're connecting to an Excel spreadsheet, select Microsoft 
Excel Driver (*.xls).

5 Click the Finish button to add the selected driver to the system and to 
continue with the database setup.

6 In the new dialog box enter a name for the data source.

7 Select your external data source.

• For Access data, click the Select button. In the dialog box, 
navigate to and select your database. Clear the Read Only 
checkbox if necessary

• For Excel data, click the Select Workbook button. In the dialog 
box, navigate to and select your spreadsheet. Clear the Read Only 
checkbox if necessary.

8 Click OK in all the dialog boxes until you return to Windows.
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2. Add Text File to ODBC

To add a text file to an ODBC system list:

1 In Windows, open the Data Sources (ODBC) option.

• Windows XP view: Select Start→Settings→Control 
Panel→Performance and Maintenance→Administrative 
Tools→Data Sources (ODBC).

• Windows Classic view: Select Start→Control 
Panel→Administrative Tools→Data Sources (ODBC).

2 In the ODBC Data Source Administrator dialog box, click the Add 
button on the User DSN tab.

3 In the Create New Data Source dialog box, select the Microsoft Text 
Driver (*.txt, *.csv) driver from the list.

4 Click the Finish button to add the driver to the system and to continue 
with the text file setup.

5 In the ODBC Text Setup dialog box, enter a Data Source Name, such 
as text files, that you can recognize when you retrieve the file. 

6 Clear the Use Current Directory checkbox. 

7 Click on the Select Directory button.

8 In the Select Directory dialog box, select the folder that the .txt file is 
in, such as c:\TextODBC. 

9 Click OK. The data source name you used, such as text files, shows up 
in the ODBC Data Source Administrator dialog box, on the User 
DSN tab. It is linked to the folder that contains your .txt file.

10 Click the Options button to expand the dialog box.

11 Click the Define Format button.

12 In the next dialog box, check the Column Name Header checkbox and 
select Tab Delimited from the Format drop-down list.

13 Click OK. If you get an error message, you can click OK on the 
message. The message is safe to ignore.

14 Click OK in the remaining dialog boxes until you return to Windows.
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3. Link ODBC to Item

To link a Still, Crawl, Roll, or Animation region item to an ODBC data 
source, refer to the following sections.

• For Still region items, see “Link to ODBC Data Source” on page 91.
• For Crawl items, see “Add Content on Content Tab” on page 119. 
• For Roll items, see “Add Content on Content Tab” on page 132.
• For Animation items, see “Add Animation Items” on page 143.

Select Database Dialog
Box

The Select Database dialog box, which is used to link ODBC data sources 
to an item, contains many features to help you select specific data for 
output, set the output order of information, and apply special formatting to 
specific table entries before the data displays during output. To do this:

1 In the Select Database Items dialog box, link your data tags to a table 
column by selecting a column name from the Source Column drop-
down list. The Source Column drop-down list links the selected 
column information to the tag displayed on the left. For example, if 
the data tag is 1-1 and your source column is City, the text in the City 
column displays as the text for the 1-1 data tag. 

If your item includes columns for displaying a list of text, InfoCaster 
fills the column in your item with the text from the selected table 
column during output. 

2 For multiple columns, select a column from the Sort drop-down list to 
determine which column InfoCaster uses to order the display of 
information. If you do not select a sort column InfoCaster plays the 
text in the order listed in the table.

3 Select the ascending or the descending option located beside the Sort 
list to determine if the selected column is sorted in ascending order 
or descending order.

• Columns with numerical data are sorted from smallest number to 
largest (ascending order) or largest number to smallest 
(descending order).

• Columns with textual data are sorted alphabetically from A - Z 
(ascending order) or in reverse alphabetical order from Z - A 
(descending order). 
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4 Use the Selection Criteria section to set specific table entries for 
playback.

a Select the AND option or the OR option from the first drop-
down list to help set the playback criteria.

AND: Sets InfoCaster to display the table entries that meet the 
criteria set in the current row and the row above. The table 
entries must have the attributes of both rows. 

In this example, Inca Station outputs
table rows with an ID less than 20 and
greater than 10, so rows 10-20.
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OR: Sets InfoCaster to display the table entries that meet the 
criteria set either in the current row or the row above. The table 
entries must have at least one of row's attributes, but not both. 

b Select a column heading from the Column list for the selection 
criteria. The Operator and Value condition applies to the 
selected column.

For example, you select the ID column from the Column list, 
you select Equals from the Operator list, and you enter 7 in the 
Value text box. InfoCaster outputs the table cells in the selected 
column with the ID of 7. 

c Select an option from the Operator list to set a parameter for 
the selection criteria and then enter a condition for the selected 
Operator in the Value text box. The selected Operator is 
completed by the entry in the Value text box. 

The following points list three different examples for using the 
Operator list and Value text box.
• If you select Equals from the Operator list and enter Toronto 

in the Value text box, InfoCaster only outputs the table row 
that includes the entry Toronto.

• If you select Greater Than from the Operator list and enter 
Milton in the Value text box, InfoCaster outputs the table 
rows with entries that come after Milton alphabetically.

In this example, Inca Station outputs
table rows with an ID less than 20 or
and ID that equals 22, so rows 1-20 
and row 22.

selection criteria

table 
entry

output
results
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• If you select Not Like from the Operator list and enter 
Ottawa in the Value text box, InfoCaster outputs all the table 
rows that do not have the entry Ottawa.

d To delete a the current row from the Selection Criteria section, 
select the DELETE option from the row's first drop-down list.

e To clear all the information in the Selection Criteria section, 
click the Clear button.

5 To view the data selected for output click the Refresh button. The 
Results area displays the table entries sorted for output.

6 To set specific table entries to display with special formatting, click 
the Advanced Formatting button and continue to the next topic. 

• If you do not want to apply special formatting, click OK in all the 
dialog boxes to return to InfoCaster. InfoCaster outputs the 
selected table entries from your ODBC data source during 
playback.

• To apply special formatting, continue to the next section.

Format Specific Data

To format specific data, click the Advanced Formatting button in the Select 
Database Items dialog box. The Format dialog box allows you to apply 
special formatting to specific words or numbers in your table. For example, 
if your table contains weather data you might want to display certain 
weather conditions in different colors. 
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1 Select a column from the Column list to determine which column 
entries in your database table are formatted. You can apply special 
formatting to each column if necessary. 

2 To format numeric data, choose an option from the Thousands 
Separator, Decimal Point, and Decimal Places lists.

3 To display a string of text before each column entry during output, 
select the Add Prefix checkbox and enter the text in the text box. 

4 To display a string of text after each column entry during output, 
select the Add Suffix checkbox and enter the text in the text box.

5 Use the Conditional Formatting options to display specific column 
entries in a different color. 

a Select the column for formatting from the first drop-down list. 
Selecting a column activates the other options in the row. 

b Select an option from the second drop-down list to set a 
parameter for the conditional formatting. Enter a word, number, 
or phrase in the text box. The entry in the text box completes 
the selection from the second list. 

c Example 1: If you select IS from the second list and enter 
SUNNY in the text box, InfoCaster applies the selected color to 
the column entries with the word SUNNY.

d Example 2: If you select DOES NOT CONTAIN from the second 
list and enter RAINY in the text box, InfoCaster applies the 
selected color to all the column entries not containing the word 
RAINY.

e Click the color chip to open the Color Picker dialog box. Use 
the Color Picker tools to select a color for the column entries. 
InfoCaster applies the selected color to the column entries 
meeting the set conditions.

6 Click OK in all the dialog boxes to return to InfoCaster. InfoCaster 
outputs the selected table entries from your ODBC data source 
during playback.
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Technical Support
You can get InfoCaster technical support from several places.

Technical Support from dealer

Contact your dealer first. Since your dealer helped you configure your system, your dealer is also the 
best resource for system configuration issues and problems.

If your dealer can’t help you...

If your local dealer is unable to resolve your technical support problems, contact Inscriber Technology 
Corporation. 

Please have your software serial number available when you contact Inscriber Technical Support. Your 
serial number can be found in a number of places, including software packaging, on the dongle, and 
on your InfoCaster CD ROM.

• Email:support@inscriber.com

You can also post a technical support question on our web site, and our support staff will answer your 
questions.

Product Updates

You can download product updates from our web site, or you can use one of these methods to receive 
updates.

• Web site:www.inscriber.com
• Email:support@inscriber.com
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