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SOFTWARE LICENSE AGREEMENT

1. NOTICE. 

THIS IS A CONTRACT. BY INDICATING YOUR ACCEPTANCE BELOW, YOU ACCEPT ALL THE TERMS AND CONDITIONS OF THIS AGREEMENT. IF YOU DO 
NOT AGREE WITH THE TERMS AND CONDITIONS OF THIS AGREEMENT, DECLINE WHERE INSTRUCTED, AND YOU WILL NOT BE ABLE TO USE THE 
SOFTWARE. LEITCH TECHNOLOGY INTERNATIONAL INC. IS WILLING TO LICENSE THIS SOFTWARE TO YOU ONLY ON THE CONDITION THAT YOU ACCEPT 
ALL OF THE TERMS CONTAINED IN THIS LICENSE AGREEMENT. 

2. Ownership and License. This is a license agreement and NOT an agreement for sale. We continue to own the copy of the software installed by this program and any 
other copy that you are authorized by this Agreement to make (the "Software"). Your rights to use the Software are specified in this Agreement, and we retain all rights 
not expressly granted to you in this Agreement. Nothing in this Agreement constitutes a waiver of our rights under any copyright law or any other law.

3. Permitted Uses. 

3.01 Right to Install and Use. You may install and use the Software on the hard disk drive of any single compatible computer that you own. However, you may not under 
any circumstances have the Software installed onto the hard drives of more than one computer at the same time, nor may you install the Software onto the hard disk drive 
of one computer and then use the original distribution media on another computer. If you wish to use the Software on more than one computer, you must either erase 
the Software from the first hard drive before you install it onto a second hard drive, or else license an additional copy of the Software for each additional computer on 
which you want to use it.

3.02  Right to Copy. You may make one (1) copy of the Software for backup and archival purposes, provided that the original and the copy are kept in your possession, 
and that your installation and use of the Software does not exceed that allowed in Section 3.01, and provided you reproduce our copyright notice on the copy.

3.03 Right to Transfer. You shall not assign, transfer sublicense, rent, lend, or lease the Software or your rights under this Agreement without our prior written approval.

4. Prohibited Uses. You may not, without written permission from us: (a) use, copy, modify, merge, or transfer copies of the Software or documentation except as 
provided in this Agreement; (b) use any backup or archival copy of the Software (or allow someone else to use such copy) for any purpose other than to replace the 
original copy in the event it is destroyed or becomes defective; or (c) disassemble, decompile or "unlock," reverse translate, or in any manner decode the Software or the 
dongle security device for any reason.

5. Limited Warranty. We make the following limited warranties from the date you acquired the Software from us or our authorized dealer:

(a) Media. For a period of twenty (20) days, the distribution media and documentation in this package will be free from defects in materials and workmanship under 
normal use. If the distribution media or documentation fail to conform to this warranty, you may, as your sole and exclusive remedy, obtain a replacement free of charge 
if you return the defective disk or documentation to us with a dated proof of purchase.

(b) Interlock Security Device. Provided you are in compliance with this Agreement, we will replace a damaged or defective interlock security device (dongle) no matter 
what the cause of the damage. In order to receive a replacement device, you must return the damaged device to Leitch Technology International Inc, 26 Peppler Street, 
Waterloo, Ontario, Canada, N2J 3C4.

(c) WARRANTY DISCLAIMER. EXCEPT AS PROVIDED ABOVE, THE SOFTWARE AND DOCUMENTATION ARE PROVIDED ON AN "AS IS" BASIS, AND WE DO 
NOT WARRANT THAT THE SOFTWARE WILL MEET YOUR REQUIREMENTS OR THAT ITS OPERATION WILL BE UNINTERRUPTED OR ERROR-FREE. WE 
EXCLUDE AND EXPRESSLY DISCLAIM ALL EXPRESS AND IMPLIED WARRANTIES AND CONDITIONS NOT STATED HEREIN, INCLUDING THE IMPLIED 
WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE.

Some jurisdictions do not allow the exclusion of implied warranties, so the above exclusion may not apply to you. This limited warranty gives you specific legal rights, 
and you may also have other legal rights, which vary from jurisdiction to jurisdiction.

6. LIMITATION OF LIABILITY. IN NO EVENT SHALL WE BE LIABLE FOR ANY INDIRECT, INCIDENTAL, SPECIAL OR CONSEQUENTIAL DAMAGES, INCLUDING 
BUT NOT LIMITED TO LOSS OF PROFITS, REVENUE, DATA, OR DATA USE, OR MACHINE USE, INCURRED BY YOU OR ANY THIRD PARTY, WHETHER IN AN 
ACTION IN CONTRACT OR TORT, EVEN IF WE HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. OUR LIABILITY TO YOU FOR ANY LOSSES 
SHALL NOT EXCEED THE GREATER OF $500 AND THE AMOUNT YOU ORIGINALLY PAID FOR THE SOFTWARE. 

Some jurisdictions do not allow these limitations or exclusions, so they may not apply to you.

7. United States Government Restricted Rights. The enclosed Software and documentation are provided with Restricted Rights. Use, duplication or disclosure by the 
U.S. Government or any agency or instrumentality thereof is subject to restrictions as set forth in subdivision (c)(1 )(ii) of the Rights in Technical Data and Computer 
Software clause at 48 C. F.R. 252.227-7013, or in subdivision (c)(1) and (2) of the Commercial Computer Software -- Restricted Rights Clause at 48 C.F.R. 52.227-19, as 
applicable. Contractor Manufacturer is Leitch Technology International Inc, 26 Peppler Street, Waterloo, Ontario, Canada, N2J 3C4

8. Termination. This license and your right to use this Software automatically terminate if you fail to comply with any provisions of this Agreement, destroy the copies of 
the Software in your possession, or voluntarily return the Software to us. Upon termination you will destroy all copies of the Software and documentation. Otherwise, the 
restrictions on your rights to use the Software will expire upon expiration of the copyright to the Software.

9. Miscellaneous Provisions. This Agreement will be governed by and construed in accordance with the laws of the Province of Ontario and not by the 1980 United 
Nations Convention on Contracts for the International Sale of Goods, as amended. This is the entire agreement between us relating to the contents of this package, and 
supersedes any prior purchase order, communications, advertising or representations concerning the contents of this package. No change or modification of this 
Agreement will be valid unless it is in writing, and is signed by us.

10. Quebec Transactions. If you reside in the Province of Quebec, Canada, you agree to the following: The parties hereto have expressly required that the present 
Agreement and its Exhibits be drawn up in the English language. Les parties aux presentes ont expressement exige que la presente convention et ses Annexes soient 
redigees en langue anglaise.

If you have any questions about this Agreement, write to us at Leitch Technology International Inc, 26 Peppler Street, Waterloo, Ontario, Canada, N2J 3C4, or call us at 
519-570-9111.
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Introduction

Welcome to InfoCaster!
Inscriber® InfoCaster™ is an exciting out-of-the box communications solution that produces 
powerful attractive multi-zone broadcast-quality page layouts for immediate display on video monitors 
to capture and inform your audience. 

Start InfoCaster To start InfoCaster, double-click on the InfoCaster icon on 
your computer desktop. 

Program 
Monitoring 
Feature

Included with InfoCaster is a program-monitoring 
feature that automatically restarts InfoCaster after a 
system interruption, such as a program closing or the 
computer rebooting. The monitor icon is displayed on 
the task bar at the bottom-right corner of your computer screen. 

For the most efficient operation, you should keep the program monitor 
turned on. If there is a system interruption, the monitor automatically logs 
in (if required), restarts InfoCaster, and starts the last layout that was 
playing. 

However, under some conditions, such as for software installations, you 
might want to turn the program monitor off so the automatic function does 
not interfere with other activities. 

Exit InfoCaster To exit InfoCaster, use one of these methods.

• Select File > Exit.
If InfoCaster automatically restarts, the 
program monitoring feature is on. Use the 
next method to exit InfoCaster. 

• Right-click on the monitor icon and select 
Shut Down InfoCaster. For details on the monitor icon, see “Program 
Monitoring Feature” on page 2.

Restart 
InfoCaster

To start InfoCaster with the program monitoring feature on, right-click on 
the monitor icon and select Start InfoCaster. 

To start InfoCaster with the program monitoring feature off, 
double-click on the InfoCaster icon on your computer 
desktop.

To set InfoCaster to always load your last opened project 
when you open InfoCaster, see “Load Last InfoCast on Startup” on 
page 229.

InfoCaster Monitor
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InfoCaster 
Workspace

The InfoCaster workspace consists of the Pages window, the Regions 
window, the Items window, and the Tree View list. Click on the Pages, 
Regions, or Items button on the main toolbar at the top of the screen to 
switch windows. 

Use the Pages window to add and schedule your InfoCast page layouts.

Use the Regions window to draw regions on your InfoCast page. Use the 
Items window to add and schedule content in your regions.

The Tree View list is always available on the left side of the screen and 
displays all of the pages available in the project, as well as the regions, 
region items and region sequences. Select a page, region, or item by 
double-clicking on it in the Tree View list or in the appropriate (Pages, 
Regions, or Items) window. 

You can also select a region in the Preview window below the Tree View list. 

Switch to Pages, Regions, or Items window.

Preview
window

Tree View
list

Pages
window

Regions
window

Items
window
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Purchase 
Options

InfoCaster is suitable for single installations, large scale networks, and 
everything in between. InfoCaster offers the following additional options 
that you can purchase to meet your needs. 

• The Inca Ports option enables you to create a region in which you can 
display layers of data created in your RTX application. The Inca Ports 
option is also sometimes referred to as the RTXports option.

• InfoCaster Player licences enable you to display your InfoCasts at 
additional sites.

• InfoCaster Network Manager enable you to manage multiple InfoCaster 
systems and effectively target localized audiences.

About This 
Document

This document introduces you to all the major features and tasks available 
in InfoCaster. It is designed to get you up and running as quickly as 
possible. You can also select Help > Help in InfoCaster to refer to the 
online help for further information.

To display the name of buttons and tools, hold the mouse cursor over the 
item on the screen. If you don’t see any text come up, select Help > 
ToolTips to activate ToolTips. 

This document assumes knowledge of Windows-based computers. For 
instructions on how to use basic Windows features, please refer to the 
Microsoft web site or to documentation that came with your computer.
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1. Open an Infocast

Open InfoCast Overview
The first step for creating digital signage layouts for video display is to open a new or existing 
InfoCast. An InfoCast is the project file that contains all the pages that you can output in a project. 

Only one InfoCast is aired at any given time on an output player. An InfoCast contains pages. Pages 
contain regions. Regions contain region items.

This chapter also explains how to save and delete your InfoCasts.

1

Open
InfoCast
 

2
Double-click
on a page 
to add regions
 

Draw a region 

4b

Open a content editor 5
Set playback sequence

Output InfoCast

3

4a

4c
Double-click on a 
region to add
content

6

Add content 
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Open New or Existing InfoCast
You can start a new InfoCast or open an existing InfoCast from your hard drive, CD, or another 
location. InfoCaster saves all changes immediately to the default location as you work, so your project 
is always up-to-date. 

Open New 
InfoCast

1 Click on the New button on the toolbar, or select File > New. 

2 In the New InfoCast dialog box, name your InfoCast, then click 
OK. The InfoCast opens in the Pages window. 
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Always Open Last 
InfoCast

To set InfoCaster to load the last project that was opened every time 
you start InfoCaster, select Edit > Preferences and check the Load Last 
Page Layout on Startup checkbox on the General tab in the Preferences 
dialog box. See “Load Last InfoCast on Startup” on page 229.

Open on Hard 
Drive

To open an existing InfoCast on your computer’s hard drive:

1 Click on the Open button on the main toolbar, or select File > 
Open. 

2 In the Open dialog box, select the InfoCast project from the 
InfoCasts folder on your hard drive, located at C:\InfoCasts by 
default.

The InfoCast opens in the Pages window. 

To check or change the default location of the InfoCasts folder, see 
“Store InfoCasts In” on page 229.

Open on CD To open an InfoCast that was saved to CD:

1 Select the Get from CD option using one of the following 
methods. 

• If an InfoCast is 
already open, select 
File > InfoCaster CD 
> Get from CD. 

• If an InfoCast is not 
already open, select 
File > Get InfoCast 
from CD.

2 Insert the CD into your 
CD ROM drive as 
prompted.

3 In the Get InfoCast From 
Disc dialog box, select an 
InfoCast from the list, then click the Get InfoCast button. Click 
Done to close the dialog box.

The InfoCast opens in the Pages window. 
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Import InfoCast You can import InfoCasts that were exported with the File > Export 
option. The Export option exports an entire project, leaving all 
referenced file paths intact.

1 Select File > Import.

2 In the Import InfoCast dialog box, go to the project folder that 
you want to import, and double-click on the folder. 

3 Click OK to import the InfoCast. 

The InfoCast copies to your InfoCasts folder, located at 
C:\InfoCasts by default.

4 If an InfoCast is already open, click on the Open button on the 
main toolbar and select the imported InfoCast from the list that 
comes up.

If an InfoCast is not already open, the InfoCast you selected 
automatically opens in InfoCaster. 

The InfoCast opens in the Pages window. 

Note: You can also import individual pages. See “Import Page” on 
page 18.
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Save InfoCast
InfoCaster automatically saves your work to a default location. You can change the default location. 
You can also save an InfoCast to a different location on your hard drive or on a CD, and copy an 
InfoCast without breaking the file paths that are referenced in the InfoCast. 

Auto Save InfoCaster saves all changes immediately to the default location, 
C:\InfoCasts, as you work, so your project is always up-to-date. You 
never have to save your InfoCast as you go. Even if something happens 
to your system, like a power outage, your projects load with your latest 
changes intact. 

All InfoCast projects are saved in the format C:\InfoCasts\(InfoCast 
name folder)\(page name folder). 

To check or change the default location of the InfoCasts folder, see 
“Store InfoCasts In” on page 229.

Save Copy To save a copy of your InfoCast to the same location:

1 Select File > Save As. 

2 In the Save As dialog box, enter a new name for the InfoCast and 
click Save. 

InfoCaster saves the selected page to your default InfoCasts folder.

Note: Copying and pasting an InfoCast to a new location can break 
file paths that are referenced by the InfoCast.

Rename To save the InfoCast with a different name, select File > Rename, then 
enter the new InfoCast name as prompted.

Save (Export) to 
New Location

To save your project to a different location on your computer without 
breaking any file paths referenced by the InfoCast, use the export 
option. 

Note: Copying and pasting an InfoCast to a new location can break 
file paths that are referenced by the InfoCast.

1 Select File > Export.

2 In the Export dialog box, select a new location for the project and 
click OK.

Use the import option (File > Import) to open exported projects.
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Save to CD To burn an InfoCast project to CD, you must have a properly 
configured CD ROM burner (CD Read-Write drive) connected to your 
system. 

1 Insert a formatted, recordable CD ROM disk into your CD Read-
Write drive. 

2 In InfoCaster, select File > InfoCaster CD > Save To CD.

3 In the Save InfoCast To 
Disc dialog box, enter a 
name for the CD ROM in 
the Please Name This 
Disc field. 

4 Set your options as 
follows. 

To add notes about the 
project to the InfoCast file, 
enter them in the 
Comments field. The 
comments appear when 
you import the project 
from the CD ROM.
To automatically load the 
project to the InfoCasts 
folder (C:\InfoCasts) when 
you import the InfoCast from the CD ROM, check the Enable Auto 
Load checkbox.
To set a playback start time for the page, check the Start Playing 
InfoCast checkbox, then choose one of the following options 
which apply after the page is imported from the CD ROM. 
• To start playback as soon as the InfoCast is copied to the 

InfoCasts folder, choose Immediately Upon Loading InfoCast.
• To set the playback time for the project, choose the At option 

and enter a start time and date. 
If you do not want to set the playback start time, clear the Start 
Playing InfoCast checkbox.
To put the InfoCast file in a central location for shared 
referencing, check the Save Shared Media Files checkbox. See 
“Store Shared Media Files In” on page 230 for details.

5 Click the Burn CD button to copy the InfoCast to the CD.

The Progress bar displays the level of completion state.

6 When the burn is completed, click Done to close the dialog box.
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Close or Delete InfoCast
You can close or delete an InfoCast.

Close InfoCast To close an InfoCast project in InfoCaster, select File > Close. 

The active InfoCast project closes, leaving the InfoCaster workspace 
blank.

Delete InfoCast To permanently delete an InfoCast project:

1 Select File > Delete. 

2 In the Delete InfoCast Layout dialog box, select the InfoCast 
project from the list. 

3 Click the Delete button. The InfoCast is deleted from the 
InfoCasts folder, located at C:\InfoCasts by default.

4 Close the dialog box.
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2. Add Pages to Infocast

Add Pages Overview
After you open an InfoCast, you add pages to it. Every InfoCast project consists of one or more pages. 
A page is the layout of the full screen digital signage image that displays on the output screen. Page 
layouts consist of regions and scheduling information. Pages open in the Regions window, as 
explained in “Open Page in Regions Window” on page 24. 

1

Open
InfoCast
 

2
Double-click
on a page 
to add regions
 

Draw a region 

4b

Open a content editor 5
Set playback sequence

Output InfoCast

3

4a

4c
Double-click on a 
region to add
content

6

Add content 
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All the pages that exist in the InfoCast are displayed in the Pages window. 
You work with pages in the Pages window. When you open an InfoCast, you 
are automatically switched to the Pages window. 

All page layouts are saved in C:\InfoCasts. To change the default folder 
location, see “Store InfoCasts In” on page 229.

Workflow By default, a blank page is added to a new InfoCast. To add another page to 
an InfoCast:

1 Switch to the Pages window. 

To do this, click on the Pages button on the main toolbar. See “Switch 
to Pages Window” on page 16.

2 Add a new page, copy a page, or import a page. 

To do this, click on the New, Duplicate, or Import button on the Pages 
window toolbar. See “Add, Copy, or Import Page” on page 18.
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Switch to Pages Window
To switch to the Pages window, use one of these methods.

• Open a new or existing InfoCast. When you open an InfoCast, you are automatically switched to 
the Pages window. 

• Click on the Pages button on the main toolbar. 

• Select Tools > Pages.

• Double-click on a page in the Tree View list.

All the pages in the selected InfoCast are displayed in the Page Library. 

The Pages window contains a toolbar, Library, Details panel, and Sequencer. The Pages window area 
changes into the Regions window or the Items window depending on what level of content you are 
working on. The Tree View list is always available to select pages, regions, region sequences, and 
region items. 

Preview Pages SequencerPages Details 

Pages toolbar
Pages button 

Pages Library

Tree View
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Change Page 
Display

To save space in the Pages window, you can change the size of the pages 
displayed in the Page Library and in the Pages Sequence list. 

Change Display of Page Library

To change the size of the page display in the Page Library, select Pages > 
Show Page Library As, then select one of the following options.

Change Display of Page Sequencer

To change the size of the page display in the Pages Sequence list, see 
“Change Sequence Display” on page 209.

Large Thumbnails

Small Thumbnails

Text Only



18 Add Pages | InfoCaster

Add, Copy, or Import Page
You can add as many pages (layouts) as you want to an InfoCast. You can add a new page, make a copy 
of a page, or import a page. Each page displays in the Page Library section of the Pages window. 

Add New Page By default, a blank page is automatically added to a new InfoCast. 

To add another new page to an InfoCast:

1 Click on the New button on the 
Pages window toolbar. 
Alternately, you can right-click in 
the Page Library, then select New 
Page from the menu. You can also 
select Pages > Add Page. 

2 In the New Page Layout dialog 
box, name the new layout.

Duplicate Page To add a copy of an existing page to your InfoCast:

1 Select the page in the Page Library. 

2 Click on the Duplicate button on the Pages window toolbar. 
Alternately, you can select Pages > Duplicate Page.

A copy of the page is added to the Page Library.

Import Page You can import pages that were exportedwith the Export 
Page command, as explained in “Export Page” on page 19. 

1 Right-click on a blank space in the Page Library, then 
select Import Page from the menu. Alternately, you 
can select Pages > Import Page.
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2 In the Import Page dialog box, double-click on the folder that is 
named after the page you want to import, then click OK. 

Export Page To save your page to a new location on your computer without breaking any 
file paths referenced by the page, export the page. 

Note: Copying and pasting a page to a new location can 
break referenced file paths. 

1 In the Pages window, right-click on the page you want 
to export and select Export Page from the menu. 
Alternately, you can select Pages > Export Page. 

2 In the Export Page To dialog box, select a new 
location for the page and click OK. 

To open exported pages, import the page. See “Import Page” on page 18.

Edit Page 
(Layout)

To edit a page’s layout, use one of these methods.

• Click on the Edit button the Pages toolbar.
• Right-click on a page in the Pages window, then select Edit Page from the 

menu. 
• Select Pages > Edit Regions.

The page opens in the Regions window where you can select any region and 
edit its content. See “Open Page in Regions Window” on page 24 for 
details.
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Rename Page 1 Select the page in the Pages window, then click the Rename button in 
the Pages toolbar. You can also right-click on the page, then select 
Rename Page from the menu.

2 In the Rename Page dialog box, enter a new name for the page, then 
click OK. 

InfoCaster changes the page name in the following places.

• On the page layout in the Pages window, both in the Page Library and in 
the Page sequence list.

• On the page title displayed in the Tree View list.
• On the page layout folder, located in your InfoCast project folder 

(C:\InfoCasts\project folder\page folder).

Delete Page To permanently delete a page from your InfoCast, right-click on the page in 
the Pages window, then select Delete Page from the menu. Alternately, you 
can select Pages > Delete Page in Library. 

To delete a page from your InfoCast sequence, see “Delete Pages from the 
Sequence” on page 197.
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3. Add Regions to Page

Add Regions Overview
After you have opened an InfoCast and selected a page, add regions to the page. Regions are playback 
zones or containers on your page layouts into which you place the content (region items) that you 
want to output. You can add many region items in each region to output at different times.

You can create 10 types of regions in your InfoCasts. Then, open each region to add content. Each 
region opens in the Items window, as explained in “Open Region in Items Window” on page 42.

• Still regions play static 
text or graphics, such 
as titles or logos. 

• Crawl regions play text 
and graphics that move 
horizontally across the 
region.

• Roll regions play text 
and graphics that 
scroll up or down the 
region.

• Animation regions play 
animated text and 
graphics.

• Digital Clock regions 
play a real-time digital 
clock or digital timer. 

• Video regions play 
video clips or live 
video. 

• Analog Clock regions play an imported graphical clock.

• Audio regions play audio independent of other region items.

• With the Inca Ports option, you can air data created in your RTX application. See “Purchase 
Options” on page 4.

• Temperature regions display a temperature reading from a temperature probe connected to your 
system.

• You can create a pop-back region and use it to expand or shrink region items during output. See 
“Draw a Pop-Back Region” on page 32. 

• You can create a background that fills up any part of your screen using any of the regions types. 
See “Draw a Background” on page 32. 

still rolldigital clock

animation

video still

crawl

background
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Workflow 1 Select the page, then switch to the Regions window. 

To do this, you can double-click on the page in the Pages window or 
Tree View list. See “Open Page in Regions Window” on page 24.

2 Draw regions on the page. 

To do this, select a region tool then click and drag the mouse cursor 
across the workspace. See “Draw Regions On the Page” on page 26.

3 Adjust region settings as needed. See “Adjust Region Settings” on 
page 35.

1

Open
InfoCast
 

2
Double-click
on a page 
to add regions
 

Draw a region 

4b

Open a content editor 5
Set playback sequence

Output InfoCast
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Open Page in Regions Window
To add regions to a page layout, select the page and switch to the Regions window. 

Select a Page To select a page, click on the page in the Page Library or in the Tree View 
list. Double-click to open the page in the Regions window.

Switch to 
Regions 
Window

With the page selected in the Pages window, switch to the Regions window.

• Double-click on the page in the Page Library or in the Tree View list.
• Click on the Regions button on the main toolbar.
• Click on the Edit button the Pages toolbar.
• Select Tools > Regions.

• Select Pages > Edit Regions.
• Right-click on a page in the Pages window, then select Edit Page from the 

menu. 

Switch to Regions window

Select page
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The page opens in the Regions window, which contains the Region draw 
tools, the Regions page layout workspace, and a region Details panel. 

Region Draw tools

Regions workspace
selected page

Region Details

Pointer tool
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Draw Regions On the Page
After you selected a page and switched to the Regions window, draw regions on the page layout. You 
can display the safe title area and grid lines on your workspace to help you position your regions.

Workflow To draw regions on a page:

1 Select a region tool in the Regions window. See “Select a Region 
Tool” on page 28.

2 Click in the workspace, then drag the mouse cursor across the 
workspace to draw the region. See “Draw Regions” on page 31.. 

Display Safe Title Area

When creating layouts, it’s a good idea to keep your items within the safe 
title area, to avoid having items cut off on certain monitors. The safe title 
area marks a safe area for displaying items on most output screens. The 
default safe title area is set at 86% of the layout window. 

To display the safe title area:

select tool draw region
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1 Use the Pointer tool in the Regions tools list to click on an area 
in your Regions workspace that is not occupied by a region item. 
Alternately, you can select Regions > Show Safe Title Area.

2 In the Page Details panel below the workspace, check the Show Safe 
Title Area checkbox to mark the layout window with a green boundary.

Note: If a region is selected, the safe title options are not displayed.

3 To change the safe title area boundary, use one of these methods.

• Click on the Default button to set the safe title area back to 86% of 
the screen. 

• Click on the Slide Bar radio button to enable the slide bar. Use the 
Slide Bar or Percent field to set the safe title area as a percentage 
of the screen.

• Click on the radio button next to the Left field to enable these 
fields. Enter values in the Left, Right, Top, or Bottom fields to set 
the boundary a certain number of pixels from the left, right, top, 
and bottom of the screen. 

Display Grid Lines on Regions Window

To display grid lines on the Regions window to help you draw and line up 
your regions, select Regions > Show Grid Lines.
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Select a Region 
Tool

In the Regions window, select the region tool that corresponds to the type 
of content you want to add, using one of these methods.

• Select a tool on the left side of the screen. You can also select the Pop-
Back Region tool from the Regions window menu, as explained in “Pop-
Back Region Tool” on page 30..

• Select Regions > Add Region, then select the region tool from the 
second command list. 

Note: To see the name of buttons and tools on the screen, hold 
the mouse cursor over the item. If you don’t see text 
appear, select Help > ToolTips to activate ToolTips.

Pointer Tool

The pointer tool is automatically selected when you click on a region. Use 
it to select, size, and move the region, or to change region details.

select tool draw region
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 Still Region Tool

Draw a still region when you want to play non-moving text and/or graphics, 
such as titles or logos, in a region. The text can be text that you type in or 
text from an external data source. You can create as many lines of text as 
you want and are able to display at a time in the selected region. You can 
connect each line to a different data source. See “Add Still Items” on 
page 55.

Crawl Region Tool 

Draw a crawl region when you want to display text and graphics that move 
horizontally across the region. The text can be text that you type in or text 
from an external data source. You can display up to 3 pre-determined 
characters (space, period, comma, hyphen, or ellipsis) and/or a graphic 
image, animation, or video clip before each text entry. You can format the 
background color. See “Add Crawl Items” on page 79.

Roll Region Tool 

Draw a roll region when you want to display text and graphics that move up 
or down the region. The text can be text that you type in or text from an 
external data source. You can format the background color. See “Add Roll 
Items” on page 83.

Animation Region Tool

Draw an animation region when you want to play animated text and 
graphics in a region. You can import animations. You can also create a 
layout of text and graphics and then animate it. The text can be text that 
you type in or text from an external data source. See “Add Animation 
Items” on page 89.

Digital Clock Region Tool 

Draw a digital clock region when you want to play a real-time digital clock 
that displays local or offset time, or a timer that counts up or down. 
Display a date or text before and/or after the clock, or on its own without 
the clock. See “Add Digital Clocks” on page 97.

Video Region Tool 

Draw a Video region when you want to play video clips or live video in the 
region. You can expand or shrink the video, or any other region item, as 
explained in “Set Triggers” on page 210. See “Add Video Items” on 
page 105.
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Analog Clock Region Tool 

Draw an analog clock region when you want to play an imported real-time 
analog clock in a region. InfoCaster provides a selection of analog clock 
files that you can use. InfoCaster also provides an analog clock building 
utility. See “Add Analog Clocks” on page 119.

Audio Region Tool

Draw an audio region when you want to play audio that is independent of 
other region content. You can draw an audio region anywhere in the layout. 
Adjust the volume, add a delay, and select a frequency (Play Once or 
Loop). See “Add Audio Items” on page 125.

Inca Ports Region Tool

Draw an Inca Port region when you want to display layers of data created 
in your RTX application.

Temperature Probe Region Tool

Draw a temperature probe region when you have a temperature probe 
connected to your system and want to display its current temperature 
reading in the region. See “Add a Temperature” on page 145.

Pop-Back Region Tool

Pop-back regions set the size that a region can expand or contract to when 
you apply a trigger. Select Regions > Pop-Back Regions in the Regions 
window. The Pop-Back Region tool becomes available. See “Draw a Pop-
Back Region” on page 32 for more information. To use a pop-back region, 
see “Set Triggers” on page 210.
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Draw Regions With the region tool selected, click in the Regions workspace, then drag 
the mouse cursor across the workspace. The region placeholder is 
displayed in the workspace.

Repeat these steps until you have drawn all the regions in your page lay-
out.To reposition the region or make any other changes to the region, see 

select tool draw region
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“Adjust Region Settings” on page 35.

Draw a Background

You can create a background using any of the regions types. To create a 
background:

1 Draw a region in the layout window that covers the entire area.

2 Select Regions >Arrange Region > Send to Back to move the region 
behind all other regions.

3 Open a content editor and add content.

Draw a Pop-Back Region

You can expand or shrink any region during output by creating a pop-back 
region, then setting a trigger. To draw a pop-back region:

1 Select Regions > Pop-Back Regions in the Regions window.

The Region Tools change to display the Pop-Back Region tool. 
Other regions that you have drawn can be seen but cannot be selected. 

2 Click on the Pop-Back Region tool to select it.
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3 Click in the Regions workspace and drag the mouse cursor across the 
workspace to draw your pop-back region. 
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You can draw as many pop-back regions as you want to use on your 
InfoCast page. For example, you can draw a full-size region to expand 
a region to full-size or you can draw a small over-the-shoulder region 
to shrink a region to that size.

4 In the Details panel below the workspace, you can give the region a 
unique name to make it easier to identify it in a list.

To exit the Pop-Back Regions window and be able to select other regions, 
select Regions > Pop-Back Regions again, to remove the checkmark. 

To apply a pop-back region, see “Set Triggers” on page 210. 

To add content to your regions, see “Add Items to Regions” on page 39.
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Adjust Region Settings 
In the Details panel below the Region workspace, you can change settings for the selected region. 
These options are the same for all the region types.

Rename 
Regions

To give your regions descriptive names, enter a new name for the selected 
region in the Name field below the Regions workspace. Press ENTER to 
apply the change. Alternately, you can select Items > Rename Item. 

Reposition 
(Move) Regions

You can change the position of regions on your page layout in two ways. 

• Enter values in the From Left or From Top field below the Regions 
workspace for precise positioning. This places the selected region a 
certain number of pixels away from the left or top of the layout.

• Drag the region item in the Regions workspace using the Pointer 
tool. 

Resize Regions You can change the size of regions on your page layout in two ways. .

• Enter pixel values for the selected region in the Width or Height field 
below the Regions workspace for precise positioning.

• Drag the region’s corner or side border in the Regions workspace 
using the pointer tool. 

Delete Regions To delete the selected region, use one of these methods.

Details panel
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• Right-click on the region, then select Delete Region from the menu.
• Select Regions > Delete Region.

Lock Region 
Size & Position

To prevent the selected region from being resized or repositioned, you can 
lock the region using one of these methods.

• Check the Lock Size and Position checkbox below the Regions 
workspace. 

• Select Regions > Lock Region. 

You can still switch to the Items window and edit content when a region is 
locked. 

To unlock a region, remove the checkmark. 

Adjust 
Overlapping 
Regions

To change the layering order of regions in your page layout, use one of 
these methods.

• Drag the region up and down in the Tree View list. Drag the region up to 
move the region in front of other regions, or down to move the region 
behind other regions.

• Use the options in the Regions > Arrange Region menu.

Designate 
Player 
Permissions

If you purchased InfoCaster Player licences for additional sites, click on the 
Region Permissions button below the Regions workspace. In the Region 
Permissions dialog box, you can set which regions of the page the sites can 
modify. 

Log Region 
Playback

To create a log file of all the times a region is aired, check the Log This 
Region checkbox in the Details panel below the Regions workspace. 

InfoCaster creates a log file that includes the player name, page name, 
region name, item name, start date, start time, stop date, stop time, and 
duration. A new log file is created each day, so the playback of an entire 
day is stored in one log file. 

To view a log file, or change default log settings, such as the status of 
automatic logging, the log file location, or the number of days a log file is 
kept on your system, see “Log Output” on page 227.
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Preview Regions
As you add content to the regions of your page layout, you can view how your layout looks in the 
Regions window in the following ways.

• Display only the region borders of the 
page layout. This is the standard view. 

To display grid lines or the video safe 
title area, See “Display Grid Lines on 
Regions Window” on page 27 or “Display 
Safe Title Area” on page 26.

• Display the region borders with a still 
image representing the content within 
each region. Select Regions > Preview All 
Regions. 
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• Display the region borders with a still 
image in selected regions only. Select the 
region, then select Regions > Preview 
Region.

To remove the still image display from a 
region, select the region, then deselect 
Regions > Preview Region. 

• Display each region with a still image 
representing the content but without region 
borders. Select Regions > Show Page 
Without Adornments. 



Add Items to Regions
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4. Add Item to Regions

Add Region Items Overview
Once you have drawn regions on a page in your InfoCast, you can add content to your regions. 

Each region opens in the Items window. A 
unique set of content editors for each 
region type becomes available in the Items 
window. You use the content editors to 
create region items. You can add multiple 
items to a region. You can add a blank item 
to the region to make the region 
transparent during playback. 

When you schedule the playback sequence 
for the region, you can set when you want 
each item to air in the region. For example, 
the video region in our example here plays 
a butterfly video clip followed by a space 
video clip.
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Workflow 1 Open an InfoCast. See “Open an InfoCast” on page 5. 

2 Add pages to the InfoCast. See “Add Pages to InfoCast” on page 13. 

3 Add regions to the page. See “Add Regions to Page” on page 21.

4 Add content (region items) to each region. See “Open a Content 
Editor” on page 44.

1

Open
InfoCast
 

2
Double-click
on a page 
to add regions
 

Draw a region 

4b

Open a content editor 5
Set playback sequence

Output InfoCast

3

4a

4c
Double-click on a 
region to add
content

6

Add content 
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Open Region in Items Window
To add content to your regions, select the region that you want to add region items to, then switch to 
the Items window.

Select a Region To select a region, use one of these methods.

• Click on the region in the Regions Library.
• Click on a region in the Tree View list.
• Click on a region in the Preview window. 

select region in Tree View, Preview, or Regions window

switch to Items window
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Switch to Items 
Window

To switch to the Items window, use one of these methods.

• With the region selected, click on the Items button on the main toolbar.
• Select Tools > Items.
• Double-click on the region in the Page Library, in the Tree View list, or in 

the Preview window. 
• Select Regions > Edit Item Sequences to switch to the Items window to 

schedule the region’s playback sequence, 

About the Items Window

The selected region opens in the Items window. The Items window contains 
the following components.

• List of content editors for that region type.
• Toolbar.
• Items Library that displays all the items in the region.
• Sequencer with options and its own toolbar. 

Content editor list Items Sequencer

Items toolbar

Items Library
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Open a Content Editor
You use a content editor to add and edit region item content. Some region types have more than one 
content editor. You can add as many items as you want in a region. 

To Add Items 1 Select a region in your InfoCast page layout, and switch to the Items 
window. See “Open Region in Items Window” on page 42 for details.

2 Select the content editor from the drop-down list in the Items 
window. Alternately, you can select Items > Add Item, then select the 
editor from the list.

3 Click on the Add button beside the content editor list. The content 
editor opens. A description of the editors for each region type is 
provided after the next section below. Also, each of the next 10 
chapters documents a region type and all of the content editors that 
pertain to it.

About Blank 
Items

Each editor list contains a Blank Item option. Select Blank Item to create a 
blank region item. Add the blank region item to your playback sequence to 
output no content for the set duration without otherwise interrupting your 
sequence. See “Schedule Playback Sequences” on page 193 for details on 
sequences.

Select content editor Click Add
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To Edit Items To open a content editor for the purpose of editing a region item, use one 
of these methods.

• Double-click on the item in the Item Library. 
• Click on the item, then click on the Edit button in the Items window 

toolbar. 
• Click on the item, then select Items > Edit Item With, and select the 

editor from the list.

The editor that was used to create the content opens.

Still Editors There are four Still region content editors.

Title Quick Editor 

Add text to a still region on your layout. The text 
can be text that you type in or text from an external 
data source. You can create as many lines of text as you want and are able 
to display at a time in the selected region. You can connect each line to a 
different data source. Format the item with a template or with custom 
settings. Add audio. See “Title Quick Editor” on page 59.

Table Quick Editor

Quickly display information from an external data source during output. 
Link text lines in Still region items that were created in TitleMotion to 
columns of external data. See “Table Quick Editor” on page 61.

TitleMotion

Create a layout of text and graphics for your region item. You cannot adjust 
audio settings in TitleMotion. You can create templates in TitleMotion. The 
templates created in TitleMotion are available in the Quick Editors. See 
“TitleMotion” on page 65.

Graphic Importer

Import a still image from a variety of file formats into the selected region. 
You can set the graphic to fill the entire still region or to maintain the 
image aspect ratio. Attach audio to graphics using the audio options on the 
Audio tab. See “Graphic Importer” on page 69.
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Add Blank Item

To make the region transparent during playback, add a blank item to the 
sequence. See “About Blank Items” on page 44.

Crawl Editors Crawl Quick Editor 

Create a simple line of crawling text in your 
Crawl region. The text can be text that you 
type in or text from an external data source. 
Link the text line in Crawl region items that 
were created in TitleMotion to external data. 
See “Crawl Quick Editor” on page 81.

TitleMotion

Create a layout of text and graphics for your region item. You cannot adjust 
audio settings in TitleMotion. You can create templates in TitleMotion. The 
templates created in TitleMotion are available in the Quick Editors. See 
“TitleMotion” on page 65.

Add Blank Item

To make the region transparent during playback, add a blank item to the 
sequence. See “About Blank Items” on page 44.

Roll Editors Roll Quick Editor 

Create rolling text in your Roll region. The 
text can be text that you type in or text from 
an external data source. You can format with 
either a template or custom settings. See 
“Roll Quick Editor” on page 86. 

Table Quick Editor

Quickly display information from an external data source during output. 
You can create as many columns of text as you want and are able to display 
at a time in the selected region. You can connect each column to a different 
data source. Link the text line in Roll region items that were created in 
TitleMotion to columns of external data. See “Table Quick Editor” on 
page 88.
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TitleMotion

Create a layout of text and graphics for your region item. You cannot adjust 
audio settings in TitleMotion. You can create templates in TitleMotion. The 
templates created in TitleMotion are available in the Quick Editors. See 
“TitleMotion” on page 65.

Add Blank Item

To make the region transparent during playback, add a blank item to the 
sequence. See “About Blank Items” on page 44.

Animation 
Editors

TitleMotion 

Use TitleMotion’s CG module to create your 
layout that consists of text and graphics. 
Then, switch to TitleMotion’s Animation 
module to add motion to your objects. You 
can create as many lines of text as you want 
and are able to display at a time in the selected region. You can connect 
each line to a different data source in the Animation Quick Editor. See 
“TitleMotion” on page 65.

Animation Quick Editor

Quickly edit text in animations that you created in TitleMotion. You can 
connect each line that you created in TitleMotion to a different data source. 
Set audio options. See “Animation Quick Editor” on page 92.

Animation Importer

Import an animation into the selected region. Attach or adjust audio using 
the audio options on the Audio tab. See “Animation Importer” on page 94. 

Add Blank Item

To make the region transparent during playback, add a blank item to the 
sequence. See “About Blank Items” on page 44.

Digital Clock 
Editors

Digital Clock Quick Editor 

Create real-time clocks displaying local or 
offset time. The time display is based on 
your computer clock. See “Digital Clock 
Quick Editor” on page 100.
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Digital Timer Quick Editor

Create a digital timer that counts up or down. Display the day, month, and 
date. See “Digital Timer Quick Editor” on page 103.

Add Blank Item

To make the region transparent during playback, add a blank item to the 
sequence. See “About Blank Items” on page 44.

Video Editors Video Clip Quick Editor 

Import a video file into the selected region. 
See “Video Clip Quick Editor” on page 108.

Live Video Quick Editor

Set the region to display live video. See “Live Video Quick Editor” on 
page 113.

Add Blank Item

To make the region transparent during playback, add a blank item to the 
sequence. See “About Blank Items” on page 44.

Analog Clock 
Editor

Analog Clock Quick Editor 

Use the Analog Clock Quick Editor to 
import an analog clock into your layout. By 
default, the time displayed by the clock is 
the local time provided by your computer 
clock. See “Analog Clock Items Overview” on page 120.

Add Blank Item

To make the region transparent during playback, add a blank item to the 
sequence. See “About Blank Items” on page 44.

Audio Editor Audio Quick Editor 

Use the Audio Quick Editor to add audio to 
the page layout to play when you output the 
audio region. Adjust the volume, add a 
delay, and select a frequency (Play Once or 
Loop). See “Add Audio” on page 75.
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Add Blank Item

To make the region transparent during playback, add a blank item to the 
sequence. See “About Blank Items” on page 44.

Temperature 
Probe Editor 

Temperature Probe Quick Editor 

If you have a temperature probe connected 
to your system, use the Temperature Probe 
Quick Editor to display current temperature 
readings in your layout. Format the item with 
custom settings.

Add Blank Item

To make the region transparent during playback, add a blank item to the 
sequence. See “About Blank Items” on page 44.
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Add Content with the Editor
Use the options on the content editor that you selected to add content to your region, to format the 
content, and to attach audio to the region item when available. 

The next 10 chapters describe the content editors for each region type. Refer to the following 10 
chapters for details on using the content editors. 

• For Still Regions, see “Add Still Items” on page 55.

• For Crawl Regions, see “Add Crawl Items” on page 79.

• For Roll Regions, see “Add Roll Items” on page 83.

• For Animation Regions, see “Add Animation Items” on page 89.

• For Digital Clock Regions, see “Add Digital Clocks” on page 97.

• For Video Regions, see “Add Video Items” on page 105.

• For Analog Clock Regions, see “Add Analog Clocks” on page 119.

• For Audio Regions, see “Add Audio” on page 75.

• For Inca Port Regions, see “Add Inca Port Content” on page 144

• For Temperature Probe Regions, see “Add a Temperature” on page 145.

Your content (region item) is added to the Item Library. 
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Automatically 
Add Items to 
the Sequence

You can set InfoCaster to automatically add new region items to the end of 
the currently selected sequence.

Check the Auto Add to Sequence checkbox in the item’s content editor.

This is a global setting that applies to all content editors. Selecting the 
checkbox in one content editor applies the setting to all editors.

Add More 
Items

To add another item to the same region, select a content editor, then click 
on the Add button on the toolbar. Add content in the editor that opens.

You can create more region items in the same region when you want the 
content in that region to change during output. The items can loop during 
playback. For example, you could add multiple items to a still region 
displaying movie titles and times. The movie items would loop 
continuously, displaying one list of movie times followed by the next list of 
movie times.

About External 
Data Sources

You can link text lines in still, crawl, roll, and animation region items to the 
following types of external data sources. For instructions on how to link to 
an external data source see “Use External Data Sources” on page 152.

• A text (.txt) file on your hard drive. 
• An HTTP or FTP page on the internet.
• Text from an XML/RSS source on the internet.
• Text from an ODBC data source.

About Data Tags 

Every text line in a Still, Crawl, Roll, or Animation region item that you 
create in a Quick Editor or TitleMotion editor contains a data tag.  A data 
tag is a name label that InfoCaster uses to link the text line to an external 
data source. 

During output, the selected content of the external data source is displayed 
in the text line. External text displays one entry at a time for stills and 
animations. You set the item duration and transition using the options in 
the sequence list, as explained in “Schedule Playback Sequences” on 
page 193. Rolls and crawls gradually display all the selected entries from 
the external data source as the item moves across the screen. 

A Crawl item contains only one text line or data tag. A Still, Roll, and 
Animation region item can contain more than one text line, each with its 
own data tag. Each text line can be linked to a different data source.

View Data Tags

By default,TitleMotion displays the data tags in the workspace. 
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To display the data tags in a Quick 
Editor, check the Show Tags 
checkbox on the Content tab. The 
tags are displayed to the left of the 
text fields in the editor. 

Data Tag Names

By default, InfoCaster names the data tags as follows.

• The Quick Editors name the data tags Line 1, Line 2, and so on. 
• The Table Quick Editor, which is available for stills and rolls, names the 

cells using the row/column protocol, 1-1, 1-2, 2-1, 2-2, and so on. 
• TitleMotion automatically names the data tags in Still and Animation 

items “Line1”, “Line2”, and so on, and names data tags in rolls and crawls 
“1-”, and so on. To link text lines in a Still or Animation item created in 
TitleMotion to more than one column of your external data, the data tags 
names of your text lines must follow row/column protocol, 1-1, 1-2, 2-1, 2-
2, and so on. You cannot edit tag names saved in a template.
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Change Item 
Display

To save space in the Items window, you can change the size of the items 
displayed in the Item Library and in the Items Sequence list. 

Change Display of Item Library

To change the size of the items displayed in the Item Library, select Items > 
Show Item Library As, then select one of the following.

Change Display of Items Sequencer

To change the size of the items displayed in the Items Sequence list, see 
“Change Sequence Display” on page 209.

Duplicate Item To create a copy of the entire item:

1 Select the region item in the Item Library.

2 Click on the Duplicate 
button on the Items 
toolbar. Alternately, 
you can select Items > 
Duplicate Item. 

If you can’t see the 
button, change the size 
of the Sequence list by 
clicking on the Brief 
View button (double arrows) above the Sequence Settings. See 
“Change Sequence Display” on page 209 for details. 

Large Thumbnails

Small Thumbnails

Text Only
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Rename Item 1 Select the region item in the Item Library.

2 Click on the Rename button on the Items toolbar. 

If you can’t see the button, change the size of the 
Sequence list by clicking on the Brief View button 
(double arrows) above the Sequence Settings. See 
“Change Sequence Display” on page 209 for details. 

3 In the Rename Item dialog box that opens, rename the 
item.

Delete Item To permanently delete an item from a region, right-click 
on the region item in the Item Library, then select Delete 
Item from the menu that comes up. 

Alternately, you can select Items > Delete Item in Library.

To delete an item from your region sequence, see “Delete 
Items from Sequence” on page 204.

Preview 
Regions Layout

To preview a still image of your region items in a page layout, see “Preview 
Regions” on page 37.



Add Still Items
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Add Still Items

Still Items Overview
Still regions play non-moving text and/or graphics, such as titles or logos, in a region. You 
can enter text or connect each text line to a data source.  For instructions on creating and 
linking to an external data source, see “Use External Data Sources” on page 152.

There are four still region content editors. This chapter contains instructions on how to use them. 

Note that because crawl, roll, and animation regions use similar editors, this chapter refers to them 
when required. 

• Title Quick Editor 

Add text to a still region on your 
layout. The data can be text that 
you type in or text from one column 
of an external data source. 

You can create as many lines of text 
as you are able to display at a time 
in the selected region. You can 
connect each line to one column of 
different data sources. 

Add text on the Content tab. 
Format the item on the Formatting 
tab. Add audio on the Audio tab. 
See “Title Quick Editor” on 
page 59.

• Table Quick Editor 

Quickly display information from 
multiple columns of an external data 
source during output. Add content 
on the Content tab. Format headers 
on the Headers tab. Format content 
font on the Font Formatting tab. Add 
audio to the region item on the 
Audio tab. See “Table Quick Editor” 
on page 61. 

• TitleMotion

Create a layout that consists of text 
and graphics for your region item. 
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Your text content can be text 
that you type in or text that 
you link to from an external 
data source. You create the 
layout in TitleMotion, but 
apply the links in the Table 
Quick Editor. 

To add text or graphic 
content, select a tool from 
the Tools palette on the right 
side of the screen. The first 
row of tools are for text. The 
other tools draw graphics. 
Then, enter your text or drag 
your mouse in the workspace 
to draw your shape.

Format your content using 
the tabs below the 
workspace. You cannot add 
audio in TitleMotion. 

You can create templates in 
TitleMotion that become 
available in the Quick Editors. See “TitleMotion” on page 65. 

• Graphic Importer 

Import a still image from a variety of file 
formats into the selected region. You 
can set the graphic to fill the entire Still 
region or maintain the image aspect 
ratio. Add content on the Content tab. 
Add audio on the Audio tab. See 
“Graphic Importer” on page 69. 

• Add Blank Item

To make the region transparent during 
playback, add a blank item to the 
sequence. See “About Blank Items” on 
page 44.
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Workflow 1 Draw a still region in the Regions window.

2 Switch to the Items window and add (or edit) content.
3 Format the content or apply other options as desired. You can import 

audio to play when the item is on-air.
4 Save the content.
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Title Quick Editor 
Select the Title Quick Editor to add non-moving text in your region item. Titles can include multiple 
lines of text. 

Add content on the Content tab. Format the content with a template or with custom settings on the 
Formatting tab. Add audio on the Audio tab. 

Open Content 
Editor

Open the Title Quick Editor from the Items window.

1 Double-click on a still region in the Regions window to switch to the 
Items window.

2 Select the Title Quick Editor from the content editor drop-down list.

3 Click the Add button to add a new region item. 

If you want to edit an existing region item, select the item in the Items 
window, select the editor and click the Edit button.

Enter Text in 
the Title Quick 
Editor

To add text in the Title Quick Editor directly, type the text in the Text box 
on the Content tab.

• For details on formatting your text, see “Format Text” on page 72.
• For details on linking your title text to a text file, an XML/RSS data feed, 

or an ODBC data source, see “External Data Sources” on page 151.
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Add Multiple 
Lines of Title 
Text

Add text lines to display multiple lines of text on output.

1 To add text lines, place 
your cursor in the text box, 
then press the ENTER key. 
Press ENTER again to add 
another line.

2 To view the data tags, 
check the Show Tags 
checkbox. Each line of text 
in the Title Quick Editor is 
labeled with a data tag. Data tags are used to link to external data 
sources. The external data feature if flexible, so you can link one or all 
of your text lines to an external data source.
For details on linking your title text to a text file, an XML/RSS data 
feed, or an ODBC data source, see “External Data Sources” on 
page 151.

Remove a Text 
Line

To remove a line of text in the Title Quick Editor, select the text in the text 
box and press BACKSPACE to delete the text. When the text box is empty, 
press BACKSPACE again to delete the line.

Add a Log Note To add a log note to the item, click the Log Note button on the Content 
tab. The Log Note window allows you to enter information to record in the 
playback log every time the item plays.

Enter any notes about the item in the text box without pressing ENTER, and 
then click Save. The note is displayed in the log file each time the item 
plays.

To view the current day’s log file, select Tools > Log Viewer. The log viewer 
opens displaying the current log file. To open a different day’s log file, 
select File > Open in the Log Viewer.

Save Content Click on the Save button in the content editor to add the content to the 
item in the layout.

Note: You can create your own templates in TitleMotion. 

Next, switch to the Audio tab to play audio with your content. Save your 
work in the editor. Set up your playback sequence, as explained in 
“Schedule Playback Overview” on page 194.
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Table Quick Editor
Select the Table Quick Editor to quickly create columns for external data in your still or roll region 
item. You can connect each line to a different data source. See “About External Data Sources” on 
page 51 for details.

Add content on the Content tab. Format headers on the Headers tab. Format column rows on the Row 
Formatting tab. Add audio to the region item on the Audio tab. 

Open Content 
Editor

Open the Table Quick Editor from the Items window.

1 Double-click on a still region in the Regions window to switch to the 
Items window.

2 Select the Table Quick Editor from the content editor drop-down list.

3 Click the Add button to add a new region item. 

If you want to edit an existing region item, select the item in the Items 
window, select the editor and click the Edit button.

Set Column and 
Header 
Options

Set up your columns and heading display options on the Content tab. 
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1 In the Number of Columns field on the Content tab, enter the number 
of columns you want your table to contain. 

2 Select the header options.

• To use the first row of data in each column of your database as the 
column header, select the Use First Entry from Database option. 

• To create your own custom column headings, select the Custom 
option. The Column options are enabled.

3 If you selected the Custom option, select a column from the Column 
item list and then enter a name for the column in the Header field. 
Repeat this step for each column header you want to label.

4 select text source

1 enter number of columns you want

2 select column heading

3 select Setup Data Source
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4 To display your column headings on output, switch to the Headers tab 
and check the Show Header checkbox.

Set Header 
Formatting 
Options

Use the options on the Header tab to set the heading display options.

1 Switch to the Headers tab.

2 Check the Show Header checkbox to enable the formatting options and 
set the header to display on output.

3 Check the Space Below Header checkbox to add extra space between 
the bottom of the header and the top of the first column row. This 
space is added to the amount of leading that is set on the Row 
Formatting tab.

4 Enter the number of pixels in the Space Below Header item box. This 
adds the amount of space (in pixels) that you enter between teh bottom 
of the header and the top of the first column row. 

5 Use the standard formatting options on the Headers tab to set the 
display options for your heading text.
For a description of the standard formatting options see “Apply 
Custom Formatting Options” on page 72.

Set Row 
Formatting 
Options

Use the options on the Row Formatting tab to set the row display options.

1 Switch to the Row Formatting tab.

2 Use the padding options to set the space (in pixels) above and below 
(Vert) or to the left and right (Horiz) of the text. Enter a number in the 
Vert or Horiz fields to se tthe vertical or horizontal padding.

3 Use the Custom Widths bar to adjust the width of the columns. By 
default, columns are spaced evenly. Drag a column separator to 
customize the width of the columns in your table.

4 Use the standard formattiong options on the Row Formatting tab to set 
the display options for your row text.
For a description of the standard formatting options see “Apply 
Custom Formatting Options” on page 72.

Link to External 
Data Source

In the Table Quick Editor, use the Setup Data Source button to link to your 
external data source. For details on linking your table to a text file, an XML/
RSS data feed, or an ODBC data source see “Use External Data Sources” 
on page 152.

Add a Log Note To add a log note to the item, click the Log Note button on the Content 
tab. The Log Note window allows you to enter information to record in the 
playback log every time the item plays.
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Enter any notes about the item in the text box without pressing ENTER, and 
then click Save. The note is displayed in the log file each time the item 
plays.

To view the current day’s log file, select Tools > Log Viewer. The log viewer 
opens displaying the current log file. To open a different day’s log file, 
select File > Open in the Log Viewer.

Save Content Click on the Save button in the content editor to add the content to the 
item in the layout.
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TitleMotion 

TitleMotion is a full-featured, broadcast quality character generator that you can use to create high-
end titles, rolls, crawls and animations. You can use the templates provided in TitleMotion or create 
your own templates for still, crawl and roll items. You cannot attach audio to TitleMotion items.

Open Content 
Editor

Open TitleMotion from the Items window.

1 Double-click on a still, roll, crawl or animation region in the Regions 
window to switch to the Items window.

2 Select TitleMotion from the content editor drop-down list.

3 select Text or
Graphic plane

format content
with tab options

add content with
Tools Palette options

2 select template
(optional) 

451 select item
in playlist 
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3 Click the Add button to add a new region item. 

If you want to edit an existing region item, select the item in the Items 
window, select the editor and click the Edit button.

Add 
TitleMotion 
Content

To create a still, crawl, roll or animation in TitleMotion:

1 Select the type of content you want to create (Still, 
Crawl, Roll, or Animation) from the list at the top of 
the screen.

2 Enter the text in the main workspace. Make sure that the Text plane 
button is selected.

3 Use the tabs below the workspace to format the text.

4 To add graphics, click on the Graphics plane button at the top of the 
screen. Use the tools in the Tools palette on the right side of the 
screen to draw.

5 To create an animation, click on the animation button at the 
top of the screen to switch to the Animation Editor (FX).

6 Select File > Save. TitleMotion closes.

See the TitleMotion Essentials manual that came with InfoCaster or refer to 
TitleMotion’s Online Help menu for further information on using 
TitlemMotion.
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Edit Content in TitleMotion or in Content Editor
After you add TitleMotion content to the TitleMotion item, you can edit 
the content of the TitleMotion item in TitleMotion or in a Content Editor.

• To edit the content in the TitleMotion application, right-click on the 
TitleMotion item in InfoCaster, then select Edit with TitleMotion from 
the list. 

• To edit the content with the Title, Roll, Crawl, or Animation Quick 
Editor, right-click on the TitleMotion item, then select Edit Item with 
(Title, Roll, Crawl, or Animation) Quick Editor from the list. The 
commands in the list vary according to the type of item you create in 
TitleMotion.

Note: The Formatting tab in the (Title, Roll, Crawl, or Animation) 
Quick Editor is not available when you open the Editor from a 
TitleMotion item. Format the text in TitleMotion.

Create a Template Use TitleMotion to create a template for your still, crawl, or roll items in 
InfoCaster. Once you export the template file you can select the file as your 
template in the InfoCaster content editors. You can apply templates to title, 
crawl, and roll items.

1 Add text in your TitleMotion workspace. If you are 
creating a template for your still, crawl, or roll items, 
make sure you have the right layout-type selected from the list in 
TitleMotion.

2 Use the tabs below the workspace window to apply formatting 
options to your text. The formatting options are saved with your 
template and are applied to your InfoCaster items when you select 
the template. 

3 Select File > Export > Export ICG File. 

4 In the Save As dialog, save your template file.

5 Exit TitleMotion.

Format InfoCaster 
Item with 
Template

Use the template file to apply consistent formatting to your InfoCaster 
items. You can apply templates to title, crawl, and roll items.

1 In the InfoCaster layout, double-click on the crawl, roll, or still item.
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2 In the (Title, Roll, or Crawl) Quick Editor, switch to the Formatting 
tab and select the Template option. 

3 In thedrop-down list, select an .icg template file. The formatting 
from the template file is applied to the current item.

TitleMotion 
Documentation

TitleMotion comes with its own set of documentation that is separate from 
the InfoCaster material. If you would like more information on using 
TitleMotion, see the TitleMotion Essentials PDF file that came with 
InfoCaster or refer to TitleMotion’s Online Help.
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Graphic Importer 

Use the Graphic Importer to import a still image (graphic file) from a local drive or from a HTTP or 
FTP site.

. 

Open Content 
Editor

Open the Graphic Importer from the Items window.

1 Double-click on a still region in the Regions window to switch to the 
Items window.

2 Select the Graphic Importer from the content editor drop-down list.

3 Click the Add button to add a new region item. 

If you want to edit an existing region item, select the item in the Items 
window, select the editor and click the Edit button.

Open Image 
from Hard 
Drive

Complete the following steps if the image is located on your hard drive.

1 Click on the Choose button on the Content tab.

2 In the Browsing Options dialog box, select 
the Local Files Browsing option and then 
click OK. 

3 In the Open dialog box select your image file 
and click Open.

4 Click on Open.

The filename is displayed on the Content tab in the text box next to the 
Choose button.
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Open Image 
from Internet

Complete the following steps if the image is located on an HTTP or FTP 
site.

1 Click on the Choose button on the Content tab.

2 In the Browsing Options dialog box, select the HTTP/FTP Files 
Browsing option and then click OK.

3 In the Internet File 
Browser dialog box enter 
the address of the HTTP 
or FTP site in the Current 
Path box. The address 
must start with http://or 
ftp://.

4 Log onto the site with one 
of the following options:

• If the site permits 
anonymous login, select 
the Anonymous option.

• If the site requires a 
name and password, 
select the Name option, 
then enter a Name and 
Password.

5 Click on the Go button 
next to the Current Path box to go to that site.

6 The files that are available on the HTTP or FTP site are displayed in 
the lower portion of the dialog box. Select the graphic file you want.

7 Click on OK.

Scale Image to 
Fill Region

To set the image to fill the entire region, select the Scale to Fill Region 
checkbox. Filling the region may increase or decrease the size of the 
original graphic, causing some distortion.

Use the Maintain Aspect Ratio option to set the graphic to scale to the 
largest possibile size without changing the aspect ratio of the original 
graphic.

Update Image To set the image to be updated when the source file in the referenced 
location changes, select the Update when Source Changes checkbox.

Add a Log Note To add a log note to the item, click the Log Note button on the Content 
tab. The Log Note window allows you to enter information to record in the 
playback log every time the item plays.
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Enter any notes about the item in the text box without pressing ENTER, and 
then click Save. The note is displayed in the log file each time the item 
plays.

To view the current day’s log file, select Tools > Log Viewer. The log viewer 
opens displaying the current log file. To open a different day’s log file, 
select File > Open in the Log Viewer.

Save Content Click on the Save button in the content editor to add the content to the 
item in the layout.



72 Add Still Items | InfoCaster

Format Text
Use the content editors to format the display of your item text. Depending on the item type, text 
formatting includes font, size, spacing, alignment, position, shadow, and background options.

Open Content 
Editor

1 Double-click on a region in the Regions window to switch to the 
Items window.

2 Select a content editor from the content editor drop-down list.

3 Click the Add button to add a new region item.

If you want to edit an existing region item, select the item in the Items 
window, select the editor and click the Edit button.

Apply Custom 
Formatting 
Options

All items share the same standard formatting options. The options may 
change slightly depending on the item type.

1 Switch to the Formatting tab.

2 Select the Custom option.
3 Apply the formatting options to your text.

See the following table for a description of the options.
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Formatting 
Option Function

Font Lists all the available fonts for your text. Select a 
font to apply the font to the text.

Size Sets the size of the text.

B Applies bold formatting.

i Applies italicized formatting.

u Applies underline formatting.

Tracking Sets the space between characters.

Width Sets the width of the characters. By default, text is 
set at 100% of its normal width. Increase the volue 
to expand the text and decrease the value to 
compress the text.

Opacity Sets the text opacity. Zero is completely 
transparent and 100 is completely opaque.

Color Sets the text color.Click 
the color chip to open 
the Color Picker. Select a 
new color for the text 
face using the Color 
Picker tools.

Leading Sets the amount of space between lines in your roll 
or title.

Position: 
Top, Left

Positions the text within the region box. Enter a 
number in the Top position field to move the text X 
number of pixels from the top of the region. Enter a 
number in the Left position field to move the text X 
number of pixels from the left side of the region. 
(To position the region item within the page layout, 
see “Reposition (Move) Regions” on page 35.)

Position: 
Top, Middle, 
Bottom

Positions the crawl text at the top, middle, or 
bottom of the region. This option is for crawls only.

Alignment:
Left, Centre, 
Right

Aligns the text to the left, center, or right-side of 
the item box. 
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Apply Template 
Formatting

You can apply formatting from a TitleMotion template to your title, crawl 
and roll items. 

1 In the Title, Roll or Crawl Quick Editor, switch to the Formatting tab 
and select the From File option.

2 In the next dialog box, select the .icg template file. The formatting 
from the template file is applied to the current item.

Edge Adds an edge to the text. Click on the Color chip 
to select the edge color.

(Edge) Width Sets the edge width.

Formatting 
Option Function

(Edge) Color Sets the edge color.

Background Adds a background to the region. Click on the 
Color chip to select color.

(Background) 
Opacity field

Sets background color opacity. Zero is completely 
transparent and 100 is completely opaque.

(Background) 
Color

Sets background color.

Shadow 
checkbox

Adds a shadow to the text.

(Shadow) 
Custom button

Sets the 
shadow 
distance, 
softness, 
opacity, color 
and position. 
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Add Audio
 You can add audio to your region items or you can add audio directly to your layout. When you add 
audio to your layout, the audio plays independently from the other content in the layout. You can 
import an audio .wav, mp3, or wm2 file.

Add Audio to 
Layout

Adding audio to your layout allows you to play an audio file independently 
from all other layout items.

1 To add audio to your layout, select the Audio region tool

2 Draw an audio region on your layout.
3 Double-click on the audio region to switch to the Items window.

4 Select the Audio Editor from the content editor drop-down list.

5 Click the Add button to add a new region item.

Apply Audio 
Options

You can apply audio to the audio region item or to any item in your layout. 

• To apply audio to an independent audio region, double-click on the 
region and open the Audio Editor from the Items window.

• To apply audio to a region item, double-click on the region in the 
Regions window, select the region item in the Items window, select a 
content editor and click the Edit button. In the content editor, switch to 
the Audio tab.
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.

Option Description

Enable Audio 
checkbox

Enables the audio options, to add audio to the 
region item. 

Choose Launches the Open dialog where you can choose 
your audio file.

Shared Media Enables the shared media option, to put the audio 
file in a central location for shared referencing. 
Then, select the shared media location from the 
drop-down list. 

Shared Media 
Folder list

Sets the shared media location from the following 
options.
• All. Adds the file to the default location 

C:\Shared Media, which is set in Preferences. See 
“Store Shared Media Files In” on page 230.

• Audio. Adds the file to a sub-folder called Audio 
under C:\Shared Media. 

• Type in a sub-folder name to create a new sub-
folder under C:\Shared Media. Adds the file to 
the new sub-folder.

Level Adjusts the volume for the audio. Audio levels 
range from zero to 100. Zero mutes the audio 
completely. One is the lowest audible level and 100 
is the highest.

Delay Delays the audio playback from the start of the 
region item by the set time, measured in 
hours:minutes:seconds.

Play Once Sets the audio file to play once and then stop.

Loop Sets the audio file to continue playing while the 
region item is on air.
The audio plays whenever the region item plays in 
the sequence. Once the region item stops playing, 
the sound stops.

Preview button Plays the audio file so you can hear the audio 
before sending it to air.

Enable Audio 
Ducking 
checkbox

Sets the audio to trigger a reduction in the audio 
level of other items that are currently playing. The 
trigger occurs when the item is played. 
You can set the audio ducking level on the General 
tab in the Preferences dialog (Edit > Preferences).
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Add a Log Note To add a log note to the item, click the Log Note button on the Content 
tab. The Log Note window allows you to enter information to record in the 
playback log every time the item plays.

Enter any notes about the item in the text box without pressing ENTER, and 
then click Save. The note is displayed in the log file each time the item 
plays.

To view the current day’s log file, select Tools > Log Viewer. The log viewer 
opens displaying the current log file. To open a different day’s log file, 
select File > Open in the Log Viewer.

Save Content Click on the Save button in the content editor to add the content to the 
item in the layout.
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Add Crawl Items
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Add Crawl Items

Crawl Items Overview
Crawl regions move text and graphics horizontally across the region. You can add text and 
text separators and set the crawl speed and direction. For instructions on creating and 
linking to an external data source, see “Use External Data Sources” on page 152.

Note that the following characters cannot be used twice consecutively in crawls: @, #, $, ^, or &.

There are two crawl region content editors. This chapter contains instructions on how to use them. 

• Crawl Quick Editor

Create a simple line of crawling text 
in your crawl region that displays 
text that you type in or text from an 
external data source. Add text on the 
Content tab. Format the item with a 
template or with custom settings on 
the Formatting tab. Add audio on 
the Audio tab. See “Crawl Quick 
Editor” on page 81. 

• Add Blank Item

Make the region transparent during 
playback. See “About Blank Items” 
on page 44.

• TitleMotion

TitleMotion is a full-featured, broadcast quality character generator that you can use to create 
high-end titles, rolls, crawls and animations. See “Add TitleMotion Content” on page 66 for 
details.

Workflow 1 Draw crawl region in Regions window.

2 Switch to Items window and add (or edit) content.
3 Format the content or apply other options as desired. You can import 

audio to play when the item is on-air.

4 Save the content.
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Crawl Quick Editor 
Use the Crawl Quick Editor to add text and text separators and add a log note. 

Add content on the Content tab. Format the content on the Formatting tab. Add audio on the Audio 
tab. 

Add Crawl 
Content in the 
Crawl Quick 
Editor

To add text in the Crawl Quick Editor directly, type the text in the Text box 
on the Content tab.

Note that the following characters cannot be used twice consecutively in 
crawls: @, #, $, ^, or &.

• For details on linking your crawl text to a text file, an XML/RSS data 
feed, or an ODBC data source, see “External Data Sources” on page 151.

• For details on formatting your crawl text, see “Format Text” on page 72.

Add Text 
Separator

To add a video clip, animation, or graphic and up to three other pre-
determined characters and/or a scalable graphic image before each text 
entry of your crawl item, do the following:

1 Check the Crawl Prefix checkbox on the Content tab.

2 Click the Setup button.
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3 In the Crawl Prefix 
dialog box that opens, 
use the four drop-down 
lists to select up to four 
items. For example, to 
place two items in front 
of your crawl text, select 
an item from the first list 
and an item from the 
second list. 

Each of the last three lists contain the following options:
• Nothing
• Graphic (Then, select the file in the Open dialog box.)
• Space
• Period ( . )
• Comma ( , )
• Hyphen ( - )
• Ellipsis ( ... )

Add a Log Note To add a log note to the item, click the Log Note button on the Content 
tab. The Log Note window allows you to enter information to record in the 
playback log every time the item plays.

Enter any notes about the item in the text box without pressing ENTER, and 
then click Save. The note is displayed in the log file each time the item 
plays.

To view the current day’s log file, select Tools > Log Viewer. The log viewer 
opens displaying the current log file. To open a different day’s log file, 
select File > Open in the Log Viewer.

Save Content Click on the Save button in the content editor to add the content to the 
item in the layout.



Add Roll Items
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Add Roll Items

Roll Items Overview
Roll regions scroll text and graphics up or down the region. 

You can add text or connect to a data source. For instructions on creating and linking to an external 
data source, see “Use External Data Sources” on page 152.

You can change the speed of your rolls and set rolls to move up or down. See “Set Item Settings” on 
page 206 for details on using the Sequence settings. 

To change the default direction of all rolls, see “Default Roll Direction” on page 230.

There are three Roll region content editors. This chapter contains instructions on how to use them.

• Roll Quick Editor 
Create rolling text in your roll 
region that displays text that you 
type in or text from an external 
data source. 

Add text on the Content tab. 
Format the item with a template or 
with custom settings on the 
Formatting tab. Add audio on the 
Audio tab.

See “Roll Quick Editor” on 
page 86. 

• Table Quick Editor 

Quickly display information from an 
external data source during output. 

Add content on the Content tab. 
Format headers on the Headers tab. 
Format content font on the Font 
Formatting tab. Add audio to the 
region item on the Audio tab.

See “Table Quick Editor” on page 88.

• TitleMotion

TitleMotion is a full-featured, 
broadcast quality character generator 
that you can use to create high-end 
titles, rolls, crawls and animations. 
See “Add TitleMotion Content” on page 66 for details. 
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• Add Blank Item

To make the region transparent during playback, add a blank item to the sequence. See “About 
Blank Items” on page 44.

Workflow 1 Draw a roll region in the Regions window.

2 Switch to the Items window and add (or edit) content.
3 Format the content or apply other options as desired. You can import 

audio to play when the item is on-air.

4 Save the content.
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Roll Quick Editor 
Select the Roll Quick Editor to create rolling text in your region item that displays text that you type in 
or text from an external data source. For instructions on creating and linking to an external data 
source, see “Use External Data Sources” on page 152. 

Add content on the Content tab. Format the content on the Formatting tab. Add audio on the Audio 
tab. 

Open Content 
Editor

Open the Roll Quick Editor from the Items window.

1 Double-click on a roll region in the Regions window to switch to the 
Items window.

2 Select the Roll Quick Editor from the content editor drop-down list.

3 Click the Add button to add a new region item. 

If you want to edit an existing region item, select the item in the Items 
window, select the editor and click the Edit button.

Add Roll 
Content in the 
Roll Quick 
Editor

To add text in the Roll Quick Editor directly, type the text in the Text box on 
the Content tab.

• For details on linking your roll text to a text file, an XML/RSS data feed, 
or an ODBC data source, see “External Data Sources” on page 151.

• For details on formatting your roll text, see “Format Text” on page 72. 
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Add a Log Note To add a log note to the item, click the Log Note button on the Content 
tab. The Log Note window allows you to enter information to record in the 
playback log every time the item plays.

Enter any notes about the item in the text box without pressing ENTER, and 
then click Save. The note is displayed in the log file each time the item 
plays.

To view the current day’s log file, select Tools > Log Viewer. The log viewer 
opens displaying the current log file. To open a different day’s log file, 
select File > Open in the Log Viewer.

Save Content Click on the Save button in the content editor to add the content to the 
item in the layout.
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Table Quick Editor
Select the Table Quick Editor to quickly create columns for external data in your region item. For 
instructions on creating and linking to an external data source, see “Use External Data Sources” on 
page 152.

Add content on the Content tab. Format headers on the Headers tab. Format column rows on the Row 
Formatting tab. Add audio to the region item on the Audio tab.

The Table Quick Editor for roll regions is identical to the Table Quick Editor for still regions. For 
complete instructions on adding content to a roll region using the Table Quick Editor, refer to “Table 
Quick Editor” on page 61.  

Open Content 
Editor

Open the Table Quick Editor from the Items window.

1 Double-click on a roll region in the Regions window to switch to the 
Items window.

2 Select the Table Quick Editor from the content editor drop-down list.

3 Click the Add button to add a new region item. 

If you want to edit an existing region item, select the item in the Items 
window, select the editor and click the Edit button.

Refer to “Table Quick Editor” on page 61 for complete instructions on 
additiong content to your roll region item using the Table Quick Editor.
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Add Animation Items

Animation Items Overview 

Animation regions play animated text and graphics.

The text can be text that you type in or text from an external data source. See “About External Data 
Sources” on page 51 for details.

You can create as many lines of text as you want and are able to display at a time in the selected 
region. You can connect each line to a different data source.

There are 3 Animation region content editors. This chapter contains instructions on how to use them.

• TitleMotion

TitleMotion is a full-featured, broadcast quality character generator that you can use to create 
high-end titles, rolls, crawls and animations. See “Add TitleMotion Content” on page 66 for 
details.

• Animation Quick Editor 

Quickly edit the text in animations 
that you created in TitleMotion, to 
link to an external data source, and to 
set audio options. You cannot add an 
animation with the Animation Quick 
Editor. 

Add text on the Content tab. Add 
audio on the Audio tab. Format the 
content in TitleMotion. See 
“Animation Quick Editor” on 
page 92. 

• Animation Importer 

Import an animation into the selected 
region. Attach or adjust audio using 
the audio options on the Audio tab. 

See “Animation Importer” on 
page 94. 

• Add Blank Item
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To make the region transparent during playback, add a blank item to the sequence. See “About 
Blank Items” on page 44.

Note that animations play back at the frame rate of the playback device. 

• ATI: 1 second = 60 frames
• NTSC: 1 second = 30 frames
• PAL: 1 second = 25 frames

Workflow 1 Draw an animation region in the Regions window.

2 Switch to the Items window and add (or edit) content.
3 Format the content or apply other options as desired. You can import 

audio to play when the item is on-air.

4 Save the content.



92 Add Animation Items | InfoCaster

Animation Quick Editor
Select the Animation Quick Editor to edit the text in animations that you created in TitleMotion. You 
can also link animation text to an external data source, and set audio options. 

To use the Animation Quick Editor, create an animation in TitleMotion, as explained in the 
TitleMotion manual that came with your InfoCaster product or in the TitleMotion online help. Then, 
edit the animation in the Animation Quick Editor. You cannot add an animation with the Animation 
Quick Editor. 

Add text on the Content tab. Add audio on the Audio tab. To format the content, use TitleMotion. 

Open Content 
Editor

Open the Animation Quick Editor from the Items window.

1 Double-click on an animation region in the Regions window to switch 
to the Items window.

2 Select an item in the Items window.

3 Select the Animation Quick Editor from the content editor drop-down 
list. 

4 Click the Edit button.

Enter Text in 
Animation 
Quick Editor

To add text in the Animation Quick Editor directly, type the text in the Text 
box on the Content tab.

• For details on formatting your text, see “Format Text” on page 72.
• For details on linking your animation text to a text file, an XML/RSS data 

feed or an ODBC data source, see “External Data Sources” on page 151.
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Format Content Use the options on the Formatting tab to set the text display options. For a 
description of the standard formatting options see “Format Text” on 
page 72.

Add Audio

See “Add Audio” on page 75 for details on importing audio to play with the 
item.

Add a Log Note To add a log note to the item, click the Log Note button on the Content 
tab. The Log Note window allows you to enter information to record in the 
playback log every time the item plays.

Enter any notes about the item in the text box without pressing ENTER, and 
then click Save. The note is displayed in the log file each time the item 
plays.

To view the current day’s log file, select Tools > Log Viewer. The log viewer 
opens displaying the current log file. To open a different day’s log file, 
select File > Open in the Log Viewer.

Save Content Click on the Save button in the content editor to add the content to the 
item in the layout.



94 Add Animation Items | InfoCaster

Animation Importer
Use the Animation Importer to import an animation file into the selected region. Attach or adjust 
audio using the audio options on the Audio tab. 

Open Content 
Editor

Open the Animation Importer from the Items window.

1 Double-click on an animation region in the Regions window to switch 
to the Items window.

2 Select the Animation Importer from the content editor drop-down list.

3 Click the Add button to add a new region item. 

If you want to edit an existing region item, select the item in the Items 
window, select the editor and click the Edit button.

Open 
Animations

1 Click the Choose button. 

The Choose button is only available when creating a new region item.

2 Open your animation as prompted. 

To select multiple animations to import at once, hold down the SHIFT 
or CTRL key as you click. When you click on the Save button in the 
editor, a region item for each animation that you selected is added to 
the Items Library.

Save Animation 
in a Central 
Location

To put the animation file in a central location so that other region items can 
use the same file instead of creating copies of the file, check the Shared 
Media checkbox.

Then, select the shared media location from the following options:
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• All: Adds the file to the default location C:\Shared Media, which is 
set in Preferences. See “Store Shared Media Files In” on page 230.

• Audio: Adds the file to a sub-folder called Audio under C:\Shared 
Media. 

• Type in a sub-folder name to create a new sub-folder under 
C:\Shared Media. Adds the file to the new sub-folder.

Preview 
Animation

The timeline indicator on the Content tab represents the entire duration of 
the animation. The arrow above the timeline shows the animation’s current 
display position. The Duration box displays the animation duration.

To preview the animation, use one of these methods:

• Drag the top arrow indicator above the timeline back and forth to 
any position in the timeline. 

• Use the Play buttons to preview your animation.

Format Content You can also set the following content options

Adjust Transparency

To adjust the item’s level of transparency, select a number in the Opacity 
box on the Content tab, where 0% represents complete transparency.

Add Audio

See “Add Audio” on page 75 for details on importing audio to play with the 
item.

Add a Log Note To add a log note to the item, click the Log Note button on the Content 
tab. The Log Note window allows you to enter information to record in the 
playback log every time the item plays.

Enter any notes about the item in the text box without pressing ENTER, and 
then click Save. The note is displayed in the log file each time the item 
plays.

To view the current day’s log file, select Tools > Log Viewer. The log viewer 
opens displaying the current log file. To open a different day’s log file, 
select File > Open in the Log Viewer.
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Save Content Click on the Save button in the content editor to add the content to the 
item in the layout.
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Add Digital Clock

Digital Clock Items Overview
Digital Clock regions play a real-time digital clock or a timer that counts up or down. 

There are two digital clock region content editors. This chapter contains instructions on how to use 
them. 

• Digital Clock Quick Editor

Create real-time clocks displaying 
local or offset time. The time display 
is based on your computer clock. 

Set the time and date display 
options on the Content tab. Format 
the content on the Formatting tab. 
Add audio on the Audio tab. 

See “Digital Clock Quick Editor” on 
page 100. 

• Digital Timer Quick Editor

Create a digital timer that counts up 
or down. Display the day, month, 
and date. 

Set the timer display options on the 
Content tab. Format the content on 
the Formatting tab. Add audio on the 
Audio tab. 

See “Digital Timer Quick Editor” on 
page 103. 

• Add Blank Item

To make the region transparent 
during playback, add a blank item to 
the sequence. See “About Blank 
Items” on page 44.
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Workflow 1 Draw a digital clock region in the Regions window.

2 Switch to the Items window and add (or edit) content.
3 Format the content or apply other options as desired. You can import 

audio to play when the item is on-air.

4 Save the content.
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Digital Clock Quick Editor 

Select the Digital Clock Quick Editor to create real-time clocks displaying local or offset time, and 
date information. 

Set the time and date display options on the Content tab. Set the text display options on the 
Formatting tab. Adjust the audio settings on the Audio tab.

By default, the time displayed by the digital clock is the local time provided by your computer clock. 

Open Content 
Editor

Open the Digital Clock Quick Editor from the Items window.

1 Double-click on a digital clock region in the Regions window to 
switch to the Items window.

2 Select the Digital Clock Quick Editor from the content editor drop-
down list.

3 Click the Add button to add a new region item. 

If you want to edit an existing region item, select the item in the Items 
window, select the editor and click the Edit button.

Set Clock 
Display 
Options

1 Check the Show Time checkbox to enable clock display. 

If you deselect this option, you can still display the day, month, and/or 
date (Show Prefix or Show Suffix).

2 Select clock display options. 

• Select the 12 Hour option to display the clock in 12 hour format, or 
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select the 24 Hour option to display the clock in 24 hour format. 
When you select the 12 hour option, you can check the Show AM/
PM checkbox to display the time of day.

• Check the Show Leading Zeros checkbox to display the hour with 
two digits. For example, if the current time is 9:14, InfoCaster 
displays 09:14.

• Check the Show Seconds checkbox to display seconds on your 
clock.

• Check the Offset checkbox to advance or delay your clock by a set 
amount of time.
• To advance your clock enter a positive number in the hours (hr) 

and minutes (min) fields. For example, to advance the clock by 
one hour ten minutes, enter 1 hr 10 min.

• To delay your clock enter a negative number in the hours (hr) 
and minutes (min) fields. For example, to delay the clock by one 
hour ten minutes, enter -1 hr -10 min.

3 To display a string of text before the digital clock, check the Show 
Prefix checkbox. Then, select one of the following prefix options: 

• Select the first option to choose a preset 
Day/Date/Month arrangement. The 
Windows Short Format and Windows 
Long Format options use the format set in 
the Microsoft Windows Date and Time 
Control Panel.

• Select the second option to enter custom text that appears before 
the digital clock. Enter the text in the text box.

4 To display a string of text after the digital clock, check the Show Suffix 
checkbox.

• Select the first option to choose a preset Day/Date/Month 
arrangement. The Windows Short Format and Windows Long 
Format options use the format set in the Microsoft Windows Date 
and Time Control Panel.

• Select the second option to enter custom text that appears after the 
digital clock. Enter the text in the text box.

Add a Log Note To add a log note to the item, click the Log Note button on the Content 
tab. The Log Note window allows you to enter information to record in the 
playback log every time the item plays.

Enter any notes about the item in the text box without pressing ENTER, and 
then click Save. The note is displayed in the log file each time the item 
plays.
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To view the current day’s log file, select Tools > Log Viewer. The log viewer 
opens displaying the current log file. To open a different day’s log file, 
select File > Open in the Log Viewer.

Save Content Click on the Save button in the content editor to add the content to the 
item in the layout.
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Digital Timer Quick Editor 

Select the Digital Timer Quick Editor to create a digital timer that counts up or counts down with 
precision in your digital clock region. 

Set the timer display options on the Content tab, set the text display options on the Formatting tab, 
and adjust the audio settings on the Audio tab. 

Open Content 
Editor

Open the Digital Timer Quick Editor from the Items window.

1 Double-click on a digital clock region in the Regions window to 
switch to the Items window.

2 Select the Digital Timer Quick Editor from the content editor drop-
down list.

3 Click the Add button to add a new region item. 

If you want to edit an existing region item, select the item in the Items 
window, select the editor and click the Edit button.

Set Timer 
Display 
Options

Use the options on the Content tab to determine how the timer displays..

Display Option Description

Format Sets the timing elements (hours, minutes, 
seconds) that the timer displays.
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Add a Log Note To add a log note to the item, click the Log Note button on the Content 
tab. The Log Note window allows you to enter information to record in the 
playback log every time the item plays.

Enter any notes about the item in the text box without pressing ENTER, and 
then click Save. The note is displayed in the log file each time the item 
plays.

To view the current day’s log file, select Tools > Log Viewer. The log viewer 
opens displaying the current log file. To open a different day’s log file, 
select File > Open in the Log Viewer.

Save Content Click on the Save button in the content editor to add the content to the 
item in the layout.

Separators Sets which character separates the hours, 
minutes, and seconds.

Leading Zeros Sets the timer to display the time in two 
digits. For example, 8:00 displays as 08:00.

Count Up Sets the timer to count-up.

Count Down Sets the timer to count-down.

From options Sets the timer to start counting either at 0:00 
or at the time set in the available field.

To options Sets the timer to stop counting at 0:00, at 
the time set in the available field, or when 
you choose to stop the timer playback (Stop 
option).

Display Option Description
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Add Video Items

Video Items Overview
Add video clips or live video to your video region using the content editors in the Items 
window. There are two video region content editors. This chapter contains instructions on 
how to use them.

• Video Clip Quick Editor

Import a video file into the selected 
region. 

Select which segment to play and set 
display options on the Content tab, 
apply graphics to overlay the video 
on the Overlay tab and adjust audio 
settings on the Audio tab.

See “Video Clip Quick Editor” on 
page 108. 

• Live Video Quick Editor 

Set the region to display live video. 
Select hardware sources for video and 
audio, or link to a streaming media 
file on the Content tab, apply a 
graphic overlay on the Overlay tab and 
adjust the audio settings on the Audio 
tab. 

See “Live Video Quick Editor” on 
page 113.

• Add Blank Item

To make the region transparent during 
playback, add a blank item to the 
sequence. See “About Blank Items” on 
page 44.
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Workflow 1 Draw a video region in the Regions window.

2 Switch to the Items window and add (or edit) content.
3 Format the content or apply other options as desired. You can import 

audio to play when the item is on-air.

4 Save the content.



108 Add Video Items | InfoCaster

Video Clip Quick Editor
The Video Clip Quick Editor imports a video clip into the selected region. Select which segment to 
play and set the display options on the Content tab. Apply a graphic overlay on the Overlay tab. Add 
audio on the Audio tab.

Open Content 
Editor

Open the Video Clip Quick Editor from the Items window.

1 Double-click on a video region in the Regions window to switch to 
the Items window.

2 Select the Video Clip Quick Editor from the content editor drop-down 
list.

3 Click the Add button to add a new region item. 

If you want to edit an existing region item, select the item in the Items 
window, select the editor and click the Edit button.

Open Video 
Clips

1 Click the Choose button. 

The Choose button is only available when creating a new region item. 

2 Open your video clip as prompted. 

To select multiple video clips to import at once, hold down the SHIFT 
or CTRL key as you click. When you click on the Save button in the 
editor, a region item for each video clip that you selected is added to 
the Items Library. 
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Save Clip in a 
Central 
Location

To put the video clip file in a central location so that other region items can 
use the same file instead of creating copies of the file, check the Shared 
Media checkbox.

Then, select the shared media location from the following options:
• All: Adds the file to the default location C:\Shared Media, which is 

set in Preferences. See “Store Shared Media Files In” on page 230.
• Audio: Adds the file to a sub-folder called Audio under C:\Shared 

Media. 
• Type in a sub-folder name to create a new sub-folder under 

C:\Shared Media. Adds the file to the new sub-folder.

Preview Video 
Clip

To preview the video, use one of these methods:

• Drag the top arrow indicator 
above the timeline back and 
forth to any position in the timeline. The top indicator shows the 
current playback position of your preview in the editor. 

• Use the Play buttons to preview your video. 

Trim Clip To set the In and Out points for the clip, use one of these methods:

• Drag the left indicator in the timeline to the frame that you want to 
use as the In point. Drag the right indicator in the timeline to the 
frame that you want as the Out point. 

• Enter the timecode of the frame you want to use for the In and for 
the Out point in the fields below the timeline. The timecode is 
measured in hours:minutes:seconds:frames (HH:MM:SS:FF). The 
left field is for the In point and the right field is for the Out field.

• During preview, click the Set In button to set the current frame as 
the In point and click the Set Out button to set the current frame as 
the Out point.

Scale Video 
Clips

To scale the video, check the Scale checkbox to enable the scale options, 
then use any of these methods:

Play Trimmed Clip

Rewind

Previous Frame

Stop Play

Next Frame

Fast Forward
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• Check the Maintain Aspect Ratio checkbox to display the video clip 
at the aspect ratio stored in the video file. Clear the checkbox to 
size the video to the aspect ratio of the region. The video may 
appear distorted if you don’t maintain the aspect ratio.

• Use the Scale slider to size the video display in your region. Click 
the Best Fit button to scale the video to the dimensions of the 
region. If the Maintain Aspect Ratio option is selected, the video 
may not completely fill the width or the height. 

• Check the Highest Quality checkbox to display your video with the 
highest image quality.

• Click and drag the video in the editor’s Preview window to 
reposition the video display in the region.

Add A Graphic 
Overlay

Apply a graphic to display over the video on the Overlay tab. 

1 Check the Display Graphic Overlay checkbox to enable the overlay 
options.

2 Click the Choose button and open your graphic file as prompted. 
When the graphic first loads, the image displays in the editor’s 
Preview window at 100% of its original size. 

3 Check the Scale checkbox to enable the scale options. Use the scale 
options to set the display options for your graphic.

• Check the Maintain Aspect Ratio checkbox to display the graphic at 
the aspect ratio stored in the image file. Clear the checkbox to size 
the graphic to the aspect ratio of the region. The graphic may 
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appear distorted if you do not maintain the aspect ratio.
• Use the Scale slider to resize the graphic. 

Click the Best Fit button at the end of the scale slider to scale the 
graphic to the dimensions of the region. If the Maintain Aspect 
Ratio option is selected, the graphic may not completely fill the 
width or the height of the region. 

4 Click and drag the image in the editor’s Preview window to reposition 
the graphic.

Add Audio You can mix audio, use the clip’s audio or disable audio on the Audio tab.

1 Switch to the Audio tab.

2 To disable audio, clear the Enable Audio checkbox.
3 To enable audio, check the Enable Audio checkbox. 

4 Select one of the following options

• To play audio from the video source, select the Clip Audio Source 
option.

• To play audio from another source, select the External Audio File 
option and click on the Choose button. Select the audio file in the 
next dialog box.

5 If you selected external audio, change the Level, Delay or Loop options 
as required.
• To adjust the volume for the audio, use the Level option. Audio 

levels range from zero to 100. Zero mutes the audio completely. 
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One is the lowest audible level and 100 is the highest.
• To delay the playback of the audio, set a time in the Delay field.
• To play the audio once and stop, select the Play Once option.
• To continue playing the audio until the item finishes playback, 

select the Loop option.
6 If you selected external audio, click on the Preview button to hear the 

audio.
7 Check the Enable Audio Ducking checkbox to set the item’s audio to 

trigger a reduction in the audio level of other items that are currently 
playing. The trigger occurs when the item’s audio is sent to air.

Add a Log Note To add a log note to the item, click the Log Note button on the Content 
tab. The Log Note window allows you to enter information to record in the 
playback log every time the item plays.

Enter any notes about the item in the text box without pressing ENTER, and 
then click Save. The note is displayed in the log file each time the item 
plays.

To view the current day’s log file, select Tools > Log Viewer. The log viewer 
opens displaying the current log file. To open a different day’s log file, 
select File > Open in the Log Viewer.

Save Content Click on the Save button in the content editor to add the content to the 
item in the layout.
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Live Video Quick Editor 

The Live Video Quick Editor sets the region to display live video during playback. 

Select hardware sources for video and audio, or link to a streaming media file on the Content tab. 
Apply a graphic overlay on the Overlay tab. Adjust audio on the Audio tab.

. Video appears at the size it was rendered in 

Open Content 
Editor

Open the Live Video Quick Editor from the Items window.

1 Double-click on a video region in the Regions window to switch to 
the Items window.

2 Select the Live Video Quick Editor from the content editor drop-down 
list.

3 Click the Add button to add a new region item. 

If you want to edit an existing region item, select the item in the Items 
window, select the editor and click the Edit button.

Add Video from 
Video Source

You can add video from a video device connected to your system.

1 Select the Video Device option on the Content tab.

2 Select a hardware device from the Video Device list. The list displays 
all available hardware devices capable of delivering video. The video 
device must be installed on the same computer that is running 
InfoCaster.
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3 Select a source from the Source list. The list displays the sources 
available within the selected video device.

4 Select an audio device from the Audio Device list. The list displays all 
available hardware devices capable of delivering audio. The audio 
device must be installed on the same computer that is running 
InfoCaster.

Add Streaming 
Video

You can add video from an .asx or asf media file streaming over the 
internet.

1 Select the URL option on the Content tab.

2 Type in the URL or file path for the .asx or .asf media file or click the 
Browse button next to the field and browse to the file location. You can 
have an .asx file stored locally which manages the connection to .asf 
media files.

3 Click the Connect button to start streaming the .asx or .asf media file.

Set Live Video 
Options

1 To display the live video at full screen size during output, check the 
Show Full Screen checkbox. The live video plays over top of all other 
regions. After the video region item finishes playback, the other 
region items are visible on-screen again.

2 Enter a duration for the live video display in the Duration field. Time 
is measured in HH:MM:SS:FF (hours:minutes:seconds: frames).

3 To enable the scale options, check the Scale checkbox. Then, use the 
following scale options to set the video display in the region item.
• Check the Maintain Aspect Ratio checkbox to display the live video 

at its original aspect ratio. Clear the checkbox to size the video to 
the aspect ratio of the region. The video may distort if you clear the 
checkbox.

• Use the Scale slider to size the video display in your region. Click 
the Best Fit button to scale the video to the dimensions of the 
region. If the Maintain Aspect Ratio option is selected, the video 
may not completely fill the width or the height. 

4 To reverse the field order of the incoming live video, check the Invert 
Field checkbox. Use this option if your input device inputs video in 
the opposite field order to your output device. 

5 To set the frame currently displayed in the preview as the image for 
representing the live video, click the Set Picon button below the 
Preview window. The image displays in the Items window's Item 
Library and Sequence list.

6 To reposition the video display in the region, click on the video in the 
editor’s Preview window, then drag the video to its new location.
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Add a Graphic 
Overlay

Apply a graphic to display over the video on the Overlay tab. The selected 
graphic displays over the live video. 

1 Check the Display Graphic Overlay checkbox to enable the options.

2 Click the Choose button, then open your graphic file as prompted. 

3 Check the Scale checkbox to enable the scale options. Use the 
following scale options to set the display options for your graphic.

• Check the Maintain Aspect Ratio checkbox to display the graphic at 
the aspect ratio stored in the image file. Clear the checkbox to size 
the graphic to the aspect ratio of the region. The graphic may 
distort if you clear the checkbox. If you maintain the aspect ratio, 
part of the graphic may extend outside the region's boundaries. 

• Use the scale slider to size the image to fit your region while 
maintaining the image aspect ratio. 

• Click on the Best Fit button beside the slider to size the graphic to 
the best fit possible. If the Maintain Aspect Ratio option is 
selected, the graphic may not completely fill the region. 

4 To reposition the graphic, drag the image in the editor’s Preview 
window.

The Duration field displays the set duration of the live video or the 
playback duration for the graphic. You cannot edit the Duration field when 
live video is set for playback. However, if there is no live video source 
selected, enter a playback duration for the selected graphic file. Time is 
measured in HH:MM:SS:FF (hours:minutes:seconds:frames).
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Add Audio to 
Live Video

You can mix audio, use the live video source’s audio or disable audio on the 
Audio tab.. 

1 Switch to the Audio tab.

2 To disable audio, clear the Enable Audio checkbox.
3 To enable audio, check the Enable Audio checkbox. 

4 Select one of the following options

• To play audio from the live video source, select the Live Audio 
Source option.

• To play audio from another source, select the External Audio File 
option and click on the Choose button. Select the audio file in the 
next dialog box.

5 If you selected external audio, change the Level, Delay or Loop options 
as required.
• To adjust the volume for the audio, use the Level option. Audio 

levels range from zero to 100. Zero mutes the audio completely. 
One is the lowest audible level and 100 is the highest.

• To delay the playback of the audio, set a time in the Delay field.
• To play the audio once and stop, select the Play Once option.
• To continue playing the audio until the item finishes playback, 

select the Loop option.
6 If you selected external audio, click on the Preview button to hear the 

audio.
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7 Check the Enable Audio Ducking checkbox to set the item’s audio to 
trigger a reduction in the audio level of other items that are currently 
playing. The trigger occurs when the item’s audio is sent to air.

Add a Log Note To add a log note to the item, click the Log Note button on the Content 
tab. The Log Note window allows you to enter information to record in the 
playback log every time the item plays.

Enter any notes about the item in the text box without pressing ENTER, and 
then click Save. The note is displayed in the log file each time the item 
plays.

To view the current day’s log file, select Tools > Log Viewer. The log viewer 
opens displaying the current log file. To open a different day’s log file, 
select File > Open in the Log Viewer.

Save Content

Click on the Save button in the content editor to add the content to the item in the layout.
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Add Analog Clocks

Analog Clock Items Overview
Analog clock regions play a real time analog clock.

There is 1 analog clock editor. This chapter contains instructions on how to use it.

• Analog Clock Quick 
Editor

Import the clock and 
format it on the 
Content tab. InfoCaster 
provides a selection of 
analog clock files that 
you can use. InfoCaster 
also provides an analog 
clock building utility. 
Adjust the audio 
settings on the Audio 
tab. By default, the 
time displayed by the 
clock is the local time 
provided by your 
computer clock. See 
“Analog Clock Quick Editor” on page 121. 

• Add Blank Item

To make the region transparent during playback, add a blank item to the sequence. See “About 
Blank Items” on page 44.

Workflow 1 Draw an analog clock region in the Regions window.

2 Switch to the Items window and add (or edit) content.
3 Format the content or apply other options as desired. You can import 

audio to play when the item is on-air.

4 Save the content.
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Analog Clock Quick Editor
You can import an existing analog clock file into an analog clock item in your layout. InfoCaster ships 
with sample analog clocks to use in your layouts, or you can use the analog clock building utility to 
create your own analog clocks. The time displayed by the clock is the local time provided by your 
computer clock.

Import the clock and format it on the Content tab. Adjust the audio settings on the Audio tab. 

Open Content 
Editor

Open the Analog Clock Quick Editor from the Items window.

1 Double-click on an analog clock region in the Regions window to 
switch to the Items window.

2 Select the Analog Clock Quick Editor from the content editor drop-
down list.

3 Click the Add button to add a new region item. 

If you want to edit an existing region item, select the item in the Items 
window, select the editor and click the Edit button.

Add Clock InfoCaster ships with a number of analog clocks, located in 
InfoCaster\Analog Clock Builder Samples\Clocks. The clock file uses the 
extension .analogclock or .psd.

1 To add content, click on the Choose button.

2 In the Open dialog, open the NTSC or PAL folder, depending if you 
want an NTSC or PAL clock. The folders are located in the 
InfoCaster\Analog Clock Builder Samples\Clocks folder.

3 Select a clock and then click Open.

Create a Clock in 
Photoshop

To create a custom clock in Adobe Photoshop, you must add the clock 
elements on specific layers.

1 In Photoshop, open a new document.

2 Add the following six layers in the Layers palette: hour, minute, 
second, face, axis, center.
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3 Add your clock elements to the appropriate layer.

• Hour: Place the image of the hour hand on the hour layer.

• Minute: Place the image of the minute hand on the minute layer.

• Second: Place the image of the second hand on the second layer.

• Face: Place the image of the clock face on the face layer.

• Axis: Place the image of the clock axis on the axis layer.

• Center: Place a filled pixel on the center layer that anchors the 
center of the face and the rotation axis of the clock hands.

4 Save the clock as a .psd file.

5 Use the Analog Clock Editor to add the clock to your layout.

Scale Clock To change the size of the analog 
clock within the region, check 
the Scale checkbox, then drag 
the Scale control to the left to decrease the size or to the right to increase 
the size.

Note: You can also resize the analog clock item box in the layout 
window. Drag the control point on the box, or use the Size W 
(width) and H (height) boxes in the Item panel to resize the item 
box. If you resize the item box, the analog clock stays the size set 
in the Content Editor.

Position Clock To position the clock within the region box, 
enter a number in the Position Top box to 
move the clock the set number of pixels from the top of the item border. 
Enter a number in the Position Left box to move the clock the set number 
of pixels from the left side of the item border. 
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Note: You can also move the analog region in the Regions window. Drag 
the item box to a new position in the Regions window, or use the 
Pos X and Y boxes in the Details panel to position the region 
box.

Adjust Clock 
Transparency

To adjust the item’s level of transparency, select a number in 
the Opacity box on the Content tab, where 0% represents 
complete transparency.

Add Log Note To add a log note to the item, click the Log Note button. The Log Note 
window allows you to enter information to record in the playback log every 
time the item plays. 

Enter any notes about the item in the text box without pressing ENTER, 
and then click Save. The note is displayed in the log file each time the 
item plays. 

To view the current day's log file, select Tools > Log Viewer. The log 
viewer opens displaying the current log file. To open a different day's log 
file select File > Open in the Log Viewer. 

Save Content Click on the Save button in the Content Editor to add the content to the 
item in the layout. 

Build Analog 
Clocks

Use the Analog Clock Builder utility to create your own analog clocks. To 
open the Analog Clock Builder, select Start > Programs > Inscriber > 
InfoCaster > Utilities > Analog Clock Builder.

For instructions on how to use this utility to create an analog clock file, 
use the Help menu in Analog Clock Builder.
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Add Animation Items

Add Inca Port Content 

With the purchase of the Inca Port option, you can display layers of data created in your 
RTX application in the Inca Port region in your layout. The Inca Port option is also referred 
to as the RTXport option.

Add Content Use the Inca Port options in the Regions window to display the content 
from an RTX application in the Inca Port region in your layout.

1 Make sure that RTX is open on your system.

2 In InfoCaster, select the Inca Port region in the Regions window.

3 In the Name field of the region details section below the Regions 
window, enter the name of the RTX surface area exactly as it is found 
in the RTX .exe code. This name is set in the SharedID property of 
the Framebuffer object.

4 Run the RTX application to output the region content.

Note: You can open the Inca Port region in the Items window, but you 
cannot schedule Inca Port regions using the Sequencer. Inca Port 
content will output when you play your InfoCast and you run the 
RTX application.
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Add Temperature

Temperature Items Overview
If you have a temperature probe connected to your system, you can display current 
temperature readings in your layout. 

There is 1 temperature probe region content editor. This chapter contains instructions on how to use 
it.

• Temperature Probe Quick Editor

Add a temperature reading to the region. 

• Add Blank Item

To make the region transparent during playback, add a blank item to the sequence. See “About 
Blank Items” on page 44.
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Workflow 1 Draw a temperature region in the Regions window.

2 Switch to the Items window and add (or edit) content.
3 Format the content or apply other options as desired. You can import 

audio to play when the item is on-air.

4 Save the content.
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Temperature Quick Editor
Use the Temperature Quick Editor to display the current temperature in your layout. You can enter the 
temperature manually or set InfoCaster to read the temperature from a temperature probe connected 
to your system.

Open Content 
Editor

Open the Temperature Quick Editor from the Items window.

1 Double-click on a temperature region in the Regions window to 
switch to the Items window.

2 Select the Temperature Quick Editor from the content editor drop-
down list.

3 Click the Add button to add a new region item. 

If you want to edit an existing region item, select the item in the Items 
window, select the editor and click the Edit button.

Set-Up 
Temperature 
Probe

In the Temperature Quick Editor you can display the temperature reading 
from the temperature probe connected to your system.

1 Select the default units for your temperature probe reading: Celsius 
or Fahrenheit.

2 Select your device from the Temperature Probe list.

3 Select the COM port that the temperature probe is connected to from 
the COM Port list.



Add Temperatures | InfoCaster 149

Add Log Note To add a log note to the item, click the Log Note button. The Log Note 
window allows you to enter information to record in the playback log every 
time the item plays. 

Enter any notes about the item in the text box without pressing ENTER, 
and then click Save. The note is displayed in the log file each time the 
item plays. 

To view the current day's log file, select Tools > Log Viewer. The log 
viewer opens displaying the current log file. To open a different day's log 
file select File > Open in the Log Viewer. 

Save Content Click on the Save button in the Content Editor to add the content to the 
item in the layout. 



150 Add Temperatures | InfoCaster



External Data Sources



152 External Data | InfoCaster

Use External Data Sources
InfoCaster allows you to link your text-based region items to content in an external data source. 
Text-based region items include still, roll, crawl, or animation items. Region item data tags link to 
the external data source, and display the text in the external file on output. Maintaining your data in 
an external file allows you to update your information easily. You can link your items to text files, 
XML/RSS data feeds, and ODBC data sources.

Data Tags Still, roll, crawl, and animation items use data tags to link to the external 
data source. See the following table for a description of the data tags in 
each editor.

Region Type Data Tag Description

Still • Title items use multiple data tags to link to multiple 
external data sources, or to multiple columns/feeds 
in one data source. You can edit the name of the 
data tag in the Title Quick Editor.

• To view the data tags, check the Show Tags 
checkbox on the Content tab in the Title 
Quick Editor.

• To add a new data tag/text line in the Title 
Quick Editor, click in the text box and then 
press ENTER.

• To remove a data tag/text line, select the text 
in the text box and press BACKSPACE to 
delete the text. When the text box is empty, 
press BACKSPACE again to delete the tag.

• Table items use multiple data tags to link to 
multiple columns/feeds in one data source. Each 
column in the Table Quick Editor has a labeled 
data tag. The first column’s data tag is 1-1, the 
second column’s data tag is 1-2, and so on. The 
data tag labels are visible when you link to your 
external data source.

Roll Roll items have one data tag that you can link to one 
external data source. The data tag is labeled 1-1 and is 
visible when you link to your external data source.
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External Data 
Output

The item type determines how the external data displays during output. 
See the following table for details.

Crawl Crawl items have one data tag that you can link to one 
external data source. The data tag is labeled Field 1 
and is visible when you link to your external data 
source. Use the prefix options to set the characters 
between the text entries in the external file.

Animation Animation items can have multiple tags that you can 
link to one external data source. You can edit the tags 
in TitleMotion, when you create your animation.

• To view the data tags, check the Show Tags 
checkbox on the Content tab in the Animation 
Quick Editor.

• To add a new data tag/text line, use the Data Tags 
tab in TitleMotion.

• To remove a data tag/text line, open the animation 
in TitleMotion and delete the data tag.

Region Type Data Tag Description

Region 
Type Output

Still • Titles display one entry at a time during output. Each 
entry displays for the amount of time set in the Item 
Duration field in the content editor. The transition and 
duration options are available after you link to your 
external data source.

• Tables displays the number of entries that fit in the 
title table item.

For example, if the item box is sized to display six 
rows and the data source contains six entries, all six 
entries display on output. If the item box is sized to 
display three rows and the data source contains six 
entries, the first three entries play for the amount of 
time set in the Item Duration field in the content 
editor, followed by the next three entries. The 
transition and duration options are available after you 
link to your external data source.

Roll Gradually displays the content as the text moves across 
the screen.
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External Data 
Features

After you link your items to an external data source, the external data 
features become available in the content editors. The features include 
Show All New Data at Least Once, Enable On Screen Update, and Data 
Transition and Duration options. You must link to the external data source 
before the options are available.

Show All New Data at Least Once
The Show All New Data at Least Once option is recommended if you 
update your data constantly and if it is important to show all data in the 
text file before playing new updates. The option is available for still, roll, 
crawl, and animation items.

1 On the Content tab in the Title, Table, Crawl, Roll or Animation 
Quick Editor, check the Show All New Data at Least Once checkbox 
to playback all data in the text file once before it renders new data. 
The option is available after you link to your external data source.

2 Click the Save button to save the setting.

Disabling this option sets InfoCaster to render and display new data 
almost immediately as the data source is updated.

Enable On Screen Update
The Enable On Screen Update option sets InfoCaster to display your 
updated text immediately on-screen, Updates you make in the content 
editor or in an external source are immediately updated during output. 
The option is available for roll and crawl items.

The Enable On Screen Updates option is recommended if your text 
contains information like temperatures or sports scores where the spacing 
remains constant. The option is not recommended if the length of your 
text entries change, since the spacing of the text will not adjust until the 
item playback starts from the beginning. For example, a text entry that is 

Crawl Gradually displays the content as the text moves across 
the screen. If you use a prefix/separator between your 
crawls, the prefix displays before the content on each 
line. 

Animation Display one entry at a time during output. Each entry 
displays for the amount of time set in the Item Duration 
field in the content editor. The transition and duration 
options are available after you link to your external data 
source.

Region 
Type Output
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longer than the current entry will not display entirely, and a text entry that 
is shorter than the current entry will contain extra space.

1 On the Content tab in the editor, check the Enable On Screen 
Update checkbox on the Content tab. 

2 Set the transition options that apply 
when the information is updated.

• Select a transition type from the 
Transition drop-down list.

• Set a transition duration in the Transition Duration field. Duration 
is set in hours:minutes:seconds:frames.

If you don’t want to apply a transition, enter 00:00:00:00 in the 
Transition Duration field.

When the Enable On Screen Update option is not selected, the item is 
updated with new content once playback starts at the beginning.

Note: The Enable Onscreen Update option is available for both external 
data and text entered in the Crawl or Roll Quick Editor.

Set Transition Options
The transition and duration options allow you to apply a transition 
between the layers of external data. This option is available for title and 
table items.

1 On the Content tab in the editor, select a transition from the 
Transition drop-down list. The transition applies when the new layer 
of data display on-air.

2 Set the duration of the transition in the Transition Duration item box. 
The duration is set in seconds.

Set Item Duration
The Item Duration sets the display duration for each layer of data. This 
option is available for title and table items.

On the content tab in the editor, set the display duration for the external 
data output in the Item Duration boxes. The duration is set in minutes and 
seconds. 
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Use Text Files as Data Source
The text line(s) in a still, roll, crawl, or animation contain data tags. InfoCaster uses these data tags 
to link the content of an external data source to your item. The external data displays as the item 
content during output. Before linking to your external data source, you need to create your data 
source. This section describes how to create and link to a text file.

Text File Types There are two main types of text files you can use in InfoCaster: linear text 
files and database text files that contain multiple columns. See the 
following table for a description of the two types.

Text File Type Description

Linear Text File Contains information that InfoCaster reads line-
by-line. InfoCaster reads the data directly from the 
text file, one line at a time.

Link Method: Set InfoCaster to read the data 
directly from the text file.

Database Text File Contains two or more columns that InfoCaster 
reads as a database table. When InfoCaster reads 
the text file through the ODBC driver the column 
formatting is retained and you can apply additional 
settings to the text data. Advanced ODBC settings 
are available to set the text formatting and display 
options.

Link Method: Set InfoCaster to read the data 
through the ODBC driver. You can then link to the 
file as an ODBC database and apply advanced 
formatting options.
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Create a Linear 
Text File

Linear text files contain information that InfoCaster reads one line at a 
time. The item type determines how the text displays on output.

Use the following steps to create a linear text file.

1 Open a text editor, like Windows 
Notepad (Start > Programs > 
Accessories > Notepad).

2 Type your first entry, such as a word, 
number, or phrase.

3 Press ENTER and add another entry.

Region 
Type Output

Still • Titles display one entry at a time during output. Each 
entry displays for the amount of time set in the Item 
Duration field in the Title Quick Editor. The transition 
and duration options are available after you link to 
your external data source.

• Tables display the number of entries that fit in the 
table item in the layout window.

For example, if the item box is sized to display six rows 
and the data source contains six entries, all six entries 
display on output. If the item box is sized to display three 
rows and the data source contains six entries, the first 
three entries play for the amount of time set in the Item 
Duration field in the Table Quick Editor, followed by the 
next three entries. The transition and duration options 
are available after you link to your external data source.

Roll Gradually displays the content as the text moves across 
the screen.

Crawl Gradually displays the content as the text moves across 
the screen. If you use a prefix/separator between your 
crawls, the prefix displays before the content on each 
line. 

Animation Displays one entry at a time during output. Each entry 
displays for the amount of time set in the Item Duration 
field in the Animation Quick Editor. The transition and 
duration options are available after you link to your 
external source.
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4 Continue adding entries as needed.

5 Save the file as a .txt file.

See Also: For information on linking to a linear text file see “Link to 
Linear Text File” on page 162.



External Data | InfoCaster 159

Create Database 
Text File

Database text files contain information that InfoCaster reads as a database 
table. When you set InfoCaster to read the multiple-column text file 
through the ODBC driver, the columns remain formatted properly. 
Advanced ODBC settings are available to set the text formatting and 
display options.

If you set InfoCaster to read the data directly from the text file (rather than 
through the ODBC driver), your items read each line as a single row and 
ignores the column formatting. 

1 Open a text editor, like Windows Notepad (Start > Programs > 
Accessories > Notepad).

2 On the first line of text in the file, type the name of the first column 
heading. 

3 Press the TAB key and enter your 
second column heading. You can 
press the TAB key twice for proper 
spacing, if necessary.

You do not have to use tabs as the 
delimiter (column separator) between 
your columns. You can use commas or your own custom delimiter. You 
will set the delimiter type when you link to the text file in InfoCaster.

4 Enter the remaining column headings, using the TAB key (or other 
delimiter) to move to the next column.

5 Press ENTER to move to the second line. The data begins on the 
second line. 

6 Add the first data entry, such as 
a word, number, or phrase, 
under the first column heading.

7 Press TAB (or other delimiter) 
to move to the second column, 
and add the column entry.

8 Add the remaining column 
entries, using the TAB key (or 
other delimiter) to move to the 
next column.

9 Press ENTER to move to the next line of text, as needed.

10 Continue adding your column entries in each new line, using the TAB 
key (or other delimiter) to move to the next column.

11 Save the file as a .txt file to a unique folder. 

See Also: For information on linking to a database text file see .
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Link Item to Text 
File

The following steps describe how to link to your external data source in 
InfoCaster.

1 In InfoCaster double-click on the 
region to open the Item Library.

2 Click on a region item in the Item 
Library.

2 Select a Quick Editor from the Editor 
list and click the Edit button.

3 In the Content tab, select the external 
data source option.

• For the Title, Roll, Crawl and 
Animation Quick Editors check 
the External Data Source 
checkbox and then click the 
Setup button.

• For the Table Quick Editor click 
the Setup Data Source button.

4 In the Select Text Source dialog, 
select the Text File option.

5 Set your playback options.

Playback Option Description

Retrieve Data Sets when InfoCaster checks the text file for 
new information.

• Select On Demand to set InfoCaster to 
update items when the data source is updated. 
InfoCaster does not play any item when the 
data source is not available. 

• Select Every and enter a time 
(hours:minutes:seconds) to set how often 
InfoCaster should look for new information. 
InfoCaster plays the last available data if the 
data source is not available. This prevents 
your output from disappearing.
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6 Click OK to apply your settings and move to the next dialog.

• If you are linking to a linear text file, where InfoCaster reads the 
data directly from the text file, complete the steps in the next 
section “Link to Linear Text File” on page 162.

• If you are linking to a multiple-column text file where InfoCaster 
reads the data through an ODBC driver and retains column 
formatting, complete the steps in the section “Link Item to 
Database Text File” on page 164.

• If you are linking to a text file ODBC database, complete the steps 
in the section “Link to Database” on page 180.

Expire Retrieved 
Data

Sets when InfoCaster will expire external data if 
the data source is unavailable. For example, your 
data source may be unavailable if your data 
source is stored on a network and the network is 
down.

• Select Never if you want to play the last data 
available to InfoCaster when the data source 
is unavailable.

• Select Always if you want to expire the last 
data available to InfoCaster when the data 
source is unavailable.

• Select After and enter a time to set how long 
the data source can be unavailable before the 
data is expired. The time is displayed in 
hh:mm:ss (hours:minutes:seconds).

When Data Expires Sets what InfoCaster displays when the data has 
expired.

• Select the Don't Show Item option if you do 
not want to play items that have expired.

• Select the Show Custom Message option if 
you want to display a message when the data 
has expired. Type in your custom text in the 
field.

Playback Option Description
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Link to Linear Text 
File

The following information describes how to set InfoCaster to read data 
directly from the linear text file. On output, the text displays line-by-line.

1 If necessary, complete steps 1 - 5 in the previous section: “Link Item 
to Text File” on page 160.

2 In the Select Text Access dialog, choose the Read Data Directly from 
the Text File option, and then click OK to move to the next dialog.

3 In the Select Text Sources dialog, click on the Choose button.

4 In the next dialog box, select the location of your text file.

• Select the Local Files Browsing option if your text file is located on 
your hard drive or a local network. 

• Select the HTTP/FTP Files Browsing option if your text file is 
located on an HTTP or FTP website.

5 Click OK.

6 Complete the following steps based on your selection: Local Files 
Browsing or HTTP/FTP Files Browsing.

Local Files
Browsing

If you selected Local Files Browsing, complete the following steps:

a In the Open dialog, select your text file. 

b Click the Open button.

HTTP/FTP Files
Browsing

If you selected HTTP/FTP Files Browsing, complete the following 
steps:

a In the Internet File Browser dialog, enter the address of the 
HTTP or FTP site in the Current Path box. The address must 
start with http:// or ftp://.

b Log on to the site by selecting one of the following Login 
options:

• If the site permits anonymous login, select the Anonymous 
option. 

• If the site requires a name and password, select the Name 
option, then enter a Name and Password.

c Click the Go button to go to that site. The files that are 
available at the HTTP or FTP site are displayed in the lower 
portion of the dialog. 

d Select the text file and then click OK.
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7 Back in the Select Text Sources dialog box, the name of the file you 
selected is displayed in the Field box and the text is displayed in the 
lower portion of the dialog box. 

You can select more files, depending on the region type.

• Crawl Items: Only select one file.
• Roll Items: Only select one file.
• Title Items: Select a file for each available line. Select a data tag 

from the Data Tag list to preview the text file content.
• Table Items: Select a file for each available line. Each line 

represents a table column. The first line with the data tag 1-1, 
represents the first column. The second line with the data tag 1-2, 
represents the second column, and so on. Use the Data Tag list 
to preview the text file contents.

• Animation Items: Select a file for each available line. Select a 
data tag from the Data Tag list to preview the text file content.

For information on how each item outputs the text see the Region 
Type table on page 157.

8 Click OK in the dialog to return to the content editor.

9 Click Save in the content editor.

Data Tags

Data Tag list

Title Item
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Link Item to 
Database Text File

The following information describes how to set InfoCaster to read the text 
file through an ODBC driver. Reading the text file through an ODBC 
driver allows you to set ODBC formatting options that apply to multiple-
column text files. After reading the text file through the ODBC driver, you 
can apply advanced formatting options in the Select Database Items 
dialog.

1 If necessary, complete steps 1 - 5 in the previous section: “Link Item 
to Text File” on page 160.

2 In the Select Text Access dialog, choose the Read Data from ODBC 
Driver option, and then click OK to move to the next dialog.

3 In the ODBC Text File Setup dialog, click the Browse button to select 
your text file. The text displays in the data preview.

4 Enter a name for the data in the Data Source Name field.

5 Set the user availability option for the data source name.

• Make Data Source Name Specific to this User registers the text file 
database for the current logged-on user. If someone else logs on to 
the computer, the database is not visible.

• Data Source Name is Available to All Users registers the text file 
database in a global location on the computer and is visible for any 
logged-on user.

6 Click Next.
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7 In the next dialog, select the delimiter (column separator) used in 
the text file from the Delimiter list: Comma, Tab, Specify Column 
Width, or Custom. If you used a custom delimiter, enter the 
character in the Custom item box. 

Note: The Specify My Column Width option allows you to separate 
your columns by setting a column width in the next dialog. 
For details on setting the column width, see “Specify My 
Column Width Option” on page 168.

8 Check the Set first row as the column headers checkbox if you want 
to change the first row of text entries into column headings.

9 Select the ANSI or OEM character set.

• Select ANSI if the application used to create the text file uses the 
ANSI character set. ANSI is typically used with Windows.

• Select OEM (original equipment manufacturer) if the application 
used to create the text file uses the OEM character set. OEM is 
typically used with DOS.

Leave ANSI as the default if you’re not sure of the character set. ANSI 
and OEM character sets share a number of characters, but each set 
also has unique characters. If you notice your text file characters do 
not display properly during preview or playback you can return to this 
dialog and change the character set.

10 Click Next. The next dialog shows you the data type contained in 
each column of the text file. 
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11 To change the data format, select a new data type from the Data Type 
item list. 

12 To set a character limit for the column text, click on a column entry 
and then type a number in the Data Maximum field. Click the Set 
button. 

Note: If you selected Specify My Column Width in the last dialog 
you need to set the width for each column at this point. For 
information on setting the column width, see the following 
topic, “Specify My Column Width Option” on page 168.

13 Click Finish to return to the Select Text Source dialog. 

In the Select Text Source dialog, notice your database text file is now 
listed as an ODBC datasource.

14 In the Select Text Source dialog, click OK. The Select Database Items 
dialog opens.

Database text file listed 
as ODBC data source. 
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15 From the Source Column drop-down list, link the data tags to the 
column you want to output. For table items, the data tag for the first 
column is 1-1, the data tag for the second column is 1-2, and so on.

16 Click OK to return to the content editor and then click Save to save 
the item.

See Also: See “Select Database Items for Output” on page 181 for more 
details on the Select Database Items dialog.
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Specify My Column Width Option
If you selected Specify My Column Width as the Data Delimiter option in 
the first ODBC Text File Setup dialog (see step 7 in the previous 
procedure), you need to set the number of characters in each column, so 
your columns display properly. 

1 In the last 
ODBC Text 
File Setup 
dialog, click 
on the first 
row. 

2 Enter the 
number of 
characters for 
the first 
column in the 
Column 
Width field 
and then click 
the Set 
button to apply the width. 

• If some of the characters from your first column move to the 
second column, click an entry in the first column again and 
increase the number in the Column Width field.

• If some of the characters from the second column stayed in the 
first column, click an entry in the first column again and decrease 
the number in the Column Width field.
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3 Click on the first entry in the second column and enter the number of 
characters for the column in the Column Width field. Click the Set 
button to apply the width.

4 Continue setting the column width for the remaining columns.
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Link to XML/RSS Data Feed
You can link your layout to an XML source, like an RSS data feed. When you link to an RSS data 
feed, RSS sends the latest updates from the data feed to your layout. To use the XML/RSS data feed 
in your item, first select XML/RSS as your data source and then set up the data feed.

Select XML/RSS as 
Data Source

Use the External Data options to select the XML/RSS data feed as the data 
source for your item.

1 In InfoCaster double-click on the 
region to open the Item Library.

2 Click on a region item in the Item 
Library.

3 Select a Quick Editor from the 
Editor list and click the Edit 
button.

4 In the Content tab, select the 
external data source option.

• For the Crawl, Roll, Title and 
Animation Quick Editors 
check the External Data 
Source checkbox and then 
click the Setup button.

• For the Table Quick Editor 
click the Setup Data Source 
button.

5 In the Select Text Source dialog, 
select the XML/RSS option.

6 Set your playback options.
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7 Click OK to apply your settings and move to the next dialog.

Playback Option Description

Retrieve Data Sets when InfoCaster checks the text file for 
new information.

• Select On Demand to set InfoCaster to 
update items when the data source is updated. 
InfoCaster does not play any item when the 
data source is not available. 

• Select Every and enter a time 
(hours:minutes:seconds) to set how often 
InfoCaster should look for new information. 
InfoCaster plays the last available data if the 
data source is not available. This prevents 
your output from disappearing.

Expire Retrieved 
Data

Sets when InfoCaster will expire external data if 
the data source is unavailable. For example, your 
data source may be unavailable if your data 
source is stored on a network and the network is 
down.

• Select Never if you want to play the last data 
available to InfoCaster when the data source 
is unavailable.

• Select Always if you want to expire the last 
data available to InfoCaster when the data 
source is unavailable.

• Select After and enter a time to set how long 
the data source can be unavailable before the 
data is expired. The time is displayed in 
hh:mm:ss (hours:minutes:seconds).

When Data Expires Sets what InfoCaster displays when the data has 
expired.

• Select the Don't Show Item option if you do 
not want to play items that have expired.

• Select the Show Custom Message option if 
you want to display a message when the data 
has expired. Type in your custom text in the 
field.
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Set Up XML Data 
Source

In the Select Data Source Structure dialog you can select the data for 
output.

1 If necessary, complete steps 1 - 5 in the previous section: “Select 
XML/RSS as Data Source” on page 170.

2 In the XML Data Source Setup dialog, enter the path to the XML file. 
If the XML/RSS data is located on the internet, start the URL with 
http://.

3 Enter a name for the XML source in the Data Source name field. 

4 Click OK. The Select Data Source Structure dialog opens.

5 In the Select Data Source Structure dialog, select an item in the XML 
File Structure list that you want to display in your region.
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6 Click the right arrow to move the item to your data structure and set the 
item to play the data feed on output.

7 Click OK. The Select Database Item dialog opens.

8 From the Source Column drop-down list, select the column you want to 
output. The selected column links to the item data tag. If you have more 
than one data tag, you can link to more than one column.

9 Click OK to return to the content editor and then click Save to save the 
item.
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See Also: See “Select Database Items for Output” on page 181 for more 
details on the Select Database Items dialog.



External Data | InfoCaster 175

Create ODBC Data Source
The Open Database Connectivity (ODBC) protocol allows different programs, like Microsoft Access 
and Microsoft Excel, to share information held in database applications. You can easily create a 
database and place almost any type of information in it, including weather data, TV shows, and 
arrival/departure times. After you create your database you can link the data to your InfoCaster item.

Create Database 
in MS Access

Create a database file in any ODBC-compliant software such as MS Access 
and MS Excel. When you change the data in this file, the data in InfoCaster 
changes as well.

To create a database file in MS Access complete the following steps.

1 Open Microsoft Access and start a new Blank Access Database. 
Depending on the version of Access you use, the Blank Access 
Database option is accessed in different ways. If you’re unsure where 
the option is, select File > New.

2 In the New Database window, enter a name and select a location for 
your database. Click the Create button.

3 In the Database window, double-click on the Create Table in Design 
View option.
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4 In the new Table window enter ID in the 
first Field Name text box and select Auto 
Number as your Data Type. 

5 Right-click on the ID entry and select 
Primary Key from the menu. In Access, 
every table must have a column that 
uniquely identifies each table row. 

6 Enter the field names (or column headings) and data types for your 
table. Your field names are your column headings.

7 Select File > Save. In the Save As dialog, enter a name for your table.

8 Select View > Datasheet View to view the table cells.

9 Enter your information in the table cells and save the table.
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Create Database 
in MS Excel 

Create a database file in any ODBC-compliant software such as MS Access 
and MS Excel. When you change the data in this file, the data in InfoCaster 
changes as well.

To create a database file in MS Excel complete the following steps.

1 Open Microsoft Excel.

2 Enter your column headings in the 
first cell of the column. InfoCaster 
uses the heading to refer to the 
column text.

3 Enter your information in the table 
cells.

4 Highlight all of the cells you want 
included in your table. Make sure to include the headings as well. You 
can highlight the cells by clicking and dragging your mouse over the 
cells, or by clicking on the first cell and then SHIFT+clicking on the 
last cell.

5 Select Insert > Name > Define.

6 Enter a name for your 
table and then click the 
Add button. The name 
must be one word only, 
and must not contain 
spaces, underscores, 
slashes, or dashes. Click 
OK to close the dialog.

7 Save the Excel 
spreadsheet.
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Add Database to ODBC System List
After you create your database tables, add the database to your system list. You need to add your 
database to the system list before InfoCaster can read the database content.

Add Database to 
ODBC System List

To add an MS Access or MS Excel file to an ODBC system list complete 
the following steps. If you are using a differnt application, the steps will 
differ slightly.

1 In Windows, open the Data Sources (ODBC) option.

• In Windows XP view: Select Start > Control Panel > Performance 
and Maintenance > Administrative Tools > Data Sources (ODBC).

• In Windows Classic view: Select Start > Control Panel > 
Administrative Tools > Data Sources (ODBC).

2 Select the User DSN tab or the System DSN tab.

• The User DSN tab 
registers the 
database for the 
current logged-on 
user. If someone 
else logs on to the 
computer, the 
database is not 
visible.

• The System DSN 
tab registers the 
database in a 
global location on 
the computer and 
is visible for any logged-on user.

3 Click the Add button to open the Create New Data Source dialog.

4 Select the driver from the list for your database.
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• If you're connecting 
to an Access 
database select 
Microsoft Access 
Driver (*.mdb).

• If you're connecting 
to an Excel 
spreadsheet select 
Microsoft Excel 
Driver (*.xls).

5 Click the Finish button 
to add the selected 
driver to the system 
and to continue with the database set up.

6 In the new dialog enter a name for the data source.

7 Select your external data source.

• For Access data, click the Select button. In the dialog, navigate to 
and select your database. Clear the Read Only checkbox if necessary.

• For Excel data, click the Select Workbook button. In the dialog, 
navigate to and select your spreadsheet. Clear the Read Only 
checkbox if necessary.

8 Click OK in all the dialogs until you return to Windows.
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Link Item to ODBC Data Source
You can create your ODBC database in any ODBC compliant program, including MS Access and MS 
Excel. Before linking your item in InfoCaster to your ODBC database, you need to add your database 
to the ODBC system list. See “Add Database to ODBC System List” on page 178 for details.

Link to Database The following steps describe how to link to your ODBC data source in 
InfoCaster.

1 In InfoCaster double-click on the region to open the Item Library.

2 Click on a region item in the Item Library.

3 Select a Quick Editor from the Editor list and click the Edit button.

4 In the Content tab, select the external data source option.

• For the Crawl, Roll, Title and Animation Quick Editors check the 
External Data Source checkbox and then click the Setup button.

• For the Table Quick Editor click the Setup Data Source button.

5 In the Select Text Source dialog, select the ODBC option.

6 Select a database from the Database list. 

7 Select the database table from the Table list. For text file databases 
the text file name displays as the table name.

8 Set your playback options.

Playback Option Description

Retrieve Data Sets when InfoCaster checks the text file for 
new information.

• Select On Demand to set InfoCaster to 
update items when the data source is updated. 
InfoCaster does not play any item when the 
data source is not available. 

• Select Every and enter a time 
(hours:minutes:seconds) to set how often 
InfoCaster should look for new information. 
InfoCaster plays the last available data if the 
data source is not available. This prevents 
your output from disappearing.
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9 Click OK to apply your settings and move to the next dialog.

Select Database 
Items for Output

In the Select Database Items dialog you can select specific data for output, 
set the data output order, and apply special formatting to specific table 
entries.

1 If necessary, complete steps 1 - 7 in the previous section: “Link to 
Database” on page 180.

2 Select a column name from the Source Column drop-down list to link 
the data tag on the left to the database column. If you do not want a 

Expire Retrieved 
Data

Sets when InfoCaster will expire external data if 
the data source is unavailable. For example, your 
data source may be unavailable if your data 
source is stored on a network and the network is 
down.

• Select Never if you want to play the last data 
available to InfoCaster when the data source 
is unavailable.

• Select Always if you want to expire the last 
data available to InfoCaster when the data 
source is unavailable.

• Select After and enter a time to set how long 
the data source can be unavailable before the 
data is expired. The time is displayed in 
hh:mm:ss (hours:minutes:seconds).

When Data Expires Sets what InfoCaster displays when the data has 
expired.

• Select the Don't Show Item option if you do 
not want to play items that have expired.

• Select the Show Custom Message option if 
you want to display a message when the data 
has expired. Type in your custom text in the 
field.

Playback Option Description
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column in your database to display during output, do not link the 
column to a data tag.

Data tags in content editor.

Select a column to 
order content output. 

Link data tags to 
database columns. 

On output item data tags 
display linked column content.
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For table items that display multiple columns of text, the data tags in 
the Table Quick Editor are set as 1-1 for the first column, 1-2 for the 
second column, and so on. When you link the data tag to the database 
column, InfoCaster displays the column contents as a list on output.

3 From the Sort drop-down list select a column for ordering content 
output. If you do not select a sort column InfoCaster plays the text in 
the order listed in the table.

4 Select the ascending or the descending option located beside the Sort 
list to determine if the selected column content is sorted in ascending 
order or descending order.

• Columns with numerical data are sorted from smallest number to 
largest (ascending order) or largest number to smallest (descending 
order).

• Columns with textual data are sorted alphabetically from A - Z 
(ascending order) or in reverse alphabetical order from Z - A 
(descending order).

Table item data tags: 
1-1 data tag is the first column in the item, 
1-2 data tag is the second column in the item. 

On output 1-1 data tag displays data 
from the "city" database column and
1-2 data tag displays data from the
"temp" database column. 
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5 Click the Refresh button at the bottom of the window to view the data 
selected for output. The Results area displays the table entries sorted 
for output. The Layout number indicates when the content is 
displayed on output: first, second, third, and so on.

Set Specific Table 
Entries for Output

In the Select Database Items dialog, use the Advanced Selection Criteria 
section to set specific table entries for playback.

1 Select the AND option or the OR option from the first drop-down 
list to help set the playback criteria.

AND: Sets InfoCaster to display the table entries that meet the 
criteria set in the current row and the row above. The table entries 
must have the attributes of both rows. 

OR: Sets InfoCaster to display the table entries that meet the criteria 
set either in the current row or the row above. The table entries must 
have at least one of row's attributes, but not both. 

The Layout number indicates what content 
displays first, second, third, and so on. 

Table Item ExampleTitle Item Example

In this example InfoCaster outputs table rows
with an ID less than 15 and greater than 5, 
so rows 6 - 14.

In this example InfoCaster outputs table rows
with an ID less than 15 or an ID that equals 20, 
so rows 1 - 14 and row 20.
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2 Select a column heading from the Column list for the selection 
criteria. The Operator and Value condition applies to the selected 
column.

For example, select the city column from the Column list, select 
Equals from the Operator list, and enter Toronto in the Value text box. 
InfoCaster outputs the row of data where Toronto is listed in the city 
column.

Other examples for using the selection criteria option:

• If you select city from the column list, select Equals from the 
Operator list, and enter Toronto in the Value text box, InfoCaster 
only outputs the table row that includes the entry Toronto.

• If you select city from the column list, select Greater Than from 
the Operator list, and enter Milton in the Value text box, 
InfoCaster outputs the table rows with entries that come after 
Milton alphabetically.

• If you select city from the column list, select Not Like from the 
Operator list, and enter Ottawa in the Value text box, InfoCaster 
outputs all the table rows that do not have the entry Ottawa.

3 To delete the current row from the Advanced Selection Criteria 
section, select the DELETE option from the row's first drop-down 
list.

4 To clear all the information in the Advanced Selection Criteria 
section, click the Clear button.

5 To quickly edit the database selections, click the Edit Query button. 

selection criteria

table 
entry

output 
results



186 External Data | InfoCaster

The Edit Query window opens, where you can edit the parameters of 
your selections in the text line. When you click OK, the edits are 
saved in the Edit Query window and are applied to your item on 
output. 

When you click OK in the Edit Query window the options in the Select 
Database Items dialog are disabled. Click the Clear Query button to 
remove the edits and to enable the options in the Select Database 
Items again.

6 To view the data selected for output click the Refresh button. The 
Results area displays the table entries sorted for output.

7 If you do not want to apply advanced formatting to specific data (see 
next topic), click OK. In the content editor, click Save. InfoCaster 
outputs the selected table entries from your ODBC data source 
during playback.

SELECT: Lists the columns connected to the data tags.
FROM: Lists the database table.
WHERE: Lists the advanced selection criteria.
ORDER BY: Lists the sort order and direction.
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Apply Advanced 
Formatting to 
Data

The advanced formatting options allow you to display specific data in a 
different color, hide specific data during output, format numeric data, and 
add a string of text before or after your data.

In this example, we only want InfoCaster to
display the "Weather Watch: Severe Thunderstorms"
warning if there is a "Y" in the warnYN column.
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Apply Color to Data
Use the conditional formatting options to apply color to specific data.

1 In the Select Database Items dialog, click the Advanced Formatting 
button.

2 In the Format dialog, select the column from the column list that will 
display the color formatting.

3 From the first list in the conditional formatting area, select the 
column that determines which entries display the color formatting on 
output. This may be the same column you selected in the last step, or 
a different column.

Selecting a column activates the other options in the row.

4 Select an option from the second drop-down list to set a parameter 
for the conditional formatting. Enter a word, number, or phrase in 
the text box. The entry in the text box completes the selection from 
the second list. 

5 Click the color chip to open the Color Picker, and use the Color 
Picker tools to select a color for the column entries.

Select the column that will
display the color formatting
on output. In this example,
InfoCaster will apply the
color formatting to the data in
the "warning" column.

Set the formatting conditions. In this example, InfoCaster
applies the color formatting to the data in the warning
column only if there is a "Y" in the warnYN column.
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If the NTSC! or PAL! warning appears, click the warning box to select 
a video-safe color. InfoCaster applies the selected color to the column 
entries that meet the set conditions.

6 If you want to clear the formatting options, choose [Select a column] 
from the first drop-down list in the row.

Hide Data During Output
Apply conditional formatting options to hide specific column entries on 
output. 

1 In the Select Database Items dialog, click the Advanced Formatting 
button.

2 In the Format dialog, select the column from the column list that 
contains the data you want to hide on output.

3 From the first list in the conditional formatting area, select the 
column that determines which entries are not shown during output. 
This may be the same column you selected in the last step, or a 
different column.

Selecting a column activates the other options in the row.

Select the column that
contains the data you want to
hide on output. In this example,
InfoCaster will hide the data
in the "warning" column.

Set the formatting conditions and then check the Hide
Item or Color checkbox. In this example, InfoCaster
hides the data in the warning column if there is not a
"Y" in the warnYN column.
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4 Select an option from the second drop-down list to set a parameter 
for the conditional formatting. Enter a word, number, or phrase in 
the text box. The entry in the text box completes the selection from 
the second list.

5 Check the Hide Item or Color checkbox to hide the item on output.

6 If you want to clear the formatting options, choose [Select a column] 
from the first drop-down list in the row.

Format Numeric Data
Use the data formatting options to format your numeric data.

1 In the Select Database Items dialog, click the Advanced Formatting 
button.

2 In the Format dialog, select the numeric column from the Column list 
and then choose an option from the Thousands Separator, Decimal 
Point, and Decimal Places lists.

Add a Prefix or Suffix
Use the Add Prefix and Add Suffix options to display text before or after 
your text on output.

1 In the Select Database Items dialog, click the Advanced Formatting 
button.

2 To display a string of text before each column entry during output, 
select the column in the Column list and then select the Add Prefix 
checkbox. Enter the text in the text box. 

On output the weather warning is hidden
for items meeting formatting conditions.

warning hiddenwarning in set color
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3 To display a string of text after each column entry during output, 
select the column in the Column list and then select the Add Suffix 
checkbox. Enter the text in the text box.



192 External Data | InfoCaster



Schedule Playback
Sequences
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5. Schedule Playback Sequences

Schedule Playback Overview
Use Sequencer and Conditional Playback to schedule the playback sequence(s) of your InfoCast pages 
and region items. 

• Schedule page playback sequences in the Sequencer in the Pages window. You can set the page 
start time, transition, duration and days of the week for for page playback. For instructions on 
setting page playback, see “Schedule InfoCast Pages” on page 195.

• Schedule region playback sequences in the Sequencer in the Items window. You can set the region 
start time, transition, duration, looping, and days of the week for region item playback. For 
instructions on setting region playback, see “Schedule Region Items” on page 201.

• Set events to be triggered in the Conditional Playback dialog. You can set sequences, items, times 
and GPI triggers to trigger a pop-back resize or the playback of other items, sequences, pages, or 
GPO output. For instructions on using triggers for playback, see “Set Triggers” on page 210.

1

Open
InfoCast
 

2
Double-click
on a page 
to add regions
 

Draw a region 

4b

Open a content editor 5
Set playback sequence

Output InfoCast

3

4a

4c
Double-click on a 
region to add
content

6

Add content 
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Schedule InfoCast Pages
Schedule the playback sequence of the pages in your InfoCast using the options in the Sequencer on 
the Pages window. You can set up one or more sequences with one or more pages for playback. 

By default, a sequence (Sequence 1) is automatically added to the sequence list and the first page 
layout in your InfoCast project is set up for output. New pages that you create or import are not 
automatically included in the page sequence for output.

Add sequence

Drag to add
page to sequence

Select sequence and 
adjust sequence settings

Select page and adjust page settings

1

2

3

4
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Add a New 
Page Sequence

Add multiple sequences to set different playback times for pages, or to 
organize pages in the sequence.

1 Click the Add button above the Sequence Settings panel.

2 In the dialog, enter a name and start time for the new sequence.

Skip or Play Sequence During Playback

By default, the checkboxes on the sequence headings are checked so that 
they play during output.

To skip a sequence 
during playback, clear 
the sequence heading 
checkbox. 

To skip only one page during output, place the page in its own sequence, 
then clear the sequence checkbox. 

Rename Sequence

To give your sequence a descriptive name, select the sequence heading in 
the sequence list, then click on the Rename button above the Sequence 
Settings panel. Name the sequence as prompted.

Delete a Sequence

To remove a sequence from the sequence list, select the sequence heading, 
then click the Delete button above the Sequencer panel. InfoCaster deletes 
the sequence heading and removes the pages from the sequence list. The 
pages remain available in the Page Library.

Check to include sequence in output
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Add Pages to a 
Sequence

Add pages to the sequence by dragging the page from the Page Library to 
the sequence heading. You can add the same page to the sequence more 
than once..

Change Order of Pages in the Sequence

To change the playback order of pages, drag the page up or down in the 
sequence list.

Delete Pages from the Sequence

To remove a page from the sequence, use one of these methods.

• Drag the page from the sequence back to the Page Library. 
• Right-click on the page in the sequence, then select Remove Page from 

the menu. 
• Select the page, then select Pages > Delete Page from Sequence.

The page remains available in the Page Library, so you can add it to the 
sequence at a later time.

Set an Offline Graphic

To display an image on your output device whenever a page is switched 
during playback, select Edit > Preferences. Use the Choose button beside 
the Offline Graphic field on the General tab to select a graphic file. See 
“Offline Graphic” on page 230 for details.

Set Sequence 
Settings

When you schedule a page sequence, you can set the sequence start time, 
and the transition between pages. Sequence Settings are applied to every 
page in a sequence.

Drag page from library to a sequence
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Click on a sequence heading in the sequence list to select it. The Sequence 
Settings panel becomes available. 

Set Sequence Start Time

1 Select a sequence heading.

2 Enter a time in the Start Sequence At field. When you start playback, 
the page sequence that is set for output at the current time plays.

Set Default Transition

You can apply a transition for page switches in your sequence. 

1 Select a sequence heading.

2 Select a transition from the Default Transition drop-down list.
3 Set how long the transition should take (in seconds) in the Duration 

field.
4 If you have selected a Wipe transition and are using Progressive VGA 

for output with GPU Acceleration enabled, enter a number in the 
Softness field to set how hard or soft the edges of the transition 
appear. Increase the number to increase the softness.

Set Page 
Settings

You can use page settings to set the playback of individual pages within 
your sequence. You can set the page to play on specific days of the week, 
set the page to not play before or after a specific date, set the page to play 
for a specific length of time, and set the transition for the page. 

Select a sequence and 
adjust Sequence Settings
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Click on a page in the sequence to select it. The Sequence Settings panel 
changes into the Page Settings panel. 

Set Days of the Week for Playback

You can set which days of the week your page will play.

1 Select a page in the sequence list.

2 In the Page Settings panel, select the checkbox beside the day(s) of the 
week that you want your page to play. 

3 Clear the days of the week that you do not want the page to play. 

You can also click on the buttons that appear beside the page in the 
sequence list to set which days the page is to play.

Set Timeline for Page Playback

If you only want the page to play for a certain number of days, use the Don’t 
Play Before and Don’t Play After Controls.

1 Select a page in the sequence list.

2 If you don’t want the page to play before a certain date, check the 
Don’t Play Before checkbox and enter a date in the field.

3 If you don’t want the page to play after a certain date, check the Don’t 
Play After checkbox and enter a date in the field.

Select a page and 
adjust Page Settings
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Set Page Duration

You can set how long pages play before the next page in the sequence is 
displayed.

1 Select a page in the sequence list.

2 Enter how long the page should play in the Page Duration field, in 
hours, minutes and seconds.

Set Page Transition

You can set what kind of transition is used to transition to the page. If the 
default transition for the sequence is dissolve, but you want one page to 
snap on screen, select the page that you want to snap on screen and choose 
the Snap transition. 

1 Select a page in the sequence list.

2 Select a transition from the Transition drop-down list.
3 Set how long the transition should take (in seconds) in the Duration 

field.
4 If you have selected a Wipe transition and are using Progressive VGA 

for output with GPU Acceleration enabled, enter a number in the 
Softness field to set how hard or soft the edges of the transition 
appear. Increase the number to increase the softness.
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Schedule Region Items
Schedule the playback sequence of the items in each region using the options in the Sequencer on the 
Item window. You can set up one or more sequences with one or more region items for playback.

If you had selected the Auto Add To Sequence checkbox in the region item editor, all your region 
items are added to the sequence by default. See “Automatically Add Items to the Sequence” on 
page 51 for details on this option.

.

Adjust Item Settings Adjust Sequence Settings 2 Drag item to
sequence

1 Add sequence

3 4
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Add a New 
Region 
Sequence

Add multiple sequences to set different playback times for items, or to 
organize items in the sequence.

1 Click the Add button above the Sequence Settings panel.

2 In the dialog, enter a name and start time for the new sequence.

Skip or Play Sequence During Playback

By default, the checkboxes on the sequence headings are checked, so that 
they play during output. 

To skip a sequence 
during playback, clear 
the sequence heading 
checkbox. 

To set a sequence to play during output, check the sequence heading 
checkbox. 

Rename Sequence

To give a sequence a descriptive name, select the sequence heading in the 
sequence lists, then click on the Rename button above the Sequence 
Settings panel. Name the sequence as prompted.

Delete a Sequence

To remove a sequence from the sequence list, select the sequence heading, 
then click the Delete button above the Sequencer panel.

Check to include sequence in output
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3 InfoCaster deletes the sequence heading and removes the region items 
from the sequence list. The region items remain available in the Item 
Library.

Add Region 
Items to a 
Sequence

Add region items to the sequence by dragging the item from the Items 
Library to the sequence heading. You can add the same item to the 
sequence more than once.

Items that are in the sequence are colored green in the Item Library. Items 
that are not in the sequence are blue.

Auto Add to Sequence

If you checked the Auto Add to Sequence checkbox in the content editor 
when you created your region item, the region item was automatically 
added to the sequence list. See “Automatically Add Items to the Sequence” 
on page 51 for details. 
 

Drag item from library to a sequence
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Add Blank Item to Sequence

To make the region transparent, add a blank item to the sequence. To do 
this, select Add Blank Item from the region item editor list. See “About 
Blank Items” on page 44 for further information. 

Change Order of Items in Sequence

To change the playback order of items, drag the item up or down in the 
sequence list in the Items window.

Delete Items from Sequence

To remove an item from the sequence, while keeping the item in the Item 
Library, use one of these methods.

• Drag the item from the sequence list back to the Item Library. 
• Right-click on the item in the sequence list, then select Remove Item 

from the menu. 
• Select Items > Delete Item in Sequencer.

Set Region 
Sequence 
Settings

When you schedule a region item sequence, you can set the sequence start 
time, the playback duration of some region items, the transition between 
items and looping options. Sequence Settings are applied to every item in a 
sequence.

Click on a sequence heading in the sequence list to select it. The Sequence 
Settings panel becomes available.

Set Sequence Start Time

1 Select a sequence heading.

Select sequence and adjust Sequence Settings
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2 Enter a time in the Start Sequence At field. When you start playback, 
the region sequence that is set for output at the current time plays.

Set Roll and Crawl Speed

You can set the speed at which rolls and crawls move across the screen.

1 Select a sequence heading in a roll or crawl region.

2 Drag the speed slider right to increase the speed.
3 Drag the speed slider left to decrease the speed.

Set Roll and Crawl Direction

You can set the direction rolls and crawls move across the screen. To 
change the default direction for all rolls and crawls, change the setting in 
the Preferences dialog.

1 Select a sequence heading in a roll or crawl region.

2 Use the Direction radio buttons to set the direction your roll or crawl.
• Set your crawls in the sequence to move To Left or To Right.
• Set your rolls in the sequence to move Up or Down.

Set Default Item Duration

1 You can set how long non-moving items play in the region until the 
next item plays. This option is available for still, digital clock, analog 
clock and temperature regions. Select a sequence heading.

2 Enter a duration in the Default Duration fields in hours, minutes and 
seconds.

Set Default Transition

You can apply a transition for when items switch in your sequence.

1 Select a sequence heading.

2 Select a transition from the Default Transition drop-down list.
3 Set how long the transition should take (in seconds) in the Duration 

field.

If you have selected a Wipe transition and are using Progressive VGA for 
output with GPU Acceleration enabled, enter a number in the Softness 
field to set how hard or soft the edges of the transition appear. Increase the 
number to increase the softness.
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Set Sequences to Loop

You can set the sequence to play through once, or to continue playback 
until another sequence is scheduled to play. This option is not available for 
still regions.

1 Select a sequence heading.

2 Check the Loop Sequence checkbox to set the sequence to start from 
the beginning when the sequence finishes until the next sequence is 
set to play.

3 Clear the Loop Sequence checkbox to set the sequence to play through 
once and then stop.

Set Items to Finish Playback Before Next Sequence Begins

You can set InfoCaster to finish playing the current sequence before playing 
the next sequence, or set sequences to play when they are scheduled no 
matter what is currently playing. This option is not available for still 
regions.

1 Select a sequence heading.

2 Check the End Item Before Changing Sequences checkbox to set 
InfoCaster to let the current item finish playback before the next 
sequence begins.
For example if you are playing a 5 minute video clip at 9:57 and the 
next sequence is scheduled to begin at 10:00, the video clip will play 
for the full five minutes and the 10:00 sequence will begin at 10:02.

3 Clear the checkbox if you want the next sequence to start at the correct 
time no matter what is currently playing..

Set Item 
Settings

You can use item settings to set the playback of individual region items 
within your sequence. 

You can set the item to play on specific days of the week, set the item to not 
play before or after a specific date, set the item to play for a specific length 
of time, and set the transition for the item. 
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Click on an item in the sequence to select it. The Sequence Settings panel 
changes into the Item Settings panel.

Set Days of the Week for Playback

You can set which days of the week your item will play.

1 Select an item in the sequence list.

2 In the Item Settings panel, select the checkbox beside the day(s) of the 
week that you want your item to play. 

3 Clear the days of the week that you do not want the item to play. 

You can also click on the buttons that appear beside the item in the 
sequence list to set which days the item is to play.

Set Timeline for Item Playback

If you only want the item to play for a certain number of days, use the Don’t 
Play Before and Don’t Play After Controls.

1 Select an item in the sequence list.

2 If you don’t want the item to play before a certain date, check the 
Don’t Play Before checkbox and enter a date in the field.

3 If you don’t want the item to play after a certain date, check the Don’t 
Play After checkbox and enter a date in the field.

Select item and adjust Item Settings
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Set Item Duration

You can set how long non-moving items play before the next item in the 
sequence is displayed. This option is available for still, digital clock, analog 
clock and temperature regions.

1 Select an item in the sequence list.

2 Enter how long the item should play in the Duration field, in hours, 
minutes and seconds.

Set Item Transition

You can set what kind of transition is used to transition to the item. If the 
default transition for the sequence is dissolve, but you want one item to 
snap on screen, select the item that you want to snap on screen and choose 
the Snap transition.

1 Select an item in the sequence list.

2 Select a transition from the Transition drop-down list.
3 Set how long the transition should take (in seconds) in the Duration 

field.

If you have selected a Wipe transition and are using Progressive VGA for 
output with GPU Acceleration enabled, enter a number in the Softness 
field to set how hard or soft the edges of the transition appear. Increase the 
number to increase the softness.
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Change Sequence Display
You can change how much information is displayed in the Sequencer depending on whether you want 
to make more room to see your items or your sequence list.

Set Sequence 
Display

To display the Sequence Settings panel, click on the Extended View button 
(double arrows) on the Sequencer toolbar. The Extended View button 
becomes the Brief View button. 

To hide the Sequence Settings, when you want more room to work on the 
items in the Library, click on the Brief View button.

Set Sequence 
Settings Display

To display or hide the Sequence, Page or Item options, click on the triangle 
beside the Sequence Settings in the Sequence Settings panel.

Set Sequence 
Item Display

To display or hide the sequence list, click on the triangle in front of the 
sequence heading.

To display the name and 
a thumbnail of your 
page or region item, 
click the Small 
Thumbnaiils button in 
the Sequencer title bar.

To display just the name 
of your page or region item, click the Text Only button in the Sequencer 
title bar.

Hides/Displays 
sequence list

Hides/Displays 
Settings panel options

Brief View/Extended View

Text Only

Small Thumbnails
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Set Triggers
You can set the playback of certain events to trigger other events to action in InfoCaster. The trigger 
event can be a region item, a region item sequence, a time, or a GPI trigger. The action event can be 
play item, play item sequence, play page, output in pop-back region, or output GPO. 

Disable 
Sequence, 
Page, or Item

In the sequence list, disable the sequence, page, or item that you want to 
use as the resulting action of the trigger.

1 Switch to the Pages or Items window.

2 Clear the checkbox in the page or region sequence heading. See “Skip 
or Play Sequence During Playback” on page 196 for details. 
You may need to put an item in its own sequence, then disable the 
sequence. 

Open 
Conditional 
Playback 
Dialog

1 Select Tools > Conditional 
Playback, or click on the 
Conditional Playback 
button on the main toolbar, 
located next to the Stop 
button. 

2 In the Conditional Playback dialog box, click New to create a new 
conditional playback event.

Conditional Playback (Triggers) button
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Select Trigger From the Trigger drop-
down list in the Event 
Setup dialog box, select 
one of the following 
items to trigger the start 
of the next action. 

Item Starts 

Sets the playback of an 
item to trigger an action. 
Select the page, region, 
sequence, and item from 
the drop-down lists.

When the trigger is aired, 
the item plays once, then 
scheduled playback resumes. If you want the item to loop during playback, 
place the item in its own sequence, then select the Loop option in the Items 
Sequence Settings panel. See “Set Sequences to Loop” on page 206.

Sequence Starts

Sets the playback of a 
sequence to trigger an 
action. Select the page 
that contains the 
sequence, the region that 
contains the sequence, 
and the sequence that is 
used as the trigger. 
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When the trigger is aired, the sequence either plays once or loops, 
depending on what you selected in the Sequence Settings panel. Then, 
scheduled playback resumes.

GPI

Sets a GPI trigger to 
trigger an action. Select 
the GPI number from the 
list which contains all 
known GPIs connected to 
your system. Then, check 
the Pulse radio button to 
trigger your selections immediately upon touching the GPI trigger, or check 
the Tone radio button to trigger your selection after holding down the GPI 
trigger for a moment.

Note: The GPI Initiated option is only available after you select the GPI 
device in the Configuration Utility. To do this: 

a Click on the Windows START button on the bottom left corner 
of your screen, then select Programs > Inscriber > InfoCaster > 
Utilities > InfoCaster Configuration Utility. 

b In the Configuration Utility, select the GPI device connected to 
your system: Live Link Installed, Serial GPI, or Software GPIs. 

The GPIs that are available with that device are displayed in the 
GPI List panel. These numbers are also displayed in the 
Conditional Playback dialog box.
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c If you selected the Serial GPI option and have more than 1 
Comm port, select the port for each GPI trigger in the Serial 
GPI Configuration panel.

Reaching Specified 
Time

Sets an action to be 
triggered at a particular 
time. Select the date and 
time. 

Select Action From the Action drop-down list, select one of the following events to occur 
when the trigger is reached.   

Note: Only pages, items, and sequences that are disabled in the sequence 
list are available in the Action list, as explained in “Disable 
Sequence, Page, or Item” on page 210.

Play Item 

Sets an item to play when 
the trigger has been 
reached. Select the page, 
region, sequence, and 
item from the list. 

Note: Only items that 
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are disabled in the sequence list are available in the Action list, as 
explained in “Disable Sequence, Page, or Item” on page 210.

Play Sequence 

Sets a sequence to play 
when the trigger has 
been reached. Select the 
page, region, and 
sequence from the list.

Note: Only sequences that are disabled in the sequence list are available 
in the Action list, as explained in “Disable Sequence, Page, or 
Item” on page 210.

Play Page:

Sets a page to play when 
the trigger has been 
reached. Select the page 
from the list. 

Note: Only pages that are disabled in the sequence list are available in 
the Action list, as explained in “Disable Sequence, Page, or Item” 
on page 210.

Pop-Back Resize 

Sets a region to be 
resized to a pop-back 
region size when the 
trigger has been reached. 
Select the page that the 
region is in, then the region. In the And It Resizes To field, select the pop-
back region that you want the region to resized to. 

To return the region of a pop-back action to its original size, create another 
trigger event and select Its Original Size in the And It Resizes To field. 

For details on pop-back regions, see “Draw a Pop-Back Region” on 
page 32. 
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GPO

Sets output from an 
external device to play 
when the trigger has 
been reached.
Select the number of the external device in the list. 

Save Click Save in the Event Setup dialog box.

The trigger is displayed in the Conditional Playback dialog box.

Skip Trigger 
Events

You can set your trigger events to be skipped during output. When triggers 
are active, the checkbox beside them is checked, and they will occur when 
the InfoCast plays.

1 Select Tools > Conditional Playback.

2 In the Conditional Playback dialog box, clear the checkbox beside the 
trigger event you want to skip.
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6. Output

Output Overview
You can start playing an InfoCast in two ways.

• Click on the Play button in the main toolbar to output your InfoCast starting from the scheduled 
time according to the times that are set in the page and region item sequence lists.

• Right-click on a blank space in the pages or items sequence list, then select Start Playback from 
the First Page to output your InfoCast starting from the first page and item in your first sequence 
list. 

InfoCaster plays the InfoCast on an output monitor. The region item that is set for output plays for 
the set duration. Then, the next item in the sequence list plays, and so on. InfoCaster loops through 
each sequence of pages and items until it reaches the start time of the next sequence in the list. Only 
one item in each region of a page layout is output to air at any given time.

While your InfoCast is playing, you cannot adjust regions in the Regions window or change the crawl 
or roll speed, However, you can add, delete, and modify content, and rearrange the sequence. 
Changes apply the next time InfoCaster plays that item. You can also control plasma display screens 
and log your output, as explained in “Log Output” on page 227. 

1

Open
InfoCast
 

2
Double-click
on a page 
to add regions
 

Draw a region 

4b

Open a content editor 5
Set playback sequence

Output InfoCast

3

4a

4c
Double-click on a 
region to add
content

6

Add content 
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Preview Before Playback
Before you send your InfoCast to air, you can preview your content in the following ways.

Content Editor 
Preview Panel

You can preview the content of each region item in the preview panel of the 
content editor as you create each item. Refer to chapters about adding 
region items, starting with “Add Items to Regions” on page 39.

Regions 
Window 
Workspace

You can preview a still image of each region item on your page layout in the 
Regions window workspace. See “Preview Regions” on page 37 for details.

Desktop Video 
Window

If you select Desktop Video window as your output device (as explained in 
“Select Output Device” on page 221), your InfoCast outputs to your 
computer monitor. You can use this method to test your layouts before 
outputting to the public.

Use GPU 
Acceleration

GPU Acceleration uses your system's graphics processing unit (GPU) 
instead of the central processing unit (CPU) to accelerate certain effects. 
GPU Acceleration is available for progressive VGA output. By default, it is 
enabled in new layouts. 

If you are updating an InfoCast that has been created in an earlier version 
of InfoCaster, you need to enable GPU Acceleration. 

To enable GPU Acceleration, switch to the Regions window, then select 
Regions > GPU Acceleration > All Regions On.

It is recommended that you leave GPU Acceleration on.
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Play InfoCast
There are two ways you can output your InfoCast; starting from the beginning of the sequence, or 
starting from the scheduled time. 

During playback, the ON AIR indicator at the top right corner of the screen lights up.

Animations play back at the frame rate of the playback device. 

ATI:  1 second = 60 frames

NTSC: 1 second = 30 frames

PAL: 1 second = 25 frames

Play at 
Scheduled Time

You can output your InfoCast so that it starts playing the content that is 
scheduled to play at specific times in the playback sequences of your 
InfoCast pages and region items. For example, if you have a sequence of 
three items with a sequence start time of 1:00 PM and each item is set to 
play for one hour, starting playback at 2:30 PM would set item number two 
to play.

With your InfoCast project open, click the Play button on the main toolbar 
at the top of the screen. Alternately, you can right-click on the page in the 
Pages window, then select Play Page from the menu, or you can select File 
> Start Playback

Play from Start You can output your InfoCast so that it starts playing the content on the 
first page and the first region item in your page and item sequence list. 

Right-click on the pages or region items sequence window below the 
sequence list, then select Start Playback from the First Page.

Stop InfoCasts Click the Stop button on the main toolbar at the top of the screen to stop 
the output. Alternately, you can select File > Stop Playback.

Play from location in sequence

On Air
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View Playback
While your InfoCast is on air, you can view the InfoCast in two locations.

• The Preview window at the bottom left corner of your InfoCaster screen.

• The selected output device.

View from 
Preview 
Window 

To see the output of your InfoCast in the Preview window at the bottom-left 
corner of your InfoCaster Creation Station screen, select Tools > Preview 
Playback. InfoCaster displays exactly what is being aired. 

Note: If Desktop Video is selected as the output device, this option is not 
available. See “Select Output Device” on page 221 below for 
details.

Select Output 
Device

InfoCaster plays your InfoCasts to an output monitor. This may be a VGA 
monitor, a video monitor, or a plasma display, depending on your hardware 
configuration. If your output monitor supports external control, you may be 
able to control it from InfoCaster. 

When you first install InfoCaster, the Configuration Utility opens, in which 
you select your output device.

To change the output device:

1 Click on the Windows START button on the bottom left corner of 
your screen, then select Programs > Inscriber > InfoCaster > Utilities 
> InfoCaster Configuration Utility.
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2 In the Configuration Utility, select one of the following output devices 
from the Select Output Device drop-down list on the Video/Audio 
Standard Change tab:

• PCI-100: Select this option to output to the output device that is 
connected to your PCI-100 card.

• Desktop Video 
Window: Select 
this option to 
output to your 
computer 
monitor via the 
Desktop Video 
window. 

• VGA Out: Select 
this option to 
output to the 
VGA output 
device that is 
connected to 
your ATI card.

• TV Out: Select this option to output to the TV output device that is 
connected to your ATI card.

• Matrox G450 / G550: Select this option to output to the output 
device that is connected to your Matrox card.

• Blackmagic DeckLink: Select this option to output to the output 
device that is connected to your BlackMagic DeckLink card.

To output to more sources, you can purchase player licences. See 
“Purchase Options” on page 4 for further information.
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3 Select a video standard from the list.

4 To connect to live video input:

a Select the Yes, I have live video input radio button. The PCI-100 
checkbox and the video standard drop-down list become 
available.

b If you have a PCI-100 card, check the PCI-100 checkbox. 
c Select NTSC or PAL from the video standard drop-down list.

4 Click OK to continue. Restart InfoCaster as prompted.

Control Plasma 
Display Screens

You can use a serial trigger to turn your plasma monitor on or off. 

1 In the Pages window, select Tools > Plasma Display Control.

2 In the Plasma Display Control dialog box, select the COM port that 
connects to your plasma display screen from the Com Port list.

3 Select your plasma display's make and model from the Plasma Display 
list. If your model is not listed, contact support@inscriber.com for 
assistance.

4 Check the Enable Automatic Display Control checkbox to enable the 
scheduling options. 

Clear the checkbox to disable InfoCaster's automatic control of the 
display screens.

5 Schedule the selected plasma display screen by selecting one of the 
following options for each day of the week:

• Select the On From radio button, then enter a start display time in 
the first field, and an end display time in the second field. 
InfoCaster keeps the plasma display on from the time set in the first 
field to the time set in the second field.

• Select On All Day to keep the plasma display on all day.
• Select Off to turn the plasma display off for that day.
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Track Output You can track which item in the sequence list is currently playing in any 
region. You can track the playback of region items in log files. 

Track Playback Item in Sequence List

To highlight the item that is currently playing: 

1 Open the region in 
the Items window to 
display its sequence 
list. See “Open 
Region in Items 
Window” on page 42.

2 Select Items > 
Display Playback 
Position in the Items window to enable this feature.

3 Click the Play button to output the InfoCast. 

Track Playback of Region Items in Log File

To create a log file of all the times the content of a region is aired, check 
the Log This Region checkbox in the Details panel below the Regions 
workspace as explained in “Log Region Playback” on page 36.

Each day, InfoCaster creates a new log file that contains the playback 
information of the entire day. The log includes the player name, page name, 
region name, item name, start date, start time, stop date, stop time, and 
duration. 

To view a log file, or change default log settings, such as the status of 
automatic logging, the log file location, or the number of days a log file is 
kept on your system, see “Log Output” on page 227.

Change 
Content During 
Playback

While your InfoCast is playing, you cannot adjust regions in the Regions 
window or change the crawl or roll speed, but you can add, delete, and 
modify content, and rearrange the sequence. Changes apply the next time 
InfoCaster plays that item. 

To skip a sequence 
during playback, clear 
the sequence heading 
checkbox. 

To set a sequence to play during output, check the sequence heading 
checkbox. To skip or enable a trigger, see “Skip Trigger Events” on 
page 215.

Check to include sequence in output



Appendix



226 Appendix | InfoCaster

Appendix

Additional Tasks
In addition to creating InfoCasts and airing them, you can also do the following in InfoCaster:

Log Output Create log files, view log files, or change default log settings, such as the 
status of automatic logging, the log file location, or the number of days a 
log file is kept on your system. See “Log Output” on page 227.

Change 
Preferences

Change your default settings in the Preferences dialog box. See “Change 
Preferences” on page 229.
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Log Output
You can log the playback of region items. A new log file is created each day, so the playback of an 
entire day is stored in one log file.

You can automatically set all regions to be logged, change the log file location, or change the number 
of days a log file is kept on your system. 

Log Region 
Playback

To create a log file of all the times the content of a region is aired, check 
the Log This Region checkbox in the Details panel below the Regions 
workspace. as explained in “Log Region Playback” on page 36.

Each day, InfoCaster creates a new log file that contains the playback 
information of the entire day. 

View Log File To view the log file after you output the project, select Tools > Log Viewer. 
The Log Viewer opens, displaying the log file for the current day. 

To open a different log file, select File > Open in the Log Viewer dialog 
box, then select the log file you want. The default folder is C:\Program 
Files\Inscriber\InfoCaster\PlaybackLogs. The date that the data was logged 
is stored as part of the log file name.
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Change Logging 
Defaults

By default, items are not set to be logged. You can enable or disable 
logging, change the storage folder for log files, and change the number of 
days that log files are stored on your system.

To change logging defaults, select Edit > Preferences and select the 
Logging tab in the Preferences dialog box. See “Log Region Playback” on 
page 227 for details. 
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Change Preferences
Select Edit > Preferences to change your default settings in the Preferences dialog box.

General Tab

Store InfoCasts In

InfoCaster saves your InfoCast projects to C:\InfoCasts by default. Pages 
are saved to C:\InfoCasts\project folder. To change the location for saved 
projects, click on the Choose button next to the Store InfoCasts In field, 
then select a new location in the dialog box that comes up. 

Load Last InfoCast on Startup

To set InfoCaster to load your last opened project when you start 
InfoCaster, check the Load Last Page Layout on Startup checkbox on the 
General tab.

Image File Lifetime Interval

To set InfoCaster to delete temporary images after a certain length of time, 
enter a value in the Image File Lifetime Interval field. Images from ODBC 
and HTTP sources are stored in the region’s temp images folder each time 
an image is updated. InfoCaster deletes images in the temp images folder 
when pages transition during output or when playback stops. However, if 
you are playing one page for a long period of time and your images are 
being updated frequently your disk space may become full.
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Offline Graphic

To display a graphic on your output device whenever a page is switched 
during playback, use the Choose button beside the Offline Graphic field to 
select a graphic file.

Default Roll Direction

To change the default direction that applies to all rolls, change the Default 
Roll Direction option on the General tab. 

Default Crawl Direction

To change the default direction that applies to all Crawl items, change the 
Default Crawl Direction option on the General tab. 

Store Shared Media Files In

You can save your audio, video, and animation files in a central location for 
shared referencing. All the region items that use the same file refer to the 
shared media folder instead of referring to copies of the same file in 
different places. 

To use this feature, you must select the Shared Media option in a content 
editor when you add a region item to a region. See “Add Items to Regions” 
on page 39 for more information about region items.

InfoCaster saves your shared media files to the default location C:\Shared 
Media. This is true when saving an InfoCast to CD as well. InfoCaster 
automatically creates the directory folders it needs.

To change the default location for shared media, click on the Choose 
button next to the Store Shared Media Files In field on the General tab in 
the Preferences dialog box. Then, select a new file location for your shared 
media.

Automatically Delete Shared Media Files

To automatically delete files in the Shared Media folder that are no longer 
referred to by any InfoCasts, check the Automatically Delete Stored Media 
Files That Are Not Referenced or Being Used By Any InfoCast checkbox.
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Output Aspect Ratio

You can set the aspect ratio for your output monitor and for your computer 
display. The aspect ratio is a global setting applied to all page layouts you 
open in InfoCaster, so individual layouts do not store aspect ratio 
information. Selecting the right aspect ratio ensures that objects maintain 
their proper shape without appearing skewed during playback. For 
example, if you output to a 16:9 display, select 16:9 in the Preferences 
dialog box. 

To select an aspect ratio for your output screen, select an option from the 
Output Aspect Ratio drop-down list.

To select an aspect ratio for your computer display, select an option from 
the VGA Aspect Ratio drop-down list.

VGA Aspect Ratio

To select an aspect ratio for your computer display, select an option from 
the VGA Aspect Ratio drop-down list. See “Output Aspect Ratio” on 
page 231 for details.

Audio Ducking Level

If you are playing several items with audio, you may want to shut off or 
reduce the audio levels when one specific item plays. This is known as 
audio ducking. 

When you enable Audio ducking for an item, all other audio that is playing 
ducks (goes quiet) by the percentage indicated in the Audio Ducking Level 
field. The default ducking level is 30% of the normal audio level. 

To change the default audio ducking level, enter a new audio ducking level 
percentage in the Audio Ducking Level field on the General tab.
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Logging Tab

Change Status of Automatic Logging

By default, items are not set to be logged. To set all items to be logged, 
check the Enable Logging checkbox on the Logging tab. To disable logging, 
clear the checkbox.

Change Default Log File Location

To store log files in a different default folder, click the Choose button and 
select a new folder as prompted.
Set Number of Keep Log Days

To change the default number of days that log files are stored on your 
system, enter another number in the Days field.

Network Tab When operating as part of the Network Manager solution, InfoCaster uses 
the options on the Network tab to connect to a Network Manager. The 
Network Manager solution includes InfoCaster, Network Manager, and the 
players. See the online help (Help > Online Help) for details.
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Technical Support
You can get InfoCaster technical support from several places.

Technical Support from dealer

Contact your dealer first. Since your dealer helped you configure your system, your dealer is also the 
best resource for system configuration issues and problems.

If your dealer can’t help you...

If your local dealer is unable to resolve your technical support problems, contact Inscriber Technology 
Corporation. 

Please have your software serial number available when you contact Inscriber Technical Support. Your 
serial number can be found in a number of places, including software packaging, on the dongle, and 
on your InfoCaster CD ROM.

• Email:support@inscriber.com

You can also post a technical support question on our web site, and our support staff will answer your 
questions.

Product Updates

You can download product updates from our web site, or you can use one of these methods to receive 
updates.

• Web site:www.inscriber.com
• Email:support@inscriber.com




